Topic: Unable to adhoc wrt54g v2.2 BCM 4712 WLAN rev 7 - backfire 10.03.1

I have been having a problem here that has been keepijng up for a lot of hours as i cannot seem to adhoc the router.

Model: Linksys wrt54g v2.2
Firmware 10.03.1

I have tried several firmwares all the way down to kamikaze and also another router (asus wl 500 gp v2 - BCM5354 chip rev 2)

Problem:

When i set the router to adhoc mode the router announces 54g but once i connect to it the Max Rate turns to 11b for the client and the router too. At that moment the router announces only 11b but works slows than 33k dial up.

At the same time i cannot even access youtube or any light browsing. My best result was with kamikaze 8.09.2 kernel 2.4 for the asus router which gave me 1mbit for bandwidth test but also turned 54g into 11b.
I also tried both b43 and wl drivers and i am out of ideas.  If anyone can replicate (or not) the same with these configs it may help understand where the problem is.
I also exhausted all web searches for solutions or looking for similar problem. I am unable to understand why i cannot use a simple adhoc  configuration without routing protocol from the the netbook  Eeepc 1015 PED-MU17 with Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01) to the router.

Here are some infos:

~# dmesg 
Linux version 2.6.32.27 (m@box) (gcc version 4.3.3 (GCC) ) #1 Wed Mar 14 03:29:17 EDT 2012
CPU revision is: 00029007 (Broadcom BCM3302)
ssb: Core 0 found: ChipCommon (cc 0x800, rev 0x09, vendor 0x4243)
ssb: Core 1 found: IEEE 802.11 (cc 0x812, rev 0x07, vendor 0x4243)
ssb: Core 2 found: Fast Ethernet (cc 0x806, rev 0x07, vendor 0x4243)
ssb: Core 3 found: USB 1.1 Device (cc 0x818, rev 0x01, vendor 0x4243)
ssb: Core 4 found: USB 1.1 Host (cc 0x817, rev 0x01, vendor 0x4243)
ssb: Core 5 found: MIPS 3302 (cc 0x816, rev 0x01, vendor 0x4243)
ssb: Core 6 found: MEMC SDRAM (cc 0x80F, rev 0x01, vendor 0x4243)
ssb: Core 7 found: PCI (cc 0x804, rev 0x0A, vendor 0x4243)
ssb: chipcommon status is 0x0
ssb: Initializing MIPS core...
ssb: set_irq: core 0x0812, irq 4 => 4
ssb: set_irq: core 0x0806, irq 5 => 5
ssb: set_irq: core 0x0818, irq 6 => 2
ssb: set_irq: core 0x0804, irq 2 => 6
ssb: after irq reconfiguration
ssb: core 0x0800, irq : 2(S)  3* 4  5  6  D  I 
ssb: core 0x0812, irq : 2(S)  3  4* 5  6  D  I 
ssb: core 0x0806, irq : 2(S)  3  4  5* 6  D  I 
ssb: core 0x0818, irq : 2(S)* 3  4  5  6  D  I 
ssb: core 0x0817, irq : 2(S)* 3  4  5  6  D  I 
ssb: core 0x0816, irq : 2(S)* 3  4  5  6  D  I 
ssb: core 0x080f, irq : 2(S)  3  4  5  6  D  I*
ssb: core 0x0804, irq : 2(S)  3  4  5  6* D  I 
ssb: Sonics Silicon Backplane found at address 0x18000000
Serial init done.
Determined physical RAM map:
 memory: 01000000 @ 00000000 (usable)
Initrd not found or empty - disabling initrd
Zone PFN ranges:
  Normal   0x00000000 -> 0x00001000
Movable zone start PFN for each node
early_node_map[1] active PFN ranges
    0: 0x00000000 -> 0x00001000
On node 0 totalpages: 4096
free_area_init_node: node 0, pgdat 80289e60, node_mem_map 802cf000
  Normal zone: 32 pages used for memmap
  Normal zone: 0 pages reserved
  Normal zone: 4064 pages, LIFO batch:0
Built 1 zonelists in Zone order, mobility grouping off.  Total pages: 4064
Kernel command line: root=/dev/mtdblock2 rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200
PID hash table entries: 64 (order: -4, 256 bytes)
Dentry cache hash table entries: 2048 (order: 1, 8192 bytes)
Inode-cache hash table entries: 1024 (order: 0, 4096 bytes)
Primary instruction cache 8kB, VIPT, 2-way, linesize 16 bytes.
Primary data cache 4kB, 2-way, VIPT, no aliases, linesize 16 bytes
Memory: 13348k/16384k available (2248k kernel code, 3036k reserved, 348k data, 136k init, 0k highmem)
Hierarchical RCU implementation.
NR_IRQS:128
console [ttyS0] enabled
Calibrating delay loop... 214.52 BogoMIPS (lpj=429056)
Mount-cache hash table entries: 512
NET: Registered protocol family 16
bio: create slab <bio-0> at 0
Switching to clocksource MIPS
NET: Registered protocol family 2
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 512 (order: 0, 4096 bytes)
TCP bind hash table entries: 512 (order: -1, 2048 bytes)
TCP: Hash tables configured (established 512 bind 512)
TCP reno registered
NET: Registered protocol family 1
squashfs: version 4.0 (2009/01/31) Phillip Lougher
Registering mini_fo version $Id$
JFFS2 version 2.2. (NAND) (SUMMARY)  © 2001-2006 Red Hat, Inc.
msgmni has been set to 26
io scheduler noop registered
io scheduler deadline registered (default)
Serial: 8250/16550 driver, 2 ports, IRQ sharing enabled
serial8250: ttyS0 at MMIO 0xb8000300 (irq = 3) is a 16550A
serial8250: ttyS1 at MMIO 0xb8000400 (irq = 3) is a 16550A
serial8250.0: ttyS0 at MMIO 0xb8000300 (irq = 3) is a 16550A
serial8250.0: ttyS1 at MMIO 0xb8000400 (irq = 3) is a 16550A
flash init: 0x1c000000 0x02000000
Physically mapped flash: Found 1 x16 devices at 0x0 in 16-bit bank
Physically mapped flash: Found an alias at 0x400000 for the chip at 0x0
Physically mapped flash: Found an alias at 0x800000 for the chip at 0x0
Physically mapped flash: Found an alias at 0xc00000 for the chip at 0x0
Physically mapped flash: Found an alias at 0x1000000 for the chip at 0x0
Physically mapped flash: Found an alias at 0x1400000 for the chip at 0x0
Physically mapped flash: Found an alias at 0x1800000 for the chip at 0x0
Physically mapped flash: Found an alias at 0x1c00000 for the chip at 0x0
 Intel/Sharp Extended Query Table at 0x0035
Using auto-unlock on power-up/resume
cfi_cmdset_0001: Erase suspend on write enabled
erase region 0: offset=0x0,size=0x2000,blocks=8
erase region 1: offset=0x10000,size=0x10000,blocks=63
Flash device: 0x400000 at 0x1fc00000
bootloader size: 262144
Creating 4 MTD partitions on "Physically mapped flash":
0x000000000000-0x000000040000 : "cfe"
0x000000040000-0x0000003f0000 : "linux"
0x000000114400-0x0000003f0000 : "rootfs"
mtd: partition "rootfs" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
mtd: partition "rootfs" set to be root filesystem
mtd: partition "rootfs_data" created automatically, ofs=300000, len=F0000 
0x000000300000-0x0000003f0000 : "rootfs_data"
0x0000003f0000-0x000000400000 : "nvram"
b44.c:v2.0
eth0: Broadcom 44xx/47xx 10/100BaseT Ethernet 00:12:17:be:f9:46
BCM47xx Watchdog Timer enabled (30 seconds, nowayout)
TCP westwood registered
NET: Registered protocol family 17
802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>
All bugs added by David S. Miller <davem@redhat.com>
VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
Freeing unused kernel memory: 136k freed
Please be patient, while OpenWrt loads ...
diag: Detected 'Linksys WRT54G/GS/GL'
b44: eth0: Link is up at 100 Mbps, full duplex.
b44: eth0: Flow control is off for TX and off for RX.
roboswitch: Probing device eth0: found a 5325! It's a 5350.
mini_fo: using base directory: /
mini_fo: using storage directory: /overlay
b44: eth0: powering down PHY
b44: eth0: Link is up at 100 Mbps, full duplex.
b44: eth0: Flow control is off for TX and off for RX.
device eth0.0 entered promiscuous mode
device eth0 entered promiscuous mode
br-lan: port 1(eth0.0) entering forwarding state
Compat-wireless backport release: compat-wireless-2011-11-29
Backport based on wireless-testing.git master-2011-12-01
cfg80211: Calling CRDA to update world regulatory domain
b43-phy0: Broadcom 4712 WLAN found (core revision 7)
ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
Registered led device: b43-phy0::tx
Registered led device: b43-phy0::rx
Registered led device: b43-phy0::radio
Broadcom 43xx driver loaded [ Features: PL ]
ip_tables: (C) 2000-2006 Netfilter Core Team
cfg80211: World regulatory domain updated:
cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
cfg80211:     (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
cfg80211:     (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
nf_conntrack version 0.5.0 (210 buckets, 840 max)
batman_adv: B.A.T.M.A.N. advanced 2012.0.0 (compatibility version 14) loaded
cfg80211: Calling CRDA for country: US
cfg80211: Regulatory domain changed to country: US
cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2700 mBm)
cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 1700 mBm)
cfg80211:     (5250000 KHz - 5330000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
cfg80211:     (5490000 KHz - 5600000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
cfg80211:     (5650000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 3000 mBm)
b43-phy0: Loading firmware version 508.1084 (2009-01-14 01:32:01)
wlan0: Creating new IBSS network, BSSID 02:16:b8:6b:0a:1a
~# lsmod 
Module                  Size  Used by    Not tainted
batman_adv            105408  0 
nf_nat_tftp              432  0 
nf_conntrack_tftp       2400  1 nf_nat_tftp
nf_nat_irc               864  0 
nf_conntrack_irc        2592  1 nf_nat_irc
nf_nat_ftp              1360  0 
nf_conntrack_ftp        4896  1 nf_nat_ftp
ipt_MASQUERADE           992  1 
iptable_nat             2304  1 
nf_nat                 11824  5 nf_nat_tftp,nf_nat_irc,nf_nat_ftp,ipt_MASQUERADE,iptable_nat
xt_NOTRACK               672  0 
iptable_raw              656  1 
xt_state                 800  3 
nf_conntrack_ipv4       7808  6 iptable_nat,nf_nat
nf_defrag_ipv4           608  1 nf_conntrack_ipv4
nf_conntrack           42560 12 nf_nat_tftp,nf_conntrack_tftp,nf_nat_irc,nf_conntrack_irc,nf_nat_ftp,nf_conntrack_ftp,ipt_MASQUERADE,iptable_nat,nf_nat,xt_NOTRACK,xt_state,nf_conntrack_ipv4
ipt_REJECT              1984  2 
xt_TCPMSS               1952  1 
ipt_LOG                 4640  0 
xt_comment               464  0 
xt_multiport            1904  0 
xt_mac                   576  0 
xt_limit                1152  1 
iptable_mangle           992  1 
iptable_filter           768  1 
ip_tables               8864  4 iptable_nat,iptable_raw,iptable_mangle,iptable_filter
xt_tcpudp               1856  5 
x_tables                9840 13 ipt_MASQUERADE,iptable_nat,xt_NOTRACK,xt_state,ipt_REJECT,xt_TCPMSS,ipt_LOG,xt_comment,xt_multiport,xt_mac,xt_limit,ip_tables,xt_tcpudp
b43                   151056  0 
mac80211              260560  1 b43
crc16                    976  1 batman_adv
cfg80211              149136  2 b43,mac80211
compat                 13312  3 b43,mac80211,cfg80211
arc4                     816  2 
aes_generic            31056  0 
deflate                 1328  0 
ecb                     1328  0 
cbc                     2016  0 
switch_robo             4208  0 
switch_core             5216  1 switch_robo
diag                    7504  0
~# iw list
Wiphy phy0
        Band 1:
                Frequencies:
                        * 2412 MHz [1] (27.0 dBm)
                        * 2417 MHz [2] (27.0 dBm)
                        * 2422 MHz [3] (27.0 dBm)
                        * 2427 MHz [4] (27.0 dBm)
                        * 2432 MHz [5] (27.0 dBm)
                        * 2437 MHz [6] (27.0 dBm)
                        * 2442 MHz [7] (27.0 dBm)
                        * 2447 MHz [8] (27.0 dBm)
                        * 2452 MHz [9] (27.0 dBm)
                        * 2457 MHz [10] (27.0 dBm)
                        * 2462 MHz [11] (27.0 dBm)
                        * 2467 MHz [12] (disabled)
                        * 2472 MHz [13] (disabled)
                        * 2484 MHz [14] (disabled)
                Bitrates (non-HT):
                        * 1.0 Mbps
                        * 2.0 Mbps (short preamble supported)
                        * 5.5 Mbps (short preamble supported)
                        * 11.0 Mbps (short preamble supported)
                        * 6.0 Mbps
                        * 9.0 Mbps
                        * 12.0 Mbps
                        * 18.0 Mbps
                        * 24.0 Mbps
                        * 36.0 Mbps
                        * 48.0 Mbps
                        * 54.0 Mbps
        max # scan SSIDs: 4
        max scan IEs length: 2285 bytes
        Coverage class: 0 (up to 0m)
        Available Antennas: TX 0x3 RX 0x3
        Configured Antennas: TX 0x1 RX 0x1
        Supported interface modes:
                 * IBSS
                 * managed
                 * AP
                 * AP/VLAN
                 * WDS
                 * monitor
                 * mesh point
        Supported commands:
                 * new_interface
                 * set_interface
                 * new_key
                 * new_beacon
                 * new_station
                 * new_mpath
                 * set_mesh_params
                 * set_bss
                 * authenticate
                 * associate
                 * deauthenticate
                 * disassociate
                 * join_ibss
                 * join_mesh
                 * remain_on_channel
                 * set_tx_bitrate_mask
                 * action
                 * frame_wait_cancel
                 * set_wiphy_netns
                 * set_channel
                 * set_wds_peer
                 * Unknown command (84)
                 * Unknown command (87)
                 * Unknown command (85)
                 * connect
                 * disconnect
        Supported TX frame types:
                 * IBSS: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
                 * managed: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
                 * AP: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
                 * AP/VLAN: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
                 * mesh point: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
                 * P2P-client: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
                 * P2P-GO: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
        Supported RX frame types:
                 * IBSS: 0x00d0
                 * managed: 0x0040 0x00d0
                 * AP: 0x0000 0x0020 0x0040 0x00a0 0x00b0 0x00c0 0x00d0
                 * AP/VLAN: 0x0000 0x0020 0x0040 0x00a0 0x00b0 0x00c0 0x00d0
                 * mesh point: 0x00b0 0x00c0 0x00d0
                 * P2P-client: 0x0040 0x00d0
                 * P2P-GO: 0x0000 0x0020 0x0040 0x00a0 0x00b0 0x00c0 0x00d0
# iw reg get
country US:
        (2402 - 2472 @ 40), (3, 27)
        (5170 - 5250 @ 40), (3, 17)
        (5250 - 5330 @ 40), (3, 20), DFS
        (5490 - 5600 @ 40), (3, 20), DFS
        (5650 - 5710 @ 40), (3, 20), DFS
        (5735 - 5835 @ 40), (3, 30)
# NETWORK

#### VLAN configuration
config switch eth0
        option enable   1

config switch_vlan eth0_0
        option device   "eth0"
        option vlan     0
        option ports    "1 2 3 4 5"

config switch_vlan eth0_1
        option device   "eth0"
        option vlan     1
        option ports    "0 5"

#### Loopback configuration
config interface loopback
        option ifname   "lo"
        option proto    static
        option ipaddr   127.0.0.1
        option netmask  255.0.0.0


#### LAN configuration
config interface lan
        option type     bridge
        option ifname   "eth0.0"
        option proto    static
        #option ipaddr  10.0.0.1
        #option netmask 255.255.0.0
        #option broadcast 10.0.255.255
        option ipaddr   192.168.1.1
        option netmask  255.255.255.0
        option broadcast 192.168.1.255
        #option dns      208.67.222.222,208.67.220.220
#### WAN configuration
config interface        wan
        option ifname   "eth0.1"
        option proto    dhcp



## WIRELESS

config wifi-device      radio0
        option type     mac80211
        option channel  11
        option phy      phy0
        option hwmode   11g
        option country  US
        option txpower  20
        option diversity 1
        option rxantenna 1              #(comment for driver default)
        option txantenna 1              #(comment for driver default)
        option disabled  0

        #option distance 5000           #(trunk)
        #option basic_rate 54000        #(trunk)
        #option beacon_int 10000        #(trunk)

        # For N capable Routers
        # Note: cannot use HT40+ with channel 11 = 11+4 = 15
        # ht '40' modes are for N frequencies

        #option htmode  HT20            #(comment for driver default)
        #list ht_capab  SHORT-GI-40     #(comment for driver default)
        #list ht_capab  DSSS_CCK-40     #(comment for driver default)

config wifi-iface
        option device   radio0
        option network  lan
        option hidden   0
        option mode     adhoc
        option ssid     openwireless
        option bssid    02:16:b8:6b:0a:1a
        #mcast_rate     5500            #(trunk)
        option encryption none
# DHCP 
config dnsmasq
        option domainneeded     1
        option boguspriv        1
        option filterwin2k      0       # enable for dial on demand
        option localise_queries 1
        option rebind_protection 1      # disable if upstream must serve RFC1918 add resses
        option rebind_localhost 1       # enable for RBL checking and similar services

        #list rebind_domain example.lan # whitelist RFC1918 responses for domains

        option local            '/lan/'
        option domain           'some.net'
        option expandhosts      1
        option nonegcache       0
        option authoritative    1
        option readethers       1
        option leasefile        '/tmp/dhcp.leases'
        option resolvfile       '/tmp/resolv.conf.auto'
        #list server            '/mycompany.local/1.2.3.4'
        #option nonwildcard     1
        #list interface         br-lan
        #list notinterface      lo
        #list bogusnxdomain     '64.94.110.11'

config dhcp lan
        option interface        lan
        option start            51
        option limit            251
        option leasetime        24h

config dhcp wan
        option interface        wan
        option ignore           1
        option domain           some.net
~# cat /etc/config/firewall 
config defaults
        option syn_flood        1
        option input            ACCEPT
        option output           ACCEPT 
        option forward          REJECT
# Uncomment this line to disable ipv6 rules
        option disable_ipv6     1

config zone
        option name             lan
        option network          lan
        option input            ACCEPT 
        option output           ACCEPT 
        option forward          REJECT

config zone
        option name             wan
        option network          wan
        option input            REJECT
        option output           ACCEPT 
        option forward          REJECT
        option masq             1 
        option mtu_fix          1

config forwarding 
        option src              lan
        option dest             wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
        option name             Allow-DHCP-Renew
        option src              wan
        option proto            udp
        option dest_port        68
        option target           ACCEPT
        option family           ipv4

# Allow IPv4 ping
config rule
        option name             Allow-Ping
        option src              wan
        option proto            icmp
        option icmp_type        echo-request
        option family           ipv4
        option target           ACCEPT

# SSH wan/lan/wlan
config rule
        option target ACCEPT
#       option src wan
        option proto tcp
        option dest_port 22

# include a file with users custom iptables rules
config include
        option path /etc/firewall.user
Hardware: Asus WL500 gpv1/WL500 gp v2/ Asus WL520GU/GC | Fonera 2100/2200 / Linksys WRT300N v1 | Linksys WRT150N v1.1 | Buffalo WHR-G54S | Linksys WRT54GL v1.1 | Linksys WRT54G v1 | Linksys WRT54G v1.1  | Linksys WRT54G v2 | Linksys WRT54G v2.2 |Linksys WRT54G v3 | Linksys WRT54G v4 | Linksys WRT54G RG | D-Link DIR-615 C1/E1 | D-Link DIR-600/601  A1 | TP-Link WR740N/WR741ND/WR841ND

Re: Unable to adhoc wrt54g v2.2 BCM 4712 WLAN rev 7 - backfire 10.03.1

The problem still remains but at least 50% was solved.

When i set the router to adhoc mode the router announces 54g but once i connect to it the Max Rate turns to 11b for the client and the router too.

I found out that this was caused by the driver default settings on the computer. It is now set to auto and 54g works as it should.

As for adhoc:

# ifconfig br-lan down;
# brctl delbr br-lan

Gets adhoc working. However after reboot br-lan get created again from /etc/config/network.
Removing the line:

"option type bridge"

Prevents br-lan to be re-created but also does not make adhoc working so something must be missing.

Since google finds NO working config setup (uci) anywhere for this and no ONE seems to know. i feel like Columbus smile

Hardware: Asus WL500 gpv1/WL500 gp v2/ Asus WL520GU/GC | Fonera 2100/2200 / Linksys WRT300N v1 | Linksys WRT150N v1.1 | Buffalo WHR-G54S | Linksys WRT54GL v1.1 | Linksys WRT54G v1 | Linksys WRT54G v1.1  | Linksys WRT54G v2 | Linksys WRT54G v2.2 |Linksys WRT54G v3 | Linksys WRT54G v4 | Linksys WRT54G RG | D-Link DIR-615 C1/E1 | D-Link DIR-600/601  A1 | TP-Link WR740N/WR741ND/WR841ND

Re: Unable to adhoc wrt54g v2.2 BCM 4712 WLAN rev 7 - backfire 10.03.1

Your ad-hoc network still references lan. Simply remove "option network lan" to unbridge it.

4 (edited by HeXiLeD 2012-03-18 23:07:57)

Re: Unable to adhoc wrt54g v2.2 BCM 4712 WLAN rev 7 - backfire 10.03.1

I am afraid that option does not solve the problem. I applied the advice to my builds as well as official builds and the outcome was still not 100% satisfactory.

When i removed option network lan from /etc/wireless (since it was still there; i was able to use the wired connection which was progress but while i was able to connect to the wireless interface; i was not able to obtain dhcp address.
This lead me to play with configurations up to the point of creating a wlan interface with it's own dhcp setup. Maybe i failed to properly do it but i still was not able to have the problem solved.

I removed and played with that option in several configs but still without success. However as stated at least it got the wired interface working properly.

Question:
By totally removing wlan from any attachment to lan; how will wlan use dhcp without any further configuration ?

Perhaps i am failing big time here but this problem has been eating all my full time and it is driving me nuts for a simple ad-hoc setup.

Hardware: Asus WL500 gpv1/WL500 gp v2/ Asus WL520GU/GC | Fonera 2100/2200 / Linksys WRT300N v1 | Linksys WRT150N v1.1 | Buffalo WHR-G54S | Linksys WRT54GL v1.1 | Linksys WRT54G v1 | Linksys WRT54G v1.1  | Linksys WRT54G v2 | Linksys WRT54G v2.2 |Linksys WRT54G v3 | Linksys WRT54G v4 | Linksys WRT54G RG | D-Link DIR-615 C1/E1 | D-Link DIR-600/601  A1 | TP-Link WR740N/WR741ND/WR841ND

Re: Unable to adhoc wrt54g v2.2 BCM 4712 WLAN rev 7 - backfire 10.03.1

I have been days around this now. Does anyone even have basic ad-hoc working with 10.03.1 ?

Hardware: Asus WL500 gpv1/WL500 gp v2/ Asus WL520GU/GC | Fonera 2100/2200 / Linksys WRT300N v1 | Linksys WRT150N v1.1 | Buffalo WHR-G54S | Linksys WRT54GL v1.1 | Linksys WRT54G v1 | Linksys WRT54G v1.1  | Linksys WRT54G v2 | Linksys WRT54G v2.2 |Linksys WRT54G v3 | Linksys WRT54G v4 | Linksys WRT54G RG | D-Link DIR-615 C1/E1 | D-Link DIR-600/601  A1 | TP-Link WR740N/WR741ND/WR841ND

6 (edited by HeXiLeD 2012-03-25 02:45:18)

Re: Unable to adhoc wrt54g v2.2 BCM 4712 WLAN rev 7 - backfire 10.03.1

jow wrote:

Your ad-hoc network still references lan. Simply remove "option network lan" to unbridge it.

The only way i was ble to adhoc it now was by doing what i did not wanted to start with which meas having 2 subnets.
Initially i wanted to have adhoc working just with one subnet. (192.168.1.1 - class C)

However if i unbrigde one subnet does not seem to be possible. How will the wlan interface reach the WAN ?

So i configured it for 2 subnets  according this wiki page.
http://wiki.openwrt.org/doc/recipes/routedap

Adhoc is working for 2 routers and they can connect to each other as well having me connected to them wired and wireless.
However 1 problem remains

Router1 lan 192.68.1.1
Router1 wlan 172.16.0.1

Router2 lan 192.168.1.2
router2 wlan 172.16.0.2

Whether i am connected to router one or 2 i can only ping from lan to lan and wlan to wlan.
I cannot ping from router1 lan to router2 wlan and vice versa.
BUT in within the same router i can ping lan and wlan.

Additionally from router 2 (not gw) i cannot access WAN while on router1 i can.
Also batman-adv is able to ping the other router mac.



My forwarding  firewall rules are as follow (on top of default setup):

# cat /etc/config/firewall

config 'defaults'
        option 'syn_flood' '1'
        option 'input' 'ACCEPT'
        option 'output' 'ACCEPT'
        option 'forward' 'REJECT'
        option 'disable_ipv6' '1'

config 'zone'
        option 'name' 'lan'
        option 'network' 'lan'
        option 'input' 'ACCEPT'
        option 'output' 'ACCEPT'
        option 'forward' 'REJECT'

config 'zone'
        option 'name' 'wifi'
        option 'network' 'wifi'
        option 'input' 'ACCEPT'
        option 'output' 'ACCEPT'
        option 'forward' 'REJECT'


config 'zone'
        option 'name' 'wan'
        option 'network' 'wan'
        option 'input' 'REJECT'
        option 'output' 'ACCEPT'
        option 'forward' 'REJECT'
        option 'masq' '1'

config 'forwarding'
        option 'src' 'lan'
        option 'dest' 'wan'

config 'forwarding'
        option 'src' 'wifi'
        option 'dest' 'wan'

config 'forwarding'
        option 'src' 'lan'
        option 'dest' 'wifi'

config 'forwarding'
        option 'src' 'wifi'
        option 'dest' 'lan'

config 'rule'
        option 'name' 'Allow-DHCP-Renew'
        option 'src' 'wan'
        option 'proto' 'udp'
        option 'dest_port' '68'
        option 'target' 'ACCEPT'
        option 'family' 'ipv4'

config 'rule'
        option 'name' 'Allow-Ping'
        option 'src' 'wan'
        option 'proto' 'icmp'
        option 'icmp_type' 'echo-request'
        option 'family' 'ipv4'
        option 'target' 'ACCEPT'

config 'rule'
        option 'target' 'ACCEPT'
        option 'src' 'wan'
        option 'proto' 'tcp'
        option 'dest_port' '22'

config 'include'
        option 'path' '/etc/firewall.user'

My questions are:

Am i missing out something for firewall rules or is this setup missing a bridge  somewhere  or it needs the routing protocol to take care of the rest ?

Hardware: Asus WL500 gpv1/WL500 gp v2/ Asus WL520GU/GC | Fonera 2100/2200 / Linksys WRT300N v1 | Linksys WRT150N v1.1 | Buffalo WHR-G54S | Linksys WRT54GL v1.1 | Linksys WRT54G v1 | Linksys WRT54G v1.1  | Linksys WRT54G v2 | Linksys WRT54G v2.2 |Linksys WRT54G v3 | Linksys WRT54G v4 | Linksys WRT54G RG | D-Link DIR-615 C1/E1 | D-Link DIR-600/601  A1 | TP-Link WR740N/WR741ND/WR841ND