Re: Fully featured OpenWrt build for the WNDR3700

hnyman wrote:
Saens wrote:

Is it possible to do a sysupgrade without keeping any settings? Luci isn't working anymore, but can still SSH into the router. Starting with a clean slate would be nice, but don't want to bother with TFTP.

If you are using squashfs image, just a simple command "firstboot" should be enough to reset the firmware to initial state.

sysupgrade -n <new-firmware-file> should also do the trick, if you are upgrading anyway. See http://wiki.openwrt.org/doc/techref/sysupgrade

2,602

Re: Fully featured OpenWrt build for the WNDR3700

Saens wrote:

Is it possible to do a sysupgrade without keeping any settings? Luci isn't working anymore, but can still SSH into the router. Starting with a clean slate would be nice, but don't want to bother with TFTP.

Actually, I think that Arokh's build has support for the reset button in WNDR3700. If you push the button (pinhole in WNDR3700's botton), that should also clear the router to the initial state.

2,603

Re: Fully featured OpenWrt build for the WNDR3700

Yes, pressing the reset button should execute the firstboot command and then reboot.

2,604

Re: Fully featured OpenWrt build for the WNDR3700

Thanks!

2,605

Re: Fully featured OpenWrt build for the WNDR3700

Hi Arokh,

Is it possible when upgrading to a new build to keep the IP address of the LAN interface?
I am not using the default IP address 192.168.1.1 on my router but another one.
Each time when I upgrade with a new build the IP address of the router is reset to 192.168.1.1 again.

Thanks,
Eric

2,606

Re: Fully featured OpenWrt build for the WNDR3700

I don't know, put a few uci commands in rc.local to reset it properly?

2,607

Re: Fully featured OpenWrt build for the WNDR3700

arokh, the mysterious lan ip reset is caused by these options:

CONFIG_IMAGEOPT=y
CONFIG_UCI_PRECONFIG_network_lan_dns=""
CONFIG_UCI_PRECONFIG_network_lan_proto="static"
CONFIG_UCI_PRECONFIG_network_lan_gateway=""
CONFIG_UCI_PRECONFIG_network_lan_netmask="255.255.255.0"
CONFIG_UCI_PRECONFIG_network_lan_ipaddr="192.168.1.1"

Simply remove them. The system will default to 192.168.1.1 anyway.

2,608 (edited by arokh 2012-03-17 03:51:31)

Re: Fully featured OpenWrt build for the WNDR3700

Thanks for the tip, should be ok in the next build smile

2,609

Re: Fully featured OpenWrt build for the WNDR3700

Hi Arokh! Thanks your build! That is very useful for me.
Would you add the staging driver "8192SU" in your build?
I compiled a build with 8192su and can recognize it, but cannot use.

2,610

Re: Fully featured OpenWrt build for the WNDR3700

jow wrote:

arokh, the mysterious lan ip reset is caused by these options:

CONFIG_IMAGEOPT=y
CONFIG_UCI_PRECONFIG_network_lan_dns=""
CONFIG_UCI_PRECONFIG_network_lan_proto="static"
CONFIG_UCI_PRECONFIG_network_lan_gateway=""
CONFIG_UCI_PRECONFIG_network_lan_netmask="255.255.255.0"
CONFIG_UCI_PRECONFIG_network_lan_ipaddr="192.168.1.1"

Simply remove them. The system will default to 192.168.1.1 anyway.

Hi Jow,

Thank you for your help, in which file can I find these options?

Cheers,
Eric

2,611

Re: Fully featured OpenWrt build for the WNDR3700

These are located in the .config file inside the kernel source directory (or using make config/menuconfig if you don't have an existing file). You can't change those unless you build the kernel yourself.

2,612

Re: Fully featured OpenWrt build for the WNDR3700

I have a question, I have made some changes to my config, obviously like most people will. Now my question, if I would upgrade the FW, will the changes stand? Changes I made are: installing transmission, unrar and added a line to the samba startup (to add non browse-able shares) file in init.d.
Thanks again for the great FW!

2,613

Re: Fully featured OpenWrt build for the WNDR3700

BlCa` wrote:

These are located in the .config file inside the kernel source directory (or using make config/menuconfig if you don't have an existing file). You can't change those unless you build the kernel yourself.

Hi BICa,

Okay thanks, I will wait for the new build of Arokh then!

Cheers, Eric

2,614

Re: Fully featured OpenWrt build for the WNDR3700

@johan81

Sysupgrade only keeps relevant configuration in /etc and whatever is in /etc/sysupgrade.conf. It will not preserve your overlay filesystem, so installed packages won't be kept.

You could do some checks in /etc/rc.local that will install the relevant packages for you in case of an upgrade.

2,615 (edited by Manp 2012-03-17 13:38:20)

Re: Fully featured OpenWrt build for the WNDR3700

arokh wrote:

You could do some checks in /etc/rc.local that will install the relevant packages for you in case of an upgrade.

and how would you do that? can you write down a couple of line as an example? it would be great help to start putting something working together.

tia smile

would something like this:

opkg update
opkg list-installed > /tmp/installed-packages.list

if !(grep qos-scripts /tmp/installed-packages.list > /dev/null)
then
    opkg install qos-scripts
fi

rm /tmp/installed-packages.list

work/be a good idea?
just a wild guess. i have no idea.

2,616

Re: Fully featured OpenWrt build for the WNDR3700

Manp wrote:
jow wrote:

Manp, no conclusions from your traces. Seems PSVita~ath9k is just a bad combo.

:°°°

well as i've said if there's anything else that i can do to provide more info let me know. of course if you guys think there is actually stuff to look at.
if you think everything on your side is in working order then there's nothing more i could do.


got_milk wrote:

I've heard of Vita's failing miserably on various routers with stock configurations. I don't think it's a problem with ath9k or OpenWrt, it's something that Sony may have to fix.

i'm sure you're right but it does work with no issues with Netgear's stock firmware (tested on latest V1.0.0.12) which iirc is based on an old Openwrt build.

if i have to wait for Sony i guess i'll be in 54g hell for way too long sad
i have no faith they'll do anything in a reasonable amount of time.

tnx smile

Dont feel bad, I get exactly the same issues with my Android devices with any Backfire build. (I have three in the house now)

When I go to stock firmware they all work just fine... Its something to do with low power management on the device that cuts the steam. I cant stream anything from  my android devices unless they are plugged in and and the screen is set to always on (not ideal). As soon as they are on wireless, not plugged in I can download/stream for about 2 mins.. then its dead until I disconnect and reconnect the Wifi on the device.. then ad infinitum.

But like you, yes it all works fine with the Stock Netgear (ugh) firmware, but its horrid and crap... I'm looking at selling this POS router and getting something that works more reliably and doesn't have such a lame POS stock firmware...

I loved Arkoh's build, but the devices I use other than my desktop wont work with it (or even the official Backfire Builds). I also get the same issues with DD-WRT as well - Conclusion, the router is crap and I am never buying Netgear again.

Re: Fully featured OpenWrt build for the WNDR3700

@arokh

Since you make heavily optimized builds, only for the wndr3700/3800 devices, you can change a compiler optimization to squeeze out some more juice from the cpu. It should speed up vpn and other encrypted connections. See this topic.

All you need to do is replace "-mtune=mips32r2" for "-mtune=24kc" in your .config (there are 2 occurrences).

2,618

Re: Fully featured OpenWrt build for the WNDR3700

Hello,
I need your assistance to establish automatically  a brouting after the booting of the router.
Which is the best means to carry out the lines below when the wan is connected?
Some advised me a script, but I do not have a level sufficient for that.
Is it possible to edit a file to insert these lines?
Thank you in advance.

router ce qui arrive sur l'interface WAN qui n'est pas IPv6 wrote:
ebtables -t broute -A BROUTING -p ! ipv6 -i eth1 -j DROP
bloquer ce qui est ponté vers l'interface WAN qui n'est pas IPv6 wrote:
ebtables -A FORWARD -p ! ipv6 -o eth1 -j DROP
ensuite on peut ajouter l'interface WAN au pont du LAN wrote:
brctl addif br-lan eth1
blocage wrote:
ebtables -A OUTPUT -p ! ipv6 -o eth1 -j DROP

2,619 (edited by Manp 2012-03-19 12:55:53)

Re: Fully featured OpenWrt build for the WNDR3700

Cythrawl wrote:

Dont feel bad, I get exactly the same issues with my Android devices with any Backfire build. (I have three in the house now)

When I go to stock firmware they all work just fine... Its something to do with low power management on the device that cuts the steam. I cant stream anything from  my android devices unless they are plugged in and and the screen is set to always on (not ideal). As soon as they are on wireless, not plugged in I can download/stream for about 2 mins.. then its dead until I disconnect and reconnect the Wifi on the device.. then ad infinitum.

But like you, yes it all works fine with the Stock Netgear (ugh) firmware, but its horrid and crap... I'm looking at selling this POS router and getting something that works more reliably and doesn't have such a lame POS stock firmware...

I loved Arkoh's build, but the devices I use other than my desktop wont work with it (or even the official Backfire Builds). I also get the same issues with DD-WRT as well - Conclusion, the router is crap and I am never buying Netgear again.

i don't think it has anything to do with hardware being crap. 3700/3800 are based on an atheros soc that afaict is pretty good hardware.
the stock firmware sure is crap tho.

btw i also suspect it's a problem with power management. a way to check this would be to have a test build compiled with power management switched off since it can't be disabled at runtime afaik, but i'm unable to compile a build so i'm stuck. maybe if arokh feels like trying wink

root@OpenWrt /root# iwconfig wlan0
wlan0     IEEE 802.11bgn  Mode:Master  Frequency:2.452 GHz  Tx-Power=20 dBm
          RTS thr:off   Fragment thr:off
          Power Management:on
root@OpenWrt /root# iwconfig wlan0 power off
Error for wireless request "Set Power Management" (8B2C) :
    SET failed on device wlan0 ; Invalid argument.

2,620

Re: Fully featured OpenWrt build for the WNDR3700

so guys i think i've found a solution for my Vita issue, or i must say a workaround. it's so simple i'm almost ashamed it took me so long. and i have to give credit where credit is due because hatchna was, at least to a degree, damn right.

so i can't have radio0 set in both g mode and g+n mode on two different ssids but i can set it up like this:

config wifi-device 'radio0'
    option type 'mac80211'
    option macaddr 'mymac'
    list ht_capab 'SHORT-GI-40'
    list ht_capab 'TX-STBC'
    list ht_capab 'RX-STBC1'
    list ht_capab 'DSSS_CCK-40'
    option txpower '20'
    option country 'IT'
    option hwmode '11ng'
    option htmode 'HT40-'
    option channel '11'

config wifi-iface
    option device 'radio0'
    option mode 'ap'
    option wps_pushbutton '1'
    option ssid 'mainwireless'
    option key 'key'
    option network 'lan'
    option encryption 'psk2'

config wifi-iface
    option device 'radio0'
    option mode 'ap'
    option ssid 'vitawireless'
    option key 'key'
    option network 'lan'
    option encryption 'psk2'
    option wmm '0'

this way i get full 300 N speeds on "mainwireless" and at the same time i have wmm disabled on "vitawireless" which is enough to make the damn thing work.

so damn simple thinking about it right now sad

thank you all guys! smile

2,621

Re: Fully featured OpenWrt build for the WNDR3700

How do i setup these? I have the same problem with my Ps Vita.

2,622

Re: Fully featured OpenWrt build for the WNDR3700

XtR wrote:

How do i setup these? I have the same problem with my Ps Vita.

you have to edit your /etc/config/wireless. make a backup of this file and then open it, it will look something like this:

config wifi-device 'radio0'
    option type 'mac80211'
    option macaddr 'your radio0 mac address, don't change this'
    list ht_capab 'SHORT-GI-40'
    list ht_capab 'TX-STBC'
    list ht_capab 'RX-STBC1'
    list ht_capab 'DSSS_CCK-40'
    option txpower '20'
    option country 'your country, don't change this'
    option hwmode '11ng'
    option htmode 'HT40-'
    option channel '9'

config wifi-iface
    option device 'radio0'
    option mode 'ap'
    option wps_pushbutton '1'
    option ssid 'your wireless 2.4 name, don't change this'
    option key 'your key, don't change this'
    option network 'lan'
    option encryption 'psk2'

config wifi-device 'radio1'
    option type 'mac80211'
    option channel '36'
    option macaddr 'your radio1 mac address, don't change this'
    option hwmode '11na'
    list ht_capab 'SHORT-GI-40'
    list ht_capab 'TX-STBC'
    list ht_capab 'RX-STBC1'
    list ht_capab 'DSSS_CCK-40'
    option txpower '17'
    option htmode 'HT40+'
    option country 'your country, don't change this'

config wifi-iface
    option device 'radio1'
    option mode 'ap'
    option encryption 'psk2'
    option wps_pushbutton '1'
    option ssid 'your wireless 5 name, don't change this'
    option key 'your key, don't change this'
    option network 'lan'

you have to edit it to look like this:

config wifi-device 'radio0'
    option type 'mac80211'
    option macaddr 'your radio0 mac address, don't change this'
    list ht_capab 'SHORT-GI-40'
    list ht_capab 'TX-STBC'
    list ht_capab 'RX-STBC1'
    list ht_capab 'DSSS_CCK-40'
    option txpower '20'
    option country 'your country, don't change this'
    option hwmode '11ng'
    option htmode 'HT40-'
    option channel '9'

config wifi-iface
    option device 'radio0'
    option mode 'ap'
    option wps_pushbutton '1'
    option ssid 'your wireless name, don't change this'
    option key 'your key, don't change this'
    option network 'lan'
    option encryption 'psk2'

config wifi-iface
    option device 'radio0'
    option mode 'ap'
    option ssid 'another wireless name <- you need to change this'
    option key 'your key'
    option network 'lan'
    option encryption 'psk2'
    option wmm '0' 

config wifi-device 'radio1'
    option type 'mac80211'
    option channel '36'
    option macaddr 'your radio1 mac address, don't change this'
    option hwmode '11na'
    list ht_capab 'SHORT-GI-40'
    list ht_capab 'TX-STBC'
    list ht_capab 'RX-STBC1'
    list ht_capab 'DSSS_CCK-40'
    option txpower '17'
    option htmode 'HT40+'
    option country 'your country, don't change this'

config wifi-iface
    option device 'radio1'
    option mode 'ap'
    option encryption 'psk2'
    option wps_pushbutton '1'
    option ssid 'your wireless n name, don't change this'
    option key 'your key, don't change this'
    option network 'lan'

basically copy and paste the first "config wifi-iface", change the ssid name, remove the wps line (not sure if needed), add the wmm line.
done. now use the "another wireless name" to connect your vita to internet, and the other ssid for every other device.

hope this helps smile

2,623

Re: Fully featured OpenWrt build for the WNDR3700

Thanks it worked!

2,624

Re: Fully featured OpenWrt build for the WNDR3700

Hey Manp, I'm glad my suggestion worked for you in some manner. I'm sure it's nice having the full 802.11n speeds available when needed now, instead of being limited by yous Vita. Glad I was able to offer some useful advice. smile

2,625

Re: Fully featured OpenWrt build for the WNDR3700

thanks mate, I owe you one!

smile