1 (edited by zoo 2010-08-11 17:30:40)

Topic: [10.03] HOWTO enable an IPv6 tunnel to HE.net (tunnelbroker.com)

Hello,

this is how you can enable IPv6 trough tunnelbroker.com service:

1. Sign up at tunnelbroker.com, apply for a tunnel

2. Prerequisites:

opkg install ip ip6tables kmod-sit kmod-iptunnel6 radvd

3. Create a file /etc/hotplug.d/iface/15-ipv6 with the following contents:

. /etc/functions.sh
NAME=ipv6
COMMAND=/usr/sbin/ip
[ "$ACTION" = "ifup" -a "$INTERFACE" = "wan" -a "$DEVICE" = "ppp0" ] && {
        [ -x $COMMAND ] && {
                # setup tunnel
                logger "HE-IPv6: starting tunnel..."

                IPADDR=$(ip -4 addr show dev $DEVICE | awk '/inet / {print $2}' | cut -d/ -f1)
                username="abcdef1234567890abcdef1234567890" # your USERID as shown at your account details
                password="abcdef1234567890abcdef1234567890" # MD5 of your password
                tunnelid="69999" # global tunnel-ID

                # update tunnel to use dynamic ipv4
                wget -q -O /dev/null "http://ipv4.tunnelbroker.net/ipv4_end.php?ipv4b=$IPADDR&pass=$password&user_id=$username&tunnel_id=$tunnelid"

                SERVER_IPv4_ENDPOINT=216.66.80.30  # change this IP, this is the Frankfurt POP
                CLIENT_IPv6_ENDPOINT=2001:470:1f0a:9999::2/64 # change this, too


                # setup tunnel
                ip tunnel add he-ipv6 mode sit remote $SERVER_IPv4_ENDPOINT local $IPADDR ttl 255
                ip link set he-ipv6 up
                ip addr add $CLIENT_IPv6_ENDPOINT dev he-ipv6
                ip route add ::/0 dev he-ipv6

                # You got a routed /64
                # Please assign an IP out of this /64 to the bridge manually, f. ex. by calling:
                #
                # uci set network.lan.ip6addr=2001:470:1f0b:9999::1/64; uci commit
                #
                # Since the IP is saved, you only need to run that command once.

                # ... and don't forget your firewall... :-)

                # done
        } &
}
[ "$ACTION" = "ifdown" -a "$INTERFACE" = "wan" -a "$DEVICE" = "ppp0" ] && {
        [ -x $COMMAND ] && {
                # destroy tunnel
                logger "HE-IPv6: destroying tunnel..."
                ip route del ::/0 dev he-ipv6
                ip tunnel del he-ipv6
                # done
        } &
}

If you are not using ppp0 for getting your WAN connection, you might want to change the ppp0 to reflect your settings.

4. Add a new rule to your firewall to ACCEPT protocol 41 from wan to the device. Use luci or do it on the cli like this:

uci add firewall rule
uci set firewall.@rule[-1].src=wan
uci set firewall.@rule[-1].target=ACCEPT
uci set firewall.@rule[-1]._name=HE-IP6
uci set firewall.@rule[-1].proto=41
uci commit firewall

This allows the IPv6 tunnel to pass your IPv4 firewall.

Important notice: Your IPv6 lan is not protected by the openwrt built-in standard firewall! You should do ip6tables firewalling manually or use shorewall6. But this is not covered in this howto.

5. configure radvd to advertise your IPv6 network on lan:
edit /etc/config/radvd

config interface
        option interface        'lan'
        option AdvSendAdvert    1
        option AdvManagedFlag   0
        option AdvOtherConfigFlag 0
        option ignore           0

config prefix
        option interface        'lan'
        # If not specified, a non-link-local prefix of the interface is used
        option prefix           '2001:470:1f0b:9999::/64'
        option AdvOnLink        1
        option AdvAutonomous    1
        option AdvRouterAddr    0
        option ignore           0

config rdnss
        option interface        'lan'
        # If not specified, the link-local address of the interface is used
        option addr             '2001:470:1f0b:9999::/64'
        option ignore           1

Please change the :9999: to reflect your routed /64.

Afterwards, run this:

/etc/init.d/radvd enable
/etc/init.d/radvd start

6. That's it, test it:

The IPv6-Tunnel is automatically brought up and down with your wan connection. So get your wan reconnected now (or just reboot the router) and do a test:

ping6 ipv6.google.com

Test from the router first. If that's working, test from clients within your lan.


7.
The /etc/hotplug.d/iface/15-ipv6 script could also be torn apart and be used from /etc/ppp/ip-[up|down].d/, which also works with little modifiations. I chose to use the hotplug style, because then it is only in one file instead of two.
And the configuration (username, password, tunnelid, ...) could also be migrated to use uci.

If you are having trouble, please double check the IPv6-Adresses! The client IPv6 endpoint and your routed /64 differ: 2001:470:1f0a:9999::/64 versus 2001:470:1f0b:9999::/64


Happy IPv6-ing,
zoo

Re: [10.03] HOWTO enable an IPv6 tunnel to HE.net (tunnelbroker.com)

See http://wiki.openwrt.org/doc/uci/network#protocol.6in4.ipv6-in-ipv4.tunnel and http://wiki.openwrt.org/doc/uci/network#dynamic.ipv6-in-ipv4.tunnel.he.net.only

Re: [10.03] HOWTO enable an IPv6 tunnel to HE.net (tunnelbroker.com)

I tried the 6scripts package, but it did not work as expected on backfire 10.03.

4

Re: [10.03] HOWTO enable an IPv6 tunnel to HE.net (tunnelbroker.com)

It is NOT the 6scripts pacakge it is the 6in4 package.

5 (edited by zoo 2010-07-02 09:13:05)

Re: [10.03] HOWTO enable an IPv6 tunnel to HE.net (tunnelbroker.com)

@Dogge: But the 6in4 package is not included in the 10.03 backfire release, yet.

6

Re: [10.03] HOWTO enable an IPv6 tunnel to HE.net (tunnelbroker.com)

Right!!

Re: [10.03] HOWTO enable an IPv6 tunnel to HE.net (tunnelbroker.com)

Thanks zoo! Your script worked very nicely here. It will do just fine until the 6in4 module is available in backfire.

It's very impressive to have a cheap asus box running at a IPv6 router with he.net!

Re: [10.03] HOWTO enable an IPv6 tunnel to HE.net (tunnelbroker.com)

http://downloads.openwrt.org/snapshots/trunk/brcm47xx/packages/

Better test whats in trunk & file a bug report on whats broken before 10.03.1 is done: they DON'T go back & update older trees (I know: I asked for ospf6d; had to roll my own)

9 (edited by buffl 2012-03-01 09:43:40)

Re: [10.03] HOWTO enable an IPv6 tunnel to HE.net (tunnelbroker.com)

hi

1. recorded on a tunnelbroker.net

2. set:

root @ OpenWrt :/ # opkg install 6in4
 Installing 6in4 (10-1) to root ...
 Downloading http://downloads.openwrt.org/backfire/10.03.1/ar71xx/packages/6in4_1
 0-1_all.ipk.
 Installing ip (2.6.29-1-2) to root ...
 Downloading http://downloads.openwrt.org/backfire/10.03.1/ar71xx/packages/ip_2.6
 .29-1-2_ar71xx. Ipk.
 Installing kmod-ipv6 (2.6.32.27-1) to root ...
 Downloading http://downloads.openwrt.org/backfire/10.03.1/ar71xx/packages/kmod-i
 pv6_2.6.32.27-1_ar71xx.ipk.
 Installing kmod-sit (2.6.32.27-1) to root ...
 Downloading http://downloads.openwrt.org/backfire/10.03.1/ar71xx/packages/kmod-s
 it_2.6.32.27-1_ar71xx.ipk.
 Installing kmod-iptunnel4 (2.6.32.27-1) to root ...
 Downloading http://downloads.openwrt.org/backfire/10.03.1/ar71xx/packages/kmod-i
 ptunnel4_2.6.32.27-1_ar71xx.ipk.
 Configuring ip.
 Configuring kmod-ipv6.
 Configuring kmod-iptunnel4.
 Configuring kmod-sit.
 Configuring 6in4.

3.performed:

uci set network.henet = interface
 uci set network.henet.proto = 6in4
 uci set network.henet.peeraddr = 216.66.84.46
 uci set network.henet.ip6addr = '2001:470:1f14:36e::2/64 '
 uci set network.henet.tunnelid = 132 435
 uci set network.henet.username = tb4eb46e34755d33.56248881
 uci set network.henet.password = 'YOUR_PASSWORD'
 uci commit network

 uci set firewall. @ zone [1]. network = 'wan henet'
 uci commit firewall

 ifup henet
 / etc / init.d / firewall restart

4.installed radvd
root@OpenWrt:/etc/config# cat radvd

 config interface
        option interface        'lan'
        option AdvSendAdvert    1
        option AdvManagedFlag   0
        option AdvOtherConfigFlag 0
        list client            ''
        option ignore           0

config prefix
        option interface        'lan'
        # If not specified, a non-link-local prefix of the interface is used
        list prefix             '2001:470:1f15:36e::/64'
        option AdvOnLink        1
        option AdvAutonomous    1
        option AdvRouterAddr    0
        option ignore           0

config route
        option interface        'lan'
        list prefix             '2001:470:1f15:36e::/64'
        option ignore           1
        option 'AdvRouteLifetime' 'infinity'

config rdnss
        option interface        'lan'
        # If not specified, the link-local address of the interface is used
        list addr               '2001:470:20::2'
        option ignore           1

config dnssl
        option interface        'lan'
        list suffix             ''
        option ignore           1

#config 'radvd'
        #option 'config_file' '/etc/radvd.conf'

5. /etc/config# ifconfig

6in4-hene Link encap:IPv6-in-IPv4
          inet6 addr: 2001:470:1f14:36e::2/64 Scope:Global
          inet6 addr: fe80::57e4:3791/128 Scope:Link
          UP POINTOPOINT RUNNING NOARP  MTU:1280  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

br-lan    Link encap:Ethernet  HWaddr 00:1D:73:B3:EA:B7
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::21d:73ff:feb3:eab7/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:238 errors:0 dropped:0 overruns:0 frame:0
          TX packets:173 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:11322 (11.0 KiB)  TX bytes:98241 (95.9 KiB)

eth0      Link encap:Ethernet  HWaddr 00:1D:73:B3:EA:B7
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2875 errors:0 dropped:0 overruns:92610 frame:0
          TX packets:2719 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:448316 (437.8 KiB)  TX bytes:1518870 (1.4 MiB)
          Interrupt:4

eth1      Link encap:Ethernet  HWaddr 00:1D:73:B3:EA:B8
          inet6 addr: fe80::21d:73ff:feb3:eab8/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:6655 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5794 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1675707 (1.5 MiB)  TX bytes:593316 (579.4 KiB)
          Interrupt:5

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:50 errors:0 dropped:0 overruns:0 frame:0
          TX packets:50 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:5901 (5.7 KiB)  TX bytes:5901 (5.7 KiB)

pppoe-wan Link encap:Point-to-Point Protocol
          inet addr:87.228.55.145  P-t-P:87.228.48.1  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
          RX packets:41 errors:0 dropped:0 overruns:0 frame:0
          TX packets:43 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3
          RX bytes:2981 (2.9 KiB)  TX bytes:3125 (3.0 KiB)

please help

10 (edited by hnyman 2012-03-01 10:38:39)

Re: [10.03] HOWTO enable an IPv6 tunnel to HE.net (tunnelbroker.com)

buffl wrote:

please help

And what is the problem?

That is Backfire, so also make sure that you have edited /etc/sysctl.conf to enable ipv6 forwarding, and rebooted after the change.
http://wiki.openwrt.org/doc/howto/ipv6.essentials#enable.routing

EDIT: you might also read this for pointers on radvd etc. (Current Backfire has firewall pretty ok, so the oldest part about firewall config is outdated.)
https://forum.openwrt.org/viewtopic.php?id=27541

Re: [10.03] HOWTO enable an IPv6 tunnel to HE.net (tunnelbroker.com)

hnyman wrote:
buffl wrote:

please help

And what is the problem?

That is Backfire, so also make sure that you have edited /etc/sysctl.conf to enable ipv6 forwarding, and rebooted after the change.
http://wiki.openwrt.org/doc/howto/ipv6.essentials#enable.routing

EDIT: you might also read this for pointers on radvd etc. (Current Backfire has firewall pretty ok, so the oldest part about firewall config is outdated.)
https://forum.openwrt.org/viewtopic.php?id=27541

thank you

router works

root@OpenWrt:/etc/config# ping ipv6.google.com
PING ipv6.google.com (2a00:1450:4010:c00::68): 56 data bytes
64 bytes from 2a00:1450:4010:c00::68: seq=0 ttl=53 time=95.871 ms
64 bytes from 2a00:1450:4010:c00::68: seq=1 ttl=53 time=90.163 ms
64 bytes from 2a00:1450:4010:c00::68: seq=2 ttl=53 time=90.207 ms
64 bytes from 2a00:1450:4010:c00::68: seq=3 ttl=53 time=92.593 ms
64 bytes from 2a00:1450:4010:c00::68: seq=4 ttl=53 time=91.049 ms
^C
--- ipv6.google.com ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max = 90.163/91.976/95.871 ms

does not work on pc
http://radikal.ru/F/s50.radikal.ru/i130/1203/1e/ea8bab64792d.jpg.html

Re: [10.03] HOWTO enable an IPv6 tunnel to HE.net (tunnelbroker.com)

sorry, my Russian is not that good, and besides, the image site spams tons of popups...

Based on the screenshot I guess that you do not have full ipv6 connectivity at the PC.

Although I usually use SixXS, below is my HEnet config for the relevant parts:.
I define the tunnel IPv6 address and the router's LAN IPv6 addres in /etc/config/network, but nothing in radvd, as it picks up the LAN ipv6 /64 from router's own address. I do not define anything for route, rdnss, dnssl, instead they are set to 'ignore'. So is yours, although there are the other arguments. So it is probably not the radvd config that is the problem.

I think that you are not explicitly defining the ipv6 LAN address from the router itself. Your ifconfig shows only the link-local fe80:: ipv6 address for the router, not a proper routable ipv6 address (2001:... ).

You need to do that in the LAN interface setup (or manually in /etc/config/network)
In your case I guess:
         option 'ip6addr' '2001:470:1f15:36e::1/64'

(just make sure that you use the tunnel ipv6 for the tunnel, and the routable /64 address for the router's LAN address.)


root@OpenWrt:/etc/config# cat network

config 'interface' 'lan'
        option 'ifname' 'eth0.1'
        option 'type' 'bridge'
        option 'proto' 'static'
        option 'ipaddr' '192.168.1.1'
        option 'netmask' '255.255.255.0'
        option 'ip6addr' '2001:d470:28:dddd::1/64'

...

config 'interface' 'sixxs'
        option 'proto' '6in4'
        option 'mtu' '1424'
        option 'ttl' '64'
        option 'peeraddr' '216.66.80.90'
        option 'ip6addr' '2001:d470:27:dddd::2/64'
        option 'tunnelid' '13xxx0'
        option 'username' 'xxxxxxxxx0f4e04.9xxxxx320'
        option 'password' 'xxxxxxx'

root@OpenWrt:/etc/config# cat radvd

config 'interface'
        option 'interface' 'lan'
        option 'AdvSendAdvert' '1'
        option 'AdvManagedFlag' '0'
        option 'AdvOtherConfigFlag' '0'
        list 'client' ''
        option 'ignore' '0'

config 'prefix'
        option 'interface' 'lan'
        option 'AdvOnLink' '1'
        option 'AdvAutonomous' '1'
        option 'ignore' '0'

config 'route'
        option 'interface' 'lan'
        list 'prefix' ''
        option 'ignore' '1'

config 'rdnss'
        option 'interface' 'lan'
        list 'addr' ''
        option 'ignore' '1'

config 'dnssl'
        option 'interface' 'lan'
        list 'suffix' ''
        option 'ignore' '1'

Re: [10.03] HOWTO enable an IPv6 tunnel to HE.net (tunnelbroker.com)

hnyman wrote:

sorry, my Russian is not that good, and besides, the image site spams tons of popups...

Based on the screenshot I guess that you do not have full ipv6 connectivity at the PC.

Although I usually use SixXS, below is my HEnet config for the relevant parts:.
I define the tunnel IPv6 address and the router's LAN IPv6 addres in /etc/config/network, but nothing in radvd, as it picks up the LAN ipv6 /64 from router's own address. I do not define anything for route, rdnss, dnssl, instead they are set to 'ignore'. So is yours, although there are the other arguments. So it is probably not the radvd config that is the problem.

I think that you are not explicitly defining the ipv6 LAN address from the router itself. Your ifconfig shows only the link-local fe80:: ipv6 address for the router, not a proper routable ipv6 address (2001:... ).

You need to do that in the LAN interface setup (or manually in /etc/config/network)
In your case I guess:
         option 'ip6addr' '2001:470:1f15:36e::1/64'

(just make sure that you use the tunnel ipv6 for the tunnel, and the routable /64 address for the router's LAN address.)

sorry, but the Russian-speaking forum no

Installed snapshots.
6tunell dragged ibpcap, kmod-ipv6, kmod-iptunnel14, kmod-sit.
configuration files 6tunell are not absent, but there were addressesauto configured link-local address.

Re: [10.03] HOWTO enable an IPv6 tunnel to HE.net (tunnelbroker.com)

probably not support windose 7 radvd

15 (edited by hnyman 2012-03-05 14:10:41)

Re: [10.03] HOWTO enable an IPv6 tunnel to HE.net (tunnelbroker.com)

buffl wrote:

probably not support windose 7 radvd

I have Win7, which quite nicely gets its ipv6 config from radvd in the Openwrt router.

Did you read my previous message? And did you correct your router's LAN interface ipv6 setup?

Re: [10.03] HOWTO enable an IPv6 tunnel to HE.net (tunnelbroker.com)

hnyman wrote:
buffl wrote:

probably not support windose 7 radvd

I have Win7, which quite nicely gets its ipv6 config from radvd in the Openwrt router.

Did you read my previous message? And did you correct your router's LAN interface ipv6 setup?

Sorry, my english
Customized according to your recommendations

root@OpenWrt:/# cat /etc/sysctl.conf
kernel.panic=3
net.ipv4.conf.default.arp_ignore=1
net.ipv4.conf.all.arp_ignore=1
net.ipv4.ip_forward=1
net.ipv4.icmp_echo_ignore_broadcasts=1
net.ipv4.icmp_ignore_bogus_error_responses=1
net.ipv4.tcp_ecn=0
net.ipv4.tcp_fin_timeout=30
net.ipv4.tcp_keepalive_time=120
net.ipv4.tcp_syncookies=1
net.ipv4.tcp_timestamps=0
net.netfilter.nf_conntrack_checksum=0
net.ipv4.netfilter.ip_conntrack_checksum=0
net.ipv4.netfilter.ip_conntrack_max=16384
net.ipv4.netfilter.ip_conntrack_tcp_timeout_established=3600
net.ipv4.netfilter.ip_conntrack_udp_timeout=60
net.ipv4.netfilter.ip_conntrack_udp_timeout_stream=180
net.ipv6.conf.all.forwarding=1

# disable bridge firewalling by default
net.bridge.bridge-nf-call-arptables=0
net.bridge.bridge-nf-call-ip6tables=0
net.bridge.bridge-nf-call-iptables=0
root@OpenWrt:/# cat etc/config/network

config 'interface' 'loopback'
        option 'ifname' 'lo'
        option 'proto' 'static'
        option 'ipaddr' '127.0.0.1'
        option 'netmask' '255.0.0.0'

config 'interface' 'lan'
        option 'ifname' 'eth0'
        option 'type' 'bridge'
        option 'proto' 'static'
        option 'ipaddr' '192.168.1.1'
        option 'netmask' '255.255.255.0'
        option 'ip6addr' '2001:470:1f14:36e::1/64'

config 'interface' 'wan'
        option 'ifname' 'eth1'
        option '_orig_ifname' 'eth1'
        option '_orig_bridge' 'false'
        option 'proto' 'pppoe'
        option 'username' 'vip6789'
        option 'password' 'DVFBoKko'

config 'switch'
        option 'name' 'switch0'
        option 'reset' '1'
        option 'enable_vlan' '1'

config 'switch_vlan'
        option 'device' 'switch0'
        option 'vlan' '1'
        option 'ports' '0 1 2 3 5'

config 'interface' 'henet'
        option 'proto' '6in4'
        option 'peeraddr' '216.66.84.46'
        option 'ip6addr' '2001:470:1f14:36e::2/64'
        option 'tunnelid' '173849'
        option 'username' 'tb4eb46e678976d33.56278900'
        option 'password' 'e3a2600i5jj43ikf04i50fe3ergt9'
root@OpenWrt:/# cat etc/config/randvd
cat: can't open 'etc/config/randvd': No such file or directory
root@OpenWrt:/# cat etc/config/radvd
config interface
        option interface        'lan'
        option AdvSendAdvert    1
        option AdvManagedFlag   0
        option AdvOtherConfigFlag 0
        list client             ''
        option ignore           0

config prefix
        option interface        'lan'
        # If not specified, a non-link-local prefix of the interface is used
        list prefix             ''
        option AdvOnLink        1
        option AdvAutonomous    1
        #option AdvRouterAddr   0
        option ignore           0

config route
        option interface        'lan'
        list prefix             ''
        option ignore           1

config rdnss
        option interface        'lan'
        # If not specified, the link-local address of the interface is used
        list addr               ''
        option ignore           1

config dnssl
        option interface        'lan'
        list suffix             ''
        option ignore           1
6in4-hene Link encap:IPv6-in-IPv4
          inet6 addr: 2001:470:1f14:36e::2/64 Scope:Global
          inet6 addr: fe80::57e4:3791/128 Scope:Link
          UP POINTOPOINT RUNNING NOARP  MTU:1280  Metric:1
          RX packets:6235 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6137 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:475564 (464.4 KiB)  TX bytes:451796 (441.2 KiB)

br-lan    Link encap:Ethernet  HWaddr 00:1D:73:B3:EA:B7
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: 2001:470:1f14:36e::1/64 Scope:Global
          inet6 addr: fe80::21d:73ff:feb3:eab7/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:21945 errors:0 dropped:0 overruns:0 frame:0
          TX packets:22066 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1919418 (1.8 MiB)  TX bytes:7102060 (6.7 MiB)

eth0      Link encap:Ethernet  HWaddr 00:1D:73:B3:EA:B7
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:39992 errors:0 dropped:0 overruns:372704 frame:0
          TX packets:40822 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:3807523 (3.6 MiB)  TX bytes:16226473 (15.4 MiB)
          Interrupt:4

eth1      Link encap:Ethernet  HWaddr 00:1D:73:B3:EA:B8
          inet6 addr: fe80::21d:73ff:feb3:eab8/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:64753 errors:0 dropped:0 overruns:0 frame:0
          TX packets:55074 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:18966130 (18.0 MiB)  TX bytes:4522042 (4.3 MiB)
          Interrupt:5

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:77 errors:0 dropped:0 overruns:0 frame:0
          TX packets:77 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:8336 (8.1 KiB)  TX bytes:8336 (8.1 KiB)

pppoe-wan Link encap:Point-to-Point Protocol
          inet addr:87.228.55.145  P-t-P:87.228.48.1  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
          RX packets:27001 errors:0 dropped:0 overruns:0 frame:0
          TX packets:25968 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3
          RX bytes:7376539 (7.0 MiB)  TX bytes:2161134 (2.0 MiB)
C:\windows\system32>ipconfig /all

????????? ????????? IP ??? Windows

   ??? ??????????  . . . . . . . . . : viena-PC
   ???????? DNS-???????  . . . . . . :
   ??? ????. . . . . . . . . . . . . : ?????????
   IP-????????????? ???????? . . . . : ???
   WINS-?????? ??????? . . . . . . . : ???

Ethernet adapter ??????????? ?? ????????? ???? 3:

   DNS-??????? ??????????? . . . . . :
   ????????. . . . . . . . . . . . . : ??????? ???????? ????? Intel(R) PRO/1000
MT
   ?????????? ?????. . . . . . . . . : 00-07-E9-0F-B7-A0
   DHCP ???????. . . . . . . . . . . : ???
   ????????????? ????????. . . . . . : ??
   IPv6-?????. . . . . . . . . . . . : 2001:470:1f14:36e:dfe:94f8:5f51:d5ae(????
????)
   ????????? IPv6-?????. . . . . . . : 2001:470:1f14:36e:c5e0:7f94:78e0:86f(????
????)
   ????????? IPv6-????? ?????? . . . : fe80::dfe:94f8:5f51:d5ae%18(????????)
   IPv4-?????. . . . . . . . . . . . : 192.168.1.6(????????)
   ????? ??????? . . . . . . . . . . : 255.255.255.0
   ???????? ????. . . . . . . . . : fe80::21d:73ff:feb3:eab7%18
                                       192.168.1.1
   DNS-???????. . . . . . . . . . . : 192.168.1.1
                                       8.8.8.8
                                       8.8.4.4
   NetBios ????? TCP/IP. . . . . . . . : ???????

Ethernet adapter ??????????? ?? ????????? ????* 3:

   ????????? ?????. . . . . . . . : ????? ???????? ??????????.
   DNS-??????? ??????????? . . . . . : hshld.com
   ????????. . . . . . . . . . . . . : Anchorfree HSS Adapter
   ?????????? ?????. . . . . . . . . : 00-FF-DE-C1-7B-26
   DHCP ???????. . . . . . . . . . . : ??
   ????????????? ????????. . . . . . : ??

?????????? ??????? isatap.{F3E45036-5465-4FCA-A307-A686357FF706}:

   ????????? ?????. . . . . . . . : ????? ???????? ??????????.
   DNS-??????? ??????????? . . . . . :
   ????????. . . . . . . . . . . . . : ??????? Microsoft ISATAP
   ?????????? ?????. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP ???????. . . . . . . . . . . : ???
   ????????????? ????????. . . . . . : ??

?????????? ??????? isatap.hshld.com:

   ????????? ?????. . . . . . . . : ????? ???????? ??????????.
   DNS-??????? ??????????? . . . . . :
   ????????. . . . . . . . . . . . . : ??????? Microsoft ISATAP #4
   ?????????? ?????. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP ???????. . . . . . . . . . . : ???
   ????????????? ????????. . . . . . : ??

17 (edited by hnyman 2012-03-05 15:51:44)

Re: [10.03] HOWTO enable an IPv6 tunnel to HE.net (tunnelbroker.com)

buffl wrote:

Customized according to your recommendations

Almost, but not quite:

You have set  option 'ip6addr' '2001:470:1f14:36e::1/64'  for router LAN ipv6.
That is probaly wrong as your HEnet tunnel has option 'ip6addr' '2001:470:1f14:36e::2/64' and ::1 is the other tunnel end.

The LAN ipv6 should be from the routable /64 segment, probably '2001:470:1f15:36e::1/64' , like I already suggested in my previous message.

Tunnel ipv6 ::1 and ::2 segment is used for nothing else, instead you have the routable /64 from which you need to assign an address for the router LAN.

Read the user-specific info you have got from HEnet, and make sure to use the tunnel addresses for the tunnel, and routable /64 for router LAN and radvd.

Re: [10.03] HOWTO enable an IPv6 tunnel to HE.net (tunnelbroker.com)

hnyman
buggy but it worked, big thank