1 (edited by stich86 2012-03-02 17:54:49)

Topic: Netgear MBRN3000

Hi guys,

i'm trying to install Backfire on a Netgear MBRN3000. It's essentialy a DGN2200 without ADSL modem, based on BCM6358

here is the output of CFE boot:

DGN2200 Boot Code V1.0.5
CFE version 1.0.37-102.9 for BCM96358 (32bit,SP,BE)
Build Date: Wed Oct  7 14:22:12 CST 2009 (neil@dev2)
Copyright (C) 2000-2009 Broadcom Corporation.

Parallel flash device: name AM29DL800B, id 0x22cb, size 8192KB
CPU type 0x2A010: 300MHz, Bus: 133MHz, Ref: 64MHz
CPU running TP0
Total memory: 33554432 bytes (32MB)
Boot Address 0xbe000000


Board IP address                  : 192.168.1.1:ffffff00
Host IP address                   : 192.168.1.100
Gateway IP address                :
Run from flash/host (f/h)         : f
Default host run file name        : vmlinux
Default host flash file name      : bcm963xx_fs_kernel
Boot delay (0-9 seconds)          : 1
Board Id (0-5)                    : 96358VW
Number of MAC Addresses (1-32)    : 11
Base MAC Address                  : 30:46:9a:62:9e:f0
PSI Size (1-64) KBytes            : 48
Main Thread Number [0|1]          : 0

i've tried to compile the original firmware from Netgear but it compile and doesn't boot with the error:

Warning: unable to open an initial console.


It use for firmware image, the TRX format with the signature
reading the original command that create netgear firmware, i've tried to make a trx image combine kernel and root fs,

we i try to flash the new image with the command "flashimage" i got this error after finished loading:

**Exception 32: EPC=8042785C, Cause=8041DD04 (TLBMod   )
                RA=00435870, VAddr=8041DD04

any suggestion?

many thanks!

Re: Netgear MBRN3000

i've made some steps

first seems that this CFE doesn't have "CFE1CFE1" signature sad
second i've flashed a firmware w/CFE (but also this haven't sign) of a D-Link 2760U

anyone has a CFE 1.0.37-102.9 with a valid signature?

Re: Netgear MBRN3000

Hi!

Sorry to bump this up :-P

Any progress on your attempt to get this working?
I am receiving mine tomorrow, just wondering :-P

Thanks.
Regards,
--
/C