Topic: Dockstar does not answer after installing image - Please HELP

After installing successfully

mw 0x6400000 0xffff 0x200000
tftpboot 0x6400000 openwrt-kirkwood-Dockstar-jffs2-128k.img


I forgot to type these 2 lines:
nand erase 0x500000 0xfb00000
nand write.e 0x6400000 0x500000 0x200000

and booted

now the device does not seem to answer anything
on serial console

nevertheless the device is hot ( so not dead yet ) but not blinking anymore

any advice would be welcome

Re: Dockstar does not answer after installing image - Please HELP

You just forgot to flash the kernel to NAND.  So if you press the reset button you should still get back into u-boot so you can try again. You didn't do any other "nand erase" commands, did you?

Re: Dockstar does not answer after installing image - Please HELP

ecc wrote:

You just forgot to flash the kernel to NAND.  So if you press the reset button you should still get back into u-boot so you can try again. You didn't do any other "nand erase" commands, did you?

I did install

#single stage bootloader

mw 0x800000 0xffff 0x40000
tftpboot 0x800000 openwrt-kirkwood-dockstar-u-boot.bin
nand erase 0x000000 0x80000
nand write.e 0x800000 0x000000 0x40000
setenv bootcmd nand read.e 0x2000000 0x100000 0x400000\; go 0x2000000
saveenv


and the uImage

mw 0x6400000 0xffff 0x300000
tftpboot 0x6400000 openwrt-kirkwood-uImage
nand erase 0x100000 0x400000
nand write.e 0x6400000 0x100000 0x400000


After installing successfully

mw 0x6400000 0xffff 0x200000
tftpboot 0x6400000 openwrt-kirkwood-Dockstar-jffs2-128k.img


I forgot to type these 2 lines:
nand erase 0x500000 0xfb00000
nand write.e 0x6400000 0x500000 0x200000

and booted

reset does not seem to work,no blinking

but the device is hot ...

Re: Dockstar does not answer after installing image - Please HELP

If you're not seeing anything on the serial connection after reset, perhaps the u-boot you flashed is using netconsole instead of the serial port?  If not, I don't how to recover except via JTAG.

Re: Dockstar does not answer after installing image - Please HELP

ecc wrote:

If you're not seeing anything on the serial connection after reset, perhaps the u-boot you flashed is using netconsole instead of the serial port?  If not, I don't how to recover except via JTAG.

Excuse my ignorancy,
what is netconsole? and what is JTAG ?

Re: Dockstar does not answer after installing image - Please HELP

mickbox wrote:

Excuse my ignorancy, what is netconsole? and what is JTAG ?

Netconsole is a u-boot feature that uses the network for its I/O instead of the serial console.  See this thread for example.

JTAG is a hardware debugging interface that can be used to write images into RAM or flash, even if the board has been "bricked".  It's the only way to recover from a truly broken u-boot, for example. See this article for more info.