Topic: Is Watchdog still broke on OM1P

I have two units that I've loaded http://downloads.openwrt.org/backfire/10.03.1-rc5/atheros/ on and units still reboot after 5 minutes.

Used the below files

openwrt-atheros-root.squashfs
openwrt-atheros-vmlinux.lzma

Also tried it with: openwrt-atheros-root.jffs2-64k 

I then tried http://downloads.openwrt.org/backfire/10.03.1-rc6/atheros/

openwrt-atheros-root.squashfs
openwrt-atheros-vmlinux.lzma

Did not try openwrt-atheros-root.jffs2-64k

Same results reboots every 5 minutes.

One unit mac address starts with: 00:12:CF:CB
Second unit's mac address starts with: 70:72:CF:20

I've used ap51-flash-gui and also FonFlash to flash these two units.

Still no luck, I have a brand new unit but have not tried the software yet

Maybe these two units were damaged somehow not sure.

Or am I using the incorrect software?

Any suggestions?

Thanks

Re: Is Watchdog still broke on OM1P

Ok,

I pulled the hw-heartbeat.sh from the open-mesh default software and created a cron by copying the same cron run from the om1p default software.
radio has now been up for 31 minutes and logs have the cron job listed.

Have not looked at the cron.err yet working looking at this now.

Jan 29 16:57:01 OpenWrt cron.err crond[962]: USER root pid 6627 cmd /sbin/hw-heartbeat.sh
Jan 29 16:57:02 OpenWrt user.notice hw-heartbeat.sh: signaling to the hw-watchdog

hw-heartbeat.sh committed out the call to the uci from the org code

#!/bin/sh
# /sbin/hw-heartbeat.sh
#  send heartbeat to the hardware watchdog 

GPO="3"
MCTL="4"

# [ "$(uci get node.general.hw_watchdog)" -eq 1 ] && { 
    gpioctl dirout $GPO ; gpioctl clear $GPO
    sleep 1
    gpioctl set $GPO
    logger -st ${0##*/} "signaling to the hw-watchdog"
# }
#

Cron

0-59/3    *    *    *    * /sbin/hw-heartbeat.sh

Thoughts?

Re: Is Watchdog still broke on OM1P

cron.err looks like it's is a busybox issue - non critical low log error.

Would have to compile a new version to get rid of the cron.err file or not log it.