Re: wzr-hp-ag300h progress

dimitris wrote:
Yoray wrote:

I flashed the trunk firmware and Luci successfully, but I found all the lights except Power light are not work well, dose anybody help to fix this bug? or what can i do to make it? Thank you guys.

I'm running the 2011-OCT-27 trunk build (r28601), without any USB sticks used (yet).  The only light that doesn't "behave" is the 2.4GHz LED, which is lit up orange even though the only 2.4GHz network I've defined is encrypted.  I've opened a ticket about it but it doesn't seem to have received any attention.

Alnico wrote:

Has anyone been able to get good stability on the ag300h with both radios enabled using OpenWRT?  I see some post here saying people got it installed but no comments about subseqent performance.  My ag300h drops 2.4 2-5 times a day requiring hard power reset to recover.

I've been turning on only the 5GHz radio until today, with no stability problems whatsoever.  I've now turned on the 2.4GHz radio as well, and connected an Android device to it.  Very light traffic (mostly idle, some apps doing periodic updates and such in the background), but I'll try some audio/video calls later and I'll update this thread.

Well, almost 24 hours of light usage later I haven't seen any problems.  The radios/WLANs are configured as specified in the ticket linked above.  I do not have LuCI installed on the router.  Perhaps it's some other package that's causing/triggering the instability, or some config option?

@Alnico: Which WPA authenticator are you using?  I'm using the default from the trunk builds, wpad-mini.  Also, can you post your 2.4 radio/WLAN config section?

Re: wzr-hp-ag300h progress

Hi,


How's it going?

Anyone is working on improving openwrt support?

Re: wzr-hp-ag300h progress

Hello I have brought a Buffalo WZR-HP-AG300H and I'm trying to configure VLANs, but I have't been able to do it.

I'm using the following version of openwrt

ATTITUDE ADJUSTMENT (bleeding edge, r29721)

I want to have each port of the eth0 switch in a different VLAN, just to test I have defined a new interface in port number 4. This is my configuration


root@OpenWrt:~# cat /etc/config/network

config 'interface' 'loopback'
    option 'ifname' 'lo'
    option 'proto' 'static'
    option 'ipaddr' '127.0.0.1'
    option 'netmask' '255.0.0.0'

config 'interface' 'lan'
    option 'ifname' 'eth0'
    option 'type' 'bridge'
    option 'proto' 'static'
    option 'ipaddr' '192.168.1.1'
    option 'netmask' '255.255.255.0'

config 'interface' 'wan'
    option 'ifname' 'eth1'
    option '_orig_ifname' 'eth1'
    option '_orig_bridge' 'false'
    option 'proto' 'static'
    option 'dns' '8.8.8.8'
    option 'ipaddr' '154.128.23.17'
    option 'netmask' '255.255.255.0'
    option 'gateway' '154.128.23.1'
    option 'broadcast' '154.128.23.255'

config 'switch'
    option 'name' 'eth0'
    option 'reset' '1'
    option 'enable_vlan' '1'

config 'switch_vlan'
    option 'device' 'eth0'
    option 'vlan' '1'
    option 'vid' '1'
    option 'ports' '0 1'

config 'switch_vlan'
    option 'device' 'eth0'
    option 'vlan' '2'
    option 'vid' '2'
    option 'ports' '2'

config 'switch_vlan'
    option 'device' 'eth0'
    option 'vlan' '3'
    option 'vid' '3'
    option 'ports' '3'

config 'switch_vlan'
    option 'device' 'eth0'
    option 'vlan' '4'
    option 'ports' '4'
    option 'vid' '4'

config 'interface' 'lan4'
    option 'proto' 'static'
    option 'ifname' 'eth0.4'
    option 'ipaddr' '192.168.4.1'
    option 'netmask' '255.255.255.0'

I can ping 192.168.1.1 (on port #1) but I can't ping 192.168.4.1 (on port #4).

If I add port 0 (CPU) on vlan 4 (tagged) I can't acces the router in any port (I have to acces through eth1).

If I add port 0 (CPU) on vlan 4 (untagged) it says «Port 1 is untagged in multiple VLANs!».

Any ideas?

thanks in advance.

79

Re: wzr-hp-ag300h progress

All your vlans are lacking a cpu port, the existing lan must be made tagged, vid is optional if it equals to vlan.

config 'interface' 'loopback'
    option 'ifname' 'lo'
    option 'proto' 'static'
    option 'ipaddr' '127.0.0.1'
    option 'netmask' '255.0.0.0'

config 'interface' 'lan'
    option 'ifname' 'eth0.1'
    option 'type' 'bridge'
    option 'proto' 'static'
    option 'ipaddr' '192.168.1.1'
    option 'netmask' '255.255.255.0'

config 'interface' 'lan4'
    option 'proto' 'static'
    option 'ifname' 'eth0.4'
    option 'ipaddr' '192.168.4.1'
    option 'netmask' '255.255.255.0'

config 'interface' 'wan'
    option 'ifname' 'eth1'
    option 'proto' 'static'
    option 'dns' '8.8.8.8'
    option 'ipaddr' '154.128.23.17'
    option 'netmask' '255.255.255.0'
    option 'gateway' '154.128.23.1'
    option 'broadcast' '154.128.23.255'

config 'switch'
    option 'name' 'eth0'
    option 'reset' '1'
    option 'enable_vlan' '1'

config 'switch_vlan'
    option 'device' 'eth0'
    option 'vlan' '1'
    option 'ports' '0 1 5t'

config 'switch_vlan'
    option 'device' 'eth0'
    option 'vlan' '2'
    option 'ports' '2 5t'

config 'switch_vlan'
    option 'device' 'eth0'
    option 'vlan' '3'
    option 'ports' '3 5t'

config 'switch_vlan'
    option 'device' 'eth0'
    option 'vlan' '4'
    option 'ports' '4 5t'

Re: wzr-hp-ag300h progress

Dimitris, is it still stable?

Re: wzr-hp-ag300h progress

jow wrote:

All your vlans are lacking a cpu port, the existing lan must be made tagged, vid is optional if it equals to vlan.

Thank you very much for your response, but that is not the problem (I have tested it just for being sure and I can't access the router)

  In this router cpu port is the #0 port. I had tried  adding it in all vlans

option 'ports' '0t 1'

...

option 'ports' '0t 2'

...

but it does not respond in any eth0 port.

May be the problem is that VLANs are not well supported for this router. Anyone does know if they are supported?

Thanks again, MIGUEL.


jow wrote:
...

config 'switch'
    option 'name' 'eth0'
    option 'reset' '1'
    option 'enable_vlan' '1'

config 'switch_vlan'
    option 'device' 'eth0'
    option 'vlan' '1'
    option 'ports' '0 1 5t'

config 'switch_vlan'
    option 'device' 'eth0'
    option 'vlan' '2'
    option 'ports' '2 5t'

config 'switch_vlan'
    option 'device' 'eth0'
    option 'vlan' '3'
    option 'ports' '3 5t'

config 'switch_vlan'
    option 'device' 'eth0'
    option 'vlan' '4'
    option 'ports' '4 5t'

82

Re: wzr-hp-ag300h progress

Make sure that your lan interface is eth0.1 like in jow's example, and NOT eth0 like in your original post.

83

Re: wzr-hp-ag300h progress

You should not listen for traffic on eth0 but eth0.x!

Re: wzr-hp-ag300h progress

snk wrote:

Make sure that your lan interface is eth0.1 like in jow's example, and NOT eth0 like in your original post.

That was the problem. Solved!!

This is my configuration (/etc/config/network), only port 4 has an IP assigned.

config 'interface' 'loopback'
    option 'ifname' 'lo'
    option 'proto' 'static'
    option 'ipaddr' '127.0.0.1'
    option 'netmask' '255.0.0.0'

config 'interface' 'lan'
    option 'type' 'bridge'
    option 'proto' 'static'
    option 'ipaddr' '192.168.1.1'
    option 'netmask' '255.255.255.0'
    option '_orig_ifname' 'eth0 radio0.network1 radio1.network1'
    option '_orig_bridge' 'true'
    option 'ifname' 'eth0.1'

config 'interface' 'wan'
    option 'ifname' 'eth1'
    option '_orig_ifname' 'eth1'
    option '_orig_bridge' 'false'
    option 'proto' 'static'
    option 'dns' '8.8.8.8'
    option 'ipaddr' '154.128.23.17'
    option 'netmask' '255.255.255.0'
    option 'gateway' '154.128.23.1'
    option 'broadcast' '154.128.23.255'

config 'switch'
    option 'name' 'eth0'
    option 'reset' '1'
    option 'enable_vlan' '1'

config 'switch_vlan'
    option 'device' 'eth0'
    option 'vlan' '1'
    option 'vid' '1'
    option 'ports' '0t 1'

config 'switch_vlan'
    option 'device' 'eth0'
    option 'vlan' '2'
    option 'vid' '2'
    option 'ports' '0t 2'

config 'switch_vlan'
    option 'device' 'eth0'
    option 'vlan' '3'
    option 'vid' '3'
    option 'ports' '0t 3'

config 'switch_vlan'
    option 'device' 'eth0'
    option 'vlan' '4'
    option 'vid' '4'
    option 'ports' '0t 4'

config 'interface' 'lan4'
    option 'proto' 'static'
    option 'ifname' 'eth0.4'
    option 'ipaddr' '192.168.4.1'
    option 'netmask' '255.255.255.0'

Thank you very much for your responses.

  MIGUEL.

85 (edited by dinoc 2012-03-08 07:46:12)

Re: wzr-hp-ag300h progress

Managed to install OpenWrt Firmware Attitude Adjustment (r30753) / LuCI Trunk (trunk+svn8323)

Set up the WiFi 2.4Ghz (only, the 5Ghz is disabled) , WPA2, AES only, Turbo(40Mhz) ... look at the status

Mode: Master | SSID: xxxx
BSSID: xxxxxx | Encryption: WPA2 PSK (CCMP)
Channel: 1 (2.412 GHz) | Tx-Power: 15 dBm
Signal: -57 dBm | Noise: -91 dBm
Bit Rate: 52.0 MBit/s | Country:

I've reverted back to Brian's dd-wrt firmware 18024 where I have a rate of 300Mbps but TX-Power is the same 15 dBm, but I least I have the proper 300Mbps rate.

Buffalo WZR-HP-AG300H

Re: wzr-hp-ag300h progress

Never give up please, in openwrt /etc/wireless, install the option "noscan 1", which might make you get the full speed again.

dinoc wrote:

Managed to install OpenWrt Firmware Attitude Adjustment (r30753) / LuCI Trunk (trunk+svn8323)

Set up the WiFi 2.4Ghz (only, the 5Ghz is disabled) , WPA2, AES only, Turbo(40Mhz) ... look at the status

Mode: Master | SSID: xxxx
BSSID: xxxxxx | Encryption: WPA2 PSK (CCMP)
Channel: 1 (2.412 GHz) | Tx-Power: 15 dBm
Signal: -57 dBm | Noise: -91 dBm
Bit Rate: 52.0 MBit/s | Country:

I've reverted back to Brian's dd-wrt firmware 18024 where I have a rate of 300Mbps but TX-Power is the same 15 dBm, but I least I have the proper 300Mbps rate.

87 (edited by joergherzinger 2012-04-24 10:29:32)

Re: wzr-hp-ag300h progress

Hi. I am currently palying around with this thingy and just found that the snapshot is missing. http://downloads.openwrt.org/snapshots/trunk/ar71xx/
Has anything changed in OpenWRT or why is this trunk almost completely empty?

Re: wzr-hp-ag300h progress

I just tried the newest trunk an I am having serious troubles with wifi. Whenever I restart wifi I can see the wireless network on my client for a short time (10 to 20 sec) and then it disappears again.
This is my config:

config interface 'lan'
    option ifname 'eth0'
    option type 'bridge'
    option proto 'dhcp'
    option macaddr '4C:E6:76:F9:01:01'
    option stp '1'
config switch
    option name 'eth0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'eth0'
    option vlan '1'
    option ports '0 1 2 3 4'
config wifi-iface
    option device 'radio0'
    option mode 'ap'
    option ssid 'global2000-intern'
    option encryption 'psk2'
    option key 'blablubb1'
    option network 'lan'

Almost everything is default and so I just don't get why this doesn't work.

Re: wzr-hp-ag300h progress

joergherzinger wrote:

I just tried the newest trunk an I am having serious troubles with wifi. Whenever I restart wifi I can see the wireless network on my client for a short time (10 to 20 sec) and then it disappears again.

Almost everything is default and so I just don't get why this doesn't work.

did you ever figure out what was wrong? I assume you've updated to a newer revision by now, what are you using?

wzr-hp-ag300h (trunk r33326)