Topic: RouterStation Pro no internet connection

Hello,

I'm just bought a RouterStation Pro, and I'm having trouble getting it to connect to the internet.  I'm relatively familiar with linux, but I've never used OpenWrt before.  Here's what I've got going on:


ISP<---- Cable Modem (Motorola SB5101U)<---- RouterStation Pro (RSP)<----- clients/PCs


Right now, I've got the cable modem plugged into the WAN port of the RSP, and I'm using a PC to serial into the RSP.  I installed new firmware, per this guide.

Here's my network config file:

config interface loopback
        option ifname   lo
        option proto    static
        option ipaddr   127.0.0.1
        option netmask  255.0.0.0

config interface lan
        option ifname   eth1
        option type     bridge
        option proto    static
        option ipaddr   192.168.1.1
        option netmask  255.255.255.0

config interface wan
        option ifname   eth0
        option proto    dhcp

config switch
        option name     eth1
        option reset    1
        option enable_vlan 1

config switch_vlan
        option device   eth1
        option vlan     1
        option ports    "0 1 2 3 4"

It's the default of the firmware image.  I screwed around with it, didn't get any results, and then put it back to normal.  I have a stock linksys WRT150N that is able to plug into the cable modem and reach the internet without any issues.  It seems to me that since I have the wan interface set to DHCP, the RSP should pull all the information it needs from the modem, but it doesn't seem to be working.  Here's what happens when I restart the network configuration:

root@OpenWrt:/# /etc/init.d/network restart
br-lan: port 1(eth1) entering disabled state
eth1: link down
device eth1 left promiscuous mode
br-lan: port 1(eth1) entering disabled state
Received SIGTERM
Entering released state
eth0: link down
device eth1 entered promiscuous mode
udhcpc (v1.15.3) started
root@OpenWrt:/# eth0: link up (100Mbps/Full duplex)
Sending discover...
eth1: link up (1000Mbps/Full duplex)
br-lan: port 1(eth1) entering forwarding state
Sending discover...
Sending discover...

It looks like the RSP is reachingout, but it's not getting a response from the modem?

Does anyone have any thoughts?  I'd really appreciate some help here.  I look forward to your wisdom.  Thanks!

-Snapplepop



Here's my bootup output:

+
AR8316 PHY found on MAC0
AR8316 PHY found on MAC1
Ethernet eth0: MAC address 00:15:6d:c8:da:18
IP: 192.168.1.20/255.255.255.0, Gateway: 0.0.0.0
Default server: 0.0.0.0

RedBoot(tm) bootstrap and debug environment [ROMRAM]
Ubiquiti Networks certified release, version 0.9.00318M.0905121200 - built 12:01:38, May 12 2009

Copyright (C) 2000, 2001, 2002, 2003, 2004 Red Hat, Inc.

Board: Ubiquiti RouterStation PRO
 Arch: ar7100pro
  RAM: 0x80000000-0x88000000, [0x8003bf00-0x87fe1000] available
Flash: 0xbf000000-0xc0000000, in 256 blocks of 0x00010000 bytes each
== Executing boot script in 1.000 seconds - enter ^C to abort
RedBoot> fis load -d -e kernel
Trying LZMA decompression...
Image loaded from 0x80060000-0x803039c0
Image is not ELF, skipping ELF parsing...
RedBoot> exec
Now booting linux kernel:
 Base address 0x80050000 Entry 0x80060000
 memsize=0x08000000
 modetty0=0,n,8,1,hw
 board=RouterStation PRO
 ethaddr=00.15.6d.c8.da.18
Linux version 2.6.32.27 (jow@nd-build-02.linux-appliance.net) (gcc version 4.3.3 (GCC) ) #5 Wed Dec 21 01:59:33 CET 2011
bootconsole [early0] enabled
CPU revision is: 00019374 (MIPS 24Kc)
Atheros AR7161 rev 2, CPU:720.000 MHz, AHB:180.000 MHz, DDR:360.000 MHz
Determined physical RAM map:
 memory: 08000000 @ 00000000 (usable)
Initrd not found or empty - disabling initrd
Zone PFN ranges:
  Normal   0x00000000 -> 0x00008000
Movable zone start PFN for each node
early_node_map[1] active PFN ranges
    0: 0x00000000 -> 0x00008000
Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 32512
Kernel command line: rootfstype=squashfs,yaffs,jffs2 noinitrd console=ttyS0,115200 board=UBNT-RSPRO board=RouterStation PRO ethaddr=00.15.6d.c8.da.18
PID hash table entries: 512 (order: -1, 2048 bytes)
Dentry cache hash table entries: 16384 (order: 4, 65536 bytes)
Inode-cache hash table entries: 8192 (order: 3, 32768 bytes)
Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
Writing ErrCtl register=0003c022
Readback ErrCtl register=0003c022
Memory: 126576k/131072k available (2126k kernel code, 4332k reserved, 423k data, 152k init, 0k highmem)
SLUB: Genslabs=7, HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
Hierarchical RCU implementation.
NR_IRQS:56
Calibrating delay loop... 478.41 BogoMIPS (lpj=2392064)
Mount-cache hash table entries: 512
NET: Registered protocol family 16
MIPS: machine is Ubiquiti RouterStation Pro
registering PCI controller with io_map_base unset
bio: create slab <bio-0> at 0
pci 0000:00:00.0: PME# supported from D0 D1 D2 D3hot
pci 0000:00:00.0: PME# disabled
Switching to clocksource MIPS
NET: Registered protocol family 2
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 4096 (order: 3, 32768 bytes)
TCP bind hash table entries: 4096 (order: 2, 16384 bytes)
TCP: Hash tables configured (established 4096 bind 4096)
TCP reno registered
NET: Registered protocol family 1
squashfs: version 4.0 (2009/01/31) Phillip Lougher
Registering mini_fo version $Id$
JFFS2 version 2.2. (NAND) (SUMMARY)  © 2001-2006 Red Hat, Inc.
yaffs Dec 10 2011 18:14:12 Installing.
msgmni has been set to 247
io scheduler noop registered
io scheduler deadline registered (default)
Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled
serial8250.0: ttyS0 at MMIO 0x18020000 (irq = 11) is a 16550A
console [ttyS0] enabled, bootconsole disabled
console [ttyS0] enabled, bootconsole disabled
Atheros AR71xx SPI Controller driver version 0.2.4
m25p80 spi0.0: mx25l12805d (16384 Kbytes)
Searching for RedBoot partition table in spi0.0 at offset 0xfe0000
Searching for RedBoot partition table in spi0.0 at offset 0xff0000
5 RedBoot partitions found on MTD device spi0.0
Creating 5 MTD partitions on "spi0.0":
0x000000000000-0x000000030000 : "RedBoot"
0x000000030000-0x000000110000 : "kernel"
0x000000110000-0x000000ff0000 : "rootfs"
mtd: partition "rootfs" set to be root filesystem
mtd: partition "rootfs_data" created automatically, ofs=2F0000, len=D00000
0x0000002f0000-0x000000ff0000 : "rootfs_data"
0x000000ff0000-0x000000fff000 : "FIS directory"
0x000000fff000-0x000001000000 : "RedBoot config"
ag71xx_mdio: probed
eth0: Atheros AG71xx at 0xb9000000, irq 4
eth1: Atheros AG71xx at 0xba000000, irq 5
eth1: AR8316 switch driver attached.
Atheros AR71xx hardware watchdog driver version 0.1.0
TCP westwood registered
NET: Registered protocol family 17
802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>
All bugs added by David S. Miller <davem@redhat.com>
VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
Freeing unused kernel memory: 152k freed
Please be patient, while OpenWrt loads ...
input: gpio-buttons as /devices/platform/gpio-buttons/input/input0
Button Hotplug driver version 0.3.1
- preinit -
Registered led device: ubnt:green:rf
Press the [f] key and hit [enter] to enter failsafe mode
eth0: link up (100Mbps/Full duplex)
- regular preinit -
switching to jffs2
mini_fo: using base directory: /
mini_fo: using storage directory: /overlay
- init -
eth0: link down

Please press Enter to activate this console. device eth1 entered promiscuous mode
Compat-wireless backport release: compat-wireless-2011-11-08-1-g4ab9b62
Backport based on wireless-testing.git master-2011-11-15
eth0: link up (100Mbps/Full duplex)
cfg80211: Calling CRDA to update world regulatory domain
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
eth1: link up (1000Mbps/Full duplex)
br-lan: port 1(eth1) entering forwarding state
usbcore: registered new device driver usb
cfg80211: World regulatory domain updated:
cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
cfg80211:     (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
cfg80211:     (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
PPP generic driver version 2.4.2
ip_tables: (C) 2000-2006 Netfilter Core Team
NET: Registered protocol family 24
ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
ar71xx-ehci ar71xx-ehci: Atheros AR71xx built-in EHCI controller
ar71xx-ehci ar71xx-ehci: new USB bus registered, assigned bus number 1
ar71xx-ehci ar71xx-ehci: irq 3, io mem 0x1b000000
ar71xx-ehci ar71xx-ehci: USB 2.0 started, EHCI 1.00
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 2 ports detected
nf_conntrack version 0.5.0 (1982 buckets, 7928 max)
CONFIG_NF_CT_ACCT is deprecated and will be removed soon. Please use
nf_conntrack.acct=1 kernel parameter, acct=1 nf_conntrack module option or
sysctl net.netfilter.nf_conntrack_acct=1 to enable it.
usb 1-2: new high speed USB device using ar71xx-ehci and address 2
ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
ar71xx-ohci ar71xx-ohci: Atheros AR71xx built-in OHCI controller
ar71xx-ohci ar71xx-ohci: new USB bus registered, assigned bus number 2
ar71xx-ohci ar71xx-ohci: irq 14, io mem 0x1c000000
usb usb2: configuration #1 chosen from 1 choice
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 2 ports detected
usb 1-2: configuration #1 chosen from 1 choice

Re: RouterStation Pro no internet connection

A little more info:

root@OpenWrt:/# ifconfig
br-lan    Link encap:Ethernet  HWaddr 00:15:6D:C8:DA:19
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:402 (402.0 B)

eth0      Link encap:Ethernet  HWaddr 00:15:6D:C8:DA:18
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1641 errors:0 dropped:0 overruns:0 frame:0
          TX packets:123 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:100912 (98.5 KiB)  TX bytes:49569 (48.4 KiB)
          Interrupt:4

eth1      Link encap:Ethernet  HWaddr 00:15:6D:C8:DA:19
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:402 (402.0 B)
          Interrupt:5

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1920 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1920 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:134400 (131.2 KiB)  TX bytes:134400 (131.2 KiB)

Re: RouterStation Pro no internet connection

Connect WRT150N to modem and RouterStation Pro to WRT150N. Does it work?

4 (edited by written_direcon 2012-01-15 00:24:54)

Re: RouterStation Pro no internet connection

Power cycle the cable modem and make sure the cable modem and the LAN side of the RSP are NOT using the same subnet.

Re: RouterStation Pro no internet connection

fyi wrote:

Connect WRT150N to modem and RouterStation Pro to WRT150N. Does it work?

Short answer:  no.

Here's the setup:  ISP<---- Cable Modem (Motorola SB5101U)<----WRT150N<----- RouterStation Pro (RSP)

Here's what happened when I restarted the network:

root@OpenWrt:/# /etc/init.d/network restart
br-lan: port 1(eth1) entering disabled state
eth1: link down
device eth1 left promiscuous mode
br-lan: port 1(eth1) entering disabled state
eth0: link down
device eth1 entered promiscuous mode
udhcpc (v1.15.3) started
root@OpenWrt:/# eth0: link up (100Mbps/Full duplex)
Sending discover...
eth1: link up (1000Mbps/Full duplex)
br-lan: port 1(eth1) entering forwarding state
Sending select for 192.168.1.106...
Lease of 192.168.1.106 obtained, lease time 86400
udhcpc: ifconfig eth0 192.168.1.106 netmask 255.255.255.0 broadcast +
udhcpc: setting default routers: 192.168.1.1
route: SIOCADDRT: No such process
udhcpc: setting dns servers: 68.105.28.11 68.105.29.11 68.105.28.12
udhcpc: setting dns domain: dc.dc.cox.net

It looks like the dhcp server on the WRT150N assigned an ip to the routerstation.  However, I still can't ping out to the internet:

PING 4.4.4.4 (4.4.4.4): 56 data bytes
ping: sendto: Network is unreachable

I am also unable to ping other devices on my local network:

PING 192.168.1.105 (192.168.1.105): 56 data bytes
^C
--- 192.168.1.105 ping statistics ---
6 packets transmitted, 0 packets received, 100% packet loss

AND, I am unable to ping the RST from other devices on my network:

C:\Users\Snapplepop>ping 192.168.1.106

Pinging 192.168.1.106 with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 192.168.1.106:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss)

Here's the ifconfig:

root@OpenWrt:/# ifconfig
br-lan    Link encap:Ethernet  HWaddr 00:15:6D:C8:DA:19
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:18 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:756 (756.0 B)

eth0      Link encap:Ethernet  HWaddr 00:15:6D:C8:DA:18
          inet addr:192.168.1.106  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4445 errors:0 dropped:0 overruns:0 frame:0
          TX packets:309 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:405804 (396.2 KiB)  TX bytes:123805 (120.9 KiB)
          Interrupt:4

eth1      Link encap:Ethernet  HWaddr 00:15:6D:C8:DA:19
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:19 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:1158 (1.1 KiB)
          Interrupt:5

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:46889 errors:0 dropped:0 overruns:0 frame:0
          TX packets:46889 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:3282512 (3.1 MiB)  TX bytes:3282512 (3.1 MiB)

and the route:

root@OpenWrt:/# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     *               255.255.255.0   U     0      0        0 br-lan
192.168.1.0     *               255.255.255.0   U     0      0        0 eth0

****Second Question****

written_direcon wrote:

Power cycle the cable modem and make sure the cable modem and the LAN side of the RSP are NOT using the same subnet.

Power cycling the cable modem actually helped a bit.  Now the modem is communicating with the RSP.  When I connected the RSP back directly to the cable modem (as in the OP) and power cycled everything, this is what I got:

root@OpenWrt:/# /etc/init.d/network restart
br-lan: port 1(eth1) entering disabled state
eth1: link down
device eth1 left promiscuous mode
br-lan: port 1(eth1) entering disabled state
eth0: link down
device eth1 entered promiscuous mode
udhcpc (v1.15.3) started
root@OpenWrt:/# Sending discover...
eth0: link up (100Mbps/Full duplex)
eth1: link up (1000Mbps/Full duplex)
br-lan: port 1(eth1) entering forwarding state
Sending discover...
Sending select for 72.209.203.184...
Lease of 72.209.203.184 obtained, lease time 86400
udhcpc: ifconfig eth0 72.209.203.182 netmask 255.255.252.0 broadcast +
udhcpc: setting default routers: 72.209.200.1
udhcpc: setting dns servers: 68.105.28.11 68.105.29.11 68.105.28.12
udhcpc: setting dns domain: dc.dc.cox.net

The cable modem assigned the RSP an IP and gave it the DNS and gateway information, which is good, but I am still unable to ping out to the internet

root@OpenWrt:/# ping 4.4.4.4
PING 4.4.4.4 (4.4.4.4): 56 data bytes
^C
--- 4.4.4.4 ping statistics ---
8 packets transmitted, 0 packets received, 100% packet loss

Here's the route information:

root@OpenWrt:/# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     *               255.255.255.0   U     0      0        0 br-lan
72.209.200.0    *               255.255.252.0   U     0      0        0 eth0
default         ip72-209-200-1. 0.0.0.0         UG    0      0        0 eth0

I can ping myself (72.209.203.184).  That seems good, but I'm not really sure what it means since I can't ping anything else.

Does anyone have any ideas?  Thanks!

Re: RouterStation Pro no internet connection

An update:

It turns out 4.4.4.4 isn't an IP that is active.  Don't I feel like a fool sad .  So, in my original configuration, I am able to ping out and reach the internet from the RSP.

Does anyone have any tips for allowing the other ports (LAN1, LAN2, and LAN3) reach the internet?  My clients can ping the router (192.168.1.10), but they can't reach anything past that.

root@OpenWrt:~# ifconfig
br-lan    Link encap:Ethernet  HWaddr 00:15:6D:C8:DA:19
          inet addr:192.168.1.10  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:115 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:9283 (9.0 KiB)  TX bytes:232 (232.0 B)

eth0      Link encap:Ethernet  HWaddr 00:15:6D:C8:DA:18
          inet addr:72.209.203.184  Bcast:72.209.203.255  Mask:255.255.252.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:15651 errors:0 dropped:0 overruns:0 frame:0
          TX packets:793 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1460405 (1.3 MiB)  TX bytes:175381 (171.2 KiB)
          Interrupt:4

eth1      Link encap:Ethernet  HWaddr 00:15:6D:C8:DA:19
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4216 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2285 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1928999 (1.8 MiB)  TX bytes:999218 (975.7 KiB)
          Interrupt:5

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:49694 errors:0 dropped:0 overruns:0 frame:0
          TX packets:49694 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:3529466 (3.3 MiB)  TX bytes:3529466 (3.3 MiB)
config 'interface' 'loopback'
        option 'ifname' 'lo'
        option 'proto' 'static'
        option 'ipaddr' '127.0.0.1'
        option 'netmask' '255.0.0.0'

config 'interface' 'lan'
        option 'ifname' 'eth1'
        option 'type' 'bridge'
        option 'proto' 'static'
        option 'ipaddr' '192.168.1.10'
        option 'netmask' '255.255.255.0'

config 'interface' 'wan'
        option 'ifname' 'eth0'
        option 'proto' 'dhcp'

config 'switch'
        option 'name' 'eth1'
        option 'reset' '1'
        option 'enable_vlan' '1'

config 'switch_vlan'
        option 'device' 'eth1'
        option 'vlan' '1'
        option 'ports' '0 1 2 3 4'

I look forward to your responses.  Thanks!

Re: RouterStation Pro no internet connection

You need to configure the ports to belong to the correct VLAN which is described in this document if I remember correctly:
http://wiki.openwrt.org/toh/ubiquiti/routerstation.pro