Topic: backfire doesn't support wifi on wrt-300n

Hi,

I have tried installing the following openwrt firmware on my Linksys wrt-300n version 1:
openwrt-wrt300n_v1-squashfs.bin
openwrt-brcm-2.4-squashfs.trx
openwrt-brcm47xx-squashfs.trx

The flash is successful for all 3 and I can use LuCI but I don't have any wifi support.  I tried:
opkg install kmod-brcm-wl-mimo
but there is no package named kmod-brcm-wl-mimo

What do I need to do to get wireless working again?

Thanks,

Re: backfire doesn't support wifi on wrt-300n

which backfire version are you using?

you might have to compile an image from source - it seems backfire RC6 and up are using a non-stable b43 driver by default. i just ran into a problem with wireless after upgrading to the newest backfire version.

try it with RC5 and see if it works.

Re: backfire doesn't support wifi on wrt-300n

I am using 10.03.1.  I will try downgrading tomorrow.

Thanks.

Re: backfire doesn't support wifi on wrt-300n

I tried 10.03.1-rc5
openwrt-brcm-2.4-squashfs.trx
openwrt-brcm47xx-squashfs(1).trx

and neither worked.  Still no wireless on my wrt-300n v1.

Thanks,

Re: backfire doesn't support wifi on wrt-300n

You need to use brcm-2.4 and install "kmod-brcm-wl-mimo".

Re: backfire doesn't support wifi on wrt-300n

I installed 10.03.1 openwrt-brcm-2.4-squashfs.trx
I went to System, Software, and typed in kmod-brcm-wl-mimo in the Download and install package box.  The following is what I saw:

Unknown package 'kmod-brcm-wl-mimo'.

Collected errors:
* opkg_install_cmd: Cannot install package kmod-brcm-wl-mimo.

Re: backfire doesn't support wifi on wrt-300n

Did you update the package lists before?

Re: backfire doesn't support wifi on wrt-300n

Thank you.  That is what I missed.  I now have a working wrt-300n v1 running openwrt 10.03.1.  You update the supported devices section just add the note about updating the package list and installing kmod-brcm-wl-mimo to get wireless working.

What is the difference between the openwrt-brcm-2.4-squashfs.trx and openwrt-wrt300n_v1-squashfs.bin?