1 (edited by nyt 2010-11-30 04:42:51)

Topic: WNDR3700 r24164 can't set channels / power properly, 5ghz issues

So, I'm stuck in a catch 22 here.

Netgear firmware is best performance, but it closes out my idle tcp sessions, which is unacceptable to me.

DD-WRT is half decent, but it has stability issues

I have run OpenWRT for years, but with this router it is not up to par.

Here's an example. 

root@ZOMGWTFBBQWIFI:~# iw phy1 info
Wiphy phy1
        Band 1:
                Capabilities: 0x11ce
                        HT20/HT40
                        SM Power Save disabled
                        RX HT40 SGI
                        TX STBC
                        RX STBC 1-stream
                        Max AMSDU length: 3839 bytes
                        DSSS/CCK HT40
                Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
                Minimum RX AMPDU time spacing: 8 usec (0x06)
                HT TX/RX MCS rate indexes supported: 0-15
                Frequencies:
                        * 5180 MHz [36] (17.0 dBm)
                        * 5200 MHz [40] (17.0 dBm)
                        * 5220 MHz [44] (17.0 dBm)
                        * 5240 MHz [48] (17.0 dBm)
                        * 5260 MHz [52] (20.0 dBm) (radar detection)
                        * 5280 MHz [56] (20.0 dBm) (radar detection)
                        * 5300 MHz [60] (20.0 dBm) (radar detection)
                        * 5320 MHz [64] (20.0 dBm) (radar detection)
                        * 5500 MHz [100] (20.0 dBm) (radar detection)
                        * 5520 MHz [104] (20.0 dBm) (radar detection)
                        * 5540 MHz [108] (20.0 dBm) (radar detection)
                        * 5560 MHz [112] (20.0 dBm) (radar detection)
                        * 5580 MHz [116] (20.0 dBm) (radar detection)
                        * 5600 MHz [120] (disabled)
                        * 5620 MHz [124] (disabled)
                        * 5640 MHz [128] (disabled)
                        * 5660 MHz [132] (20.0 dBm) (radar detection)
                        * 5680 MHz [136] (20.0 dBm) (radar detection)
                        * 5700 MHz [140] (20.0 dBm) (radar detection)
                        * 5745 MHz [149] (20.0 dBm)
                        * 5765 MHz [153] (20.0 dBm)
                        * 5785 MHz [157] (20.0 dBm)
                        * 5805 MHz [161] (20.0 dBm)
                        * 5825 MHz [165] (20.0 dBm)

iwinfo reporting txpower of 0...

root@ZOMGWTFBBQWIFI:~# iwinfo phy1 txpower
*  0 dBm (   1 mW)
   2 dBm (   1 mW)
   4 dBm (   2 mW)
   6 dBm (   3 mW)
   8 dBm (   6 mW)
  10 dBm (  10 mW)
  12 dBm (  15 mW)
  14 dBm (  25 mW)
  16 dBm (  39 mW)
  18 dBm (  63 mW)
  20 dBm ( 100 mW)


root@ZOMGWTFBBQWIFI:~# tail -n20 /etc/config/wireless | egrep 'txpower|channel|ht_'
        list 'ht_capab' 'SHORT-GI-40'
        list 'ht_capab' 'TX-STBC'
        list 'ht_capab' 'RX-STBC1'
        list 'ht_capab' 'DSSS_CCK-40'
        option 'channel' '157'
        option 'txpower' '20'


I can't set txpower at all with iw

root@ZOMGWTFBBQWIFI:~# iw phy phy1 set txpower fixed 20
command failed: Operation not supported (-122)


I can't set channels to anything in a DFS range.

root@ZOMGWTFBBQWIFI:~# iw reg get
country US:
        (2402 - 2472 @ 40), (3, 27)
        (5170 - 5250 @ 40), (3, 17)
        (5250 - 5330 @ 40), (3, 20), DFS
        (5490 - 5600 @ 40), (3, 20), DFS
        (5650 - 5710 @ 40), (3, 20), DFS
        (5735 - 5835 @ 40), (3, 30)



config 'wifi-device' 'radio1'
        option 'type' 'mac80211'
        option 'macaddr' '30:46:9a:10:49:a9'
        option 'hwmode' '11na'
        list 'ht_capab' 'SHORT-GI-40'
        list 'ht_capab' 'TX-STBC'
        list 'ht_capab' 'RX-STBC1'
        list 'ht_capab' 'DSSS_CCK-40'
        option 'country' 'US'
        option 'disabled' '0'
        option 'htmode' 'HT40+'
        option 'distance' '50'
        option 'channel' '56'
        option 'txpower' '17'


root@ZOMGWTFBBQWIFI:~# wifi
'radio0' is disabled
'radio0' is disabled
Configuration file: /var/run/hostapd-phy1.conf
wlan0: IEEE 802.11 Configured channel (56) not found from the channel list of current mode (2) IEEE 802.11a
wlan0: IEEE 802.11 Hardware does not support configured channel
Could not select hw_mode and channel. (-1)
wlan0: Unable to setup interface.
rmdir[ctrl_interface]: No such file or directory
Failed to start hostapd for phy1
root@ZOMGWTFBBQWIFI:~# wifi
'radio0' is disabled
'radio0' is disabled
Configuration file: /var/run/hostapd-phy1.conf
wlan0: IEEE 802.11 Configured channel (56) not found from the channel list of current mode (2) IEEE 802.11a
wlan0: IEEE 802.11 Hardware does not support configured channel
Could not select hw_mode and channel. (-1)
wlan0: Unable to setup interface.
rmdir[ctrl_interface]: No such file or directory
Failed to start hostapd for phy1



If I put it on a channel without DFS, It will take the commands.

config 'wifi-device' 'radio1'
        option 'type' 'mac80211'
        option 'macaddr' '30:46:9a:10:49:a9'
        option 'hwmode' '11na'
        list 'ht_capab' 'SHORT-GI-40'
        list 'ht_capab' 'TX-STBC'
        list 'ht_capab' 'RX-STBC1'
        list 'ht_capab' 'DSSS_CCK-40'
        option 'country' 'US'
        option 'disabled' '0'
        option 'htmode' 'HT40+'
        option 'distance' '50'
        option 'channel' '157'
        option 'txpower' '20'

root@ZOMGWTFBBQWIFI:~# wifi
'radio0' is disabled
'radio0' is disabled
Configuration file: /var/run/hostapd-phy1.conf
Using interface wlan0 with hwaddr 30:46:9a:10:49:a9 and ssid 'ZOMGWTFBBQWIFI'


I can sit right near the router, connect at 300mbps, and my speeds still are less than the 802.11n/b/g ap I have across the house.  Something isn't right here.  I built from the latest trunk, 24164.  Backfire latest svn also had the same issues.

I also see a bunch of this in dmesg:

ath: Failed to stop TX DMA in 100 msec after killing last frame
ath: Timeout while waiting for nf to load: AR_PHY_AGC_CONTROL=0x40d1a

root@ZOMGWTFBBQWIFI:~# dmesg | grep TX\ DMA | wc -l
39
root@ZOMGWTFBBQWIFI:~# dmesg | grep AR_PHY | wc -l
2

This is also an 02r router.

Re: WNDR3700 r24164 can't set channels / power properly, 5ghz issues

Check out the wiki, you need to set some build flags for wifi 5GHz to be enabled.

3 (edited by nyt 2010-11-30 06:23:05)

Re: WNDR3700 r24164 can't set channels / power properly, 5ghz issues

napierzaza wrote:

Check out the wiki, you need to set some build flags for wifi 5GHz to be enabled.

Do you mean these?  5ghz is enabled, it just doesn't seem to work right.  Am I missing something?  I read over http://wiki.openwrt.org/toh/netgear/wndr3700 while building.

I see the same behavior with the prebuilt images, which is the reason for building my own.


[nyt@cc:~/openwrt/trunk]: egrep -i CRDA\|REGD .config
CONFIG_PACKAGE_crda=y
CONFIG_ATH_USER_REGD=y

4 (edited by eleon216 2010-11-30 13:32:19)

Re: WNDR3700 r24164 can't set channels / power properly, 5ghz issues

Hi,

Maybe I can clear some things up.

You cannot set channels which require DFS because ath9k doesn't support DFS (now?).

I can set the txpower with

iwconfig wlan1 txpower xxdBm

In the US only 17dBm are allowed on channel 36-48, and I'm not sure about channel 149-165 because I cannot use them in my country. 

But I have the  same issue on the channels 36-48. In Austria 20dBm are allowed, but I am unable to use it.

I set CONFIG_ATH_USER_REGD=y, and I added option country AT in /etc/config/wireless

This config is running on a routerstation pro with Mikrotik R52N-Wifi which I set up a few months ago (backfire 10.03 r21803) and I can use 20dBm.
But its not working on my new WNDR3700 (backfire r24064), I'm stuck with 17dBm but I'm not sure were this value come from:

dmesg:

Compat-wireless backport release: compat-wireless-2010-10-14-7-gab01eca
Backport based on wireless-testing.git master-2010-10-19
cfg80211: Calling CRDA to update world regulatory domain
ar71xx: pll_reg 0xb8050014: 0x1099
eth1: link up (100Mbps/Full duplex)
SCSI subsystem initialized
cfg80211: World regulatory domain updated:
    (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
    (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
.....
PCI: Enabling device 0000:00:11.0 (0000 -> 0002)
ath: EEPROM regdomain: 0x60
ath: EEPROM indicates we should expect a direct regpair map
ath: Country alpha2 being used: 00
ath: Regpair used: 0x60
ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
Registered led device: ath9k-phy0::radio
Registered led device: ath9k-phy0::assoc
Registered led device: ath9k-phy0::tx
Registered led device: ath9k-phy0::rx
ieee80211 phy0: Atheros AR9280 Rev:2 mem=0xb0000000, irq=48
PCI: Enabling device 0000:00:12.0 (0000 -> 0002)
ath: EEPROM regdomain: 0x60
ath: EEPROM indicates we should expect a direct regpair map
ath: Country alpha2 being used: 00
ath: Regpair used: 0x60
ieee80211 phy1: Selected rate control algorithm 'minstrel_ht'
Registered led device: ath9k-phy1::radio
Registered led device: ath9k-phy1::assoc
Registered led device: ath9k-phy1::tx
Registered led device: ath9k-phy1::rx
ieee80211 phy1: Atheros AR9280 Rev:2 mem=0xb0010000, irq=49
...
cfg80211: Calling CRDA for country: AT
cfg80211: Regulatory domain changed to country: AT
    (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
    (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm)
    (5170000 KHz - 5250000 KHz @ 40000 KHz), (N/A, 2000 mBm)
    (5250000 KHz - 5330000 KHz @ 40000 KHz), (N/A, 2000 mBm)
    (5490000 KHz - 5710000 KHz @ 40000 KHz), (N/A, 2700 mBm)

So 20dBm should be allowed!

but iw list shows:

root@OpenWrt:~# iw list 
Wiphy phy1
    Band 1:
        Capabilities: 0x11ce
            HT20/HT40
            SM Power Save disabled
            RX HT40 SGI
            TX STBC
            RX STBC 1-stream
            Max AMSDU length: 3839 bytes
            DSSS/CCK HT40
        Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
        Minimum RX AMPDU time spacing: 8 usec (0x06)
        HT TX/RX MCS rate indexes supported: 0-15
        Frequencies:
            * 5180 MHz [36] (17.0 dBm)
            * 5200 MHz [40] (17.0 dBm)
            * 5220 MHz [44] (17.0 dBm)
            * 5240 MHz [48] (17.0 dBm)
            * 5260 MHz [52] (20.0 dBm) (radar detection)
            * 5280 MHz [56] (20.0 dBm) (radar detection)
            * 5300 MHz [60] (20.0 dBm) (radar detection)
            * 5320 MHz [64] (20.0 dBm) (radar detection)
            * 5500 MHz [100] (20.0 dBm) (radar detection)
            * 5520 MHz [104] (20.0 dBm) (radar detection)
            * 5540 MHz [108] (20.0 dBm) (radar detection)
            * 5560 MHz [112] (20.0 dBm) (radar detection)
            * 5580 MHz [116] (20.0 dBm) (radar detection)
            * 5600 MHz [120] (20.0 dBm) (radar detection)
            * 5620 MHz [124] (20.0 dBm) (radar detection)
            * 5640 MHz [128] (20.0 dBm) (radar detection)
            * 5660 MHz [132] (20.0 dBm) (radar detection)
            * 5680 MHz [136] (20.0 dBm) (radar detection)
            * 5700 MHz [140] (20.0 dBm) (radar detection)
            * 5745 MHz [149] (20.0 dBm) (passive scanning, no IBSS)
            * 5765 MHz [153] (20.0 dBm) (passive scanning, no IBSS)
            * 5785 MHz [157] (20.0 dBm) (passive scanning, no IBSS)
            * 5805 MHz [161] (20.0 dBm) (passive scanning, no IBSS)
            * 5825 MHz [165] (20.0 dBm) (passive scanning, no IBSS)
        Bitrates (non-HT):
            * 6.0 Mbps
            * 9.0 Mbps
            * 12.0 Mbps
            * 18.0 Mbps
            * 24.0 Mbps
            * 36.0 Mbps
            * 48.0 Mbps
            * 54.0 Mbps
    max # scan SSIDs: 4
    max scan IEs length: 148373504 bytes
    Coverage class: 0 (up to 0m)
    Supported interface modes:
         * IBSS
         * managed
         * AP
         * AP/VLAN
         * WDS
         * monitor
         * mesh point
    Supported commands:
         * new_interface
         * set_interface
         * new_key
         * new_beacon
         * new_station
         * new_mpath
         * set_mesh_params
         * set_bss
         * authenticate
         * associate
         * deauthenticate
         * disassociate
         * join_ibss
         * remain_on_channel
         * set_tx_bitrate_mask
         * action
         * set_wiphy_netns
         * set_channel
         * Unknown command (66)
         * connect
         * disconnect
    Supported TX frame types:
....

There were some crda-updates 24063 (trunk) 24064(backfire) maybe I try a version before this update.

But my connection is fast (11na 40Mhz 8-12MBytes/s) and really stable, but only with 17dBm txpower.

5 (edited by MarkMentovai 2010-11-30 17:05:00)

Re: WNDR3700 r24164 can't set channels / power properly, 5ghz issues

txpower

iw is a little unorthodox in that it accepts transmit power values in mBm (millibels referenced to 1 milliwatt) rather than the more familiar dBm (decibels referenced to 1 milliwatt.) 100 mBm = 1 dBm.

root@OpenWrt:/# iw | grep txpower
        dev <devname> set txpower <auto|fixed|limit> [<tx power in mBm>]
        phy <phyname> set txpower <auto|fixed|limit> [<tx power in mBm>]
root@OpenWrt:/# iw phy phy1 set txpower limit 20
command failed: Operation not supported (-122)
root@OpenWrt:/# iw phy phy1 set txpower limit 2000
root@OpenWrt:/#

DFS

Sorry, no DFS support. Yet.

17 dBm

This is the maximum allowed in the US in the 5170-5250MHz range. The value comes from the FCC, and is supplied via CRDA. If you want a higher transmit power in the 5GHz band, try one of the high channels, where the limit is 30dBm. (The WNDR3700 will actually top out around 22dBm on those channels, whether or not it’s accurately reflected.)

Your “iw info” shows an artificial cap of 20dBm across the 5GHz band. You should try building without (yes, without) CONFIG_ATH_USER_REGD=y, as you appear to be in the US and you shouldn’t need it anyway.

Re: WNDR3700 r24164 can't set channels / power properly, 5ghz issues

looks like i have 5ghz sorted.  Was able to download at 20MB/s from wifi.  I disabled REGD and put a fresh flash on. 30dbm on channel 157 with HT40+ seemed to be good.

However, even with HT40- on channel 11 on 2.4ghz, I can see that it's using dual band with inssider, but cannot connect any faster than 130mbit.  Any ideas on that one?  inssider even lists it as a 300mbps ap.

Re: WNDR3700 r24164 can't set channels / power properly, 5ghz issues

Disabling REGD did't work for me on channel 36-48 sad

I get

wlan0: IEEE 802.11 Configured channel (56) not found from the channel list of current mode (2) IEEE 802.11a
wlan0: IEEE 802.11 Hardware does not support configured channel

but I'm don't really care, the only 5Ghz client is in the same room as the router, so a txpower of 17dBm is fine. It's only nagging me because it's working with 20dBm on the routerstation in the flat where I used to live, but not on the WNDR3700 in my new flat. But this is the only regression of my new living arrangements so I think I can live with it smile

8 (edited by nyt 2010-12-01 12:25:16)

Re: WNDR3700 r24164 can't set channels / power properly, 5ghz issues

eleon216 wrote:

Disabling REGD did't work for me on channel 36-48 sad

I get

wlan0: IEEE 802.11 Configured channel (56) not found from the channel list of current mode (2) IEEE 802.11a
wlan0: IEEE 802.11 Hardware does not support configured channel

but I'm don't really care, the only 5Ghz client is in the same room as the router, so a txpower of 17dBm is fine. It's only nagging me because it's working with 20dBm on the routerstation in the flat where I used to live, but not on the WNDR3700 in my new flat. But this is the only regression of my new living arrangements so I think I can live with it smile

That says channel 56, not something betwen 36 and 48.

Try using channel 157 with txpower 30 and htmode 40+ I get great results

9 (edited by eleon216 2010-12-01 13:10:05)

Re: WNDR3700 r24164 can't set channels / power properly, 5ghz issues

oh sorry, I just copy the entry of your post because I get the same error, but for channel 40.
I live in autria so I can only use 36-48 100mW without DFS for all other channels I need DFS, and on channel 147+ only 25mW are allowed. 

But to your 2,4GHz question.

130Mbps seem like HT20 MCS 15  (20MHz and 2 spartial streams)
135Mbps would be HT20 MCS 7 (40MHz and 1 spartial stream)
http://wireless.kernel.org/en/developers/Documentation/ieee80211/802.11n
you can check the status of connection with this comand

 iw wlan0 station dump

but HT40 on 2,4GHz is only available if no other accesspoint is present on this channels, so if your are living in an apartment building there is no chance to use HT40.
130Mbps is the maximum for a 11n 2x2 wifi card with HT20. With a 3x3 wifi you can run MSC 23 (with 3 spartial streams) which would be up to 195Mbps

10 (edited by nyt 2010-12-01 13:11:40)

Re: WNDR3700 r24164 can't set channels / power properly, 5ghz issues

eleon216 wrote:

oh sorry, I just copy the entry of your post because I get the same error, but for channel 40.
I live in autria so I can only use 36-48 100mW without DFS for all other channels I need DFS, and on channel 147+ only 25mW are allowed. 

But to your 2,4GHz question.

130Mbps seem like HT20 MCS 15  (20MHz and 2 spartial streams)
135Mbps would be HT20 MCS 7 (40MHz and 1 spartial stream)
http://wireless.kernel.org/en/developers/Documentation/ieee80211/802.11n
you can check the status of connection with this comand

 iw wlan0 station dump

but HT40 on 2,4GHz is only available if no other accesspoint is present on this channels, so if your are living in an apartment building there is no chance to use HT40

It actually broadcasts correctly on HT40-, I see it on channels 11 and 7 when I set it up to use 11.  However, I can only connect at 130mbps at max.  Not quite sure of the issue there.  I have another 2.4ghz AP I'm using in the mean time, but would prefer to have this work right sad

Re: WNDR3700 r24164 can't set channels / power properly, 5ghz issues

I have also noticed the 17dBm if ATH_USER_REGD=y.
This is on a Routerstation, the Radio is from Europe. If I don't use the ath_user_regd, the Max tx-power returns to the correct 20dBm. If I remember correctly it also reduces Max tx-power for channels in the 2.4 Ghz band.

Seems like a bug?

12 (edited by MarkMentovai 2010-12-01 23:33:50)

Re: WNDR3700 r24164 can't set channels / power properly, 5ghz issues

eleon216, your dmesg output shows that your card is coded with a world regulatory domain (0x60) and you’re trying to set it up for AT. I wouldn’t expect that to work well without CONFIG_ATH_USER_REGD=y. The whole 5GHz would be off-limits.

Note that on the current trunk, with CONFIG_ATH_USER_REGD=y, the maximum settable power will be restricted to whatever the card’s CTL-based safe maximum power is on any given channel. Without CONFIG_ATH_USER_REGD=y, the power will still be restricted to the same value, but you won’t see it in iw or iwconfig, it’ll silently be capped to the channel’s maximum.

My WNDR3700s have the following as their CTL-based power limits:
ath0 (AR9223): 25dBm (315mW) across the 2.4GHz band (channels 1-14)
ath1 (AR9220) on the 5GHz band:
Channels 36-48: 17dBm (50mW)
Channels 52-64: 20dBm (100mW)
Channels 100-140: 24dBm (250mW)
Channels 149-165: 21dBm (125mW)

Thoughts:

1. You’re never going to get a transmit power higher than 17dBm on channels 36-48. You might see a higher value there (like 20dBm) in iw or iwconfig, but the card will limit you to 17dBm anyway.

2. It’s confusing that the maximum power shown by iw and iwconfig takes the CTL limit into account with CONFIG_ATH_USER_REGD=y, but not without it. Without it, the regulatory domain’s power limits overwrite the CTL limits (although the card will still never set a power higher than the CTL limits).

3. The method that’s used to compute the CTL max power when CONFIG_ATH_USER_REGD=y is set is fragile. There’s a bug that causes the maximum power to be artificially limited to (in my case) 20dBm (100mW) on the 2.4GHz band with ath0 when CONFIG_ATH_USER_REGD=y. This is why I don’t recommend CONFIG_ATH_USER_REGD if you don’t need it. (For example, if you’re in the US and have US-coded cards.)

13

Re: WNDR3700 r24164 can't set channels / power properly, 5ghz issues

Interesting.

Any idea on the 2.4ghz 130mbps limit?

Re: WNDR3700 r24164 can't set channels / power properly, 5ghz issues

The 2.4GHz band is so noisy where I am that I haven’t really bothered with HT40 too much there.

You said you saw 130Mb/s with HT40 on the 2.4GHz band. What are you seeing with HT40 on 5GHz, for comparison? And what with HT40 on 2.4GHz using your other AP?

eleon’s suggestion to run “iw wlan0 station dump” sounds like it might provide useful information too.

15

Re: WNDR3700 r24164 can't set channels / power properly, 5ghz issues

I connect at a full 300mbps on HT40 with 5ghz.  I have transfer rates of up to 20MB/s over the network using that.

While I have my other AP on which is currently servicing 2.4ghz, the netgear will not be able to do HT40.  I will have to get a dump sometime the network is not in use and I can disable the other AP.

It definitely uses the correct frequency range and two channels, but the rate will never go above 130mbps even near the router.  For comparison, I am getting over 200mbps to my alternate AP through a floor.

Re: WNDR3700 r24164 can't set channels / power properly, 5ghz issues

Mark thanks for the info (btw. what does CTL stand for?) so 17dBm it is sad

@nyt: use "iw wlan0 station dump"  on the AP to check if your actual connection has 20MHz MCS 15 (2 spatial streams) or 40Mhz MCS 7 (1 spatial stream)
If it uses only 20MHz check if other accesspoints or other non-802.11 devices are aktiv on 2.4GHz. If thats the case you stuck at 20Mhz = 130Mbps.
Maybe the other accesspoint is working in 40MHz-Mode because it's a draft-N and is missing the neighbor-friendly restrictions of 40Mhz on 2.4Ghz. 

If you get 40MHz but 130Mbps it's because you only get one physical pathway between the AP and the client. This is often the case if AP and client are too near, bad antenna-alignment,...

Re: WNDR3700 r24164 can't set channels / power properly, 5ghz issues

nyt wrote:

I connect at a full 300mbps on HT40 with 5ghz.  I have transfer rates of up to 20MB/s over the network using that.

While I have my other AP on which is currently servicing 2.4ghz, the netgear will not be able to do HT40.  I will have to get a dump sometime the network is not in use and I can disable the other AP.

It definitely uses the correct frequency range and two channels, but the rate will never go above 130mbps even near the router.  For comparison, I am getting over 200mbps to my alternate AP through a floor.

I would like a little clarification, when everyone is reporting speeds is it in megabits / second, or megabytes per second? 

With stock firmware and an older (mid year) dd-wrt before they went to the 2.6 kernel it was 15+ megabytes per second.  though right now i am lucky to get above 5 megabytes/second.

18

Re: WNDR3700 r24164 can't set channels / power properly, 5ghz issues

ccdoggy wrote:
nyt wrote:

I connect at a full 300mbps on HT40 with 5ghz.  I have transfer rates of up to 20MB/s over the network using that.

While I have my other AP on which is currently servicing 2.4ghz, the netgear will not be able to do HT40.  I will have to get a dump sometime the network is not in use and I can disable the other AP.

It definitely uses the correct frequency range and two channels, but the rate will never go above 130mbps even near the router.  For comparison, I am getting over 200mbps to my alternate AP through a floor.

I would like a little clarification, when everyone is reporting speeds is it in megabits / second, or megabytes per second? 

With stock firmware and an older (mid year) dd-wrt before they went to the 2.6 kernel it was 15+ megabytes per second.  though right now i am lucky to get above 5 megabytes/second.

Industry standard. MB/s is megabytes, mbps is megabits per second.

@eleon, the wndr3700 was definitely broadcasting on two channel widths as observed by inssider.  However I will have to wait until later to dump station info.

Re: WNDR3700 r24164 can't set channels / power properly, 5ghz issues

CTL stands for Conformance Test Limits.

CTL data comes from the card’s EEPROM, or in this case when the card doesn’t have its own EEPROM but the relevant data is stored in the device’s flash memory, the art (Atheros Radio Test) or caldata (calibration data) MTD partition. art == caldata, they’re two names for the same thing. OpenWrt calls it art, and the WNDR3700’s stock firmware calls it caldata. Atheros Radio Test is software used to calibrate the card.

20

Re: WNDR3700 r24164 can't set channels / power properly, 5ghz issues

Here is the info...  can't connect on a 40mhz channel, though it's enabled.


root@ZOMGWTFBBQWIFI:/etc/config# iw phy0 info
Wiphy phy0
        Band 1:
                Capabilities: 0x11ce
                        HT20/HT40
                        SM Power Save disabled
                        RX HT40 SGI
                        TX STBC
                        RX STBC 1-stream
                        Max AMSDU length: 3839 bytes
                        DSSS/CCK HT40
                Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
                Minimum RX AMPDU time spacing: 8 usec (0x06)
                HT TX/RX MCS rate indexes supported: 0-15
                Frequencies:
                        * 2412 MHz [1] (27.0 dBm)
                        * 2417 MHz [2] (27.0 dBm)
                        * 2422 MHz [3] (27.0 dBm)
                        * 2427 MHz [4] (27.0 dBm)
                        * 2432 MHz [5] (27.0 dBm)
                        * 2437 MHz [6] (27.0 dBm)
                        * 2442 MHz [7] (27.0 dBm)
                        * 2447 MHz [8] (27.0 dBm)
                        * 2452 MHz [9] (27.0 dBm)
                        * 2457 MHz [10] (27.0 dBm)
                        * 2462 MHz [11] (27.0 dBm)
                        * 2467 MHz [12] (disabled)
                        * 2472 MHz [13] (disabled)
                        * 2484 MHz [14] (disabled)
                Bitrates (non-HT):
                        * 1.0 Mbps
                        * 2.0 Mbps (short preamble supported)
                        * 5.5 Mbps (short preamble supported)
                        * 11.0 Mbps (short preamble supported)
                        * 6.0 Mbps
                        * 9.0 Mbps
                        * 12.0 Mbps
                        * 18.0 Mbps
                        * 24.0 Mbps
                        * 36.0 Mbps
                        * 48.0 Mbps
                        * 54.0 Mbps
        max # scan SSIDs: 4
        max scan IEs length: 147914752 bytes
        Coverage class: 0 (up to 0m)
        Supported interface modes:
                 * IBSS
                 * managed
                 * AP
                 * AP/VLAN
                 * WDS
                 * monitor
                 * mesh point
        Supported commands:
                 * new_interface
                 * set_interface
                 * new_key
                 * new_beacon
                 * new_station
                 * new_mpath
                 * set_mesh_params
                 * set_bss
                 * authenticate
                 * associate
                 * deauthenticate
                 * disassociate
                 * join_ibss
                 * remain_on_channel
                 * set_tx_bitrate_mask
                 * action
                 * set_wiphy_netns
                 * set_channel
                 * Unknown command (66)
                 * connect
                 * disconnect
        Supported TX frame types:
                 * IBSS: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
                 * managed: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
                 * AP: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
                 * AP/VLAN: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
                 * (null): 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
                 * (null): 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
        Supported RX frame types:
                 * IBSS: 0x00d0
                 * managed: 0x0040 0x00d0
                 * AP: 0x0000 0x0020 0x0040 0x00a0 0x00b0 0x00c0 0x00d0
                 * AP/VLAN: 0x0000 0x0020 0x0040 0x00a0 0x00b0 0x00c0 0x00d0
                 * (null): 0x0040 0x00d0
                 * (null): 0x0000 0x0020 0x0040 0x00a0 0x00b0 0x00c0 0x00d0



root@ZOMGWTFBBQWIFI:/etc/config# iwconfig wlan0
wlan0     IEEE 802.11bgn  Mode:Master  Frequency:2.462 GHz  Tx-Power=27 dBm
          RTS thr:off   Fragment thr:off
          Power Management:on



root@ZOMGWTFBBQWIFI:/etc/config# iw wlan0 station dump
Station 00:23:6c:97:d7:cf (on wlan0)
        inactive time:  10 ms
        rx bytes:       657583
        rx packets:     7360
        tx bytes:       13592105
        tx packets:     10920
        signal:         -51 dBm
        tx bitrate:     130.0 MBit/s MCS 15


root@ZOMGWTFBBQWIFI:~# iw reg get
country US:
        (2402 - 2472 @ 40), (3, 27)
        (5170 - 5250 @ 40), (3, 17)
        (5250 - 5330 @ 40), (3, 20), DFS
        (5490 - 5600 @ 40), (3, 20), DFS
        (5650 - 5710 @ 40), (3, 20), DFS
        (5735 - 5835 @ 40), (3, 30)

root@ZOMGWTFBBQWIFI:~# iw phy0 set channel 11 HT40-
root@ZOMGWTFBBQWIFI:~# iw wlan0 station dump
Station 00:23:6c:97:d7:cf (on wlan0)
        inactive time:  10 ms
        rx bytes:       1299046
        rx packets:     10933
        tx bytes:       17437821
        tx packets:     15509
        signal:         -51 dBm
        tx bitrate:     130.0 MBit/s MCS 15


http://imgur.com/bH7Ac.png

21

Re: WNDR3700 r24164 can't set channels / power properly, 5ghz issues

nevermind

looks like the atheros chipset in my macbook doesnt do ht40 on 2.4....
lovely.

other card i have works fine


Station c8:3a:35:c4:3b:1a (on wlan0)
        inactive time:  2460 ms
        rx bytes:       73084
        rx packets:     408
        tx bytes:       84790
        tx packets:     242
        signal:         -50 dBm
        tx bitrate:     162.0 MBit/s MCS 12 40Mhz