Topic: Non working images with backfire imagebuilder for ar71xx

Hello

I can not build a working image for a tl-wr1043nd with the imagebuilder. The Image boot but i can only connect in failsafemode. I have also tried the most resent version from svn.

Building from source works but i administrate more than 50 router running openwrt (up ti now still whiterussian) . It would be much more handy to do this with the imagebuilder.

Any idea ?
Arnd

Re: Non working images with backfire imagebuilder for ar71xx

Yes. The ipkg implementation used by the imagebuilder does not handle al ldependencies correctly. Sometimes it silently leaves out essential packages like libuci or uci. Provide a full package lsit when invoking make image. See http://wiki.openwrt.org/doc/howto/imagebuilder

Re: Non working images with backfire imagebuilder for ar71xx

FWIW I've just noticed that the backfire imagebuilder for ar71xx is based on 10.03-rc3 (r20653) and not 10.03 (r20728).
I'm new to this imagebuilder business (and OpenWRT tbh) - do you think it would work if I just grabbed the r20728 packages and stuck them into imagebuilder? For that matter, would grabbing images from trunk into my local imagebuilder package directory work?

Sorry for semi-hijacking the thread.. although we could be having the same problem - you may be experiencing a problem from r20653 which was solved by r20728.

TIA.

jsp.

Re: Non working images with backfire imagebuilder for ar71xx

Yes, puttin in newer .ipk files will work as expected

Re: Non working images with backfire imagebuilder for ar71xx

Thanks for that.
I actually ended up trying it and so far so good. Only issue is the use of the kernel virtual ipk - the kernel is actually in the Imagebuilder tree and not in a package so it uses the kernel from the Imagebuilder. r20728 has kernel version 2.6.32.10 (which is in the Imagebuilder) and current trunk (r22101) expects 2.6.32.14.
Anyway.. I'll stick with r20728 for now and try to figure out my latest problem.. kernel panic when loading modules.. which is weird because if the modules are downloaded as packages and in jffs then there is no panic - when incorporated into the squashfs image at least one panics.

Thanks again for your response.

jsp.

6 (edited by jsp 2010-07-11 04:16:46)

Re: Non working images with backfire imagebuilder for ar71xx

Apologies for replying to my own post and not just editing the previous one but I wanted this standalone.. Some observations on Imagebuilder for AR71xx which may help others when searching through forums..

The Imagebuilder in Backfire 10.03 for AR71xx (OpenWrt-ImageBuilder-ar71xx-for-Linux-i686.tar.bz2 dated 03-Apr-2010 18:55 with size 340411713) is a little broken - it contains packages and kernels from 10.03-RC3 (r20653) instead of 10.03 (r20728) but it can be fixed..

Download ImageBuilder and extract..
then download the packages from the official package repository into the packages directory of the imagebuilder tree (something like rm packages/*; wget -r -nd -np -l 1 'http://downloads.openwrt.org/backfire/10.03/ar71xx/packages/' -P packages )

Copying the packages alone isn't enough though and you may experience kernel panics when some modules are loaded.. the "kernel" ipkg is actually a dummy package and the kernels are already in the Imagebuilder tree, so to update those..

Grab http://downloads.openwrt.org/backfire/10.03/ar71xx/openwrt-ar71xx-vmlinux.elf and overwrite build_dir/linux-ar71xx/vmlinux.elf

Grab http://downloads.openwrt.org/backfire/10.03/ar71xx/openwrt-ar71xx-vmlinux.gz and uncompress to build_dir/linux-ar71xx/vmlinux

You might also want to change the version in include/version.mk

It seems a little like a hack but for the last few hour it's been running as well as the previous stock tl-1043nd factory image with all my additional stuff which used to be in overlay (jffs) now happily bundled together in a single squashfs image.