Re: Backfire 10.03 Released

@Lutz_R, You have to pick up a channel for radio, "auto" channel pickup dosen't work with b43 on Backfire

27

Re: Backfire 10.03 Released

Lutz_R wrote:

I couldnt' get wireless running on an Asus Wl500g deluxe and Linux 2.6. Linux 2.4 works fine.
Here are some logs from dmesg, iwconfig, /etc/config/wireless, etc. Maybe someone knows the solution.

That's strange. the WL-500gD should work very well with 2.6 and b43 (at least mine does, but I'm stuck at r15160 and haven't tried Backfire yet on that machine).
There's nothing strange in the logs, but you shouldn't need the "macaddr" configuration line.
Is wpad running? Post the output of "logread".

28 (edited by mateoosh 2010-04-17 09:25:27)

Re: Backfire 10.03 Released

Hi,

Just tried flash backfire to Linksys AG241 V2 (used openwrt-AG241v2-squashfs-code.bin) and doesn't work -  linux not booting. I had to fall back to Kamikadze 8.09.03 which works absolutely perfect (same image as above).

cheers,

Mati.

Re: Backfire 10.03 Released

Lutz_R wrote:

I couldnt' get wireless running on an Asus Wl500g deluxe and Linux 2.6. Linux 2.4 works fine.
Here are some logs from dmesg, iwconfig, /etc/config/wireless, etc. Maybe someone knows the solution.
http://nopaste.info/6271242fe1.html
http://nopaste.info/9d312f883a.html
http://nopaste.info/e6e659615e.html
http://nopaste.info/2cc0aeda7d.html
http://nopaste.info/1e1eb0cf75.html
http://nopaste.info/b8d9481614.html

If this is the "v2" version of the router, then it's a known problem that affects a lot of us;

https://dev.openwrt.org/ticket/6907

Re: Backfire 10.03 Released

Can someone create a firmaware binary of OpenWrt for the SpeedTouch 580 ....Please?????????????

Re: Backfire 10.03 Released

USB is not working on a ASUS 520GU and kernel 2.6
any solutions?

Re: Backfire 10.03 Released

USB does work on the wl-520GU.  I have a UVC webcam working.  I have the following kernel modules installed:
kmod-b43 - 2.6.32.10+2010-03-24-5                                                                                                                 
kmod-b43legacy - 2.6.32.10+2010-03-24-5                                                                                                           
kmod-cfg80211 - 2.6.32.10+2010-03-24-5                                                                                                           
kmod-crc-ccitt - 2.6.32.10-1                                                                                                                     
kmod-crypto-aes - 2.6.32.10-1                                                                                                                     
kmod-crypto-arc4 - 2.6.32.10-1                                                                                                                   
kmod-crypto-core - 2.6.32.10-1                                                                                                                   
kmod-diag - 2.6.32.10-6                                                                                                                           
kmod-i2c-core - 2.6.32.10-1
kmod-input-core - 2.6.32.10-1
kmod-ipt-conntrack - 2.6.32.10-1
kmod-ipt-core - 2.6.32.10-1
kmod-ipt-nat - 2.6.32.10-1
kmod-ipt-nathelper - 2.6.32.10-1
kmod-mac80211 - 2.6.32.10+2010-03-24-5
kmod-nls-base - 2.6.32.10-1
kmod-ppp - 2.6.32.10-1
kmod-pppoe - 2.6.32.10-1
kmod-switch - 2.6.32.10-3
kmod-usb-core - 2.6.32.10-1
kmod-usb-ohci - 2.6.32.10-1
kmod-usb2 - 2.6.32.10-1
kmod-video-core - 2.6.32.10-1
kmod-video-uvc - 2.6.32.10-1

Try adding the ones that you are missing from the above list.

Re: Backfire 10.03 Released

Why are there two brcm images on the download directory?
http://downloads.openwrt.org/backfire/10.03/brcm47xx/
How should I install Backfire to my Asus WL500gP?

34

Re: Backfire 10.03 Released

You should use .trx. The .trx2 file is only required for newer G3G devices.

35 (edited by dOCtoR MADneSs 2010-05-04 10:26:47)

Re: Backfire 10.03 Released

Hi,

I've a WRT54GS v1. I installed backfire final release "brcm47xx" on it. All is working, expect wifi. I kept my kamikaze (last stable release) configuration files.
The b43, b43_legacy module and many others are loaded at startup, but I can't see my SSID with my wifi devices. When I switch to backfire final release "brcm-2.4", the wifi works.

So I think it's always due to lack of support for my wifi chipset on 2.6 kernel. Is there a workaround for it ?

Thank you for your support

Re: Backfire 10.03 Released

Hello,

I installed Backfire on a x86 PC. Almost everything works fine, but I cannot get the power button to get working.
Acpid is not installed (it is not in busybox either). How can catch the power button event?

Thanks.

Re: Backfire 10.03 Released

Hi,

Has dnat and port forwarding broken been fixed? ( https://dev.openwrt.org/ticket/2558 ) on these release.

Thanks in advance!

Re: Backfire 10.03 Released

After I stayed on kernel 2.4.x for a long time. Yesterday I decided to switch to 2.6.32 on my "Buffalo WHR-HP-G54" (Broadcom 44xx/47xx).
So in installed brcm47xx-squashfs.trx (Backfire, 10.03, r20728) and it works out of the box.

Its fabulous to still have support in the newest release for a 4 year old router. Great work!
(I have tested ap psk2, and ethernet trunk's so far.)

39 (edited by johndoe 2010-05-16 10:50:33)

Re: Backfire 10.03 Released

AntiCat wrote:

Its fabulous to still have support in the newest release for a 4 year old router. Great work!

Anyway it's scandalous that still lacking the support for new Brcm63xx modem/routers like the Linksys wag320n.

Re: Backfire 10.03 Released

johndoe wrote:

Anyway it's scandalous that still lacking the support for new Brcm63xx modem/routers like the Linksys wag320n.

As far as I know Broadcom has a very strict NDA. This makes it very hard or even impossible to develop a Linux driver.

41 (edited by drrignell 2010-05-16 23:03:09)

Re: Backfire 10.03 Released

Lutz_R wrote:

I couldnt' get wireless running on an Asus Wl500g deluxe and Linux 2.6. Linux 2.4 works fine.
Here are some logs from dmesg, iwconfig, /etc/config/wireless, etc. Maybe someone knows the solution.
http://nopaste.info/6271242fe1.html
http://nopaste.info/9d312f883a.html
http://nopaste.info/e6e659615e.html
http://nopaste.info/2cc0aeda7d.html
http://nopaste.info/1e1eb0cf75.html
http://nopaste.info/b8d9481614.html

Are you perhaps running the wrong drivers? My Asus WL-500g deluxe is running on 'broadcom' drivers, under Kamikaze and 2.4.35 kernel though.

This:

root@d3fault:~# cat /etc/config/wireless

config 'wifi-device' 'wl0'
        option 'type' 'broadcom'

Not this:

root@OpenWrt:~# cat /etc/config/wireless
config 'wifi-device' 'radio0'
        option 'type' 'mac80211'

Re: Backfire 10.03 Released

Lutz_r: I have wifi running on an Asus wl500g deluxe under Linux 2.6, Backfire 10.03 r21214. Same configuration as you, except that I am using PSK instead of PSK2.

Re: Backfire 10.03 Released

johndoe wrote:
AntiCat wrote:

Its fabulous to still have support in the newest release for a 4 year old router. Great work!

Anyway it's scandalous that still lacking the support for new Brcm63xx modem/routers like the Linksys wag320n.

Stop buying those crappy broadcom devices, then this problem will not exist anymore...

44 (edited by Kurgan 2010-05-24 23:08:40)

Re: Backfire 10.03 Released

Does it actually run on a WRT54GL? Isn't the flash memory too small for such a big release? I'm still installing WhiteRussian (with 2.4 kernel) on the WRT54GL routers that I configure, because I can install openvpn and tcpdump and I still have some KB of flash free...


EDIT: Sorry, I meant Kamikaze.

Re: Backfire 10.03 Released

Kurgan wrote:

Does it actually run on a WRT54GL? Isn't the flash memory too small for such a big release? I'm still installing WhiteRussian (with 2.4 kernel) on the WRT54GL routers that I configure, because I can install openvpn and tcpdump and I still have some KB of flash free...

4MB is enough for backfire 10.03, so yes. The standard image is about 2.4 MB.

46 (edited by Kurgan 2010-05-24 23:08:07)

Re: Backfire 10.03 Released

I have just tried, and I cannot install openvpn because I need more space...

root@OpenWrt:/etc/config# opkg install openvpn
Installing openvpn (2.1.1-1) to root...
Downloading http://downloads.openwrt.org/backfire/10.03/brcm47xx/packages/openvpn_2.1.1-1_brcm47xx.ipk.
Installing kmod-tun (2.6.32.10-1) to root...
Downloading http://downloads.openwrt.org/backfire/10.03/brcm47xx/packages/kmod-tun_2.6.32.10-1_brcm47xx.ipk.
Installing libopenssl (0.9.8m-3) to root...
Configuring kmod-tun.
Collected errors:
* verify_pkg_installable: Only have 804kb available on filesystem /overlay, pkg libopenssl needs 1301
* opkg_install_cmd: Cannot install package openvpn.

Sorry, I was drinking a White Russian, maybe. I wanted to say "Kamikaze" (7.09), that is the latest that runs on such low memory.

47 (edited by Lutz_R 2010-06-01 18:53:41)

Re: Backfire 10.03 Released

I am sorry for not responding a long time.
Canni: I tried the channel set to 5 and 6, doesn't work
ath: wpad is not running, and I don't know how to start it
spjakob: I do not own a wl-500g premium, i got a deluxe
drrignell: Linux 2.4 worked, but not as good as kamikaze. bittorrent with wifi leads to a huge packet loss. after 100mb of loaded data there are about 100mb of loss. I try to get it running with a more recent 2.6 kernel.
pfugl: I now do not any encryption, same result. sad

//Update: I finally managed to find out how to run hostapd. here is its output. it has been started with "hostapd -dd /var/run/hostapd-phy0.conf"
http://nopaste.info/92fa6830d9.html
but no wireless interface got an essid set, and no laptop is receiving a signal

here is the output of logread http://nopaste.info/a4a658492d.html

Re: Backfire 10.03 Released

Is there somebody that could help me with this issue, please?
I installed Backfire on a x86 PC. Almost everything works fine, but I cannot get the power button to get working.
Acpid is not installed (it is not in busybox either). How can catch the power button event?

I could not find any info regarding this on the web.

Re: Backfire 10.03 Released

Still no answer on support for WRT54GS with 2.6 kernel (i mean, wifi support, because I can't get it works)

Re: Backfire 10.03 Released

Thank you for your work.

I read in the release notes the following supported platform:

* Marvell Kirkwood: SheevaPlug, GuruPlug, OpenRD... (kirkwood)

Please, could you post instructions about how to install OpenWRT in a SheevaPlug.

In fact I own a Seagate Dockstar (coming from provider) but I guess the procedure is going to be the same.