OpenWrt Forum Archive

Topic: TP Link WR1043ND 11n gigabit router

The content of this topic has been archived between 20 Jul 2013 and 7 May 2018. Unfortunately there are posts – most likely complete pages – missing.

rdbpt wrote:

I tried to use "radio0" and "wlan0" as the tag for "option device" and "config 'wifi-device'" because when I do a iwconfig I get a device named wlan0. Does the tag matter?

The config entry should be radio0 (I would think it matters, but am not sure). You will only see wlan0 in iw/ifconfig. It's similar to using wlan0 in the config for older Atheros chipsets and seeing ath0 in iw/ifconfig....could be wrong here, as I think ath0 only shows up in ifconfig, and wlan0 in iwconfig.

Maybe it's the build you're using. I was running r19501 before I bricked mine. Perhaps we followed the same upgrade procedure?

From build r19501, all I did was change the wireless mode to Client (sta) and network from lan to wan. I also broke the bridge between lan and eth0.1, but I'm not sure if that was necessary.

Also, make sure you don't have anything connected to the physical WAN port as you can only have one WAN.

For those who are looking to add a serial port, I found the trick to opening the case is simply unscrewing the SMA retaining nuts and removing the outer (black) frame to expose the front clips.

1.  Remove the two screws from under the rubber feet at the back of the device.
2.  Unscrew all three retaining nuts on the SMA connectors and carefully push them into the housing.
3.  Push one of the bottom screws back into place to separate the top from the outer frame.
4.  With the top slightly open, push the bottom plastic away from the outer frame.
5.  Remove outer frame.
6.  With a flathead screwdriver or similar tool, gently pry the two front clips apart.
7.  Carefully separate the bottom guide posts from the top of the unit, then pull the top section forward.

FWIW, I installed the daily build (from http://downloads.openwrt.org/snapshots/trunk/ar71xx/) as of a few days ago and it failed to come up normally.  It would come up in failsafe mode if I hit the button a few times, but I was unable to make it come up in normal mode.  I suspect it was due to the mtdblock not getting mounted correctly, as mount_root also failed to work in failsafe mode. I spent a little time trying to debug it with rtz on IRC, but was unable to get it to work. I've since switched back to the factory firmware.

Anyway, my question is: is there a better build or source of a build that I should be using?

this snapshot doesnt support vlans and i hope you know that.

You can use my or obsy`s openwrt. Our firmwares support vlans.

shibby wrote:

this snapshot doesnt support vlans and i hope you know that.

You can use my or obsy`s openwrt. Our firmwares support vlans.

Can you give me the link for the sourcecode-patch, thx.

Would like to upgrade to a newer build than r19052, but if I understood it right vlan and failsafe don' t work together.

Maybe you have a working image and a md5sum already :-)

KillaB wrote:
rdbpt wrote:

I tried to use "radio0" and "wlan0" as the tag for "option device" and "config 'wifi-device'" because when I do a iwconfig I get a device named wlan0. Does the tag matter?

The config entry should be radio0 (I would think it matters, but am not sure). You will only see wlan0 in iw/ifconfig. It's similar to using wlan0 in the config for older Atheros chipsets and seeing ath0 in iw/ifconfig....could be wrong here, as I think ath0 only shows up in ifconfig, and wlan0 in iwconfig.

Maybe it's the build you're using. I was running r19501 before I bricked mine. Perhaps we followed the same upgrade procedure?

From build r19501, all I did was change the wireless mode to Client (sta) and network from lan to wan. I also broke the bridge between lan and eth0.1, but I'm not sure if that was necessary.

Also, make sure you don't have anything connected to the physical WAN port as you can only have one WAN.

Hello,
After several hours around the issue, I went back to r19296, did a image reinstall and managed to make PSK2 working, etc using the above sugestion. I'm using radio0 on the config file, and when I do a iwconfig it shows wlan0 as the device.

Now I come into a diferent isse but that is related to my lack of expertise on openwrt and not the WR1043ND itself, and I ended up configuring my wlan port as part of the wan, and I'm NATing from my LAN to the WAN.

root@OpenWrt:/# cat /etc/config/network
config 'switch' 'eth0'
        option 'vlan1' '1 2 3 4 5*'
        option 'vlan2' '0 5'

config 'interface' 'loopback'
        option 'ifname' 'lo'
        option 'proto' 'static'
        option 'ipaddr' '127.0.0.1'
        option 'netmask' '255.0.0.0'

config 'interface' 'lan'
        option 'ifname' 'eth0.1'
        option 'proto' 'static'
        option 'ipaddr' '192.168.2.1'
        option 'netmask' '255.255.255.0'

config 'interface' 'wan'
        option 'ifname' 'wlan0'
        option 'proto' 'dhcp'

root@OpenWrt:/# cat /etc/config/wireless
config wifi-device  radio0
        option type     mac80211
        option channel  5
        option macaddr  00:19:e0:66:66:68
        option hwmode   11ng
        option htmode   HT20
#       option htmode   'HT40-'
#       option htmode   'HT40+'
        option county   DE
        list ht_capab   SHORT-GI-40
        list ht_capab   DSSS_CCK-40
        # REMOVE THIS LINE TO ENABLE WIFI:

config wifi-iface
        option device   radio0
        option network  lan
        option mode     sta
        option ssid     SSID
        option encryption psk2
        option key      PASSWORD

root@OpenWrt:/# cat /etc/config/firewall
config defaults
#       option syn_flood        1
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT

config zone
        option name     lan
        option input    ACCEPT
        option output   ACCEPT
        option forward  ACCEPT

config zone
        option name     wan
        option input    REJECT
        option output   ACCEPT
        option forward  REJECT
        option masq     1
        option mtu_fix  1

config forwarding
        option src      lan
        option dest     wan
        option masq     1

The "home" DHCP server on 192.168.1 network assigns the IP address to the WR1043ND.

When I have more time I'll fiddle around the NAT issue. I intend to have bridging between LAN and WAN (to have all computers on the 192.168.1. network and because of that I'm having double NATs to connect to the internet and vice versa), but that looks like a general WRT issue so I'll leave it out of this thread.

Thank you for your help,
regarda,
rdb

(Last edited by rdbpt on 14 Feb 2010, 18:47)

@rdbpt

Not sure about your issue, but I use the following settings so that you can use wired WAN and wireless WAN interchangeably (not at the same time of course).
I had firewall problems when using OpenVPN and ended up using the firewall scripts from 8.09.2 to sort them out, but otherwise left the stock firewall settings unchanged.

/etc/config/network:
config interface      wan
        option ifname eth0.2
        option proto   dhcp


/etc/config/wireless:
config wifi-iface
        option device   radio0
        option network  wan
        option mode     sta
        option ssid     SSID
        option encryption psk2
        option key      PASSWORD

(Last edited by KillaB on 14 Feb 2010, 23:30)

sala wrote:

Will jumbo frames work with openwrt on WR1043ND or driver only accepts 1500 frame size?

What about jumbo frames? Can it pass larger than 1500 frames between lan ports? It is like the most important thing in a gigabit router and no one really cares about it sad

http://www.smallnetbuilder.com/lanwan/l … l-networks

(Last edited by sala on 15 Feb 2010, 09:52)

sala wrote:
sala wrote:

Will jumbo frames work with openwrt on WR1043ND or driver only accepts 1500 frame size?

What about jumbo frames? Can it pass larger than 1500 frames between lan ports? It is like the most important thing in a gigabit router and no one really cares about it sad

http://www.smallnetbuilder.com/lanwan/l … l-networks

The stock firmware makes no mention of it, nor the packaging, nor the manual. Therefore, on the surface I would say no. Down the road is anyone's guess. You would need to ask Realtek about the specs of the RTL8366RB.

I also have a Realtek controller on my Atom board (RTL8111/8168B) which doesn't support jumbo frames. I can transfer files to and from the Atom board through the switch of the WR1043ND at speeds upwards of 31MB/s even without jumbo frames, so I'm pretty happy about that.

KillaB wrote:

Ok, so I thought I read this link before without any mention of jumbo frames.
Now it states it can handle them.
http://www.realtek.com.tw/products/prod … ProdID=197

I also have Belkin F5D8235 v1000 which has RTL8366SR chip (should be very similar to RTL8366RB) and it has jumbo frame support, there is no word in manual nor any configurable item in web interface but it works out of box with 1.5K-9K frames. And with 9K frames I can achieve about 50MB/s copy speed from NSA-220 nas to workstation. With default 1.5K its about 20MB/s.
I think when chip supports it then its down to module and kernel network stack to do the rest.

(Last edited by sala on 15 Feb 2010, 12:10)

KillaB wrote:
sala wrote:
sala wrote:

Will jumbo frames work with openwrt on WR1043ND or driver only accepts 1500 frame size?

What about jumbo frames? Can it pass larger than 1500 frames between lan ports? It is like the most important thing in a gigabit router and no one really cares about it sad

http://www.smallnetbuilder.com/lanwan/l … l-networks

The stock firmware makes no mention of it, nor the packaging, nor the manual. Therefore, on the surface I would say no. Down the road is anyone's guess. You would need to ask Realtek about the specs of the RTL8366RB.

I also have a Realtek controller on my Atom board (RTL8111/8168B) which doesn't support jumbo frames. I can transfer files to and from the Atom board through the switch of the WR1043ND at speeds upwards of 31MB/s even without jumbo frames, so I'm pretty happy about that.

Take a look at http://www.realtek.com.tw/products/prod … ProdID=197 (first google hit)

"Supports 9216 bytes jumbo packet length forwarding at wire speed"

Is the trouble of having different MTUs in your Network worth the speed improvement ?

Im sure jumboframes suport is implemented.

this is what i got during switch speed test using 2 comps (1gbps lan cards on realtek chip) with raid0

Iperf TEST
http://www.pivo.neostrada.pl/rspro-switch-artek.png


FTP TEST
http://www.pivo.neostrada.pl/rspro-switch.png

Any idea when the patches necessary for vlans + failsafe will make it into the trunk?

pjz wrote:

Any idea when the patches necessary for vlans + failsafe will make it into the trunk?

No idea. But for what? All patches you need are in this topic smile

Thanks for your answers!!

p1vo wrote:

Im sure jumboframes suport is implemented.
this is what i got during switch speed test using 2 comps (1gbps lan cards on realtek chip) with raid0
Iperf TEST
FTP TEST

Simple ping test would also confirm. If larger than 1500 frames answer then you have support if not then dont. Also I think frames size cant be any number larger than 1500, you can increase it by steps.

ping -f -l <frame size> <host>
toad wrote:

Take a look at http://www.realtek.com.tw/products/prod … ProdID=197 (first google hit)

"Supports 9216 bytes jumbo packet length forwarding at wire speed"

I see. Its just chip but as I said, module we have in openwrt must also support this.

toad wrote:

Is the trouble of having different MTUs in your Network worth the speed improvement ?

Depends how large is your network, how many different devices you have and how important this speed gain really is for you.

(Last edited by sala on 16 Feb 2010, 12:05)

p1vo wrote:

Im sure jumboframes suport is implemented.

this is what i got during switch speed test using 2 comps (1gbps lan cards on realtek chip) with raid0

Iperf TEST
http://www.pivo.neostrada.pl/rspro-switch-artek.png


FTP TEST
http://www.pivo.neostrada.pl/rspro-switch.png

1043ND don't support jumbo frame, I had ask TP-LINK, as it say it support up to 19xx only
and you can test it using ping -f -l
but the realtek switch does support jumbo frame, that means we just need to find a way to enable it

Dear Dummy,



Our TL-WR1043ND support the maximum frame size up to 1999 Byte.



If you need any further help please feel free to contact me.

To get our technical support more quickly, please go to http://www.tp-link.com/support/faq.asp



Best Regards?


Howard He  (???)

Technical Support Engineer

TP-LINK Technology Co.,LTD. 

TEL:  2650 2563

E-mail:Howard.he@tp-link.com

QQ:164390276

MSN: howard.he@live.cn
                                2009-10-29

(Last edited by DummyPLUG on 16 Feb 2010, 16:49)

shibby wrote:
pjz wrote:

Any idea when the patches necessary for vlans + failsafe will make it into the trunk?

No idea. But for what? All patches you need are in this topic smile

...except that they don't apply to HEAD anymore, and they're going to keep getting more and more out of date.  I'd rather see them merged in where they can get the benefits of full maintenance.

Hi Guys,
thanks for your efforts for this, to all involved.
i have been following this thread but cannot understand everything because for some reason i cannot find what I need to strat understanding OPENWRT.
I took a leap of faith and installed this firmware
http://openwrt.groov.pl/WR1043NDv1/r19581/
logged on via telnet. changed password for root and installed webif (i could not get luci to work + i do not know which is better at what).
I managed to setup the wireless and have changed some settings, namely hwmode, in the /etc/config/wireless file but the maximum wireless connection i get is 130mbps.
anyway i can get this to connect at 300mbps? Also I am from Malta. I set the country to MT is it correct?

Another thing i would like to ask is if i can make the router block incomming connections from certain ip ranges. idealy I edit a file like the ipsec.conf on the QNAP ts-210.


Thanks again and I apologise if i went of topic for some reason....
Not intentional.