OpenWrt Forum Archive

Topic: Constantly slow upload OpenWrt and PPPoE (VDSL)

The content of this topic has been archived on 1 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hi guys,

I currently have an issue with my upload (outbound) which is very and constantly slow. I've been looking for days but I dont seem to find anyone with the same issue. So its probably a config issue.

Setup:

  • Router:  Linksys WRT1900AC on OpenWrt CC 15.05.1 r49389 (WAN: eth1.7 via PPPoE)

  • Modem:  Zyxel VMG1312-B30A in Bridgemode

  • ISP:  VDSL50 (50/10) by German 1&1 (Telekom)

Browsing web, IPTV (IGMP Proxy), DDNS etc. work like a charm. Inbound is full 48Mbit. QoS tools are completely uninstalled and still pending.

Issue
I seem to get a constant Outbound of only 50-100kbit/s. This number is from the real time graphs. Also did I download a file with a remote machine from my Nextcloud Ubuntu server which is in my local network.
A speedtest.net from my Mac (WiFi) and speedtest-cli from my ubuntu machine (ethernet) output 0.00 mbit/s upload, but I feel like this could be a firewall and/or rounding issue. Because using the betterspeedtest.sh script directly from the openwrt router outputs 0.08mbit/s of upload.

What I tested:

  • Connect my mac to the modem and dial in via PPPoE directly -> full speed up and down

  • Install lucy-app-qos and started it with defaults-> no difference

Since I do get upstream, can it be a firewall issue? I don't know much about QoS configuration and I do not feel any difference in whether or not qos-scripts is active with defaults?!

So what could be the possible limiting factor?

Thank you
Julian

(Last edited by oaigh on 8 Oct 2017, 17:55)

Network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option ipaddr '10.1.1.1'
        option netmask '255.255.255.0'

config interface 'iptv'
        option ifname 'eth0.2'
        option proto 'static'
        option ipaddr '10.1.2.1'
        option netmask '255.255.255.0'
        option igmp_snooping '1'

config interface 'wan'
        option proto 'pppoe'
        option username 'X1und1/XXXXXXXXATonline.de'
        option password 'XXXXXXXXXXXXXX'
        option ifname 'eth1.7'
        option keepalive '10 5'

config interface 'wan_vlan8'
        option ifname 'eth1.8'
        option proto 'dhcp'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '0 1 2 3 5'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option vid '2'
        option ports '0t 1t 2t 3t 5t'

config switch_vlan
        option device 'switch0'
        option vlan '7'
        option vid '7'
        option ports '4t 6t'

config switch_vlan
        option device 'switch0'
        option vlan '8'
        option vid '8'
        option ports '4t 6t'

The discussion might have continued from here.