OpenWrt Forum Archive

Topic: Wifi on TL-WR1043ND v4

The content of this topic has been archived on 9 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Dear OpenWrt community,

I installed the last version available for this router (4.4.14 on snapshots).

My /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/qca956x_wmac'
        option htmode 'HT20'
        option disabled 1

config wifi-iface
        option device 'radio0'
        option network 'wlan0'
        option mode 'ad-hoc'
        option ssid 'openwrt'
        option encryption 'none'
        option key '1234567890'

and my /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd79:6c61:2e76::/48'

config interface  'wlan0'
        option proto static
        option force_link 1
        option ipaddr '192.168.1.102'
        option netmask '255.255.255.255'

config interface 'lan'
        #option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.0.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 0t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '5 0t'

I have two issues I don't understand.

1.\

When I set

option disabled 1

in

/etc/config/wireless/

 iw dev

returns the Interface wlan0. and when I set

option disabled 0

it doesn't detect any wireless interface. It seems to me it should be the opposite ?

2.\

The wireless interface does not get its own IP adress, nor does it connect to the ad-hoc network. I don't get where the trouble might be.

(Last edited by koko12 on 14 Sep 2017, 10:50)

The discussion might have continued from here.