Topic: IP problem with static IP´s on Wifi Interface (IP 1.1.1.1)

Hello,

i set up a Raspberry Pi B+ with openwrt as Client to bridge traffic incoming from Wifi to my Ethernet port.
I use OpenWrt DD-r48151.
I only setup static IP´s on this setup and all works. But i get some ARP requests which saing

Who has 192.1.1.40? Tell 1.1.1.1

I never set this 1.1.1.1 IP. My pi is 192.1.1.31 on Wifi and 192.168.2.100 on Ethernet and working with relayd to bridge the traffic.

So why does my System use 1.1.1.1 as sender ip address.
There are also arp packeges with the right ip address 192.1.1.31 so it uses both but why and how can i stop this?

thanks in advance

Re: IP problem with static IP´s on Wifi Interface (IP 1.1.1.1)

Short reply,

i found my Error here... I disabled dnsmasq on /etc/init.d/dnsmasq to prevent my system for setting up an dhcp server. When i enable dnsmasq the "1.1.1.1" Ip is changed to my wifi ip so it´s fine.

But my problem why i disabled this was that my system setup it´s own dhcp server and so completely shut down the network of my company. So is there an option to completely stop the dhcp function without stopping dnsmasq?
I know i can put the ignore tag into the /etc/config/dhcp but i don´t trust the system if there is still an dhcp server running.

So if someone knows how to shut down dhcp without dnsmasq it would be nice if you can tell me how.

greetings Patrick

Re: IP problem with static IP´s on Wifi Interface (IP 1.1.1.1)

See the DHCP pools in DNS and DHCP configuration. You need to configure one pool for each logical interface in your /etc/config/network, and set the 'ignore' option to '1'.