Topic: Tplink TL-WA5210g V1 stuck on redboot

Hello,

I had a power failure during the installation process. Now my TPLINK TL-WA5210Gv1 is bricked but I can access (serial or telnet) a redboot : 

RedBoot> version
RedBoot(tm) bootstrap and debug environment [RAM]
Non-certified release, version (patched for dump flashing) - built 12:50:19, Dec 26 2012
Copyright (C) 2000, 2001, 2002, 2003, 2004 Red Hat, Inc.
Copyright (C) 2009 NewMedia-NET GmbH
Board: ap51
RAM: 0x80000000-0x81000000, [0x8002fab0-0x80fed000] available
FLASH: 0xbfc00000 - 0xbfff0000, 64 blocks of 0x00010000 bytes each.
RedBoot>

can anyone help me to finish the installation process ?

Best regards,
bidule

Re: Tplink TL-WA5210g V1 stuck on redboot

There is a program called ap51flash which runs on a Linux PC, it will automatically flash most of the AP51 redboots.   You don't need serial at all but you can use it to watch.

The router only has 16MB of RAM, so I would use an old version of OpenWrt.  Newer versions are going to run out of RAM and crash.

Re: Tplink TL-WA5210g V1 stuck on redboot

Hello mk24,

thank you for your reply.

I have to start tftpd manualy on the WA5210Gv1 for the ap51flash program to work. I have try several images but I get either :

"Unsupported image"
then
"ignoring file"
then
"[81:d3:e4:14:bc:09]: is of type 'ubiquiti' that we have no image for"

or [81:d3:e4:14:bc:09]: type 'ubiquiti router' detected
[81:d3:e4:14:bc:09]: ubiquiti router: connection to tftp server established - uploading 7168 blocks ...
[81:d3:e4:14:bc:09]: ubiquiti router: received TFTP error: CRC error

I might have to change the mac address in the image, do you know how this could be done ?

Sincerely,
bidule

Re: Tplink TL-WA5210g V1 stuck on redboot

this is what I get on the serial console :

TFTPD: Connect from 192.168.1.25 port 13337
TFTPD: Upload completed (got 3670016 bytes).
Checking uploaded file...
DUMP_FW: Bad dump header
header dump: 0x4F 0x08 0x00 0x1c

TFTPD: Error 2: CRC error

Re: Tplink TL-WA5210g V1 stuck on redboot

use wa5210g to ubnt software recovery mode

Re: Tplink TL-WA5210g V1 stuck on redboot

Hello,

Thank you for your help. Where do you find the wa5210g to ubnt software recovery mode ?

Please find bellow the command available on the redboot of my TL-WA5210Gv1:
RedBoot> help
Manage aliases kept in FLASH memory
   alias name [value]
Set/Query the system console baud rate
   baudrate [-b <rate>]
Manage machine caches
   cache [ON | OFF]
Display/switch console channel
   channel [-1|<channel number>]
Execute an image
   exec [-b <argv addr>] [-c "kernel command line"] [-w <timeout>]
        [<entry point>]
Manage FLASH images
   fis {cmds}
Manage configuration kept in FLASH memory
   fconfig [-i] [-l] [-n] [-f] [-d] | [-d] nickname [value]
Execute code at a location
   go [-w <timeout>] [-c] [-n] [entry]
Help about help?
   help [<topic>]
Display command history
   history
Set/change IP addresses
   ip_address [-l <local_ip_address>[/<mask_len>]] [-h <server_address>]
Load a file
   load [-r] [-v] [-h <host>] [-p <TCP port>][-m <varies>] [-c <channel_number>]
        [-b <base_address>] <file_name>
Reset the system
   reset
Start tftp server and wait for firmware update
   tftpd
Display RedBoot version information
   version

Re: Tplink TL-WA5210g V1 stuck on redboot

obviously, in wa5210g to ubnt software: https://forum.openwrt.org/viewtopic.php?id=53928

Re: Tplink TL-WA5210g V1 stuck on redboot

Hello,

I have tried with the software but it is stuck with "unknow mac address" message.

I have tried to upload an image through redboot but the AP get stuck when I execute the image.

nyone to suggest what I could try next ?

Thank you for helping