1 (edited by danielsender 2017-04-20 02:44:08)

Topic: wireless is disabled or not associated

I just finished installing openwrt on a linksys e4200v2. Everything went ok and I attempted to configure it as a bridge repeater. However when I ran a "scan" and "join" the main wifi a problem came up. Now the wireless tab shows a message "wireless is disabled or not associated" . I tried on luci to click disable/enable again but to no avail. I will appreciate any help.

Thanks.

Re: wireless is disabled or not associated

You can't put a regular client mode interface into a bridge.  Use routed client instead.  Make sure your wan or wwan interface is not a bridge, and the client is the only thing in it.

For a true bridge across an AP-client wifi connection, the AP needs to support WDS mode, then you can use client-WDS.

Re: wireless is disabled or not associated

Can you please tell me how to proceed to do that? This is my first experience with openwrt. In the past I used dd-wrt with other routers and I was able to configure them as "repeater bridge". Is that equivalent to  "routed client"?

Thanks.

4 (edited by mk24 2017-04-20 03:20:54)

Re: wireless is disabled or not associated

I don't like the Join button script which makes a new interface, etc.  That is unnecessarily complicated.
Start with a default configuration
Manually create a client mode wifi interface-- enter the SSID and encryption settings for the AP you are going to get Internet from.  Put it in the 'wan' network.
Go to Network - Interfaces - Edit button for WAN - Physical Settings.  Uncheck Bridge.  Select the wifi interface you created.
Go to the main status page you should see an IPv4 WAN connection has become active.  If the AP gave you an address in 192.168.1.X you will need to change your LAN IP to a different range before it can route to the internet.
You can connect the now unused wan ethernet interface to the LAN bridge to use all 5 ports for wired devices.
You can of course create an AP mode wifi.  OpenWrt does not enable an AP when first started.  Note that if you lose the connection to the ISP AP, the other AP will go off the air and you will need a wired connection to log into the router.

5 (edited by danielsender 2017-04-20 08:15:22)

Re: wireless is disabled or not associated

Before selecting the type of configuration I must get the wireless to work - The 2.4GHz band is not working while the 5GHz does. I checked with "uci show wireless" and I don't see any instance of the word "disabled", I even tried setting "disabled=0" but it didn't do anything. I wonder if there is any other knob to turn on the radio.
Thanks

6 (edited by danielsender 2017-04-20 17:51:25)

Re: wireless is disabled or not associated

I just entered: "wifi detect" and there is no output.

This is the output of "wifi status":

{
    "radio0": {
        "up": false,
        "pending": false,
        "autostart": true,
        "disabled": false,
        "retry_setup_failed": true,
        "config": {
            "path": "mbus\/mbus:pcie-controller\/pci0000:00\/0000:00:01.0\/0000:01:00.0",
            "country": "00",
            "hwmode": "11a",
            "channel": "auto",
            "distance": 10
        },
        "interfaces": [
            {
                "section": "@wifi-iface[0]",
                "config": {
                    "mode": "ap",
                    "key": "xxxxxxxxxx",
                    "ssid": "araoz",
                    "encryption": "psk2+ccmp",
                    "mode": "ap",
                    "network": [
                        "lan"
                    ]
                }
            },
            {
                "section": "@wifi-iface[2]",
                "config": {
                    "ssid": "vivaldi",
                    "mode": "sta",
                    "bssid": "B4:75:0E:FB:F8:B2",
                    "key": "xxxxxxxxxxx",
                    "encryption": "psk2+ccmp",
                    "mode": "sta",
                    "network": [
                        "lan"
                    ]
                }
            }
        ]
    },
    "radio1": {
        "up": true,
        "pending": false,
        "autostart": true,
        "disabled": false,
        "retry_setup_failed": false,
        "config": {
            "channel": "36",
            "hwmode": "11a",
            "path": "mbus\/mbus:pcie-controller\/pci0000:00\/0000:00:02.0\/0000:02:00.0",
            "htmode": "HT20",
            "country": "00"
        },
        "interfaces": [
            {
                "section": "@wifi-iface[1]",
                "ifname": "wlan1",
                "config": {
                    "mode": "ap",
                    "ssid": "araoz_5g",
                    "key": "xxxxxxxxxxx",
                    "encryption": "psk2+ccmp",
                    "mode": "ap",
                    "network": [
                        "lan"
                    ]
                }
            }
        ]
    }
}

Notice that in radio0 the "up" string is false, while in radio1 is true. I don't see in the configuration options the variable "up", if that would be a way to kick it off.

Re: wireless is disabled or not associated

Finally I gave up on setting openwrt with the Luci interface. IMHO it is not very intuitive. I just followed the instructions on forum.openwrt.org/viewtopic.php?id=39077 using the CLI - Everything went fine, and the repeater bridge works flawlessly.

Thanks anyway.