Topic: Designated Driver on BT Homehub 5A, kernel version 4.4.14?

Hi all,

My Homehub5 has been running DD for exactly a year without a blip. Last night I thought I'd give it some update lovin' for the latest versions of LUCI and OpenVPN that I've been setting up over the last week or two. This in turn led me to try and install some modules (fwbuilder) that need a 4.4.14 kernel - I'm still on 4.4.7.

I fired up my build PC and refreshed the packages etc and the build failed at musl-1.1.14 which googling showed was down to an out of date source tree. I updated the code from git and now get 'kernel too large' messages.

Just in case I'd goofed I cloned a whole new distribution from git, ran make defconfig which produced these errors:

tmp/ recursive dependency detected!
tmp/   symbol PACKAGE_iptables is selected by PACKAGE_vpnbypass
tmp/   symbol PACKAGE_vpnbypass depends on PACKAGE_ip
tmp/   symbol PACKAGE_ip is selected by PACKAGE_luci-mod-freifunk-community
tmp/   symbol PACKAGE_luci-mod-freifunk-community depends on PACKAGE_libuci
tmp/   symbol PACKAGE_libuci is selected by PACKAGE_firewall
tmp/     symbol PACKAGE_firewall is selected by PACKAGE_luci-app-firewall
tmp/   symbol PACKAGE_luci-app-firewall is selected by PACKAGE_luci-app-p2pblock
tmp/   symbol PACKAGE_luci-app-p2pblock depends on PACKAGE_iptables

the only packages out of those I have selected is iptables, firewall and luci-app-firewall. Ran make menuconfig to try and see why it thinks I have vpnbypass selected and noticed the lantiq device now only has 'default' as a profile, no other options. Let it build anyway and it's trying to build for a TDW8970 router?

Baffled. I notice LEDE has a download for the Homehub5 so is it dead as far as OpenWRT is concerned?



Re: Designated Driver on BT Homehub 5A, kernel version 4.4.14?

OK, a bit further on. I've solved the recursive package problem by removing feeds/packages/net/vpnbypass/*

There's no profile selections for the HH5A because target/linux/lantiq/xrx200/profiles only has a default entry in despite there being a dts entry and LED configurations etc, so I copied the config from my old source tree and called it to match the naming scheme. Deleted everything in tmp/.* and reran make defconfig and menuconfig which gives me the right info in the profile selection.


I still get a TDW8970 (tp link?) build and 'kernel too big' errors. I guess I'm the only one doing this now smile