hello guys i am new in the forum, i have a queston.
I have set-top-box that needs separate Switch before router so it can work.
I want to remove the switch and feed the set-top-box thru port 4 of WRT1900AC v.1 router.
For that purpose i have to assign new VLAN to switch configuration, but here's the tough part, i don't know how to configure the VLAN's to work simultaneously.
Here's the /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd2b:69fe:a8a9::/48'

config interface 'lan'
        option ifname 'eth0'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '192.168.1.1'

config interface 'wan'
        option ifname 'eth1'
        option _orig_ifname 'eth1'
        option _orig_bridge 'false'
        option proto 'static'
        option ipaddr '78.90.146.176'
        option netmask '255.255.255.0'
        option gateway '78.90.146.1'
        option dns '78.90.146.1 89.190.192.247'
        option macaddr '00:E0:4C:32:BC:37'

config interface 'wan6'
        option ifname 'eth1'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 5'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 6'

As far i can tell i have to make config switch_vlan 1.1 and config switch_vlan 1.2, in 1.1 i have to write assigned ports to my home network, and in  1.2 i have to make the passthru Port 4 <--> WAN.
port 5 is the CPU on the router, but what is port 6 in config?
Please help with config.

(Last edited by stanislav.suba6ev on 29 Nov 2016, 15:18)