OpenWrt Forum Archive

Topic: WISP MODE openwrt

The content of this topic has been archived on 6 May 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hello guys,
I have problem implementing wisp mode  in  OpenWrt,  it  works fine in all router model that  I have tested so far but, the problem is that the AP ssid won't appear if the wwan ssid is not present.
I don't know how to setup the router to keep the AP ssid (lan) side active even  the wwan ssid is not in range.
I am sharing the WiFi config  and network config files  that I am using so maybe one of you can point me to the right way to do wisp mode  without losing the AP SSID .
thanks you.

WIRELESS config v1 
config wifi-device 'radio0'
    option type 'mac80211'
    option hwmode '11g'
    option path 'platform/ar933x_wmac'
    option htmode 'HT20'
    option disabled '0'
    option channel '7'
    option txpower '18'
    option country 'US'

config wifi-iface
    option ssid 'APSSID'
    option encryption 'psk2'
    option device 'radio0'
    option mode 'sta'
    option bssid 'E8:94:F6:69:65:30'
    option key 'xxxxxx'
    option network 'wwan'

config wifi-iface
    option device 'radio0'
    option mode 'ap'
    option ssid 'OpenWrt'
    option encryption 'psk-mixed'
    option key 'xxxxx'
    option network 'wifiap'

ETHERNET config v1

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fdf3:bb56:3ed1::/48'

config interface 'lan'
    option ifname 'eth0'
    option force_link '1'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option ip6assign '60'

config interface 'wan'
    option ifname 'eth1'
    option proto 'dhcp'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '0 1 2 3 4'

config interface 'wwan'
    option proto 'dhcp'

config interface 'wifiap'
    option _orig_ifname 'wlan0-1'
    option _orig_bridge 'false'
    option proto 'static'
    option ipaddr '192.168.3.1'
    option netmask '255.255.255.0'

config interface 'br1'
    option proto 'relay'
    option ipaddr '192.168.2.1'
    list network 'lan'
    list network 'wifiap'

this is the sencond config that I use but I have the same problem.. no AP SSID appear when WWAN not present.

Wireless config v2

config wifi-device 'radio0'
    option type 'mac80211'
    option channel '7'
    option hwmode '11g'
    option path 'platform/ar933x_wmac'
    option txpower '30'
    option country 'US'
    option disabled '0'

config wifi-iface
    option network 'wwan'
    option ssid 'SSID'
    option encryption 'psk2'
    option device 'radio0'
    option mode 'sta'
    option bssid 'E8:94:F6:69:65:30'
    option key 'xxxxx'

config wifi-iface
    option device 'radio0'
    option mode 'ap'
    option ssid 'OpenWrt'
    option network 'lan'
    option encryption 'psk-mixed'
    option key 'xxxxxx'

 Network config v2

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fddc:8b34:f1fc::/48'

config interface 'lan'
    option ifname 'eth0'
    option force_link '1'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.2.1'
    option netmask '255.255.255.0'
    option ip6assign '60'

config interface 'wan'
    option ifname 'eth1'
    option proto 'dhcp'
    option type 'bridge'

config interface 'wan6'
    option ifname '@wan'
    option proto 'dhcpv6'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '0 1 2 3 4'

config interface 'wwan'
    option proto 'dhcp'

WISPMODE:
WISP mode is simply a wireless WAN mode where your wireless access point device acts like a router internally but uses the wireless signal from another router as it's WAN interface. Since it is using the wireless interface for both WAN interface to the Internet and WLAN interface internally, it cuts the wireless bandwidth in half. So if the originating router has 30Mbps bandwidth then you can get only maximum of 15Mbps of bandwidth out of it.

The issue is known.  If a configured STAtion becomes unavailable this will also hang the WLAN.  There are a few solutions, but the easiest one is to disable the STAtion (WISP if you prefer) automatically on boot.  If you have a button, then you may alternatively make some of these tools work on demand

this post will lead you to some options.
https://forum.openwrt.org/viewtopic.php … 32#p311832

and this was recently posted with a bit more intelligence in it, but I have not yet tried it.
https://forum.openwrt.org/viewtopic.php … 47#p337947

Thanks you.. that is good information.

Update:
I made a test of the  following recipe , and works perfect.
wiki.openwrt.org/doc/recipes/ap_sta

The discussion might have continued from here.