Topic: Network-Switch tab missing in CC 15.05.1 on WRT1900ACS

Hello all.

I have a WRT1900ACS with CC 15.05.1 flashed. I was trying to configure my VLANs but I cannot find the Switch menu under Network tab that I got on my other OpenWRT-flashed routers.

http://img.imgur.com/zWL64O5.png

I tried flashing the previous official release (15.05) but I did not get the Switch tab either.

Then I started reading the forums for a solution, and I came across this one:

edit /etc/config/network and add

config 'switch' 'eth0'
        option 'enable' '1'
        option 'enable_vlan' '1'
        option 'reset' '1'

But whenever I try to configure a VLAN, not only it does not work, but it bricks the router to the point I have to manually revert it to stock settings. I guess it has to be enabled by other means in order for it to work.

Anyone knows a solution to this?

Thanks in advance.

Regards.

Re: Network-Switch tab missing in CC 15.05.1 on WRT1900ACS

Hi,

Exactly same problem here, also WRT1900ACS and CC 15.05.1!

One thing I figured: It's not bricked, just that you don't get access anymore through the LAN ports. I was still able to access LuCI and SSH via Wifi. So was able to revert the config without having to factory reset everything.

swconfig dev switch0 show

indicates that VLAN should be working fine. However other posts mention that the stock image will not work for VLAN on WRT1900ACS. Others said you need to install the ip package via opkg (as opposed to using the stock busybox command).
I'm going to try these things out and let you know again. Please also post if you have found a solution in the meanwhile.

SoftIce

Re: Network-Switch tab missing in CC 15.05.1 on WRT1900ACS

The default acs vlan config should look something like:

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 6'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 5'
Linksys WRT1900ACS v1 (Shelby)  |  Linksys WRT3200ACM (Rango)

4 (edited by SoftIce79 2016-06-22 16:11:58)

Re: Network-Switch tab missing in CC 15.05.1 on WRT1900ACS

Thanks sera, that did the trick!
I added your config to /etc/config/network and the Switch tab appeared in LuCI, also the router was not hanging anymore.

I figured the port mapping is as follows for the ACS:
Port0 - LAN Port 4
Port1 - LAN Port 3
Port2 - LAN Port 2
Port3 - LAN Port 1
Port4 - WAN
Port5 - CPU [WAN]
Port6 - CPU [LAN] - thanks sera!

I wanted to map my WAN interface to VLAN10, so I simply did the following:
Network -> Switch -> Add -> VLAN ID: 10, Port 4: tagged, CPU: tagged, Rest: off
Network -> Interfaces -> WAN -> Physical Settings -> Bridge interfaces: select eth0 and eth0.10

That's all. Finally my ACS was able to pick its IP via DHCP from my ISP's ONT (Optical Network Terminal).

Hope this helps someone else.

SoftIce

Re: Network-Switch tab missing in CC 15.05.1 on WRT1900ACS

You're welcome, Port6 is the other cpu interface (eth1).

Linksys WRT1900ACS v1 (Shelby)  |  Linksys WRT3200ACM (Rango)

Re: Network-Switch tab missing in CC 15.05.1 on WRT1900ACS

Hello guys. I have the same Issue, I don`t have a switch menu. I am new at all this and started playing with openWRT only couple of days ago, because my WRT1900acs V1 started to reboot constantly, lose 2.4MHz network, and in general perform poorly.  Now I have managed to sort out the wifi, and all the needed port forwarding and etc, but I need to setup vlans for my IPTV boxes. And I cant find anywhere how to do it. I noticed that I am missing the Switch menu  selection. Can anyone tell me how exactly I could activate it?

Can anyone tell me how to

Re: Network-Switch tab missing in CC 15.05.1 on WRT1900ACS

The answer is in post 3 and 4 above.  Check if your /etc/config/network file contains a section like Sera posted in post 3, if it does not, add it, reboot and the switch tab should be activated.

Also as noted above, before working on the switch, configure a wifi AP and log in via wifi.  That will continue to work if you misconfigure the Ethernet.

This has probably been fixed in later versions.