OpenWrt Forum Archive

Topic: davidc502 1900ac 3200acm builds

The content of this topic has been archived between 26 Feb 2018 and 7 May 2018. Unfortunately there are posts – most likely complete pages – missing.

There were 2 new mvebu (sub)targets added ~12 days back. You may have to rework your config a little.

kirkgbr wrote:

David or anyone else building their own. 

It's been a couple months since I last built.  For some reason it seems the location of my built images landed in a different / path location.

From:
bin/targets/mvebu/generic/

To:
bin/targets/mvebu/cortexa9/

Did anyone else notice this or did I do something wrong?

There is new hardware added for mvebu and it screwed some things up.  Be sure to check your .config for the images you want to build as you will have to re-select them.

eduperez wrote:
Villeneuve wrote:
        option noscan '1'

Note: option may be illegal, and its use in a congested area will probably hinder not help. I use it in my /etc/config/wireless but I live in a rural area where my closest competitor is ~100m distant.

The fact is you only need to use it when you are not allowed to use it... If you live in a non-congested area, then your device will not detect any nearby AP, and will happily use 40MHz. If you live in a congested area, then your device will go down to 20MHz, as per legal requirements, unless you use that parameter.

What "legal requirements"?
Draft N APs don't have it yet they are not illegal! (not only that, but a whole lot of AC APs also don't care).

It seems like nothing more than an anti feature.

(Last edited by NamesAreAPain on 22 Mar 2018, 08:18)

NamesAreAPain wrote:

What "legal requirements"?
Draft N APs don't have it yet they are not illegal! (not only that, but a whole lot of AC APs also don't care).

It seems like nothing more than an anti feature.

From https://wiki.openwrt.org/doc/uci/wirele … e_options:

option noscan
Do not scan for overlapping BSSs in HT40+/- mode.
Turning this on will violate regulatory requirements!

Villeneuve wrote:

There were 2 new mvebu (sub)targets added ~12 days back. You may have to rework your config a little.

davidc502 wrote:

There is new hardware added for mvebu and it screwed some things up.  Be sure to check your .config for the images you want to build as you will have to re-select them.


Thanks to both of you.  I ripped out my old config and created a new one but still the location for built images is now

bin/targets/mvebu/cortexa9/

Back to the drawing board. sad

Hello! Can somebody help me with my WRT3200ACM? (Davidc latest build 2018/02)
I want to configure VLAN as follows:
VLAN 100 Management (LAN, untagged)
VLAN 101 Wifi-Corporate (tagged)
VLAN 102 Wifi-Devices (tagged)
VLAN 103 Wifi-Guest (tagged)
Switch is correctly configured, separated DHCP-Server. My /config/network output:

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fd77:70b1:eb8d::/48'

config interface 'lan'
    option type 'bridge'
    option proto 'static'
    option netmask '255.255.255.0'
    option ip6assign '60'
    option delegate '0'
    option ipaddr '10.101.100.252'
    option gateway '10.101.100.254'
    option broadcast '10.101.100.255'
    option _orig_ifname 'eth0 wlan0 wlan0-1 wlan0-2 wlan1 wlan1-1 wlan1-2 radio2.network1'
    option _orig_bridge 'true'
    option ifname 'eth1'

config interface 'wan'
    option proto 'dhcp'
    option ifname 'eth1.100'

config interface 'wan6'
    option proto 'dhcpv6'
    option ifname 'eth1.100'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option vid '1'
    option ports '0 1 2 3 5 6'

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option ports '3t 4 5t 6t'
    option vid '100'

config switch_vlan
    option device 'switch0'
    option vlan '3'
    option vid '101'
    option ports '3t 5t 6t'

config switch_vlan
    option device 'switch0'
    option vlan '4'
    option vid '102'
    option ports '3t 5t 6t'

config switch_vlan
    option device 'switch0'
    option vlan '5'
    option vid '103'
    option ports '3t 5t 6t'

config interface 'Corporate'
    option type 'bridge'
    option proto 'static'
    option ipaddr '10.101.101.252'
    option netmask '255.255.255.0'
    option gateway '10.101.101.254'
    option broadcast '10.101.101.255'
    option _orig_ifname 'eth1 eth1.100 wlan0'
    option _orig_bridge 'true'
    option ifname 'eth1.101'

config interface 'Devices'
    option type 'bridge'
    option proto 'static'
    option ipaddr '10.101.102.252'
    option netmask '255.255.255.0'
    option gateway '10.101.102.254'
    option broadcast '10.101.102.255'
    option _orig_ifname 'eth1 eth1.101 wlan0-1'
    option _orig_bridge 'true'
    option ifname 'eth1 eth1.102'

config interface 'Management'
    option type 'bridge'
    option proto 'static'
    option ifname 'eth1 eth1.100'
    option ipaddr '10.101.100.252'
    option netmask '255.255.255.0'
    option gateway '10.101.100.254'
    option broadcast '10.101.100.255'

config interface 'Guest'
    option type 'bridge'
    option proto 'static'
    option ipaddr '10.101.103.252'
    option netmask '255.255.255.0'
    option gateway '10.101.103.254'
    option broadcast '10.101.103.255'
    option _orig_ifname 'eth1 eth1.103 wlan1'
    option _orig_bridge 'true'
    option ifname 'eth1.103'

Problem is, Connection on Management Interface seems to be wrong. I can't access the device if i won't connect directly to my pc. Also wireless devices won't get DHCP-Lease from separated DHCP-Server (Management-IF).
I've connected one cable to LAN1.

Thank you very much!

Redbullmachtfit

Ok so it turns out I only partially solved the issue - when I put in the the route directly \\192.168.10.1\ I can access the samba share but the share does not appear in my Networks folder (only on wifi - works fine on lan).

Any ideas here? I feel like this is a firewall issue or some broadcast service isn't working correctly. When I type "net view" in command prompt it actually finds \\openwrt which just throws me off even more.

Suggestions?


davidc502 wrote:
winger88 wrote:

Hi,

I just installed the latest 1200ac firmware from David's site and while the samba share works on wired connections, it doesnt even show up on wireless. I tried putting in the route \\192.168.10.1 but that also doesnt work.

Like I said, works on wired connections - any help greatly appreciated!

--------
edit solved my own issue by removing the following from the samba config:
    interfaces = |INTERFACES|
    bind interfaces only = yes

Just to clarify - there is no risk on the wan side for this is there?

There's always risk, but unless you've set up Samba for the Wan and changed the firewall rules to accommodate Samba on the Wan interface, you should be fine.

Great job figuring out the issue!!

@kirkgbr, due to the two mvebu (sub)target (espressobin,omnia) additions there are naming changes; around this commit. When I said rework config, it was because it messed up my config a small amount, but the naming has changed.

Villeneuve wrote:

@kirkgbr, due to the two mvebu (sub)target (espressobin,omnia) additions there are naming changes; around this commit. When I said rework config, it was because it messed up my config a small amount, but the naming has changed.

Ah, ok.  So the destination path naming change is normal.   Sorry for the misunderstanding.

Thanks Villeneuve

kirkgbr wrote:
Villeneuve wrote:

@kirkgbr, due to the two mvebu (sub)target (espressobin,omnia) additions there are naming changes; around this commit. When I said rework config, it was because it messed up my config a small amount, but the naming has changed.

Ah, ok.  So the destination path naming change is normal.   Sorry for the misunderstanding.

Thanks Villeneuve

The feeds have changed, so if you save feeds like I do, they need to change to reflect the new URL's.

I haven't checked to see if the lede vs. openwrt urls now go to the same place, but just the same I updated my feeds.

eduperez wrote:
NamesAreAPain wrote:

What "legal requirements"?
Draft N APs don't have it yet they are not illegal! (not only that, but a whole lot of AC APs also don't care).

It seems like nothing more than an anti feature.

From wiki.openwrt.org/doc/uci/wireless#mac80211_device_options

option noscan
Do not scan for overlapping BSSs in HT40+/- mode.
Turning this on will violate regulatory requirements!

A wiki with no citations is not a valid source!

(Last edited by NamesAreAPain on 22 Mar 2018, 22:59)

davidc502 wrote:
wayne1958 wrote:
davidc502 wrote:

The next build for the v1 should include kernel 4.14.  Looks like there was a commit that hit trunk that automatically does what it needs to to keep the V1 from rebooting.

Great stuff - looking forwards to it. But tell me, did you ever get to the bottom of the missing minidlna packages?

Sorry, but minidlna never circled back around to me.

What a pain, but thanks for lettting me know. (I never got samba to work so need minidlna to serve media...)

Over the past couple of weeks I've tried to make several builds. However, they all have the same issue with Wifi not working. All I get are these blank drop downs that I can do nothing with. I've tried several things to try to rebuild wifi but nothing works.

I also tried the daily build on the lede site, but it has the same issue for me.

davidc502 wrote:

Over the past couple of weeks I've tried to make several builds. However, they all have the same issue with Wifi not working. All I get are these blank drop downs that I can do nothing with. I've tried several things to try to rebuild wifi but nothing works.

I also tried the daily build on the lede site, but it has the same issue for me.

I would think your build should be exactly the same as the buildbot output. Do you get a manifest showing any diff with the buildbot manifest? I imagine there are packages that failed to build and are minimal dependencies for the wifi. https://downloads.openwrt.org/snapshots … 9.manifest

Do you use exactly the same config as the buildbot? Git problems? Make clean? Log files?

I have never built my own lede or openwrt so just consider these rhetorical and no reply needed. I haven't built much of anything for years so can be safely ignored in general.

I've been using your builds for a while now, I have a WRT1900ACv2 and a WRT3200ACM, the 1900ACv2 works flawlessly, however the 3200ACM needs to be rebooted somewhere between daily to weekly, because the (wireless) connections just stop working, the previous build I was on it wasn't even possible to get into luci when it got to that state, but since updating to r6302 it seems the connections just stop working after a while, unfortunately usually it's at night and my baby monitor stops working, so I don't spend the time to check dmesg, i just get up from bed and reset the router.

I'm just wondering, the current kmod-mwlwifi is from 20180118 on r6302, would a newer build on the mwlwifi drivers with the newer firmware for the 88W8964 possibly fix this? And is there any simple environment to set up to build this, since afaik I'll to match the kernel version in the build I'm running to build it against?

(Last edited by marcmicalizzi on 23 Mar 2018, 16:55)

marcmicalizzi wrote:

I've been using your builds for a while now, I have a WRT1900ACv2 and a WRT3200ACM, the 1900ACv2 works flawlessly, however the 3200ACM needs to be rebooted somewhere between daily to weekly, because the (wireless) connections just stop working, the previous build I was on it wasn't even possible to get into luci when it got to that state, but since updating to r6302 it seems the connections just stop working after a while, unfortunately usually it's at night and my baby monitor stops working, so I don't spend the time to check dmesg, i just get up from bed and reset the router.

I'm just wondering, the current kmod-mwlwifi is from 20180118 on r6302, would a newer build on the mwlwifi drivers with the newer firmware for the 88W8964 possibly fix this? And is there any simple environment to set up to build this, since afaik I'll to match the kernel version in the build I'm running to build it against?

The next build will have the latest drivers.  You might try r6365 on the 3200acm and see if that doesn't fix the issue. That's what I'm running on my 3200acm, and it works great. Keep in mind this is the "experimental" build, so the packages will likely go away when the new build comes out.

https://davidc502sis.dynamic-dns.net/sn … tal/r6365/

marcmicalizzi wrote:

I've been using your builds for a while now, I have a WRT1900ACv2 and a WRT3200ACM, the 1900ACv2 works flawlessly, however the 3200ACM needs to be rebooted somewhere between daily to weekly, because the (wireless) connections just stop working, the previous build I was on it wasn't even possible to get into luci when it got to that state, but since updating to r6302 it seems the connections just stop working after a while, unfortunately usually it's at night and my baby monitor stops working, so I don't spend the time to check dmesg, i just get up from bed and reset the router.

I'm just wondering, the current kmod-mwlwifi is from 20180118 on r6302, would a newer build on the mwlwifi drivers with the newer firmware for the 88W8964 possibly fix this? And is there any simple environment to set up to build this, since afaik I'll to match the kernel version in the build I'm running to build it against?

After rebooting, login to luci. Remove "luci-app-watchcat". I had a similar situation and ultimately pin pointed it to watchcat, it seems to hog the router making luci inaccessible.

beginner67890 wrote:
davidc502 wrote:

Over the past couple of weeks I've tried to make several builds. However, they all have the same issue with Wifi not working. All I get are these blank drop downs that I can do nothing with. I've tried several things to try to rebuild wifi but nothing works.

I also tried the daily build on the lede site, but it has the same issue for me.

I would think your build should be exactly the same as the buildbot output. Do you get a manifest showing any diff with the buildbot manifest? I imagine there are packages that failed to build and are minimal dependencies for the wifi. https://downloads.openwrt.org/snapshots … 9.manifest

Do you use exactly the same config as the buildbot? Git problems? Make clean? Log files?

I have never built my own lede or openwrt so just consider these rhetorical and no reply needed. I haven't built much of anything for years so can be safely ignored in general.

Yeah, I'm going to have to check some of this stuff out. 

It's just odd that the daily build is working or not working the same way, but I don't hear others complaining about it.  What I may do is put a build out on the server and have some of you check to see if it's just me or not.

Thanks for the input.

davidc502 wrote:

The next build will have the latest drivers.  You might try r6365 on the 3200acm and see if that doesn't fix the issue. That's what I'm running on my 3200acm, and it works great. Keep in mind this is the "experimental" build, so the packages will likely go away when the new build comes out.

I'll give it a shot, is it sysupgrade compatible with r6302, or should I do a clean flash?

marcmicalizzi wrote:
davidc502 wrote:

The next build will have the latest drivers.  You might try r6365 on the 3200acm and see if that doesn't fix the issue. That's what I'm running on my 3200acm, and it works great. Keep in mind this is the "experimental" build, so the packages will likely go away when the new build comes out.

I'll give it a shot, is it sysupgrade compatible with r6302, or should I do a clean flash?

It's compatible so all of your settings will come over.

David, hopefully soon you should have something sorted out to feel confident on another test build. I can give it a try on the 28th as I will have time to burn for testing with my WRT1900AC/v2.

(Last edited by Notsofast on 23 Mar 2018, 18:58)

I need a few testers to determine is wifi is working or not. When I flash, I get some blank dropdowns in the SSID configuration, but is this my situation or is it happening to everyone? This does have the latest commit for the wifi driver.

https://davidc502sis.dynamic-dns.net/sn … /cortexa9/

davidc502 wrote:

I need a few testers to determine is wifi is working or not. When I flash, I get some blank dropdowns in the SSID configuration, but is this my situation or is it happening to everyone? This does have the latest commit for the wifi driver.

https://davidc502sis.dynamic-dns.net/sn … /cortexa9/

I can do a fresh install 1st thing in the morning, just to check your drop down in the wifi section.  Maybe we can find a config issue with fresh install vs system upgrade, or it being with particular model or models.

davidc502 wrote:

I need a few testers to determine is wifi is working or not. When I flash, I get some blank dropdowns in the SSID configuration, but is this my situation or is it happening to everyone? This does have the latest commit for the wifi driver.

https://davidc502sis.dynamic-dns.net/sn … /cortexa9/

I have not been on here in quite awhile. But after I saw nbd had pushed commit to trunk

https://git.openwrt.org/?p=openwrt/stag … 6848943e9a

which is a fix or a hack however you want to look at it for the ac1900acv1 I did a fresh build from trunk. I ran into the wifi dropdown issue instead of dinking with it I just deleted the /etc/config/wireless and rebooted and reconfigured.

OpenWrt SNAPSHOT, r6503-5faa955
-----------------------------------------------------
root@LEDE:~# uname -a
Linux LEDE 4.14.27 #0 SMP Mon Mar 19 22:28:49 2018 armv7l GNU/Linux
root@LEDE:~# uptime
19:14:31 up 3 days, 21:55,  load average: 0.00, 0.00, 0.00
root@LEDE:~#

Hopefully this helps someone.