Re: TP-Link Archer MR200

Heinz wrote:

@sebastiii Leds have diffrent config because new lede build use new usbport trigger, and I not config leds use this trigger.

Ok smile thanks for explanation, so what can be done ? smile need to install a special package ?
That's not a big deal about led, the biggest issue i can have is that SIM issue.

Does LEDE can be used for VPN lan to lan or client to lan ?
Thanks.

Re: TP-Link Archer MR200

Just added a feedback, SIM card issue didn't happen yet smile (so maybe upgrade from official to upgrade android board was the good thing to do) smile

Re: TP-Link Archer MR200

could someone tell me how to install lede in mr200, i have that router, i am trying to use tftp.

who could tell me how much?

please


Julio Cesar

Re: TP-Link Archer MR200

@Julio

Read the first post of page 3 tongue

Re: TP-Link Archer MR200

Hi just bought Archer MR200 and flashed lede to it works like a champ, except port forwarding just like the oem firmware.
Have set wan to static 192.168.225.100 stil no luck plz help

Re: TP-Link Archer MR200

@chybber, i didn't succeed too, surely missing something sad

107

Re: TP-Link Archer MR200

Good. I installed LEDE splitting and joining the firmware files and then tftp. It seems to work.
Is there any way of extracting the firmware of the 4G modem from the vendor's firmware and flash/update it directly from LEDE?
Additionally, I found, doing "adb shell" and "netstat -natup" that the web server (h ttpd) that serves the web interface of the 4G modem is listening on all interfaces. Even if we set a password for it, I think it should be better to listen on the internal interface only (bridge0).

108 (edited by hongkongkiwi 2017-02-23 12:02:28)

Re: TP-Link Archer MR200

Hi All,

Unfortunately I bricked my router! I'm following the instructions at:
https://pwassi.privatedns.org/lede/archerc20i/

This is for a similar router the Archer C20i

Does anybody know the correct dd command to extract the config & settings for the MR200? So basically I have at the moment:
dd if=mr200_original.bin of=mr200_configs.bin bs=64k count=3 skip=125

I've based this on the flash layout, so just hoping somebody could confirm. It looks like there is no "rom" only "romfile".

This is for the C20i but would it be the same for the MR200?

109 (edited by Deam 2017-02-23 20:50:03)

Re: TP-Link Archer MR200

Please tell me how to filter a mac adress wich is connected via lan.

Does i can upgrade now from old Heinz build to official build via UI ?

110 (edited by sebastiii 2017-03-12 18:25:21)

Re: TP-Link Archer MR200

Deam wrote:

Please tell me how to filter a mac adress wich is connected via lan.

Does i can upgrade now from old Heinz build to official build via UI ?

You can do the upgrade (but backup your setting before.)
On my side the upgrade didn't auto restore the setting and i must restore it manually smile
About the mac adress i don't know sad

Re: TP-Link Archer MR200

Hi smile

@Heinz
I have tested the original firmware, like now i can have unlimited data for the weekend and the SIM not found didn't happen.
So it seems to happen with LEDE (randomly) but it happen so i don't have the real clue of this but maybe it's related to enable the httpd service from android card ? (like no clue, i don't know where it comes from).

With original firmware, i can't ping 192.168.225.1 but no webpage available, so original firmware talk directly to the android card without the httpd enable.

I'm maybe wrong but could be nice to do it differently ?

Re: TP-Link Archer MR200

Can someone help? I have the EU version 1 of the MR200 and mainly I use it with a 4G simcard. The current provider here in Greece has locked the router so you can use only their network using a custom firmware that does not allow the upgrade or use of a tplink firmware if you try to upgrade through the routers web interface.

Can someone tell me if there is a way to remove the existing custom firmware and install the originalfrom tplink using TFTP recovery?

Thanks!

Re: TP-Link Archer MR200

yiannis5 wrote:

Can someone help? I have the EU version 1 of the MR200 and mainly I use it with a 4G simcard. The current provider here in Greece has locked the router so you can use only their network using a custom firmware that does not allow the upgrade or use of a tplink firmware if you try to upgrade through the routers web interface.

Can someone tell me if there is a way to remove the existing custom firmware and install the originalfrom tplink using TFTP recovery?

Thanks!

try with wireshark connected to port1 to see the requests comming from router for firmware name wink