My WRT-1900ACS has been installed on a separate firewall segment. I just want to use it as an accesspoint and let the firewall route all traffic.

My network file looks like this:

root@OpenWrt:/etc/config# cat network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdbc:39d3:dab5::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth1'
        option proto 'static'
        option ipaddr '172.18.2.3'
        option netmask '255.255.255.0'
        option gateway '172.18.2.1'
        option dns '172.18.2.1'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth0'
        option proto 'dhcpv6'

Firewall is 172.18.2.1 and accepting and routing everything from 172.18.2.3

LAN switchport 1 is connected to the firewall, no cable in WAN

Trying to install a package, I get:

root@OpenWrt:/etc/opkg# opkg install https://downloads.openwrt.org/snapshots/trunk/mvebu/generic/packages/packages/mc_4.8.16-1_mvebu.ipk
Collected errors:
 * wfopen: https://downloads.openwrt.org/snapshots/trunk/mvebu/generic/packages/packages/mc_4.8.16-1_mvebu.ipk: No such file or directory.
 * pkg_init_from_file: Failed to extract control file from https://downloads.openwrt.org/snapshots/trunk/mvebu/generic/packages/packages/mc_4.8.16-1_mvebu.ipk.

Traceroute 8.8.8.8

root@OpenWrt:/etc/config# traceroute 8.8.8.8
traceroute to 8.8.8.8 (8.8.8.8), 30 hops max, 38 byte packets
 1  172.18.2.1 (172.18.2.1)  0.520 ms  0.388 ms  0.379 ms

Using TCPDUMP on my firewall, it seems that no packages reaches the firewall. I guess that OpenWRT wants to use the WAN port even though I have set the default gateway to be on the LAN

Routing table:

root@OpenWrt:/etc/config# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         172.18.2.1      0.0.0.0         UG    0      0        0 br-lan
172.18.2.0      *               255.255.255.0   U     0      0        0 br-lan

But this seems correct to me...?

What am I overlooking?

Regards, Lars.