1 (edited by troessler 2006-07-06 10:11:33)

Topic: Newbie (me) / Asus WL-500gP / WAN-Interface / pppoe

Hi there,
I have an Asus WL-500gP and managed to install OpenWRT without any problems.
Now, I have struggled quite a long time getting the WAN-interface working with pppoe. I've followed the numerous hints in forums and in the corresponding wiki, but I did not manage to make it work. :-(
Since I am absolutely new to OpenWRT, I don't really know if there are (besides the obvious) nvram-settings that could affect the wan-interface.
Is it possible that someone who has a working system with Asus WL-500gP and pppoe could post a complete list of nvram-settings? Then I could check all the settings and - hopefully - find my problem.

Using FAQ and forum-topics, I have tried the following configuration without success:
wan_device=eth0
wan_ifname=vlan1
vlan1ports="0 5"
vlan1hwname=et0
wan_proto=pppoe
ppp_idletime=10
ppp_mtu=1492
ppp_passwd=XXX
ppp_redialperiod=15
ppp_username=XXX
pppoe_ifname=vlan1

I've tried numerous other ways, but since there is an infinite number of false configurations, I don't think that it is useful posting them all.

Thanks in advance

Thilo

PS. Maybe I should have pointed out that I use White Russian RC 5.

Re: Newbie (me) / Asus WL-500gP / WAN-Interface / pppoe

i got pppoe running by setting the following nvram variables, after a "mtd erase nvram"

wan_device=eth0
nvram set lan_ifnames="vlan0 eth2"
nvram set wlan_ifname=eth2
nvram set wan_ifname=ppp0
nvram set wan_proto=pppoe
nvram set ppp_idletime=10
nvram set ppp_mtu=1492
nvram set ppp_passwd=XXXX
nvram set ppp_redialperiod=15
nvram set ppp_username=XXX

i don't think i've set the pppoe_ifname variable. i can't double check that at the moment, because device is running nice and smooth @ a friends house.

chris

ps i also set

nvram set sdram_init=0x0009
nvram set sdram_ncdl=0
to enable 32MB

Re: Newbie (me) / Asus WL-500gP / WAN-Interface / pppoe

Thanks a lot, works perfectly :-)

Thilo

Re: Newbie (me) / Asus WL-500gP / WAN-Interface / pppoe

if you also used "mtd erase nvram", don't forget to enable boot_wait again, using webif or enter
"nvram set boot_wait=on"

Re: Newbie (me) / Asus WL-500gP / WAN-Interface / pppoe

This works fine, too:

nvram set vlan0ports="1 2 3 4 5t"
nvram set vlan0hwname=et0
nvram set vlan1ports="0 5t"
nvram set vlan1hwname=et0
nvram set wan_device=vlan1
nvram set wan_ifname=ppp0
nvram set wan_proto=pppoe
nvram set ppp_idletime=10
nvram set ppp_mtu=1492
nvram set ppp_username=<yourid>
nvram set ppp_passwd=<yourpw>
nvram set ppp_redialperiod=15

The default vlan-setup was a bit messed up ..

Re: Newbie (me) / Asus WL-500gP / WAN-Interface / pppoe

Dear all,

I am not the best in linux, but I want learn ant that is way I flash my Asus WL-500g Premium to WhiteRussian RC6.
I have got ADSL modem with RJ45 which I connect to Asus. Reading wiki and many forums, I set my router:

nvram set vlan1ports="0 5"
nvram set wan_ifname=vlan1
nvram set lan_ifnames="vlan0 eth2"
nvram set lan_ifname=br0
nvram commit

nvram set sdram_init=0x0009
nvram set sdram_ncdl=0
nvram commit
reboot

nvram set wan_ifname=ppp0
nvram set pppoe_ifname=vlan1
nvram set wan_device=vlan1




nvram set wan_ifname=ppp0
nvram set wan_proto=pppoe
nvram set ppp_idletime=10
nvram set ppp_mtu=1492
nvram set ppp_passwd= password ISP
nvram set ppp_redialperiod=15
nvram set ppp_username= login ISP
nvram set pppoe_ifname=vlan1
nvram set wan_device=vlan1
nvram commit

then:
root@OpenWrt:~# ifup wan
### ifup wan: ignored wan_proto="pppoe" (not supported)

nvram set wan_ifname=vlan1
nvram set wan_proto=dhcp
nvram commit

root@OpenWrt:/# ifup wan
root@OpenWrt:/# info, udhcpc (v0.9.9-pre) started
debug, Sending discover...
debug, Sending discover...
debug, Sending discover...
info, No lease, forking to background.

What I do wrong?

Please help. How can I erase all settings, because probably I set something wrong and I must will be to set everything again.

Regards,
natash