OpenWrt Forum Archive

Topic: DIR-300 rev. B5 WiFi as Client and AP mode at the same time. Help!

The content of this topic has been archived on 28 Mar 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hello i have D-link DIR-300 rev. B5 working on Zyxel Keenetic Start firmware. I use my router as Wifi Client (to ISP) and AP to my home network at the same time. Everything works fine and i can simply configure this mode from WEBui.

Recently I decided to study OpenWrt using my D-link DIR-300 rev. B5 as test platform and tried to replicate the existing configuration Wifi Client and AP on one device. Install OpenWrt-15.05. Turn on LuCI.

In LuCI add WiFi Client to my ISP and everything OK. Packets from lan go to external networks.
Working /etc/config/wireless:

config wifi-device 'radio0'
    option type 'mac80211'
    option hwmode '11g'
    option path '10180000.wmac'
    option txpower '20'
    option country '00'
    option disabled '0'
    option channel '13'
    option htmode 'HT20'

config wifi-iface
    option network 'wwan'
    option ssid 'kotya_wifi'
    option encryption 'psk2'
    option device 'radio0'
    option mode 'sta'
    option bssid '10:BF:xx:xx:xx:xx'
    option key '12345678'  

Working routing table:
root@OpenWrt:~# route

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         192.168.93.1    0.0.0.0         UG    0      0        0 wlan0
10.0.0.0        *               255.255.255.0   U     0      0        0 br-lan
192.168.93.0    *               255.255.255.0   U     0      0        0 wlan0
192.168.93.1    *               255.255.255.255 UH    0      0        0 wlan0

After that in Luci i add second wifi interface which will working as local AP. After applying changes wifi is down (wifi indicator light is off) and network not working. Rebooting don't help.
/etc/config/wireless become:

config wifi-device 'radio0'
    option type 'mac80211'
    option hwmode '11g'
    option path '10180000.wmac'
    option htmode 'HT40'
    option txpower '20'
    option country '00'
    option disabled '0'
    option channel '13'

config wifi-iface
    option network 'wwan'
    option ssid 'kotya_wifi'
    option encryption 'psk2'
    option device 'radio0'
    option mode 'sta'
    option bssid '10:BF:xx:xx:xx:xx'
    option key '12345678'

config wifi-iface
    option device 'radio0'
    option mode 'ap'
    option ssid 'ZyXEL'
    option wmm '0'
    option encryption 'psk2+ccmp'
    option key '12345678' 

Routing table become:
root@OpenWrt:~# route

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
10.0.0.0        *               255.255.255.0   U     0      0        0 br-lan

When i from LuCI delete local AP and reboot network work again.

How to make work my DIR-300 rev. B5 WiFi as Client and AP mode at the same time? Whats wrong ?

Help !! I have installed latest firmware "openwrt-ramips-rt305x-dir-300-b7-squashfs-sysupgrade.bin" and vlan switch works fine but i cant figure out how to get both untagged and tagged on same ports.. So if someone knows how to solve this please help me...

The most serious problem is that the wifi is stone dead. I have tried many settings but i cant get it working.. no signal
but the led says its turned on... but it's not..

I just returned to Zyxel Keenetic Start firmware and forget about wifi problem

Grefwenius wrote:

i cant figure out how to get both untagged and tagged on same ports.

This mode isn't supported by driver (and I think by hardware too)

123serge123 wrote:
Grefwenius wrote:

i cant figure out how to get both untagged and tagged on same ports.

This mode isn't supported by driver (and I think by hardware too)


I dont know who's writing this driver but i think this is very odd situation because there a big need of sending both untagged and tagged packets. Ex. Your isp is sending internet untagged but the packet for digitaltv is tagged.

So please can anyone with good knowlegde about the driver and chipset explain this ????
And also give an answer of the wifi question.

Maybe someone knows a workaround...for the tagging problem


Ps. No offense 123serge123

Grefwenius wrote:

Maybe someone knows a workaround...for the tagging problem

As workaround you can try doubletag mode. After adding 'option doubletag 1' into switch config do command

vconfig add eth0.2 100

for output frame tagged with vid=100 when use interface eth0.2.100 as example.

The discussion might have continued from here.