Re: help to hex edit tp-link tl-wr841n v11

Firmware Version: 3.16.9 Build 160325 Rel.62500n
Hardware Version: WR841N v11 00000000

File:
volatilesystems.org/dl/openwrt/targets/tl-wr841n-v11/openwrt-ar71xx-generic-tl-wr841-v11-squashfs-factory.bin

Error code: 18005
Upgrade unsuccessfully because the version of the upgraded file was incorrect. Please check the file name.

Only on label on device is noticed "EU/11.0"

52 (edited by shalzz95 2016-10-25 01:56:46)

Re: help to hex edit tp-link tl-wr841n v11

For the EU/v11, there are problems installing the Boromini build through the web interface. Even when the file is rename to a shorter name.

But installing throught the TFTP recovery via bootloader works perfectly.

Re: help to hex edit tp-link tl-wr841n v11

@shalzz95

I'm new to OpenWRT in general, mind elaborating? Thanks smile

54 (edited by zdenek 2016-10-26 23:20:38)

Re: help to hex edit tp-link tl-wr841n v11

A can confirm that Boromini build can be flashed via tftp recovery into EU/11.0. But it must be a some differencies betwen hardware - did not lit POWER led.

55 (edited by shalzz95 2016-10-26 19:17:37)

Re: help to hex edit tp-link tl-wr841n v11

I think I have found the root cause why the power led isn't working and possibly other bugs.

The board name is read as tl-wr841n-v9 even thought the model info is correct i.e. V11 .

# cat /tmp/sysinfo/board_name 
tl-wr841n-v9
# cat /tmp/sysinfo/model 
TP-Link TL-WR841N/ND v11

The lib/ar71xx.sh sets the board name from /proc/cpuinfo which again show v9 as the machine.
 

# cat /proc/cpuinfo 
system type        : Qualcomm Atheros QCA9533 ver 2 rev 0
machine              : TP-LINK TL-WR841N/ND v9
...
VCEI exceptions : not available

Which of course results in the wrong led being set as the status_led

56 (edited by zdenek 2016-10-26 23:44:03)

Re: help to hex edit tp-link tl-wr841n v11

Have a sense to force flash standard 15.05.1 build for v9 into EU/11.0? I can test it.

Re: help to hex edit tp-link tl-wr841n v11

The power led bug has been fixed in trunk.

I have backported the changes to 15.05.1

Here are the images if anyone wants to try.

drive.google.com/drive/folders/0B21lyv8DoENLUm5WbzlweTJlSjg?usp=sharing

58

Re: help to hex edit tp-link tl-wr841n v11

shalzz95 wrote:

The power led bug has been fixed in trunk.

I have backported the changes to 15.05.1

Here are the images if anyone wants to try.

drive.google.com/drive/folders/0B21lyv8DoENLUm5WbzlweTJlSjg?usp=sharing

Apparently these changes fix a power led in expense of the rest of LEDs.
HW: WR841N(UA) v11
Could lit any of leds via /sys/class/leds subsystem but triggers seem not working properly.
Image has been working stable though.
Therefore for now ones has either to stay with all leds but power or with no leds except power.

Re: help to hex edit tp-link tl-wr841n v11

jx1 wrote:
shalzz95 wrote:

The power led bug has been fixed in trunk.

I have backported the changes to 15.05.1

Here are the images if anyone wants to try.

drive.google.com/drive/folders/0B21lyv8DoENLUm5WbzlweTJlSjg?usp=sharing

Apparently these changes fix a power led in expense of the rest of LEDs.
HW: WR841N(UA) v11
Could lit any of leds via /sys/class/leds subsystem but triggers seem not working properly.
Image has been working stable though.
Therefore for now ones has either to stay with all leds but power or with no leds except power.

All LEDs including the triggers are working for me. Are you sure your leds are not working or is it just your led settings?

60

Re: help to hex edit tp-link tl-wr841n v11

shalzz95 wrote:

The power led bug has been fixed in trunk.

All LEDs including the triggers are working for me. Are you sure your leds are not working or is it just your led settings?

Absolutely. Tried twice to write v11images (factory->openwrt->openwrt-sysupgrade->factory and again with v11 from trunk [openwrt-ar71xx-generic-tl-wr841-v11-squashfs-factory.bin    3932160    24-Oct-2016 17:22] )   - same result: no LEDS except power (with default|zeroed led settings). As soon as a single led rule is created (no matter which type) - power led stops working as well. Brings back to life crafting a new system led configuration item.

Re: help to hex edit tp-link tl-wr841n v11

This is my first post, it is great to contribute to this great forum :-)

jx1 wrote:
shalzz95 wrote:

The power led bug has been fixed in trunk.

All LEDs including the triggers are working for me. Are you sure your leds are not working or is it just your led settings?

Absolutely. Tried twice to write v11images (factory->openwrt->openwrt-sysupgrade->factory and again with v11 from trunk [openwrt-ar71xx-generic-tl-wr841-v11-squashfs-factory.bin    3932160    24-Oct-2016 17:22] )   - same result: no LEDS except power (with default|zeroed led settings). As soon as a single led rule is created (no matter which type) - power led stops working as well. Brings back to life crafting a new system led configuration item.

shalzz95, thank you for linking the firmware! I have successfully installed it, but I confirm that only the power led works; all other leds are turned off. I am on EU/v11, the router is brand new.

Cheers,
Guido

62 (edited by zdenek 2016-11-11 10:33:47)

Re: help to hex edit tp-link tl-wr841n v11

Yes, I can confirm too that firmware with md5sum (downloaded from google drive)

06b2aea88fff92ea3f818756c3fed2fc  openwrt-ar71xx-generic-tl-wr841n-v11-squashfs-factory.bin

works, but lit only POWER led.

But previous firmware (downloaded from volatilesystems.org/dl/openwrt/targets/tl-wr841n-v11/)

b29d4f1467cbd818fa9d29ce52154e7e openwrt-ar71xx-generic-tl-wr841n-v11-squashfs-factory.bin

works in opposite mode. All leds except power.

Both firmware tested on one EU/11.0 device.

63 (edited by maks.rogala 2016-11-15 01:36:07)

Re: help to hex edit tp-link tl-wr841n v11

Guy I'm new to this. I just want to share eduroam connection so I can play on my ps4. I have the v11 EU and i cannot flash the software, the error 18005 pops out. Can you tell me in a few steps how to flash it so I can try doing this openwrt thing to my router? Also i have a mac. I tried ubuntu but i cannot connect to the interent so its pointless.

Re: help to hex edit tp-link tl-wr841n v11

Just wondering, I'd really like to get Chaos Calmer with LUCi into my v11, I'm fairly comfortable with moving images around at least in the general sense. Would it make more sense right now to just grab v10 and put it in over the serial port (because I guess any other way would reject it)? Is there a script lying around for that that I could follow to do that? If not is there both a good image and instructions for another approach? (I didn't have much trouble picking up the TFTP approach because there was a nice video to watch, for serial right now it's not quite so well laid out but I ordered one of these USB-serial jobs and it just came in because I figured I'd be in trouble if I didn't have one available.)

Re: help to hex edit tp-link tl-wr841n v11

Which v11. Please, in future, specify exactly EU/11 or any other versions...

For non-EU v11 use trunk v11 image (without luci) and then sysupgrade -F v10.

For EU/v11 use image from two post above.

66 (edited by jlawton 2016-11-29 16:52:38)

Re: help to hex edit tp-link tl-wr841n v11

It's the non-EU that I need. Could you elaborate a little? I see the sysupgrade command page and the -F option looks a bit risky, I can't actually find any detailed instructions on this site using it, don't want to brick anything before its time. Are you saying for the second part you just identify certain packages that implement LUCi from v10 and sysupgrade them, or do you bring the whole image over and it "just happens" to reside offset to the first image somehow? I don't want to make this uber-geeky but I want to have some principle that I'm thinking at least ought to work, it sort of sounds like "there was expected to be" a real non-EU v11 build by now but if I have a little clearer idea how this works I'll likely get it OK.

Re: help to hex edit tp-link tl-wr841n v11

Has anyone had issues with Tito loading on v11.0?

On macOS I setup the tftp as

connect 192.168.0.86
trace
binary
rexmt 1
timeout 60
put wr841nv11_tp_recovery.bin

The file is never sent, sometimes times out sometimes no route to host, with my IP as 192.168.0.66.

This is point to point and through a switch.

Thanks for any pointers

Re: help to hex edit tp-link tl-wr841n v11

OK now what I'm seeing is confusing me. Got v11.1 hardware, want to go in load the trunk from factory then do the sysupgrade -F with v10 to get back LUCi. So right now I've just got the factory restored code, wanted to be sure I wasn't taking any steps I couldn't easily undo. Hooked up serial port and I didn't see the "autobooting..." message but there were a few lines of garbled stuff at the beginning. Fooled around with the port settings and if I set the port to 7 chars 2 stop bits then I see all of the serial info clearly and NOW I CAN SEE the autobooting message but it's not responding to a tpl. Is that typical behavior for the factory load? (Oh yeah it doesn't take the tpl with the port at 8/1 where I'm guessing when the msg SHOULD come up either.) I'm not exactly an expert at what I'm looking at but I "have a hunch" I'm just supposed to be "getting the attention" of the bootloader to start the console so loading trunk first shouldn't change that. If what I'm seeing makes sense and you can explain a little then maybe I should go ahead to trunk but I'm a little uncertain that what I'm seeing makes sense. Is there any way to issue that sysupgrade command without using the serial port? (Apologize again for my ignorance, very sorry!)

Re: help to hex edit tp-link tl-wr841n v11

Let me clarify my previous message, with the TL-WR841N v11.1 hardware I don't seem to be able to get a bootloader prompt even though I can see the proper serial data and amplitude leaving the port. Serial adapter is a Frentaly CH340G and software is PuTTY 0.67 on Windows 7 Professional. I'm even trying to find if it could accept a "break" or other special character but haven't found anything. I'm leaving it in 115200-8N1 mode when I'm not experimenting although it seems curious nobody mentioned the scrambled-looking data because that could be a clue too, yeah maybe it's just I'm not in proper charset but I'm wondering if they went and put the bootloader portion under a different protocol? (Maybe they're thinking they're trying to use this to protect IP? It's just curious that's all, I could be WAY off.) It's just I don't see how to get a build with a decent version of fq-codel on this unit without serial port access with the current state of CC for this HW.

Re: help to hex edit tp-link tl-wr841n v11

Please, read posts above. This is not for v11. You must run tftp server. Once more, please, read whole discussion...

Cda0 wrote:

Has anyone had issues with Tito loading on v11.0?

On macOS I setup the tftp as

connect 192.168.0.86
trace
binary
rexmt 1
timeout 60
put wr841nv11_tp_recovery.bin

The file is never sent, sometimes times out sometimes no route to host, with my IP as 192.168.0.66.

This is point to point and through a switch.

Thanks for any pointers

Re: help to hex edit tp-link tl-wr841n v11

zdenek wrote:

Please, read posts above. This is not for v11. You must run tftp server. Once more, please, read whole discussion...

Cda0 wrote:

Has anyone had issues with Tito loading on v11.0?

On macOS I setup the tftp as

connect 192.168.0.86
trace
binary
rexmt 1
timeout 60
put wr841nv11_tp_recovery.bin

The file is never sent, sometimes times out sometimes no route to host, with my IP as 192.168.0.66.

This is point to point and through a switch.

Thanks for any pointers

I just rolled a XP VM and ran tftp32.

worked like a charm.

cheers

Re: help to hex edit tp-link tl-wr841n v11

shalzz95 wrote:

I think I have found the root cause why the power led isn't working and possibly other bugs.

The board name is read as tl-wr841n-v9 even thought the model info is correct i.e. V11 .

# cat /tmp/sysinfo/board_name 
tl-wr841n-v9
# cat /tmp/sysinfo/model 
TP-Link TL-WR841N/ND v11

The lib/ar71xx.sh sets the board name from /proc/cpuinfo which again show v9 as the machine.
 

# cat /proc/cpuinfo 
system type        : Qualcomm Atheros QCA9533 ver 2 rev 0
machine              : TP-LINK TL-WR841N/ND v9
...
VCEI exceptions : not available

Which of course results in the wrong led being set as the status_led

zdenek wrote:

Have a sense to force flash standard 15.05.1 build for v9 into EU/11.0? I can test it.


sounds worth a try. has this been tested by somebody ?

Re: help to hex edit tp-link tl-wr841n v11

Some more datapoints. I have a 841N(TPD) ver 9.0, ver 10.0 and ver 11.1, all bought in EU.

For the project I'm working on I need 15.05.1 but I had to re-build the firmware image to eliminate things I don't need, to get space for the things I want which would not fit otherwise.
Currently running
   Chaos Calmer 15.05.1 r49389 / LuCI for-15.05 branch (git-16.344.58491-d4bec26)

I note that the 9.0, the 10.0 and the 11.1 hardware flashes correctly, from the stock TP-link firmware, using the image I built earlier today:
  openwrt-ar71xx-generic-tl-wr841n-vXX-squashfs-factory.bin
where XX is v9, v10 or v11 respectively. No need to patch the images; just configure, build, flash and off it goes. That may not be true for the 15.05.1 release images, it is true when using the images I built today.

There are two quite visible hardware differences between v10.0 and v11.1 hardware.
For one, the WAN LED is now bi-color, can be green or orange. Flipping the tp-link:green:wlan LED makes the LED light up orange, not green, green still seems to indicate WAN activity.
The second difference is that the shape of the antenna is different, the v9.0 and v10.0 box have identical antennas; the v11.1 antennas are bigger and look like the antennas used on Archer-C7 machines. They are still non-detachable though.

One more comment: these units have 4MB of flash and that is "taxing it" with 15.05 firmware. I use these units for a multi-unit wifi network (at a unit price of EUR 17 they are hard to beat) but I saw someone wanting to experiment creating an eduroam proxy and the like. Please do realize that the flash constraint does make for a challenge, if this is your first OpenWRT experiment then I would suggest to use a box with more resources (like the aforementioned Archer C7) because you can use the stock OpenWRT image and just add packages, which you cannot do with the '841 because you will run out of space.

Hope this helps,

Geert Jan

Re: help to hex edit tp-link tl-wr841n v11

hi i have flashed the trunk version. But i can not install luci, because "No space left on device.". Must i manually build a image with buildin luci? Or when is there an official image?

75 (edited by grumbler 2017-01-12 22:56:56)

Re: help to hex edit tp-link tl-wr841n v11

alex1702 wrote:

Must i manually build a image with buildin luci?

Yes, ofcourse

P.S. I try build own image with the Luci and the OpenVPN. Generated image too big and I removed LuCI: OpenVPN is required for me.