I am new to openwrt and trying to identify what would be cutting my download speed in by almost 40%.

When using openwrt I consistently get speeds of  60-65 Mbit/s but with the stock firmware, other routers, or connected directly to the modem I consistently get speeds of 115 Mbit/s.


All help is appreciated.

Please let me know what other info you would like:


Build: 

CHAOS CALMER (Bleeding Edge, r46836)

ethtool eth0

Settings for eth0:
    Supported ports: [ ]
    Supported link modes:   1000baseT/Full 
    Supported pause frame use: No
    Supports auto-negotiation: No
    Advertised link modes:  1000baseT/Full 
    Advertised pause frame use: No
    Advertised auto-negotiation: No
    Speed: 1000Mb/s
    Duplex: Full
    Port: MII
    PHYAD: 30
    Transceiver: external
    Auto-negotiation: on

/etc/config/network

config switch 'eth0'
    option name 'eth0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'eth0'
    option vlan '1'
    option ports '1 2 3 4 8t'

config switch_vlan
    option device 'eth0'
    option vlan '2'
    option ports '0 8t'

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fdb7:5e45:a65c::/48'

config interface 'lan'
    option ifname 'eth0.1'
    option force_link '1'
    option type 'bridge'
    option proto 'static'
    option netmask '255.255.255.0'
    option ip6assign '60'
    option ipaddr '192.168.2.1'

config interface 'wan'
    option ifname 'eth0.2'
    option _orig_ifname 'eth0.2'
    option _orig_bridge 'false'
    option proto 'dhcp'

config interface 'wan6'
    option ifname 'eth0.2'
    option proto 'dhcpv6'