Hi,

I´ve configured a relay (network lan - wan linux firewall). Devices in LAN should get ip addresses from Linux Gateway. OK

Additionally there is a guest subnet only for wifi (wlan0-1). OK

Therefore dnsmasq-dhcp should be used. NOK

Thu Sep  3 16:22:45 2015 daemon.info dnsmasq-dhcp[3529]: DHCPDISCOVER(wlan0-1) b4:ce:f6:08:da:bf
Thu Sep  3 16:22:45 2015 daemon.info dnsmasq-dhcp[3529]: DHCPOFFER(wlan0-1) 192.168.254.155 b4:ce:f6:08:da:bf

But no DHCPREQUEST !!

If I stop relayd, DHCP for guest is fully functional!

Firewall for testing disabled.

Thanks in advance for your help

Chris



cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd7b:dfeb:9ce3::/48'

config interface 'lan'
        option _orig_ifname 'eth0.1 wlan0 radio1.network1'
        option _orig_bridge 'true'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.153.1'
        option netmask '255.255.255.0'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'

config interface 'wan6'
        option ifname '@wan'
        option _orig_ifname '@wan'
        option _orig_bridge 'false'
        option proto 'dhcp'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 2 3 4 5'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 1'

config interface 'guest'
        option _orig_ifname 'wlan0-1'
        option _orig_bridge 'false'
        option proto 'static'
        option ipaddr '192.168.254.1'
        option netmask '255.255.255.0'

config interface 'lwan'
        option proto 'relay'
        list network 'lan'
        list network 'wan'
        option ipaddr '192.168.0.153'

config interface 'guestwan'
        option proto 'relay'
        list netowrk 'guest'
        list network 'wan'
        option ipaddr '192.168.254.1'

config route


------------------------------

cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/guest/'
        option domain 'guest'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'


config dhcp 'guest'
        option interface 'guest'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv6 'server'
        option ra 'server'
        option ra_management '1'


config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'