My setup is

  • wan - PPPoE (dynamic) with a fixed IP block 74.116.186.176/28 routed to me.

  • wan6 - HeNet 6in4 tunnel

    • routed /64 = 2001:470:1d:9e2::/64 - tunnel address

    • routed /48 = 2001:470:b183::/48

  • lan very standard

    • IPv4 DHCP Pool 192.168.30.1/27

    • IPv6 DHCP Pool 2001:470:b183:30::0/64  (IPv6 /64 hint 30)

  • servers: Four servers providing dns, smtp, imap, http, webdav (ssl), davical. NO DHCP(6) assignment, all addresses are static

    • IPv4 addresses assigned from 74.116.186.176/28

    • IPv6 addresses assigned from 2001:470:b183:10::xxx/64  (IPv6 /64 hint 10)

I have been having trouble recently with IPv6 connectivity.
The only solution seems to be setting the IPv6 assignment hint for the LAN to 0 this seems solves the connectivity problem.
Setting it to any other value causes problems.
Has anybody else seen this, is there a solution that will allow it to work as advertised.

Original network config

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fd5c:255d:58d5::/48'

config interface 'lan'
    option ifname 'eth0.1'
    option force_link '1'
    option type 'bridge'
    option proto 'static'
    option ipaddr '10.14.30.1'
    option netmask '255.255.255.224'
    option ip6assign '64'
    option ip6hint '30'

config interface 'wan'
    option ifname 'eth1'
    option proto 'pppoe'
    option username 'me'
    option password 'my password'

config interface 'wan6'
    option _orig_ifname 'eth1'
    option _orig_bridge 'false'
    option proto '6in4'
    option ipaddr '74.116.186.177'
    option peeraddr '216.66.38.58'
    option ip6addr '2001:470:1c:9e2::2/64'
    option ip6prefix '2001:470:b183::/48'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'
    option blinkrate '2'
    option enable_vlan4k '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '2 3 5t'

config switch_port
    option device 'switch0'
    option port '1'
    option led '6'

config switch_port
    option device 'switch0'
    option port '2'
    option led '9'

config switch_port
    option device 'switch0'
    option port '5'
    option led '2'

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option ports '0 1 5t'

config interface 'dmz'
    option proto 'static'
    option ifname 'eth0.2'
    option ipaddr '74.116.186.177'
    option netmask '255.255.255.240'
    option ip6assign '64'
    option ip6hint '10'