OpenWrt Forum Archive

Topic: Set MTU for wireless interface (particulatly bridged one)

The content of this topic has been archived on 12 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

How can I set the mtu for a bridge ?  I need first to set the mtu of each downstream interface then to the bridge (manually it work doing ifoncifg interface mtu 2000).

I have tried something like this but it does not work (setting LAN_V20 to mtu 2000)

/etc/config/network

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fd02:15b3:9237::/48'

config interface 'INTERFACE_ETH1'
    option proto 'none'
    option auto '1'
    option ifname 'eth1'
    option mtu '4000'

config interface 'BRIDGE_V1'
    option type 'bridge'
    option proto 'none'
    option auto '1'
    option stp '1'
    option _orig_ifname 'eth1 wlan1'
    option _orig_bridge 'true'
    option ifname 'eth1'
    option mtu '1500'

config interface 'LAN_V1'
    option force_link '1'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option _orig_ifname 'eth1'
    option _orig_bridge 'false'
    option ifname 'br-BRIDGE_V1'
    option mtu '1500'

config interface 'BRIDGE_V20'
    option type 'bridge'
    option proto 'none'
    option ifname 'eth1.20'
    option auto '1'
    option stp '1'
    option mtu '1500'

config interface 'SWITCH_V100'
    option type 'bridge'
    option proto 'none'
    option ifname 'eth1.100'
    option auto '1'
    option mtu '1500'

config interface 'LAN_V20'
    option proto 'static'
    option ifname 'br-BRIDGE_V20'
    option netmask '255.255.255.0'
    option ipaddr '192.168.20.1'

config interface 'WAN'
    option ifname 'eth0'
    option proto 'dhcp'

config interface 'WAN_6M'
    option ifname 'eth0'
    option _orig_ifname 'eth0'
    option _orig_bridge 'false'
    option proto 'static'
    option ip6addr '2a01:e35:2f01:a60::2/64'
    option ip6gw 'fe80::6aa3:78ff:fe1c:2b77'
    option ip6prefix '2A01:E35:2F01:A60::/61'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'
    option mirror_source_port '0'
    option mirror_monitor_port '0'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option vid '1'
    option ports '0 2'

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option ports '1 6'
    option vid '2'

config switch_vlan
    option device 'switch0'
    option vlan '3'
    option ports '0t 1t 2t 3t 6t'
    option vid '100'

config switch_vlan
    option device 'switch0'
    option vlan '4'
    option vid '101'
    option ports '0t 3'

config interface 'BRIDGE_V200'
    option type 'bridge'
    option proto 'none'
    option ifname 'eth1.200'
    option auto '1'
    option stp '1'
    option mtu '1500'

config interface 'LAN_V200'
    option proto 'static'
    option ifname 'br-BRIDGE_V200'
    option ipaddr '192.168.200.1'
    option netmask '255.255.255.0'

config switch_vlan
    option device 'switch0'
    option vlan '5'
    option vid '20'
    option ports '0t 4t 5t'

config interface 'LAN_V20_6'
    option proto 'static'
    option ifname 'br-BRIDGE_V20'
    option ip6addr '2a01:e35:2f01:a61::1/64'

config interface 'LAN_V20_6L'
    option proto 'static'
    option ifname 'br-BRIDGE_V20'
    option ip6addr 'fd02:15b3:9237:20::1/64'

config interface 'LAN_V200_6L'
    option proto 'static'
    option ifname 'br-BRIDGE_V200'
    option ip6addr 'FD02:15B3:9237:200::1/64'

config interface 'WAN_6D'
    option proto 'dhcpv6'
    option ifname 'eth0'
    option reqaddress 'try'
    option reqprefix 'auto'
    option master '1'

config interface 'A_EMERGENCY'
    option proto 'none'
    option ifname 'br-BRIDGE_V1'

config interface 'A_MAIN'
    option proto 'none'
    option ifname 'br-BRIDGE_V20'

config interface 'A_PRIVATE_OBJECT'
    option proto 'none'
    option _orig_ifname 'br-BRIDGE_200'
    option _orig_bridge 'false'
    option ifname 'br-BRIDGE_V200'

config interface 'BRIDGE_V101'
    option type 'bridge'
    option ifname 'eth1.101'
    option _orig_ifname 'eth1.101'
    option _orig_bridge 'true'
    option proto 'none'
    option mtu '1500'
    option stp '1'

config interface 'LAN_V101'
    option proto 'static'
    option ifname 'br-BRIDGE_V101'
    option ipaddr '192.168.101.1'
    option netmask '255.255.255.0'

config interface 'LAN_V101_6'
    option proto 'static'
    option ifname 'br-BRIDGE_V101'
    option ip6assign '64'
    option ip6hint '0'

And /etc/config/wireless

config wifi-device 'radio0'
    option type 'mac80211'
    option hwmode '11g'
    option path 'platform/qca955x_wmac'
    option htmode 'HT20'
    option channel '3'
    option country 'FR'
    option distance '10'
    option txpower '20'

config wifi-device 'radio1'
    option type 'mac80211'
    option channel '36'
    option hwmode '11a'
    option path 'pci0000:01/0000:01:00.0'
    option htmode 'VHT80'
    option txpower '17'
    option country 'FR'
    option distance '10'

config wifi-iface
    option device 'radio1'
    option mode 'ap'
    option wds '1'
    option network 'BRIDGE_V20'
    option encryption 'psk2+ccmp'
    option key 'XXXXXXXXXXXXXXX'
    option macaddr '02:16:3E:95:01:14'
    option ssid 'titikata_bridge_V20'

config wifi-iface
    option device 'radio0'
    option mode 'ap'
    option ssid 'Titikaka_SOS1'
    option encryption 'psk2+ccmp'
    option key 'XXXXXXXXXXXXXXX'
    option hidden '1'
    option network 'BRIDGE_V1'

config wifi-iface
    option device 'radio0'
    option mode 'ap'
    option ssid 'Titikaka_V20'
    option network 'BRIDGE_V20'
    option encryption 'psk2+ccmp'
    option key 'XXXXXXXXXXXXXXX'
    option wps_pushbutton '0'

config wifi-iface
    option device 'radio0'
    option mode 'ap'
    option network 'BRIDGE_V200'
    option encryption 'psk2+ccmp'
    option key 'XXXXXXXXXXXXXXX'
    option wps_pushbutton '0'
    option ssid 'Titikaka_V200'

Thanks

Bastien

seems wifi doesnt have specific mtu option(maybe it gets the lan vlan mtu you bridged it to)
in your case BRIDGE_V1

http://wiki.openwrt.org/doc/uci/wireless

(Last edited by makarel on 29 Aug 2015, 15:12)

I have tried to to increase the mtu of the bridge BRIDGE_V20. It does not work either.

Bastien

i tryied on mine(AA) and cant change it either

So bug. Opened #20425

seems some older devices(mine also) cant handle mtu > 1500 and  in some builds mtu is locked wan<>lan
https://dev.openwrt.org/ticket/14148
i cant change mtu more or less then default 1500(i have wan pppoe.. autoconfigured mtu 1492); lan has mtu 1500

here it sais that per interface shouold work - but doesnt
https://lists.openwrt.org/pipermail/ope … 27941.html

and here .. manual config should work
https://www.gargoyle-router.com/phpbb/v … amp;t=1419

ifconfig eth0.1 mtu 1500

(Last edited by makarel on 29 Aug 2015, 18:33)

The discussion might have continued from here.