Re: Working on Netgear WNDR3700v5

I was able to get OpenWrt installed using ldpinney's instructions. Although I still upgraded u-boot so that I wouldn't have to deal with SERCOMM's signature checks.

If anybody else got confused by the picture on the first page, TX and VCC pins seems to be swapped in that picture. Once I plugged them correctly, I was able to input using serial console.

Unfortunately, I wasn't able to get wireless working (neither 5 nor 2.4 GHz) even after compiling own openwrt image from maikoool repo (ldpinneys image on google drive seems to be from March 28 which I think corresponded to the first version of the patch).

Anyway, thanks for all the work! A lot of progress have been made recently and this router is getting closer to working.

Re: Working on Netgear WNDR3700v5

Hi,

I'm a total noob when it comes to openwrt, but I bought this router, because of the great price/performance. And I wanted to replace my current isp router, well because it's just a piece of sh*t. 

So the thing is I got this router while under the impression that I could install dd-wrt/open wrt. My isp does support own equipment from customers, but the router needs to be able to have seperate vlans; for iptv and internet. With some other services like igmp and dhcp from wan to the vlans.

So the standard firmware doesn't support that, but appearently openwrt/ddwrt does. So I was happy to find that this 5th version has been added to openwrt.

But I'm still waiting, and I would like it asap. Now I don't want to rush anybody. As you're doing this for free I presume. And I'm a total noob at this kind of programming. So I just wanted to say thank you for all the effort so far! And I'm hoping you could keep us updated more frequently. smile Because now my router is just an overpriced wifi switch/ap sad

Re: Working on Netgear WNDR3700v5

commit 0e44251720e73d93e5c6dca21d1b7798df98abbc
Author: blogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date:   Tue Apr 26 11:43:53 2016 +0000

    ramips: Add support for the Netgear WNDR3700v5
   
    https://wiki.openwrt.org/toh/netgear/wndr3700
   
    wndr3700v5 uses the single-core dual thread MediaTek MT7621S SoC.
   
    Signed-off-by: L. D. Pinney <ldpinney@gmail.com>
   
    git-svn-id: svn://svn.openwrt.org/openwrt/trunk@49247 3c298f89-4303-0410-b956-a3cf2f4a3e73

Latest Toy : GnuBee PC-1

Re: Working on Netgear WNDR3700v5

Ldpinney: do the radios work?

Asking so I can update the wiki page.

LEDE 17.01 RC2+ on D-Link DIR-860L B1 :: Netgear WNDR3700 v1 (2x) & v2 (1x) :: PC Engines APU2 :: Ubiquiti Unifi AC Pro (2x) :: TP-Link TL-WR1043ND v1 (1x) & v2 (4x) :: TL-WR841N (2x) :: LEDE trunk on Asus WL-500W (wl) :: OpenWrt Attitude Adjustment 12.09.1 on Asus WL-500G Deluxe

Re: Working on Netgear WNDR3700v5

Presently the radios do not work very well.

Latest Toy : GnuBee PC-1

Re: Working on Netgear WNDR3700v5

Ok thanks, updated the wiki entries.

LEDE 17.01 RC2+ on D-Link DIR-860L B1 :: Netgear WNDR3700 v1 (2x) & v2 (1x) :: PC Engines APU2 :: Ubiquiti Unifi AC Pro (2x) :: TP-Link TL-WR1043ND v1 (1x) & v2 (4x) :: TL-WR841N (2x) :: LEDE trunk on Asus WL-500W (wl) :: OpenWrt Attitude Adjustment 12.09.1 on Asus WL-500G Deluxe

Re: Working on Netgear WNDR3700v5

I have wndr3700v5 too, it is so hard to make this firmware work? Why staff don't answer? They forget that they were in the same situation as us!

Re: Working on Netgear WNDR3700v5

Good to know you are working on it.
Unfortunately i did not have the time to get in deep waters.

59 (edited by bionic_slasher 2016-05-25 20:02:14)

Re: Working on Netgear WNDR3700v5

Hi everyone, Im also a noob in this world and just bouth this modem and got the v5 one, I googled around and found this topic... so Im depending on your magic also big_smile
any news?

Re: Working on Netgear WNDR3700v5

Any updates?

Re: Working on Netgear WNDR3700v5

Siebevp wrote:

Any updates?

Still the same. 2.4 GHz radio doesn't seem to work.  5 Ghz kind of works for me but only on channel 36.

Re: Working on Netgear WNDR3700v5

andrius wrote:
Siebevp wrote:

Any updates?

Still the same. 2.4 GHz radio doesn't seem to work.  5 Ghz kind of works for me but only on channel 36.

Ok thanks for the update!

Re: Working on Netgear WNDR3700v5

Hi everyone! I thank the developers for a great effort. I would like to ask where I can download the latest version of firmware for WNDR3700 v5? I would also like to know how I can install this image to the new device. Can I follow the standard documentation or this device requires a specific installation procedure? Many thanks in advance for your help.

Re: Working on Netgear WNDR3700v5

Is there a howto installing the trunk-firmware?
There is no webflash.img - only a .bin.

Re: Working on Netgear WNDR3700v5

Hi,

I have a similar issue. I have the WNDR3700v5. I can find the sysupgrade image in the trunk:
downloads.openwrt.org/snapshots/trunk/ramips/mt7621

Where can I find the factory one?

Any recommandation would be really welcome.

Alex

Re: Working on Netgear WNDR3700v5

alexvan wrote:

Hi,

I have a similar issue. I have the WNDR3700v5. I can find the sysupgrade image in the trunk:
downloads.openwrt.org/snapshots/trunk/ramips/mt7621

Where can I find the factory one?

Any recommandation would be really welcome.

Alex

There is no factory image. You can't flash it via webinterface. There are instructions earlier in this thread but you need serial cable.

Re: Working on Netgear WNDR3700v5

Thank you. This answers my question, too.
Will there be the possibility to flash in webinterface in near future?

68 (edited by hikey 2016-10-23 15:58:57)

Re: Working on Netgear WNDR3700v5

Dear All,

I have build a LEDE firmware based on your works.
both of 2.4g and 5g wifi (and LEDs) are working fine for me.
The only issue is the USB port...

I 'd like to share it here and looking for feedback.
Please some body help to test it.

Download link  eyun.baidu.com/s/3mi0Mjri
Firmware file name: EN_lede-r1948-ramips-mt7621-wndr3700v5-squashfs-sysupgrade.bin

Optional processes:
1) You may replace the uboot with pb-boot-wndr3700v5.bin with "mtd write pb-boot-wndr3700v5.bin u-boot"
It is an uboot come with DHCP which allowed you to access the miniweb without changing the ip address.

2) If you have tried the firmware on openwrt.org , you might have to rewrite the eeprom because the rom was build with a wrong firmware size.(which would have overwrite your eeprom)
You may replace it with command in putty " mtd write eeprom_wndr3700v5.bin factory "
Thanks

Re: Working on Netgear WNDR3700v5

Dear hikey, Dear Francis,

I follow your posts since the start, thanks a lot for your great work. It is very helpful for everyone.

I use the WNDR3700v5 and I have tested 2 firmwares :

- OpenWRT optimized for the NETGEAR router
- LEDE by hikey

For OpenWRT :

I have tried with SERCOM updater from Windows XP virtual machine without success "Cannot open file"  but the router in recovery mode was detected.

So I used the tool that Francis has created to certify the firmware and the file was recognized but when I have loaded it on the router, it was bricked.

After a full reset (stock firmware + reboot) the router was debricked.

For LEDE
I have tried with SERCOM updater from Windows XP virtual machine without success "Cannot open file"  but the router in recovery mode was detected.

So I used the tool that Francis has created to certify the firmware and the file was recognized. So I have loaded it on the router and after 10 - 15 minutes, the router is flashed and works !

Beautiful webpage (192.168.1.1) so I have configured some parameters (root password, IP adress...).

When I have rebooted the device, all parameters were lost... I think that we cannot write into the memory of the device.

Please, do you have any information about that or any recommendation? It would be very helpful to progress together on the topic.

Let me know if you need any further information, it would be a pleasure.

Thanks!

Re: Working on Netgear WNDR3700v5

Thank you for the feedbacks.
I believe the problem comes from the official uboot.

I am not familiar with the method you flash customer firmware.
but after you flash my firmware, you may backup the fullrom.bin through ssh.
and then you can replace the uboot with the one I provided.

rewrite the eeprom if possible, because if you have tried the openwrt firmware, it had already erased the eeprom partition.

71 (edited by andrius 2016-11-06 23:21:09)

Re: Working on Netgear WNDR3700v5

hikey wrote:

I have build a LEDE firmware based on your works.
both of 2.4g and 5g wifi (and LEDs) are working fine for me.
The only issue is the USB port...

Hi, any idea what you have done in your image to make 2.4g wifi work? I tried your image and 2.4g WiFi initially didn't work. Then I changed Country code to China (while keeping channel 1 and mode N). Changing country to CN somehow helped to bring up 2.4g wifi interface. However, the same trick didn't work on official lede image. So, it must be something you changed that makes 2.4g wifi work.

72 (edited by hikey 2016-11-08 11:05:02)

Re: Working on Netgear WNDR3700v5

andrius wrote:
hikey wrote:

I have build a LEDE firmware based on your works.
both of 2.4g and 5g wifi (and LEDs) are working fine for me.
The only issue is the USB port...

Hi, any idea what you have done in your image to make 2.4g wifi work? I tried your image and 2.4g WiFi initially didn't work. Then I changed Country code to China (while keeping channel 1 and mode N). Changing country to CN somehow helped to bring up 2.4g wifi interface. However, the same trick didn't work on official lede image. So, it must be something you changed that makes 2.4g wifi work.

I have changed the address of radio in eeprom.
I will upload the codes to my github later.
I believe the eeprom data of your device had already been damaged by previous firmwares. 
You may fix it with the eeprom file I have uploaded, and brings up your 2.4G without any  modification of the settings of wlan.

73 (edited by andrius 2016-11-09 01:06:14)

Re: Working on Netgear WNDR3700v5

hikey wrote:

I have changed the address of radio in eeprom.
I will upload the codes to my github later.

Thanks a lot, really appreciated. This is indeed what is hapening. Please try to push this eeprom fix to upstream as well, so that all other users would benefit too. It looks that even current version of LEDE breaks eeprom.

P.S. Even with correct eeprom somehow I still need to set country to CN and channel to 1. With wrong eeprom 2.4 wifi doesn't work at all.

Re: Working on Netgear WNDR3700v5

Thank you hikey and andrius for your information.

I will try to rewrite the eeprom that you have distributed this weekend and let you know.

Have a nice day.

Re: Working on Netgear WNDR3700v5

spliter8 wrote:

Thank you hikey and andrius for your information.

I will try to rewrite the eeprom that you have distributed this weekend and let you know.

Have a nice day.

Any luck?

I actually tried to use dts from hikey's image with stock LEDE build but somehow 2.4 ghz wifi still didn't work. I'm not sure what else I'm missing...