Hi friends,

I have "ATTITUDE ADJUSTMENT (12.09, r36088)" with a router "tp-wr741nd".

I generate my image bin with the generator of images would have to be by default OpenVPN client, and everything is going well, I have the following configuration on the network.

My objective is that any devices connect in my router use the VPN, I downloaded configuration of VPNgate of your webpage vpngate.net and copy in  "/etc/openvpn/"

WLAN open ----------------->/ OpenWRT 12.09 One Antena \------------------>My PC
"SSID-CULTUR"-------->  < client--master (((/\))) "SSID-home" >------------------->WPA2-PSK CCMP AES
 192.168.1.1                     192.168.1.111   /   \   192.168.30.1                                192.168.30.105
                                                            /     \

/etc/config/network

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config interface 'lan'
    option ifname 'eth0'
    option type 'bridge'
    option proto 'static'
    option netmask '255.255.255.0'
    option ipaddr '192.168.30.1'

config interface 'wan'
    option ifname 'eth1'
    option proto 'dhcp'

config switch
    option name 'eth0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'eth0'
    option vlan '1'
    option ports '0 1 2 3 4'

config interface 'wwan'
    option proto 'dhcp'

config interface 'VPN'
    option ifname 'tun0' 
    option defaultroute '0' 
    option peerdns '0' 
    option proto 'none'

/etc/config/firewall

config defaults
    option syn_flood '1'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'REJECT'

config zone
    option name 'lan'
    option network 'lan'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'REJECT'

config zone
    option name 'wan'
    option input 'REJECT'
    option output 'ACCEPT'
    option forward 'REJECT'
    option masq '1'
    option mtu_fix '1'
    option network 'wan wwan'

config forwarding
    option src 'lan'
    option dest 'wan'

config rule
    option name 'Allow-DHCP-Renew'
    option src 'wan'
    option proto 'udp'
    option dest_port '68'
    option target 'ACCEPT'
    option family 'ipv4'

config rule
    option name 'Allow-Ping'
    option src 'wan'
    option proto 'icmp'
    option icmp_type 'echo-request'
    option family 'ipv4'
    option target 'ACCEPT'

config rule
    option name 'Allow-DHCPv6'
    option src 'wan'
    option proto 'udp'
    option src_ip 'fe80::/10'
    option src_port '547'
    option dest_ip 'fe80::/10'
    option dest_port '546'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-ICMPv6-Input'
    option src 'wan'
    option proto 'icmp'
    list icmp_type 'echo-request'
    list icmp_type 'echo-reply'
    list icmp_type 'destination-unreachable'
    list icmp_type 'packet-too-big'
    list icmp_type 'time-exceeded'
    list icmp_type 'bad-header'
    list icmp_type 'unknown-header-type'
    list icmp_type 'router-solicitation'
    list icmp_type 'neighbour-solicitation'
    list icmp_type 'router-advertisement'
    list icmp_type 'neighbour-advertisement'
    option limit '1000/sec'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-ICMPv6-Forward'
    option src 'wan'
    option dest '*'
    option proto 'icmp'
    list icmp_type 'echo-request'
    list icmp_type 'echo-reply'
    list icmp_type 'destination-unreachable'
    list icmp_type 'packet-too-big'
    list icmp_type 'time-exceeded'
    list icmp_type 'bad-header'
    list icmp_type 'unknown-header-type'
    option limit '1000/sec'
    option family 'ipv6'
    option target 'ACCEPT'

config include
    option path '/etc/firewall.user'

config zone
    option input 'ACCEPT'
    option output 'ACCEPT'
    option name 'VPN'
    option forward 'ACCEPT'
    option masq '1'
    option network 'VPN'

config forwarding
    option dest 'lan'
    option src 'VPN'

config forwarding
    option dest 'VPN'
    option src 'lan'

i am execute the vpn client

root@OpenWrt:/etc/rc.d# /usr/sbin/openvpn --config /etc/openvpn/vpngate.ovpn tun0 &
root@OpenWrt:/etc/rc.d# Sat Jan 17 17:09:08 2015 OpenVPN 2.2.2 mips-openwrt-linux [SSL] [LZO2] [EPOLL] built on Mar 14 2013
Sat Jan 17 17:09:08 2015 WARNING: No server certificate verification method has been enabled.  See http://openvpn.net/howto.html#mitm for more info.
Sat Jan 17 17:09:08 2015 NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables
Sat Jan 17 17:09:08 2015 Control Channel MTU parms [ L:1559 D:140 EF:40 EB:0 ET:0 EL:0 ]
Sat Jan 17 17:09:08 2015 Socket Buffers: R=[87380->131072] S=[16384->131072]
Sat Jan 17 17:09:08 2015 Data Channel MTU parms [ L:1559 D:1450 EF:59 EB:4 ET:0 EL:0 ]
Sat Jan 17 17:09:08 2015 Attempting to establish TCP connection with 121.135.46.36:1444 [nonblock]
Sat Jan 17 17:09:09 2015 TCP connection established with 121.135.46.36:1444
Sat Jan 17 17:09:09 2015 TCPv4_CLIENT link local: [undef]
Sat Jan 17 17:09:09 2015 TCPv4_CLIENT link remote: 121.135.46.36:1444
Sat Jan 17 17:09:09 2015 TLS: Initial packet from 121.135.46.36:1444, sid=9621412f c2ae2538
Sat Jan 17 17:09:10 2015 VERIFY OK: depth=0, /CN=8948p.net/O=mp56xk_ouggdt22/C=US
Sat Jan 17 17:09:12 2015 Data Channel Encrypt: Cipher 'AES-128-CBC' initialized with 128 bit key
Sat Jan 17 17:09:12 2015 Data Channel Encrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
Sat Jan 17 17:09:12 2015 Data Channel Decrypt: Cipher 'AES-128-CBC' initialized with 128 bit key
Sat Jan 17 17:09:12 2015 Data Channel Decrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
Sat Jan 17 17:09:12 2015 Control Channel: TLSv1, cipher TLSv1/SSLv3 DHE-RSA-AES256-SHA, 2048 bit RSA
Sat Jan 17 17:09:12 2015 [8948p.net] Peer Connection Initiated with 121.135.46.36:1444
Sat Jan 17 17:09:14 2015 SENT CONTROL [8948p.net]: 'PUSH_REQUEST' (status=1)
Sat Jan 17 17:09:14 2015 PUSH: Received control message: 'PUSH_REPLY,ping 3,ping-restart 10,ifconfig 10.211.1.1 10.211.1.2,dhcp-option DNS 10.211.254.254,dhcp-option DNS 8.8.8.8,route-gateway 10.211.1.2,redirect-gateway def1'
Sat Jan 17 17:09:14 2015 OPTIONS IMPORT: timers and/or timeouts modified
Sat Jan 17 17:09:14 2015 OPTIONS IMPORT: --ifconfig/up options modified
Sat Jan 17 17:09:14 2015 OPTIONS IMPORT: route options modified
Sat Jan 17 17:09:14 2015 OPTIONS IMPORT: route-related options modified
Sat Jan 17 17:09:14 2015 OPTIONS IMPORT: --ip-win32 and/or --dhcp-option options modified
Sat Jan 17 17:09:14 2015 TUN/TAP device tun0 opened
Sat Jan 17 17:09:14 2015 TUN/TAP TX queue length set to 100
Sat Jan 17 17:09:14 2015 /sbin/ifconfig tun0 10.211.1.1 pointopoint 10.211.1.2 mtu 1500
Sat Jan 17 17:09:14 2015 /sbin/route add -net 121.135.46.36 netmask 255.255.255.255 gw 192.168.1.1
Sat Jan 17 17:09:14 2015 /sbin/route add -net 0.0.0.0 netmask 128.0.0.0 gw 10.211.1.2
Sat Jan 17 17:09:14 2015 /sbin/route add -net 128.0.0.0 netmask 128.0.0.0 gw 10.211.1.2
Sat Jan 17 17:09:14 2015 Initialization Sequence Completed

Now connection on VPN