OpenWrt Forum Archive

Topic: Problem with Apple Ipad/iphone using client repeater on 14.07

The content of this topic has been archived on 4 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

I have a problem with apple products since upgrading to Barrier Breaker 14.07.  If the openwrt radio is setup with a client bridge and a single AP then an IPad connects fine but if I add an extra virtual AP it will not connect.  The same setup on Attitude Adjustment 12.09 works.  A PC or android device will connect with no problem while the ipad will not.  The problem seems to be limited to just apple products.  I have reproduced the issue with Iphone, Ipad, and MacAir.  Below are basic config files, just enough to reproduce the issue.  I have tested this on TP-Link models 841, 3500, 3600 & ac1750 with the same result.  I have also tested with the latest trunk version and the apple problem persists.  Any help is be greatly appreciated!

This is the message displayed on an Ipan when connecting: Unable to join the Network "OpenWrt_A"

Configs from TP-Link TL0WR841N Ver 8.2

Wireless:
config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/ar934x_wmac'
        option htmode 'HT20'
        option disabled '0'
        option txpower '30'
        option country 'US'

config wifi-iface
        option network 'wwan'
        option ssid 'OpenWrt'
        option encryption 'psk2'
        option device 'radio0'
        option mode 'sta'
        option bssid 'xx:xx:xx:xx:xx:xx'
        option key '12345678'

config wifi-iface
        option device 'radio0'
        option mode 'ap'
        option encryption 'none'
        option ssid 'OpenWrt_A'
        option network 'lan'

config wifi-iface
        option device 'radio0'
        option mode 'ap'
        option encryption 'none'
        option ssid 'OpenWrt_B'



Network:
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd6e:74bc:f970::/48'

config interface 'lan'
        option ifname 'eth1'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0'
        option proto 'dhcp'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 4'

config interface 'wwan'
        option proto 'dhcp'

Some printers are also unable to connect.

I believe I encountered the same thing with the Bleeding Edge Breaking Barrier and I haven't upgraded to the latest Breaking Barrier 14.07 yet.  I never tested on Attitude Adjustment 12.09 as it was not compatible with the hardware TP Link WDR 4300 v1.6 at the time I installed but i believe it later said that it worked on the hardware in the compatibility chart.

If I setup multiple virtual APs with a WDS link setup between the routers, my Macbook would not be able to connect to the wifi.  I'm not sure if I exhaustively tested with iPhone as I was using the Mac to setup and configure OpenWRT and I would have an ethernet cable plugged in and unplug it and switch to the wireless and back and forth at the time.

I was trying to setup one router with two APs  (tplink and tplink-guest) and then setup a WDS link between the two of them and then advertise the same two APs (tplink and tplink-guest) on the 2nd router but it wouldn't work with the Mac but I believe my wife's computer (Win 7) was fine at the time of testing.

In the end I had to only enable the guest AP on the primary router on both radios and on the second router turn off the other AP on the other radios on the second router as a workaround.

I wanted to advertise both wifi networks on both routers (and add additional routers possibly in the future) but it seems like I couldn't do this and the Macbook couldn't connect at all if I enabled the 2nd AP on each of the radios.   I could only have tplink-guest on the radio0 and tplink on radio1  (not both on the same radio again).

                      tplink + tplink-guest  <------------------- WDS ------------------------>  tplink-guest
                         /                                                                           \
                        / radio0                                                                      \  radio0
                 +------------+                                                                   +------------+
Internet <-----> |  Router1   |                                                                   | Router 2   |
                 +------------+                                                                   +------------+
                       \  radio1                                                                      /  radio1
                        \                                                                            /
                      tplink + tplink-guest  <------------------ WDS ------------------------->  tplink

looking for some insight as well.

I would suggest you concentrate on the setup with your Macbook since it is the most flexible device. Apple relies heavily on Bonjour to access network resources have you setup and configure avahi correctly?

Another issue I find, while testing it is best to connect to the wireless network via the control panel (instead of from the right menubar).. this way you can delete the SSID from the list. I find that helps.

(Last edited by iamalittlepepper on 7 Jan 2015, 09:35)

The problem extends to IPads and a number of printer models.  Ideally the issue would be corrected on the radio side.

The discussion might have continued from here.