OpenWrt Forum Archive

Topic: OpenWRT running as VDSL modem only

The content of this topic has been archived on 24 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hi everyone!

My new ISP have given me a VDSL modem/router running a proprietary OpenWRT derivate (based on 12.09). Unfortunately, the hardware sucks and yields poor performance on my LAN both wired and wireless. So what I want is to use the ISP-box as a modem only, and use my ASUS RT-AC66U as a router. I also have IPTV through the ISP-box, so I suspect the IPTV configuration will have to stay in the ISP-box as well.

Summarized, what I want to achieve is a setup like this:

http://i.imgur.com/dl4URFw.png

Unfortunately I have no idea how to configure this using UCI. I have tried to read the documentation, but it seems my previous knowledge is too limited.

Here are some (I believe relevant) excerpts from the config as preconfigured by my ISP.

$ uci export network
package network

config interface 'loopback'
    option is_lan '1'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config interface 'lan'
    option is_lan '1'
    option type 'bridge'
    option proto 'static'
    option ifname 'eth3 eth4'
    option ipaddr '10.0.0.1'
    option netmask '255.255.255.0'
    option bridge_instance '1'

config interface 'guest'
    option is_lan '1'
    option proto 'static'
    option ipaddr '10.0.1.1'
    option netmask '255.255.255.0'

config interface 'wan'
    option proto 'pppoe'
    option ifname 'ptm0.1'
    option service 'Data'
    option wan_instance '3.1.2.1'
    option username <***>
    option password <***>

config interface 'iptv'
    option proto 'none'
    option type 'bridge'
    option auto '1'
    option ifname 'ptm0.103 eth1 eth2'
    option bridge_instance '2'
$ uci export layer2_interface_vdsl
package layer2_interface_vdsl

config vdsl_interface
    option unit '0'
    option ifname 'ptm0.1'
    option baseifname 'ptm0'
    option name 'VDSL2'
    option dslat '1'
    option ptmprio '1'
    option ipqos '1'

$ uci export layer2_interface_vlan
package layer2_interface_vlan

config vlan_interface
    option name 'vlan_IPTV'
    option ifname 'ptm0.103'
    option baseifname 'ptm0'
    option vlan8021q '103'
    option vlan8021p '3'
    option bridge '1'

Does anyone know how to configure the OpenWRT-box to acheive what I want? I have root SSH access, so that's not a problem. Also, it would be nice to be able to configure the OpenWRT box by plugging into one of the available ethernet ports.

Thanks in advance – any help at all would be greatly appreciated!

Since the VDSL modem is based on Openwrt 12.09 this configuration must be in /etc/config/network .

The original config:
lan = eth3 + eth4
iptv = eth1 + eth2 ( in bridge com vlan 103 of ptm0 )

I sugest this:

config interface 'wan'
    option proto 'none'
    option type 'bridge'
    option ifname 'ptm0.1 eth3 eth4'
    option auto '1'

That way the vlan 1 from ptm will be bridged to eth3 and eth4.
You can connect the wan port of the RT-AC66U router on eth3 or eth4.

The RT-AC66U will be configured to do pppoe with the same user/password as previously used by the VDSL modem.

To add to zhadoom, if it were my setup...
I would replace your Asus for one that is supported by OpenWRT and setup a VLAN Trunk port to be able to forward your iptv and internet to another device and distribute it from there to which ever router/ managed switch you like.
Makes the whole setup a whole lot more flexible and saves pulling additional cables to multiple places around the premises.

Anyway, in zhadoom's setup you won't have an ability to connect to your ISP modem router anymore.
So, you need to take out eth3 or eth4 and keep 'lan' interface to be able to connect to the ISP modem router at a later time, like you wanted...

So, connect Asus to port 3 and keep port 4 free for later configuration purposes of your ISP modem router.

config interface 'wan'
    option proto 'none'
    option type 'bridge'
    option ifname 'ptm0.1 eth3'
    option auto '1'

config interface 'lan'
    option is_lan '1'
    option type 'bridge'
    option proto 'static'
    option ifname 'eth4'
    option ipaddr '10.0.0.1'
    option netmask '255.255.255.0'
    option bridge_instance '1'

Thanks a lot for the suggestions!

hvandrie wrote:

To add to zhadoom, if it were my setup...
I would replace your Asus for one that is supported by OpenWRT and setup a VLAN Trunk port ...

This would obviously be the better solution, but unfortunately my budget can't sustain the expense of replacing the ASUS at the moment.

Anyway, I tried the WAN bridge approach, but I wasn't able to get a PPPoE connection up and running. I tried configuring both my ASUS RT-AC66U and a laptop with PPPoE connected on the bridged interface, but the connection timed out both times. Maybe my ISP has some limitations on what devices they'll negotiate a connection with. Is there any way to do this having the DSL-box negotiate the PPPoE connection?

(Last edited by donwalt on 12 Aug 2014, 07:28)

donwalt, not going to give you very specific advice, but I have followed this thread and it seems you still havn't found a solution that you are happy with, wo here I go...

I understand your VDSL modem "works", but it is slow, and you want something better for your LAN. That is, your problem is communication (speed) between your own computers, within your own network.

Also, I understand you dont want to mess with your IPTV.

How about you leave the VDSL modem in its default configuration. Let it handle the IPTV and also DHCP, internal DNS and NAT. Perhaps turn off WIFI. Then configure your ASUS router to work in "bridge mode" - that is probably not very hard. This way all your computers can communicate with each other without disturbing the VDSL modem.

I don't think it's a limitation of your ISP, think something aint still right in your setup.
What you could try it to spoof the mac address of your ISP modem router in the PPPoE connection from your Asus, letting the ISP think it's their modem trying to connect.

But, don't know whether your Asus is able to do so...

zo0ok wrote:

How about you leave the VDSL modem in its default configuration. Let it handle the IPTV and also DHCP, internal DNS and NAT. Perhaps turn off WIFI. Then configure your ASUS router to work in "bridge mode" - that is probably not very hard. This way all your computers can communicate with each other without disturbing the VDSL modem.

Yep, that's how I have it working now, and it's working reasonably OK. I haven't done any systematic benchmarking of the box I got from my ISP, but the overall network performance seemed sluggish compared to my old setup having the ASUS plugged into a cable modem. I figured that if I gave the ISP-box a little less to think about, it would behave nicer.

The other thing is that I have the ASUS set up with some services (file server, git remote, transmission etc) that I would like to be able to access from outside my LAN. In my current setup, I can of course achieve this by forwarding some ports from the ISP-box. What I wanted to take advantage of is that ASUS actually provides a free DynDNS service, but in order for my router to register with the service, it has to have a public IP on the WAN port.

Anyway, thank you all for your help. I'll evaluate my current setup for a while, and if I'm not satisfied and I do find a solution, I'll be sure to post it here.

The discussion might have continued from here.