Topic: MA260 using QMI with BB

Hi.

I have not been here long, but I am already building and flashing images to my TL-MR3420v2! OpenWRT rocks!

I am trying to get WAN working through an MA260 USB 3G stick using the QMI interface, as using standard USB-Serial seems to want to fail. Here is where I am at:

1) Build image containing the "usb-modeswitch" and the USB serial modules and QMI etc.
2) Connect USB stick and the log shows me I have 3x ttyUSBx devices and a "cdc-wdm0" and "wwan0" with a MAC address
3) Configure an interface in "/etc/config/network" like so:

config interface 'mobile'
  option proto 'qmi'
  option device '/dev/cdc-wdm0'
  option apn 'general.t-mobile.uk'

4) Reload the network config
5) Nothing sad

Am I being totally stupid? I am really struggling to find any more resource on this and I really need this to work for the project I am working on. Any help would be great!

Cheers.

Re: MA260 using QMI with BB

Maybe this could help?
http://trac.gateworks.com/wiki/3g

Cheers,
guenther

Re: MA260 using QMI with BB

Please leave some feedback if you get the MA260 to work with QMI.

There is a list of tested 3G modems at:
http://ofmodemsandmen.com/supported.html
but since those folks have added some custom code it's not certain that they'd all work on stock OpenWRT BB.

4 (edited by guenti 2014-07-31 11:57:56)

Re: MA260 using QMI with BB

FYI, Huawei E378 (Japan-Version of E372, called "Softbank HW005") works fine on latest Trunk.

5 (edited by mauritzius 2014-11-18 23:43:15)

Re: MA260 using QMI with BB

Another fyi: I have the same setup as the OP, but my MA260 works fine using /dev/ttyUSB2 as device. The other two ttyUSB? devices do not work for me.

EDIT: I just got QMI working on Barrier Breaker! Install uqmi and kmod-usb-net-qmi-wwan and configure it.
This is the relevant part of my /etc/config/network section:

config interface 'wan'
    option device '/dev/cdc-wdm0'
    option apn 'drei.at'
    option proto 'qmi'
    option ifname 'wwan0'
Too many devices running on OpenWRT right now...