1 (edited by vbelot 2014-05-28 17:26:04)

Topic: WAG160n V1 Barrier Breaker Firmware

Hi everybody,

I know that a lot of people still have this buggy modem. That is why I have decided to compile a new firmware for it instead of leaving it in a cupboard. I have compiled 4 versions for the WAG160N v1. Version 1 is the most complete and the free space should be enough for most people (the free space is used mainly for configuration files).

/!\ There is no DSL support, this firmware will convert you WAG160N v1 into a Ethernet/Wifi router /!\

It is possible to go back to official firmware with DSL support very easily. If you need to go back to the official firmware, simply flash WAG160Nv1-EU-ANNEXA-ETSI-1.00.16-code-openwrt-flashable through OpenWrt (https://mega.co.nz/#!icNGRIia!ncxj6kscwCr3jN7D9-VDR7dOqJw8ti34_UJuMmZo1hs).

http://s13.postimg.org/eqxwwsv7r/image.png

Version 1 (around 168kB free):
OpenWrt Barrier Breaker r40862
Web Interface : Luci r10249
QoS, UPnP, Dynamic DNS, Custom Commands, Wake On Lan
OpenVPN 2.3.2 PolarSSL
Updated ath9k Wifi drivers (more stable)

https://mega.co.nz/#!mZkxAaIZ!s6LAQsXJI04JNSAimymK8q0cVf0GGs2r-uKMTFhEhpw

Version 2 (around 168kB free):
OpenWrt Barrier Breaker r40862
Web Interface : No UI (only SSH/Telnet)
OpenVPN 2.3.2 OpenSSL (with openvpn-easy-rsa)
Updated ath9k Wifi drivers (more stable)

https://mega.co.nz/#!uMcCmLSD!0z7ZwVSpoB2OmKnBcsnT40YR5EiGvQWIcVa2YErGJCc

Version 3 (around 360kB free):
OpenWrt Barrier Breaker r40862
Web Interface : Luci r10249
QoS, UPnP, Dynamic DNS, Custom Commands, Wake On Lan
No OpenVPN
Updated ath9k Wifi drivers (more stable)

https://mega.co.nz/#!TA8UwCLL!AzSbuVE7WpjX6PMf95Bmhuk-Wa5ViaIUmphzx6kuLBw

Version 3 bis - unstripped libraries & kept opkg data (around 296kB free):
OpenWrt Barrier Breaker r40862
Web Interface : Luci r10249
QoS, UPnP, Dynamic DNS, Custom Commands, Wake On Lan
No OpenVPN
Updated ath9k Wifi drivers (more stable)

https://mega.co.nz/#!7VNFiRpK!wRHBT6saIl2Ye4FlSqwdlX6iNesENlNO51MWtXlxYQc

Instructions :
To flash the router you need :
- A screwdriver
- A little wire or a stapple
- Nothing else smile

Most people were using a LVTTL cable however, it requires you to buy an adapter, to solder, ... it takes time. I realised that to stop the boot we can actually press ANY key, in fact that mean that if we generate any signal on the serial input, the boot stop.
First you have to open the modem by removing the 4 screws and the plastic top. There are some clips on the side, but even if you break these clips the top will still fit perfectly with the screws.

http://s13.postimg.org/4jfdke8zr/image.png

When you power the modem, you have only 1s to activate the Recovery Mode. The trick is to rub a stapple or a wire between the pin 4 (in red) and the pin 1 (in orange) while booting. Do not solder  anything, the goal is not to generate a clean signal but to generate noise !
The easiest way is to hold the stapple between  pin 1 and 4 (do not shortcut pin 1 and 3) and to rub it slightly when it boots. It should activate the recovery mode almost everytime. If it doesn't work you can also rub the stapple between pin 4 (in red) and pin 3 (+3.3V, next to pin 4).
If you succeed, the power LED goes off and the Ethernet LED should be blinking. If the power LED is still on 5s after you plugged the router, it failed. Just unplug the modem and try again. If the ethernet light is off verify you plugged the ethernet cable properly smile.

http://s13.postimg.org/3v6j1ga9z/image.png

Now you should be able to access the CFE Web Interface at http://192.168.1.1. You can also flash the firmware by TFTP if you really want).

http://s13.postimg.org/ibtsg0zrb/image.png

Upload the OpenWrt firmware and you're done !
Wifi is not activated by default, you have to activate it (do not forget to activate 40Mhz mode in settings to get Wifi n but do not force 40Mhz). You can associate the Wifi LED in the LED menu. I let you discover the firmware smile
Thanks to Virus since I used his patch as a base (with some modifications which were required by the last OpenWrt version).

2 (edited by tsalp 2014-06-04 09:48:00)

Re: WAG160n V1 Barrier Breaker Firmware

@vbelot

Your work is excellent

There is one question, however. I used the first firmware and the wifi seems to be completely absent.

root@OpenWrt:~# uci show wireless
root@OpenWrt:~#
root@OpenWrt:~# wifi detect
root@OpenWrt:~#

How would it be possible to enable the wifi ?
Am I missing something ?

>>> EDIT >>>

dmesg output related to wireless is as follows:

[   10.180000] cfg80211: Calling CRDA to update world regulatory domain
[   10.192000] cfg80211: World regulatory domain updated:
[   10.196000] cfg80211:  DFS Master region: unset
[   10.200000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[   10.212000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   10.220000] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   10.228000] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
[   10.236000] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[   10.244000] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[   10.252000] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)

.
.
.
.
[   10.512000] ath: phy0: Bad EEPROM checksum 0x0 or revision 0x0000
[   10.520000] ath: phy0: Unable to initialize hardware; initialization status: -22
[   10.528000] ath9k 0000:00:01.0: Failed to initialize device
[   10.536000] ath9k: probe of 0000:00:01.0 failed with error -22



Please note that the board has been previously flashed with attitude_adjustment (which left no disk space for openvpn), but the ath_data had not been saved as backup.

Initial intention was that wifi would not be used but since the new image is equipped with wireless drivers, it is worth trying to have wifi enabled, as well

3 (edited by vbelot 2014-06-20 18:32:00)

Re: WAG160n V1 Barrier Breaker Firmware

Hi tsalp, could you send me a copy of your complete dmesg please. Could you also send me a copy of your current mtd4 to check if you wifi calibration data are still present ?

To do that, telnet/ssh the router and write:

cat /etc/mtd4 > /www/caldata

and go to http://192.168.1.1/caldata to download the file.

If you go back to the original firmware, is wifi working ?

4 (edited by GhostKU 2014-10-10 13:33:22)

Re: WAG160n V1 Barrier Breaker Firmware

How can I use a separate port for WAN with this firmware?
It says that eth1 is for LAN and eth0 is for WAN but actually all 4 Ethernet ports works for LAN?
Thanks

Re: WAG160n V1 Barrier Breaker Firmware

Really a good job~thank you !

Re: WAG160n V1 Barrier Breaker Firmware

Barrier Breaker comes with a limited set of packages on default install.


clip in feather hair extensions
feather extentions
freindship braclets

Re: WAG160n V1 Barrier Breaker Firmware

Hello,

It is possible to install additional packages? I have to install ppp-mod-ppoa but it tells me that:



Installing ppp-mod-pppoa (2.4.7-2) to root...
Downloading http://192.168.1.102/ppp-mod-pppoa_2.4.7-2_brcm63xx.ipk.

Collected errors:
* satisfy_dependencies_for: Cannot satisfy the following dependencies for ppp-mod-pppoa:
*     libc *     libc *     kernel (= 3.10.49-1-ad222baab7cf17d00e255c5edc11fa85) *     kernel (= 3.10.49-1-ad222baab7cf17d00e255c5edc11fa85) *     kernel (= 3.10.49-1-ad222baab7cf17d00e255c5edc11fa85) *     kernel (= 3.10.49-1-ad222baab7cf17d00e255c5edc11fa85) *     kernel (= 3.10.49-1-ad222baab7cf17d00e255c5edc11fa85) *
* opkg_install_cmd: Cannot install package ppp-mod-pppoa.

Please hep me! sad

Re: WAG160n V1 Barrier Breaker Firmware

GhostKU wrote:

How can I use a separate port for WAN with this firmware?
It says that eth1 is for LAN and eth0 is for WAN but actually all 4 Ethernet ports works for LAN?
Thanks

Hi, After lots of re-flashes i've managed to do it but i dont know if it worths posting the solution. The main problem is swconfig is not managing the switch in the right way so you have to install robocfg and configure the switch with it, after that you should create a init script to start your vlan configuration in every reboot (robocfg turns into default mode with a single vlan in eth1 when you reboot). If youre still interested in this i will post a step-by-step guide. Mine is fully working right now with lan port 1 as wan. Regards