OpenWrt Forum Archive

Topic: Openwrt support for Huawei HG655b

The content of this topic has been archived between 12 Mar 2018 and 5 May 2018. Unfortunately there are posts – most likely complete pages – missing.

Hi,
I succeeded to create access point with MN422G but I don't know what drivers are needed. It doesn't work only with zd1211, it seems it needs also ath9k-htc. The other devices freeze the wifi and don't work, but they seem to need the rts8192cu kernel module.

https://app.box.com/s/tnc1o1drz4mbu4w1vhuj7jg6q84m53pf

I found out another issue related to wifi: If you select WPA2 encryption with TKIP it will limit the connection speed to 54Mbps. AES allows N to work correctly. I ended up having a AES AP and a separate TKIP AP for my legacy devices.

@fratzicu: can you post an example config of your led setup? I think using different vlans forces processing in the cpu instead of the switch hardware so I would expect performance issues at high throughput (or at least a rise in cpu usage)

Hi,
I will post this evening the config, just tell me which file has this info. I used the luci interface to configure.

in /etc/config/system I found:

config led
    option trigger 'netdev'
    option default '0'
    option name 'Data'
    option dev 'br-lan'
    option sysfs 'HW65x:green:dsl'
    option mode 'tx rx'

config led
    option name 'USB'
    option sysfs 'HW65x:green:usb'
    option default '1'
    option trigger 'usbdev'
    option dev '1-2'

config led
    option default '0'
    option name 'Admin'
    option trigger 'netdev'
    option sysfs 'HW65x:green:lan4'
    option mode 'tx rx'
    option dev 'eth0.2'

config led
    option default '0'
    option name 'WiredWan'
    option trigger 'netdev'
    option sysfs 'HW65x:green:lan1'
    option mode 'tx rx'
    option dev 'eth0.3'

config led
    option default '0'
    option name 'LAN 3'
    option sysfs 'HW65x:green:lan3'
    option trigger 'netdev'
    option dev 'eth0.1'
    option mode 'tx rx'

config led
    option default '0'
    option name 'LAN 2'
    option sysfs 'HW65x:green:lan2'
    option trigger 'netdev'
    option dev 'eth0.1'
    option mode 'tx rx'
 

In /etc/config/network I have:

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'xxxx:xxxx:xxxx::/48'

config interface 'lan'
    option type 'bridge'
    option proto 'static'
    option netmask '255.255.255.0'
    option _orig_ifname 'eth0.1 wlan0-1 wlan0'
    option _orig_bridge 'true'
    option ifname 'eth0.1'
    option mtu '1480'
    option gateway '192.168.x.1'
    option dns '192.168.x.1'
    option ipaddr '192.168.x.11'
    option ip6assign '64'

config switch
    option name 'eth0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'eth0'
    option vlan '1'
    option ports '1 2 8t'

config switch_vlan
    option device 'eth0'
    option vlan '2'
    option ports '3 8t'

config switch_vlan
    option device 'eth0'
    option vlan '3'
    option ports '0 8t'

config interface 'Admin'
    option proto 'static'
    option ifname 'eth0.3'
    option ipaddr '192.168.y.1'
    option netmask '255.255.255.0'

config interface 'WAN'
    option proto 'static'
    option ifname 'eth0.2'
    option netmask '255.255.255.0'
    option ipaddr '192.168.x.21' 

(Last edited by fratzicu on 12 Jul 2015, 20:05)

@andoru
I found a solution for the broken wireless. You can still use the device as access point using a usb dongle. Mine worked with a zydas chipset, see my previous post. My wifi chip is probably fried, I cannot repair it. It seems it costs a lot more than a new or used device.

Hello fratzicu!
I installed your build, from May 30th but I have a problem with the kernel. I tried to install some packages but they require kernel 3.18.17, while your build has kernel 3.18.14. Can you make a new build, with the new kernel?

Other than that, it works perfect. I split my lan ports intro vlans, and assigned each one a LED to blink, I saw somebody asked that on the forum.

10x a lot!

Edit: I tried installing the latest build from trunk but I get a reboot loop. I don't have a serial console to see what's wrong.

(Last edited by keffr3n on 12 Jul 2015, 20:46)

hi,

I can do that. Not all packages from the openwrt website work with any build. anyway, you should learn yourself how to build an firmware image. Actually it is very simple.

What package do you need installed?

I'll compile an image, but not too soon. This week is very crowded for me, maybe in 3-4 days. There is a june build, with 3.8.17 kernel, see my post https://forum.openwrt.org/viewtopic.php … 31#p282531

Kind regards

(Last edited by fratzicu on 12 Jul 2015, 20:46)

I'm installing your june build right now, i'll be back with feedback. I was triying to install ledtrig usb, just for fun. I put in a 8gb usb drive and i will use it to do network boot (ipxe). ledtrig usb would give me an indicator on when usb is accesed.

I played these days with chromium os (Arnold the Bat builds) and I would love to make it boot from lan or eaven web.

Hope you'll be successfull

fratzicu wrote:

Hope you'll be successfull

I installed your june version, kernel version is ok, also opkg config, but wifi doesn't work....

Does anyone know if there are any major issues with OpenWRT from trunk on this device? Is WiFi working/stable?
I'm tempted to switch to OWRT but I couldn't get a clear picture from this thread on whether it's usable or not.

I have hardware version C. Is there any difference between this and version A? Is it possible to switch back to default firmware and/or will it miss calibration data?

Protip on using trunk: download the archive with all the packages so you'll be able to install from a local repo later on, once trunk becomes incompatible.

(Last edited by cmn on 13 Jul 2015, 13:23)

wifi is working.  In june version, Maybe I didn't put the driver for the wifi, as i used a usb dongle. I think you should build yourself an image with what packages you need. it's very simple.

First, on a linux box, you need to install some packages necessary for compiling. In Ubuntu, this would be

sudo apt-get install  build-essential binutils flex bison autoconf gettext texinfo sharutils subversion libncurses5-dev ncurses-term zlib1g-dev gcc patch bzip2 libncurses5-dev gawk subversion git libc6-dev libtirpc1 libtirpc-dev default-jdk zip make pkg-config unzip linux-libc-dev-armel-cross linux-libc-dev-armhf-cross linux-libc-dev

but some packages might have different names
Than, you need to choose a folder for compiling openwrt and cd (change directory) to that folder.
than you need to get the sources

git clone git://git.openwrt.org/openwrt.git

than cd openwrt (change directory to openwrt downloaded folder)
after that, give commands

scripts/feeds update -a
scripts/feeds install -a

than, customize your image

make menuconfig

choose what target you need (BCm 63xx), subtarget HG655b, profile default
and target images at least squashfs
choose what packages you need, but note that you have a limited amount of space on the flash. In general, the image must not be bigger than 7 mb. A larger image could erase the calibration data.
If you choose (with space) M variant, the package will be built, but not installed on the image. If you choose *, the package will be included in the image. All the dependencies are automatically selected.
After that you compile:

make V=s

and look in openwrt/bin folder for the images and packages.

What packages do you need installed? Maybe I will build an image with your packages included.
Another option is to install the image on openwrt snapshot (if they are for hg655b) and install with opkg afterwards (but you need to configure network from commandline, as luci is not included there)

kind regards,

I went ahead and installed the trunk version. With the SMP version I got a boot loop, so that did not work. I installed the generic version and it worked. However, the install is very basic: no wifi drivers, no luci, no wan interface. Furthermore, is seems there's no longer an archive with all the available packages. Here's what I did.

First, download a copy of the trunk packages with wget:

wget \
     --recursive \
     --no-clobber \
     --convert-links \
     --domains downloads.openwrt.org \
     --no-parent \
         downloads.openwrt.org/snapshots/trunk/brcm63xx/generic/packages/

Keep the packages until you switch to a new OpenWRT version.

Enter the newly created downloads.openwrt.org directory and start a simple HTTP server:

python2 -m SimpleHTTPServer

Edit /etc/opkg.conf with the local repo:

...
src/gz chaos_calmer_luci http://192.168.1.10:8000/snapshots/trunk/brcm63xx/generic/packages/luci
...

Run opkg update and opkg install with the packages listed here
Install luci: opkg install luci
Reboot
Edit /etc/config/wireless and delete the "option disabled '1'" line
Enable wifi with wifi smile
In LuCI add a new vlan on port 1, and remove the port from the first vlan.
Add new wan and wan6 interfaces and assign them to the newly created vlan.

Configure the rest as needed and now you should have a working, dual stack, home router.  At the time of this edit mine has been going for a day without any issues.

A big thank you to everyone involved in the porting process.

To be added are the configs for the switch LEDs. Does anyone have a working config for this (without making a vlan for each port)?
Another thing I noticed is that OpenWRT does not read the devices' MAC addresses. Is this a known bug?

(Last edited by cmn on 14 Jul 2015, 15:12)

About the MAC address: It seems that the openwrt firmware reads the mac address written in the CFE (toeards thebeginning of the flash) which is the same for all devices, and not the MAC from NVRAM (towards the end of flash). I found the address of the MAC address and gave it in my previous posts on this thread but I don't know how to code it. Maybe danitool can do this. My solution is with the jtag. You copy the CFE with jtag (or all flash) and then edit the CFE address with the 00...01...02 kind MAC address and replace it with the address on the back of the device and flash it back with jtag. Maybe there is some mtd command to do that from inside openwrt but I don't know.

@cmn...
Nice to know you succeeded. You should still try to build your own images. If you use squashfs system, the applications use less space on the flash.
Also, I can tell you that this device is very good. I saw it's potentialfrom the beginning, that's why I decided to try to call for openwrt support for it. This device can be bought very cheap as second-hand device (around max 10 euros). At my workplace I use it as:
- wired bridge
- in the usb port a usb hub is connected
- in the usb hub I have a printer that serves 4 computers (needs a litthe config for print server)
- in the usb hub I have a usb wireless dongle that acts as an access point (this device has a fried wifi chip so I compiled a flash image with additional driver) so now the wired bridge is also wireless
- vsftpd, samba, minidlna, openvpn client/server (I can connect to it from anywhere), ddns, ntpc, etc
- I plan to add in the usb hub a usb hdd with external power source (as probably the usb power will not be enough for all devices connected to the usb hub)

You can use it also with a usb 3g dongle (and if you properly configure some dongles you can use their microsd card as a storage). So many possibilities. It has a pretty good performances. At home I have a media server on it (another device) with minidlna used daily for my daughter's animated movies. Can serve also mkvs in full hd or at least hd.


Works great!  So buy it as you may like it very much. I bought 4. It's plenty of them on the market! You just need to learn some stuff  about compiling in linux.

Next thing, I plan to create a mesh network with 4 devices just to learn about mesh. Just I don't have time to play with it.
Kind regards.

(Last edited by fratzicu on 14 Jul 2015, 20:39)

I've been looking through the SoC wiki page and it seems the device has some features which which have open source  drivers but are not included/integrated in OpenWRT..

.dual core cpu support is WIP. Only userspace apps are able to use the 2nd core (if it works at all; boot loop with SMP image atm)
.hardware random number generator. It needs rng-tools installed. Perhaps it should be added to the default packages?
.hardware acceleration for cryptography. Not integrated into OpenWRT. Would be nice to use with OpenVPN to increase throughput.


@fratzicu...
I did compile an image for a different router. I have a slow PC, and after waiting for a day I discovered I got my kernel config not exactly as I wanted, or missing some package. So compiling is too much of a hassle for me. I still have about 50% free space on the the device so I'm not pressed on that end.

I was thinking of installing OpenVPN and usb storage also, but from experience, the speed is quite low. Do you have some numbers on the throughput on your OpenVPN setup? Is a tun or tap?

(Last edited by cmn on 14 Jul 2015, 21:09)

In openvpn the maximum speed is about 1 Mb/s. With usb storage, with ntfs, speed is about 3 Mb/s. With ext3 the speed is about 5-6 Mb.
I compiled with smp and worked.

My last build with usb 3g support here:
https://app.box.com/s/dqfeig7ylg3xr22xl3hkji6g1ctz9uec

(Last edited by fratzicu on 16 Jul 2015, 20:26)

I wanted to share my internet connection (ADSL) with my friend. Thus on total we need
1.     ADSL Modem+Wireless router form my home which I already have working.
2.    Wireless router for my friend’s home (but he has Huawei HG655b Home gateway)
Thus, we are interested in configuring “Huawei HG655b Home gateway” into a wireless router.
Our requirements for “Huawei HG655b Home gateway” are:-
1.     Use LAN1 port as WAN port for internet connection from my home to his home.
2.    Route the internet connection into a different IP address/subnet (separate ip address space for his home i.e.192.168.1.1/24 and my home i.e. 192.168.9.1/24)
3.    Have wireless lan enabled as Access Point for his home WLAN.
4.    Use LAN2-4 ports as part of same WLAN (i.e. 192.168.1.1/24)
5.    Enable dhcp only for his WLAN (i.e. 192.168.1.1/24)
6.    Use firewall
7.    Run transmission torrent which accesses the files (for upload/download) from connected USB pen drive.
With above requirements, we narrowed down to
https://downloads.openwrt.org/chaos_cal … fs-cfe.bin
After configuring the device, we are facing issue that WAN port (i.e. eth0.1) is not functioning:-
1.    Any ping to device in my home network (i.e. . 192.168.9.1/24), shows Tx packets, but zero Rx packets (courtesy ifconfig)
2.    Any ping from my network to static ip address of “Huawei HG655b Home gateway” says Host not detected.
3.    In my ADSL modem, LAN port statistics shows no packet traffic when it is connected to his “Huawei HG655b Home gateway” WAN port(LAN1), but shows lot of packet traffic when connected to other LAN ports (LAN2-4).
4.    In my WLAN dhcp server (raspbian), when I connect a new client, shows additional logs related to DHCP Request etc, but when we connect his “Huawei HG655b Home gateway”, nothing gets logged.
5.    The Wireless AP is working properly as well as LAN2-4 ports are also working as part of WLAN

It would be a great help if you can provide help/directions on:-
1.    How to debug this issue.
2.    Which tool to use in order to debug/monitor WAN port
3.    How to enable logs for dhcp, firewall, and packet traffic statistics.
After firmware upload, we have modified configuration files only through ssh (as wan port was not working and hence no update, package install etc was possible).
For your reference, I am pasting my configuration files below:-
Cat /etc/config/network

config interface 'loopback'
        option ifname   'lo'
        option proto    'static'
        option ipaddr   '127.0.0.1'
        option netmask  '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdc0:6830:080c::/48'

config interface 'lan'
        option ifname   'eth0.2'
        option type     'bridge'
        option proto    'static'
        option ipaddr   '192.168.1.1'
        option netmask  '255.255.255.0'
#       option force_link '1'
#       option ip6assign '60'

config interface 'wan'
        option ifname   'eth0.1'
        option proto    'static'
        option ipaddr   '192.168.9.225'
        option gateway  '192.168.9.135'
        option netmask  '255.255.255.0'

config switch
        option name     'eth0'
        option reset    '1'
        option enable_vlan '1'
config switch_vlan
        option name     'eth0.2'
        option device   'eth0'
        option vlan     '2'
        option ports    '1 2 3 8t'

config switch_vlan
        option name     'eth0.1'
        option device   'eth0'
        option vlan     '1'
        option ports    '0'


Cat /etc/config/wireless
config wifi-device  radio0
        option type     mac80211
        option channel  11
        option hwmode   11g
        option path     'pci0000:00/0000:00:01.0'
        option htmode   HT20
# REMOVE THIS LINE TO ENABLE WIFI:
#       option disabled 1

config wifi-iface
        option device   radio0
        option network  lan
        option mode     ap
        option ssid     HomeA0875503
        option key      password
        option encryption       psk2+tkip

Cat /etc/config/dhcp
config dnsmasq
        option domainneeded     '1'
        option boguspriv        '1'
        option filterwin2k      '0'
        option localise_queries '1'
        option rebind_protection        '1'
        option rebind_localhost '1'
        option local            '/lan/'
        option domain           'lan'
        option expandhosts      '1'
        option nonegcache       '0'
        option authoritative    '1'
        option readethers       '1'
        option leasefile        '/tmp/dhcp.leases'
        option resolvfile       '/tmp/resolv.conf.auto'
        option localservice     '1'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'

config dhcp 'wan'
        option interface        'wan'
        option ignore           '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'

Cat /etc/config/firewall
config defaults
        option syn_flood        1
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT
# Uncomment this line to disable ipv6 rules
#       option disable_ipv6     1

config zone
        option name             lan
        list   network          'lan'
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT

config zone
        option name             wan
        list   network          'wan'
#       list   network          'wan6'
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT
#       option forward          REJECT
        option masq             1
        option mtu_fix          1

config forwarding
        option src              lan
        option dest             wan

config forwarding
        option src              wan
        option dest             lan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
        option name             Allow-DHCP-Renew
        option src              wan
        option proto            udp
        option dest_port        68
        option target           ACCEPT
        option family           ipv4

# Allow IPv4 ping
config rule
        option name             Allow-Ping
        option src              wan
        option proto            icmp
        option icmp_type        echo-request
        option family           ipv4
        option target           ACCEPT

config rule
        option name             Allow-IGMP
        option src              wan
        option proto            igmp
        option family           ipv4
        option target           ACCEPT

# Allow DHCPv6 replies
# see https://dev.openwrt.org/ticket/10381
config rule
        option name             Allow-DHCPv6
        option src              wan
        option proto            udp
        option src_ip           fe80::/10
        option src_port         547
        option dest_ip          fe80::/10
        option dest_port        546
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-MLD
        option src              wan
        option proto            icmp
        option src_ip           fe80::/10
        list icmp_type          '130/0'
        list icmp_type          '131/0'
        list icmp_type          '132/0'
        list icmp_type          '143/0'
        option family           ipv6
        option target           ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Input
        option src              wan
        option proto    icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        list icmp_type          router-solicitation
        list icmp_type          neighbour-solicitation
        list icmp_type          router-advertisement
        list icmp_type          neighbour-advertisement
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Forward
        option src              wan
        option dest             *
        option proto            icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

# include a file with users custom iptables rules
config include
        option path /etc/firewall.user

Also, various relevant logs which we came across while our futile debug exercise
Ifconfig
br-lan    Link encap:Ethernet  HWaddr 02:10:18:01:00:01
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::10:18ff:fe01:1/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:846 errors:0 dropped:0 overruns:0 frame:0
          TX packets:453 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:62852 (61.3 KiB)  TX bytes:58804 (57.4 KiB)

eth0      Link encap:Ethernet  HWaddr 02:10:18:01:00:01
          inet6 addr: fe80::10:18ff:fe01:1/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:438 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:44509 (43.4 KiB)

eth0.1    Link encap:Ethernet  HWaddr 02:10:18:01:00:01
          inet addr:192.168.9.225  Bcast:192.168.9.255  Mask:255.255.255.0
          inet6 addr: fe80::10:18ff:fe01:1/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:864 (864.0 B)

eth0.2    Link encap:Ethernet  HWaddr 02:10:18:01:00:01
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:414 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:39433 (38.5 KiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1393 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1393 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:94732 (92.5 KiB)  TX bytes:94732 (92.5 KiB)

wlan0     Link encap:Ethernet  HWaddr 7A:F3:A3:4E:08:10
          inet6 addr: fe80::78f3:a3ff:fe4e:810/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1080 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1069 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:125545 (122.6 KiB)  TX bytes:165678 (161.7 KiB)

root@OpenWrt:~# cat /sys/class/net/eth0.1/*
0
6
02:10:18:01:00:01
ff:ff:ff:ff:ff:ff
1
0
0x0
0
0
cat: read error: Invalid argument
0x1003
6
2
0
cat: read error: Is a directory
1500
cat: read error: Invalid argument
0
up
cat: read error: Operation not supported
cat: read error: Is a directory
cat: read error: Invalid argument
cat: read error: Is a directory
cat: read error: Is a directory
0
1
DEVTYPE=vlan
INTERFACE=eth0.1
IFINDEX=6
root@OpenWrt:~# cat /sys/class/net/eth0.2/*
0
6
02:10:18:01:00:01
ff:ff:ff:ff:ff:ff
cat: read error: Is a directory
1
0
0x0
0
0
cat: read error: Invalid argument
0x1303
5
2
0
cat: read error: Is a directory
cat: read error: Is a directory
1500
cat: read error: Invalid argument
0
up
cat: read error: Operation not supported
cat: read error: Is a directory
cat: read error: Invalid argument
cat: read error: Is a directory
cat: read error: Is a directory
0
1
DEVTYPE=vlan
INTERFACE=eth0.2
IFINDEX=5
cat: read error: Is a directory

root@OpenWrt:~# ifstatus lan
{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "uptime": 1192,
        "l3_device": "br-lan",
        "proto": "static",
        "device": "br-lan",
        "updated": [
                "addresses"
        ],
        "metric": 0,
        "delegation": true,
        "ipv4-address": [
                {
                        "address": "192.168.1.1",
                        "mask": 24
                }
        ],
        "ipv6-address": [

        ],
        "ipv6-prefix": [

        ],
        "ipv6-prefix-assignment": [

        ],
        "route": [

        ],
        "dns-server": [

        ],
        "dns-search": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ]
        },
        "data": {

        }
}
root@OpenWrt:~# ifstatus wan
{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "uptime": 1253,
        "l3_device": "eth0.1",
        "proto": "static",
        "device": "eth0.1",
        "updated": [
                "addresses",
                "routes"
        ],
        "metric": 0,
        "delegation": true,
        "ipv4-address": [
                {
                        "address": "192.168.9.225",
                        "mask": 24
                }
        ],
        "ipv6-address": [

        ],
        "ipv6-prefix": [

        ],
        "ipv6-prefix-assignment": [

        ],
        "route": [
                {
                        "target": "0.0.0.0",
                        "mask": 0,
                        "nexthop": "192.168.9.135",
                        "source": "0.0.0.0\/0"
                }
        ],
        "dns-server": [

        ],
        "dns-search": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ]
        },
        "data": {

        }
}

root@OpenWrt:~# iw wlan0 info
Interface wlan0
        ifindex 7
        wdev 0x2
        addr 7a:f3:a3:4e:08:10
        ssid HomeA0875503
        type AP
        wiphy 0
        channel 11 (2462 MHz), width: 20 MHz, center1: 2462 MHz
root@OpenWrt:~# iw list
Wiphy phy0
        max # scan SSIDs: 4
        max scan IEs length: 2257 bytes
        Retry short limit: 7
        Retry long limit: 4
        Coverage class: 0 (up to 0m)
        Available Antennas: TX 0 RX 0
        Supported interface modes:
                 * IBSS
                 * managed
                 * AP
                 * AP/VLAN
                 * WDS
                 * monitor
                 * mesh point
        Band 1:
                Capabilities: 0x2f2
                        HT20/HT40
                        Static SM Power Save
                        RX Greenfield
                        RX HT20 SGI
                        RX HT40 SGI
                        TX STBC
                        RX STBC 2-streams
                        Max AMSDU length: 3839 bytes
                        No DSSS/CCK HT40
                Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
                Minimum RX AMPDU time spacing: 2 usec (0x04)
                HT RX MCS rate indexes supported: 0-15, 32
                TX unequal modulation not supported
                HT TX Max spatial streams: 2
                HT TX MCS rate indexes supported may differ
                Frequencies:
                        * 2412 MHz [1] (20.0 dBm)
                        * 2417 MHz [2] (20.0 dBm)
                        * 2422 MHz [3] (20.0 dBm)
                        * 2427 MHz [4] (20.0 dBm)
                        * 2432 MHz [5] (20.0 dBm)
                        * 2437 MHz [6] (20.0 dBm)
                        * 2442 MHz [7] (20.0 dBm)
                        * 2447 MHz [8] (20.0 dBm)
                        * 2452 MHz [9] (20.0 dBm)
                        * 2457 MHz [10] (20.0 dBm)
                        * 2462 MHz [11] (20.0 dBm)
                        * 2467 MHz [12] (20.0 dBm) (no IR)
                        * 2472 MHz [13] (20.0 dBm) (no IR)
                        * 2484 MHz [14] (20.0 dBm) (no IR)
        valid interface combinations:
                 * #{ managed, AP, mesh point } <= 8,
                   total <= 8, #channels <= 1
        HT Capability overrides:
                 * MCS: ff ff ff ff ff ff ff ff ff ff
                 * maximum A-MSDU length
                 * supported channel width
                 * short GI for 40 MHz
                 * max A-MPDU length exponent
                 * min MPDU start spacing

Hello everybody, salut
if someone can help me with a diagnosis on my router HG655 BRZ ver.A. I want to try to fix it . It has no connection or wireless LAN . Just stay active startup led . I tried resetting 30.30.30 ...
How did this state : anyone played the fuse igniting it and extinguished it . ill send a photo if anybody wants
Thanks !

razvaneuu wrote:

Hello everybody, salut
if someone can help me with a diagnosis on my router HG655 BRZ ver.A. I want to try to fix it . It has no connection or wireless LAN . Just stay active startup led . I tried resetting 30.30.30 ...
How did this state : anyone played the fuse igniting it and extinguished it . ill send a photo if anybody wants
Thanks !

hi
http://wiki.openwrt.org/doc/howto/generic.failsafe

by the way can't establish a connection between the router and PC via LAN router (not active )

Pinging 192.168.1.1 with 32 bytes of data:

Request timed out.
Hardware error.
Hardware error.
Hardware error.

Ping statistics for 192.168.1.1:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

sure np tongue

(Last edited by razvaneuu on 12 Aug 2015, 20:58)

razvaneuu wrote:

by the way can't establish a connection between the router and PC via LAN router (not active )

let me get my crystal ball lol

was thinking about doing something that JTAG pins to comunicate. i only have an USB  CA-42 nokia cable. Hyper terminal or something

waits 2 seconds
I managed to get reply from the victim .I've played with him holding down the reset button and start it while ping 192.168.1.1 -n 55
Reply from 192.168.1.1: bytes=32 time<1ms TTL=100
Reply from 192.168.1.1: bytes=32 time<1ms TTL=100
Reply from 192.168.1.1: bytes=32 time<1ms TTL=100

Ping statistics for 192.168.1.1:
    Packets: Sent = 55, Received = 43, Lost = 12 (21% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 1ms, Average = 0ms

entered the router 192.168.1.1 ansd ask me to :
Update Software

Step 1: Obtain an updated software image file from your ISP.

Step 2: Enter the path to the image file location in the box below or click the "Browse" button to locate the image file.

Step 3: Click the "Update Software" button once to upload the new image file.

NOTE: The update process takes about 2 minutes to complete, and your DSL Router will reboot.

ill try to find the firmware now..

Using tftp to send a firmware to it, whats the packets command to send Not more than 1400 p ?, cuz with 1500 pachets or more router chokes

Sorry, posts 401 to 400 are missing from our archive.