OpenWrt Forum Archive

Topic: DIR-600 B5 works with OpenWRT

The content of this topic has been archived between 21 Apr 2018 and 22 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

In despite of official OpenWRT's DIR-600 B5 wiki, the router works great under OpenWRT control - WAN, LAN, WLAN and LEDs are fully functional.
All you have to do is to build DIR-610 A1 'initramfs-uImage' and 'squashfs-sysupgrade' images and upload them exactly as described here:
http://wiki.umeahackerspace.se/w/index. … Dir-300b5.
Prebuilt images are availlable here:
http://www.imperium-romanum.pl/openwrt/ … uImage.bin
http://www.imperium-romanum.pl/openwrt/ … pgrade.bin

When using 'sysupgrade', add '-F' switch.

(Last edited by lelekx on 8 Mar 2014, 16:54)

Hi! It's my first time that I hack a router to install OpenWrt and I've tried the procedure that you posted but it doesn't work and I don't know why. (Anyway the correct url for the wiki page is: http://wiki.umeahackerspace.se/wiki/Dir-300b5 )

I have succesfully loaded OpenWrt in RAM, but when I put sysupgrade with -F option it does something very fast and it reboots normally with the official firmware... I don't know what I have to do, help me please.

(Last edited by costi on 27 May 2014, 17:56)

Ok I've done it! Now I have OpenWrt!
I have another problem now, I don't know how to configure the internet connection via wan port. Here is my /etc/config/network (more or less as default):

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fd6c:6f00:86a0::/48'

config interface 'lan'
    option ifname 'eth0.1'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.0.140'
    option gateway '192.168.0.1'
    option netmask '255.255.255.0'
    option ip6assign '60'

config interface 'wan'
    option ifname 'eth0.2'
    option netmask '255.255.255.0'
    option gateway '192.168.1.1'
    option proto 'static'
    option ippaddr '192.168.1.140'

config interface 'wan6'
    option ifname '@wan'
    option proto 'dhcpv6'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '0 1 2 3 6t'

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option ports '4 5'

(Last edited by costi on 28 May 2014, 21:53)

costi wrote:

Ok I've done it! Now I have OpenWrt!
I have another problem now, I don't know how to configure the internet connection via wan port. Here is my /etc/config/network (more or less as default):

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fd6c:6f00:86a0::/48'

config interface 'lan'
    option ifname 'eth0.1'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.0.140'
    option gateway '192.168.0.1'
    option netmask '255.255.255.0'
    option ip6assign '60'

config interface 'wan'
    option ifname 'eth0.2'
    option netmask '255.255.255.0'
    option gateway '192.168.1.1'
    option proto 'static'
    option ippaddr '192.168.1.140'

config interface 'wan6'
    option ifname '@wan'
    option proto 'dhcpv6'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '0 1 2 3 6t'

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option ports '4 5'

The WAN configuration looks completely different from default... Regardless. You need to describe what WAN configuration you are trying to set before we can tell you how to set it.

What is your WAN? What protocol or settings does it need?

First, thank you for the reply! Sorry for my bad explanation.
Now I have done the reset to default, so this is my new network configuration:

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fd34:d11b:c426::/48'

config interface 'lan'
    option ifname 'eth0.1'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option ip6assign '60'

config interface 'wan'
    option ifname 'eth0.2'
    option proto 'dhcp'
    option macaddr ':'

config interface 'wan6'
    option ifname '@wan'
    option proto 'dhcpv6'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '0 1 2 3 6t'

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option ports '4 6t'

What I would want it's this: (for now I want this... Later I will want a wifi repeater with also ethernet connections with dhcp enabled with similar IP range, if it's possible... )

I have modem-router "A" that is connected via ethernet lan cable to the WAN port of this router "B" with OpenWRT.
Modem A has DHCP enabled and gives IP in the range of 192.168.1.101/199.
Router B should have a static ip configured in the network file (for example 192.168.1.140) and dhcp server enabled for the devices connected to its wifi or ethernet lan, with IP in the range of 192.168.2.101/199.

OK, but bearing in mind you will still need to reserve the IP used by this router in the DHCP table of the host modem-router "A", to stop it accidentally giving the IP to another device.

Set up your /etc/config/network as follows:

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fd34:d11b:c426::/48'

config interface 'lan'
    option ifname 'eth0.1'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.2.1'
    option netmask '255.255.255.0'
    option ip6assign '60'

config interface 'wan'
    option ifname 'eth0.2'
    option proto 'static'
    option ipaddr '192.168.1.140'
    option gateway '192.168.1.1'
    option dns '192.168.1.1'
    option netmask '255.255.255.0'

config interface 'wan6'
    option ifname '@wan'
    option proto 'dhcpv6'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '0 1 2 3 6t'

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option ports '4 6t'

Thank you, but It doesn't work. I have also setup the static ip in the dhcp table of my modem A (TP-Link TD-W8970) and then tried also to disable the static ip in the network configuration file of router B...
The Router B has its correct ip (192.168.1.140) and also the devices connect to it via ethernet have their correct ones, but it can't connect to internet.  Furthermore I don't see its IP in the table of connected clients of modem A, also the wan led of router B flashes continuously. Do you think the problem is with modem A? Maybe do I have to set anything particular with ports or firewall?

(Last edited by costi on 29 May 2014, 16:35)

What is the IP address of your modem A? I've assumed it's 192.168.1.1 but it could really be anything - and you need to know what it is. If you know it, can you ping it from router B (ssh) when configured as above?

What about changing WAN proto from 'static' to 'dhcp' - if you've tried this earlier, did it get an IP address?

(Last edited by qasdfdsaq on 29 May 2014, 16:55)

qasdfdsaq wrote:

What is the IP address of your modem A? I've assumed it's 192.168.1.1 but it could really be anything - and you need to know what it is. If you know it, can you ping it from router B (ssh) when configured as above?

What about changing WAN proto from 'static' to 'dhcp' - if you've tried this earlier, did it get an IP address?

The ip of modem A it's 192.168.1.1, it's correct, from other devices connected to it I can ping it.
I've tried both static and dhcp for wan on router B but doesn't work. With proto static the ping to 192.168.1.1 freezes in loop at first packet, it does not go on nor stop. With proto dhcp the ping stops and gives "network unreachable".
Also with dhcp it doesn't show ip in ifconfig result nor in the clients list of modem A.

Here's is my result of "ifconfig -a"  with proto static:

br-lan    Link encap:Ethernet  HWaddr 14:D6:4D:79:79:0C  
          inet addr:192.168.2.1  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fd34:d11b:c426::1/60 Scope:Global
          inet6 addr: fe80::16d6:4dff:fe79:790c/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:836 errors:0 dropped:0 overruns:0 frame:0
          TX packets:286 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:82631 (80.6 KiB)  TX bytes:32159 (31.4 KiB)

eth0      Link encap:Ethernet  HWaddr 14:D6:4D:79:79:0C  
          inet6 addr: fe80::16d6:4dff:fe79:790c/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:843 errors:0 dropped:0 overruns:0 frame:0
          TX packets:637 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:99355 (97.0 KiB)  TX bytes:57220 (55.8 KiB)
          Interrupt:5 

eth0.1    Link encap:Ethernet  HWaddr 14:D6:4D:79:79:0C  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:836 errors:0 dropped:0 overruns:0 frame:0
          TX packets:286 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:82631 (80.6 KiB)  TX bytes:32159 (31.4 KiB)

eth0.2    Link encap:Ethernet  HWaddr 14:D6:4D:79:79:0C  
          inet addr:192.168.1.140  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::16d6:4dff:fe79:790c/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:346 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:14772 (14.4 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:563 errors:0 dropped:0 overruns:0 frame:0
          TX packets:563 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:50229 (49.0 KiB)  TX bytes:50229 (49.0 KiB)

wlan0     Link encap:Ethernet  HWaddr 14:D6:4D:79:79:0C  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

And this with proto dhcp:

br-lan    Link encap:Ethernet  HWaddr 14:D6:4D:79:79:0C  
          inet addr:192.168.2.1  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fd34:d11b:c426::1/60 Scope:Global
          inet6 addr: fe80::16d6:4dff:fe79:790c/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:610 errors:0 dropped:0 overruns:0 frame:0
          TX packets:500 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:51054 (49.8 KiB)  TX bytes:43666 (42.6 KiB)

eth0      Link encap:Ethernet  HWaddr 14:D6:4D:79:79:0C  
          inet6 addr: fe80::16d6:4dff:fe79:790c/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:614 errors:0 dropped:0 overruns:0 frame:0
          TX packets:552 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:62911 (61.4 KiB)  TX bytes:64694 (63.1 KiB)
          Interrupt:5 

eth0.1    Link encap:Ethernet  HWaddr 14:D6:4D:79:79:0C  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:610 errors:0 dropped:0 overruns:0 frame:0
          TX packets:500 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:51054 (49.8 KiB)  TX bytes:43666 (42.6 KiB)

eth0.2    Link encap:Ethernet  HWaddr 14:D6:4D:79:79:0C  
          inet6 addr: fe80::16d6:4dff:fe79:790c/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:47 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:17307 (16.9 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:254 errors:0 dropped:0 overruns:0 frame:0
          TX packets:254 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:17400 (16.9 KiB)  TX bytes:17400 (16.9 KiB)

wlan0     Link encap:Ethernet  HWaddr 14:D6:4D:79:79:0C  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

I'm thinking that my wan port is broken... I do not use it for a long time, so I don't know.

(Last edited by costi on 29 May 2014, 17:38)

Just two questions : if you are flashing into a DIR-600 B5 an image made for a dlink DIR-610 A1 succesfully, is it posible that it does not work ( that image ) in DIR-610 A1? spite it was generated for it .....

I have been trying all bins I found for  DIR-610 A1 in the net and always fails to boot  Im still using the original firm...  any sugestion or method to make it work???

Can anyone tell me how to flash? The above links are down. I have Rev. B6, but the hardware seems to be the same:
https://dev.openwrt.org/ticket/18046

Can I just flash via web interface?

lelekx wrote:

In despite of official OpenWRT's DIR-600 B5 wiki, the router works great under OpenWRT control - WAN, LAN, WLAN and LEDs are fully functional.
All you have to do is to build DIR-610 A1 'initramfs-uImage' and 'squashfs-sysupgrade' images and upload them exactly as described here:
http://wiki.umeahackerspace.se/w/index. … Dir-300b5.
Prebuilt images are availlable here:
http://www.imperium-romanum.pl/openwrt/ … uImage.bin
http://www.imperium-romanum.pl/openwrt/ … pgrade.bin

When using 'sysupgrade', add '-F' switch.

Hi, i I built DIR-610 A1 initramfs-uImage, but when I load it to ram I got a looping during boot, as desbribed here: https://forum.openwrt.org/viewtopic.php … 93#p258493
Can you help me?

I also compiled a newest release and got into a loop during boot. But then I realized that the OP wrote a post in March 2014, so I decided to try an older release from March 2014, and it worked!

I used (more or less randomly) release 39923. The router works now in WiFi client mode (not available in factory firmware) and is very stable with good wireless speed. I noticed, though, that opkg does not work, but perhaps that can be fixed (didn't want to dig into that, since I made the image for my friend who does not need this functionality). Also, the release 39923 does not compile, if I include radvd package.

Here are my images:

openwrt-ramips-rt305x-dir-610-a1-initramfs-uImage.bin
https://mega.nz/#!GFJSlZrI!WNX_LeDV-tN_ … seAjiiiOz0
md5: 829a60e6a5dde0e16400072ab6aa63d2

openwrt-ramips-rt305x-dir-610-a1-squashfs-sysupgrade.bin
https://mega.nz/#!DZwxzY5Y!WF-dSaDeVmKw … CT1tUNJiMo
md5: f3a265b9af2038040ad13e08a8246ff2

And here is an image, which can be flashed directly from the original factory Web GUI through firmware upgrade (no need to solder a serial port):

openwrt-ramips-rt305x-dir-600-b5-squashfs-factory.bin
https://mega.nz/#!7VISEDBD!6Nl-6f4NwmY7 … 0P4yo2eHwk
md5: b2a0f39930e2805ded2fd62dde0bd15c

(Last edited by depswa on 20 Sep 2015, 12:33)

Hi, I tried to install your firmware on my dir-600 b5 router.
It loads the firmware, but I'm not able to connect to the box using telnet for the first configuration.
can you please help me?

Is the router functioning in general? For example, can you get an IP address from DHCP, is there a OpenWRT wifi network, does it replies to pings? If so, telnet should work (it did in my case). Otherwise, the firmware might not have been installed.

I actually have not tested the firmware for flashing from Web GUI: I prepared it manually by modifying the header in HEX editor after I returned the router to my friend. So I myself flashed the firmware through serial. But if router accepts the firmware during Web flash, it should be correct.

(Last edited by depswa on 5 Mar 2015, 12:53)

Hi, it does not work, no dhcp, no pings. 3 network leds are green fixed, 1 is off. the wifi led is off

Ok, then my guess would be that the firmware for flashing from Web GUI is not functional. You can easily recover to stock firmware (or any other) using emergency room. In that case, the only method to reliably flash a firmware is to open the case, solder three pins and flash through serial. That should work for sure.

ok, I know how to recover the old firmware using emergency room, I' m doing a lot of tests, so I have recovered the original firmware in the past days...
more complicated for me to use the serial...no other way to do the job?

anyway, tnks for your answers

No, unfortunately, there is no other way.

I don't know, why OpenWRT community does not support this router, even though it seems feasible. Perhaps, because the router is too old and it is not worth the effort... I compiled the firmware just for fun for my friend, but otherwise I would have just bought another router.

depswa wrote:

I also compiled a newest release and got into a loop during boot. But then I realized that the OP wrote a post in March 2014, so I decided to try an older release from March 2014, and it worked!

Thanks for the images, it works like a charm on my DIR-600 B6 smile

"depswa wrote:
I also compiled a newest release and got into a loop during boot. But then I realized that the OP wrote a post in March 2014, so I decided to try an older release from March 2014, and it worked!
Thanks for the images, it works like a charm on my DIR-600 B6 smile"

Hi, I too, own the DIR-600 B6. Since most of the links are dead could you please explain how you installed open-wrt on your device?

Thank you very much!

vdrenzo wrote:

Hi, I too, own the DIR-600 B6. Since most of the links are dead could you please explain how you installed open-wrt on your device?

Thank you very much!

Hi,

Links given above by depswa are still alive !

Hi
I'm trying to use the D-Link DIR 600 B5 as a wireless bridge.
The reason for this is because I want to get a more stable connection for my PS4 since sony seem to have cheaped out on whatever wireless receiver they installed and really I don't want to have to run a huge length of cable to my ps4 since the router is shared with my housemates and it's positioned on another floor of the house.
So instead I'd rather try use this old router and run a cable from it into the ps4

I have a few questions:
1) Will this work for the purpose I stated above?
2) The directions I've read so far in this thread start by saying "solder a serial port"?
I know how to solder but my experience is with re-wiring guitars and pickups, not dealing with circuit boards soooo what exactly do I need to solder in this?

Hello Guys,
after hard working i have it done, who installing openwrt on my Dlink DIR600 B5, without connect it to Serial Port ... big_smile
Now what you are required for this?
1. You need to download this Files:
|-> My build of Original Firmware (mirror)
|-> openwrt-ramips-rt305x-dir-610-a1-initramfs-uImage.bin
|-> openwrt-ramips-rt305x-dir-610-a1-squashfs-sysupgrade.bin
2. You need a local Webhost to download a part of Firmware to your Dlink.
3. You have an NFS-Server online (to make it easier flash first part of Firmware...)
Now thats it!

[ For the background: I had compiled my own firmware.bin form the Original Source Code from the Dlink Server. (GPL Source v2.17)
In this case I have build it with busybox v1.19.1 with any more functions in it. Inc. the telnetd daemon you need to get burn the uloader.img to the router...
The telnetd daemon is available on the Port 2323 and you don't need any login data!)

( This configure I used: )
|-> 192.168.0.1 ==> Router IP (@ first part of flash)
|-> 192.168.0.2 ==> My Client PC (@ first part of flash)
-----------------------------------------------------------------------
|-> 192.168.1.1 ==> Router IP (in sec. part)
|-> 192.168.1.2 ==> My Client PC (in sec. part)
==========================================
My NFS-Server + Webhost Folder is: /var/www .In there is a Subfolder who called dlink, witch the openwrt.img's are copied into it...
($ cp openwrt-ramips-rt305x-dir-610-a1-squashfs-sysupgrade.bin openwrt-ramips-rt305x-dir-610-a1-initramfs-uImage.bin /var/www/dlink/
[ ! Don't forget the right chmod + chown ! ]
$ sudo chown -R nobody:nogroup /var/www/dlink && sudo chmod -R 777 /var/www/dlink )

So when you finished all downloads and maked your Server Live,  you are ready to bring it On:
1. Flash MyBuild Frimware (dir600b_v2.17_bbox-v1.19.1.bin) to device. (You can use the emergency room or the normal Upload Site from the router...)
2. After the Router is rebooted you can connect via telnet to your device:
$ telnet 192.168.0.1 2323
3. When you connected you need to upload the uImage.bin to device. (Via wget | tftp | ftp get/put | nfs-mount ...)
    In this case I used nfs-mount to flash it:
$ mount -o nolock -t nfs 192.168.0.2:/var/www /home
$ cd /home/dlink
$ busybox flash_unlock /dev/mtd/2 # don't use /dev/mtdblock/2, this is the wrong path to flash!
$ busybox flashcp openwrt-ramips-rt305x-dir-610-a1-initramfs-uImage.bin /dev/mtd/2
# Now don't turn off device or you get a brick! .... After 1-2 min the Command are finished. You see it when a new Line are displayed. ( e.g. $ )
$ reboot -f    # Now Reboot ...
After that the Power LED goes On, then Off, then blinking 5-10 sec... In that time when its blinking the LED for the first LAN should me lights UP. (... e.g. Your PC is connect to it ... ^^)
Now at the end of booting device the Power+LAN1 Lights are ON.
4. Then the Openwrt Web Interface are available @ 192.168.1.1 . Your PC you gived the IP: 192.168.1.2 .
You can now flash the openwrt-ramips-rt305x-dir-610-a1-squashfs-sysupgrade.bin Firmware to Device... !
After the next Reboot, IT DONE !!!!

Now Have fun with the Next Generation Firmware: Openwrt :-D

(Sorry for my bad English but iam from Germany and iam really dump in English session @ School ^^)
So have a nice time ...
MFG Master X