Hello,

I have tested the following with relayd and isc-dhcp-relay-ipv4 and the servers receive the forwarded DHCP discovers but do not respond with an offer or a nack.

I have included the following below:

Relevant /etc/config, output of ifconfig, route, arp -a, tcpdump, ps, brctl show, dhcrelay -d, df, free and logread at the end.

I have a TP-Link TL -WDR3600 hardware version 1.3 running AA 12.09, revision: r36088, target ar71xx/generic. It has had the factory image and then sysupgrade image applied.

I'm using it in station mode to connect to someone else's Netgear DG834Gv5 with Firmware V1.6.01.34 as I'm sharing their house.
I have an alternative wireless propriety AP, that runs isc-dhcp and can run tcpdump and see the discovery packets, but doesn't respond to forwarded requests with relayd or dhcrelay.

Both the Netgear and alternative AP DHCP services provide leases for wireless and wired clients connected directly.

I can get it to connect in station mode, with the configuration in the Bridged Client Mode (with relayd) guide, what doesn't work is DHCP relaying.
The DHCP servers are seeing the Discover packets and they look valid, the servers don't respond though. I have confirmed this with tcpdumps at both ends and a client in the middle that's seeing the broadcasts.

Enabling the DHCP server within OpenWRT works but assigns the wrong network as that is for the lan interface, as the offset for that uses the interfaces network.

I have seen it work randomly twice; I say randomly as both times when I have had a tcpdump running whilst on the phone chatting to friends, it has suddenly done DORA with no intervention from me after around 30 minutes of just sending discovery packets.

So on to the configuration and results. I used this guide: http://wiki.openwrt.org/doc/howto/clien … ith.relayd

The Netgear is 192.168.0.1 on network 192.168.0.0/24.
The Openwrt is 192.168.1.1 on 192.168.1.0/24.
wlan0 receives a DHCP reservation of 192.168.0.10 from the Netgear or the alternative AP.


relayd has been run with and without the -G(ateway option) 192.168.0.1, for example:

/usr/sbin/relayd -I br-lan -I wlan0 -L 192.168.0.10 -B -D -G 192.168.0.1

dhcrelay has been run as: dhcrelay -i br-lan -i wlan0 -a -d 192.168.0.1

From opkg list | grep relay the versions I am using are:

isc-dhcp-relay-ipv4 - 4.2.4-2
relayd - 2011-10-24-4e8f1fa4ca2b176500362843a9e57ea5abd4b7a3

/etc/config/wireless

config wifi-device 'radio0'
    option type 'mac80211'
    option macaddr 'f8:1a:67:eb:cf:d9'
    option hwmode '11ng'
    option htmode 'HT20'
    list ht_capab 'LDPC'
    list ht_capab 'SHORT-GI-20'
    list ht_capab 'SHORT-GI-40'
    list ht_capab 'TX-STBC'
    list ht_capab 'RX-STBC1'
    list ht_capab 'DSSS_CCK-40'
    option disabled '0'
    option channel '1'

config wifi-iface
    option device 'radio0'
    option network 'wwan'
    option mode 'sta'
    option ssid 'SSID'
    option encryption 'psk'
    option key 'secret'

config wifi-device 'radio1'
    option type 'mac80211'
    option channel '36'
    option macaddr 'f8:1a:67:eb:cf:da'
    option hwmode '11na'
    option htmode 'HT20'
    list ht_capab 'LDPC'
    list ht_capab 'SHORT-GI-20'
    list ht_capab 'SHORT-GI-40'
    list ht_capab 'TX-STBC'
    list ht_capab 'RX-STBC1'
    list ht_capab 'DSSS_CCK-40'
    option disabled '1'

config wifi-iface
    option device 'radio1'
    option network 'lan'
    option mode 'ap'
    option ssid 'OpenWrt'
    option encryption 'none'


/etc/config/network

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config interface 'lan'
    option ifname 'eth0.1'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option gateway '192.168.0.1'
    option dns '192.168.0.1'

config interface 'wan'
    option ifname 'eth0.2'
    option proto 'dhcp'

config switch
    option name 'eth0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'eth0'
    option vlan '1'
    option ports '0t 2 3 4 5'

config switch_vlan
    option device 'eth0'
    option vlan '2'
    option ports '0t 1'

config interface 'wwan'
    option proto 'dhcp'

config interface 'stabridge'
    option proto 'relay'
    option network 'lan wwan'
    option ipaddr '192.168.0.10'


/etc/network/dhcp

config dnsmasq
    option domainneeded '1'
    option boguspriv '1'
    option filterwin2k '0'
    option localise_queries '1'
    option rebind_protection '1'
    option rebind_localhost '1'
    option local '/lan/'
    option domain 'lan'
    option expandhosts '1'
    option nonegcache '0'
    option authoritative '1'
    option readethers '1'
    option leasefile '/tmp/dhcp.leases'
    option resolvfile '/tmp/resolv.conf.auto'

config dhcp 'lan'
    option interface 'lan'
    option start '100'
    option limit '150'
    option leasetime '12h'
    option ignore '1'

config dhcp 'wan'
    option interface 'wan'
    option ignore '1'


/etc/config/firewall

config defaults
    option syn_flood '1'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'REJECT'

config zone
    option name 'lan'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'ACCEPT'
    option network 'lan wwan'

config zone
    option name 'wan'
    option network 'wan'
    option input 'REJECT'
    option output 'ACCEPT'
    option forward 'REJECT'
    option masq '1'
    option mtu_fix '1'

config forwarding
    option src 'lan'
    option dest 'wan'

config rule
    option name 'Allow-DHCP-Renew'
    option src 'wan'
    option proto 'udp'
    option dest_port '68'
    option target 'ACCEPT'
    option family 'ipv4'

config rule
    option name 'Allow-Ping'
    option src 'wan'
    option proto 'icmp'
    option icmp_type 'echo-request'
    option family 'ipv4'
    option target 'ACCEPT'

config rule
    option name 'Allow-DHCPv6'
    option src 'wan'
    option proto 'udp'
    option src_ip 'fe80::/10'
    option src_port '547'
    option dest_ip 'fe80::/10'
    option dest_port '546'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-ICMPv6-Input'
    option src 'wan'
    option proto 'icmp'
    list icmp_type 'echo-request'
    list icmp_type 'echo-reply'
    list icmp_type 'destination-unreachable'
    list icmp_type 'packet-too-big'
    list icmp_type 'time-exceeded'
    list icmp_type 'bad-header'
    list icmp_type 'unknown-header-type'
    list icmp_type 'router-solicitation'
    list icmp_type 'neighbour-solicitation'
    list icmp_type 'router-advertisement'
    list icmp_type 'neighbour-advertisement'
    option limit '1000/sec'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-ICMPv6-Forward'
    option src 'wan'
    option dest '*'
    option proto 'icmp'
    list icmp_type 'echo-request'
    list icmp_type 'echo-reply'
    list icmp_type 'destination-unreachable'
    list icmp_type 'packet-too-big'
    list icmp_type 'time-exceeded'
    list icmp_type 'bad-header'
    list icmp_type 'unknown-header-type'
    option limit '1000/sec'
    option family 'ipv6'
    option target 'ACCEPT'

config include
    option path '/etc/firewall.user'


iw dev wlan0 link:

Connected to c0:3f:0e:ca:91:c0 (on wlan0)
    SSID: SSID
    freq: 2412
    RX: 6609683 bytes (76359 packets)
    TX: 316539 bytes (1261 packets)
    signal: -63 dBm
    tx bitrate: 54.0 MBit/s

    bss flags:    short-preamble short-slot-time
    dtim period:    0
    beacon int:    100


tcpdump -vni br-lan port 67 or port 68
tcpdump: listening on br-lan, link-type EN10MB (Ethernet), capture size 65535 bytes
00:44:11.655046 IP (tos 0x0, ttl 64, id 0, offset 0, flags [none], proto UDP (17), length 576)
    0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request from 00:10:75:41:35:9d, length 548, xid 0xd192af63, Flags [none]
      Client-Ethernet-Address 00:10:75:41:35:9d
      Vendor-rfc1048 Extensions
        Magic Cookie 0x63825363
        DHCP-Message Option 53, length 1: Discover
        Client-ID Option 61, length 7: ether 00:10:75:41:35:9d
        Vendor-Class Option 60, length 12: "udhcp 1.13.2"
        MSZ Option 57, length 2: 576
        Parameter-Request Option 55, length 7:
          Subnet-Mask, Default-Gateway, Domain-Name-Server, Hostname
          Domain-Name, BR, NTP
00:44:14.664051 IP (tos 0x0, ttl 64, id 0, offset 0, flags [none], proto UDP (17), length 576)
    0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request from 00:10:75:41:35:9d, length 548, xid 0xd192af63, Flags [none]
      Client-Ethernet-Address 00:10:75:41:35:9d
      Vendor-rfc1048 Extensions
        Magic Cookie 0x63825363
        DHCP-Message Option 53, length 1: Discover
        Client-ID Option 61, length 7: ether 00:10:75:41:35:9d
        Vendor-Class Option 60, length 12: "udhcp 1.13.2"
        MSZ Option 57, length 2: 576
        Parameter-Request Option 55, length 7:
          Subnet-Mask, Default-Gateway, Domain-Name-Server, Hostname
          Domain-Name, BR, NTP


route:
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         192.168.0.1     0.0.0.0         UG    0      0        0 wlan0
192.168.0.0     *               255.255.255.0   U     0      0        0 wlan0
192.168.1.0     *               255.255.255.0   U     0      0        0 br-lan


ifconfig
br-lan    Link encap:Ethernet  HWaddr F8:1A:67:EB:CF:D8 
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1706 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1007 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:353708 (345.4 KiB)  TX bytes:135946 (132.7 KiB)

eth0      Link encap:Ethernet  HWaddr F8:1A:67:EB:CF:D8 
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2552 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2361 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:720809 (703.9 KiB)  TX bytes:666061 (650.4 KiB)
          Interrupt:4

eth0.1    Link encap:Ethernet  HWaddr F8:1A:67:EB:CF:D8 
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2552 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1040 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:674873 (659.0 KiB)  TX bytes:137464 (134.2 KiB)

eth0.2    Link encap:Ethernet  HWaddr F8:1A:67:EB:CF:D8 
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1321 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:519153 (506.9 KiB)

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:24 errors:0 dropped:0 overruns:0 frame:0
          TX packets:24 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:2366 (2.3 KiB)  TX bytes:2366 (2.3 KiB)

wlan0     Link encap:Ethernet  HWaddr F8:1A:67:EB:CF:D9 
          inet addr:192.168.0.10  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:539 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1277 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:32
          RX bytes:342183 (334.1 KiB)  TX bytes:320910 (313.3 KiB)

arp -a
IP address       HW type     Flags       HW address            Mask     Device
169.254.6.163    0x1         0x2         00:10:75:41:35:9d     *        br-lan
192.168.1.100    0x1         0x2         b8:27:eb:50:30:90     *        br-lan
192.168.0.1      0x1         0x2         c0:3f:0e:ca:91:be     *        wlan0


brctl show
bridge name    bridge id        STP enabled    interfaces
br-lan        8000.f81a67ebcfd8    no        eth0.1


From ps:
1388 root       896 S    /usr/sbin/relayd -I br-lan -I wlan0 -L 192.168.0.10 -B -D

and when it has been run with -G

1388 root       896 S    /usr/sbin/relayd -I br-lan -I wlan0 -L 192.168.0.10 -B -D -G 192.168.0.1

dhcrelay -i br-lan -i wlan0 -a -d 192.168.0.1
/var/run/utmp: No such file or directory

Internet Systems Consortium DHCP Relay Agent 4.2.4
Copyright 2004-2012 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/
Listening on LPF/wlan0/f8:1a:67:eb:cf:d9
Sending on   LPF/wlan0/f8:1a:67:eb:cf:d9
Listening on LPF/br-lan/f8:1a:67:eb:cf:d8
Sending on   LPF/br-lan/f8:1a:67:eb:cf:d8
Sending on   Socket/fallback
Adding 11-byte relay agent option
Forwarded BOOTREQUEST for 00:10:75:41:35:9d to 192.168.0.1
Adding 11-byte relay agent option
Forwarded BOOTREQUEST for 00:10:75:41:35:9d to 192.168.0.1
Adding 11-byte relay agent option
Forwarded BOOTREQUEST for 00:10:75:41:35:9d to 192.168.0.1

df -h
Filesystem                Size      Used Available Use% Mounted on
rootfs                    5.1M      1.5M      3.6M  30% /
/dev/root                 2.0M      2.0M         0 100% /rom
tmpfs                    61.9M    384.0K     61.5M   1% /tmp
tmpfs                   512.0K         0    512.0K   0% /dev
/dev/mtdblock3            5.1M      1.5M      3.6M  30% /overlay
overlayfs:/overlay        5.1M      1.5M      3.6M  30% /



free
             total         used         free       shared      buffers
Mem:        126676        23936       102740            0         1788
-/+ buffers:              22148       104528
Swap:            0            0            0


logread
Feb 18 23:38:03 OpenWrt syslog.info syslogd started: BusyBox v1.19.4
Feb 18 23:38:03 OpenWrt kern.notice kernel: klogd started: BusyBox v1.19.4 (2013-03-14 11:28:31 UTC)
Feb 18 23:38:03 OpenWrt kern.notice kernel: [    0.000000] Linux version 3.3.8 (blogic@Debian-60-squeeze-64-minimal) (gcc version 4.6.3 20120201 (prerelease) (Linaro GCC 4.6-2012.02) ) #1 Sat Mar 23 16:49:30 UTC 2013
Feb 18 23:38:03 OpenWrt kern.debug kernel: [    0.000000] MyLoader: sysp=b3a3d853, boardp=492118fc, parts=f35d1cdf
Feb 18 23:38:03 OpenWrt kern.info kernel: [    0.000000] bootconsole [early0] enabled
Feb 18 23:38:03 OpenWrt kern.info kernel: [    0.000000] CPU revision is: 0001974c (MIPS 74Kc)
Feb 18 23:38:03 OpenWrt kern.info kernel: [    0.000000] SoC: Atheros AR9344 rev 2
Feb 18 23:38:03 OpenWrt kern.info kernel: [    0.000000] Clocks: CPU:560.000MHz, DDR:450.000MHz, AHB:225.000MHz, Ref:40.000MHz
Feb 18 23:38:03 OpenWrt kern.info kernel: [    0.000000] Determined physical RAM map:
Feb 18 23:38:03 OpenWrt kern.info kernel: [    0.000000]  memory: 08000000 @ 00000000 (usable)
Feb 18 23:38:03 OpenWrt kern.info kernel: [    0.000000] Initrd not found or empty - disabling initrd
Feb 18 23:38:03 OpenWrt kern.warn kernel: [    0.000000] Zone PFN ranges:
Feb 18 23:38:03 OpenWrt kern.warn kernel: [    0.000000]   Normal   0x00000000 -> 0x00008000
Feb 18 23:38:03 OpenWrt kern.warn kernel: [    0.000000] Movable zone start PFN for each node
Feb 18 23:38:03 OpenWrt kern.warn kernel: [    0.000000] Early memory PFN ranges
Feb 18 23:38:03 OpenWrt kern.warn kernel: [    0.000000]     0: 0x00000000 -> 0x00008000
Feb 18 23:38:03 OpenWrt kern.debug kernel: [    0.000000] On node 0 totalpages: 32768
Feb 18 23:38:03 OpenWrt kern.debug kernel: [    0.000000] free_area_init_node: node 0, pgdat 802f1100, node_mem_map 81000000
Feb 18 23:38:03 OpenWrt kern.debug kernel: [    0.000000]   Normal zone: 256 pages used for memmap
Feb 18 23:38:03 OpenWrt kern.debug kernel: [    0.000000]   Normal zone: 0 pages reserved
Feb 18 23:38:03 OpenWrt kern.debug kernel: [    0.000000]   Normal zone: 32512 pages, LIFO batch:7
Feb 18 23:38:03 OpenWrt kern.debug kernel: [    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
Feb 18 23:38:03 OpenWrt kern.debug kernel: [    0.000000] pcpu-alloc: [0] 0
Feb 18 23:38:03 OpenWrt kern.warn kernel: [    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 32512
Feb 18 23:38:03 OpenWrt kern.notice kernel: [    0.000000] Kernel command line:  board=TL-WDR4300 console=ttyS0,115200 rootfstype=squashfs,jffs2 noinitrd
Feb 18 23:38:03 OpenWrt kern.info kernel: [    0.000000] PID hash table entries: 512 (order: -1, 2048 bytes)
Feb 18 23:38:03 OpenWrt kern.info kernel: [    0.000000] Dentry cache hash table entries: 16384 (order: 4, 65536 bytes)
Feb 18 23:38:03 OpenWrt kern.info kernel: [    0.000000] Inode-cache hash table entries: 8192 (order: 3, 32768 bytes)
Feb 18 23:38:03 OpenWrt kern.warn kernel: [    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
Feb 18 23:38:03 OpenWrt kern.warn kernel: [    0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
Feb 18 23:38:03 OpenWrt kern.info kernel: [    0.000000] Writing ErrCtl register=00000000
Feb 18 23:38:03 OpenWrt kern.info kernel: [    0.000000] Readback ErrCtl register=00000000
Feb 18 23:38:03 OpenWrt kern.info kernel: [    0.000000] Memory: 126464k/131072k available (2211k kernel code, 4608k reserved, 418k data, 212k init, 0k highmem)
Feb 18 23:38:03 OpenWrt kern.info kernel: [    0.000000] SLUB: Genslabs=9, HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
Feb 18 23:38:03 OpenWrt kern.info kernel: [    0.000000] NR_IRQS:51
Feb 18 23:38:03 OpenWrt kern.info kernel: [    0.000000] Calibrating delay loop... 278.93 BogoMIPS (lpj=1394688)
Feb 18 23:38:03 OpenWrt kern.info kernel: [    0.070000] pid_max: default: 32768 minimum: 301
Feb 18 23:38:03 OpenWrt kern.info kernel: [    0.070000] Mount-cache hash table entries: 512
Feb 18 23:38:03 OpenWrt kern.info kernel: [    0.080000] NET: Registered protocol family 16
Feb 18 23:38:03 OpenWrt kern.info kernel: [    0.080000] gpiochip_add: registered GPIOs 0 to 22 on device: ath79
Feb 18 23:38:03 OpenWrt kern.info kernel: [    0.090000] MIPS: machine is TP-LINK TL-WDR3600/4300/4310
Feb 18 23:38:03 OpenWrt kern.warn kernel: [    0.090000] registering PCI controller with io_map_base unset
Feb 18 23:38:03 OpenWrt kern.info kernel: [    0.310000] bio: create slab <bio-0> at 0
Feb 18 23:38:03 OpenWrt kern.info kernel: [    0.310000] PCI host bridge to bus 0000:00
Feb 18 23:38:03 OpenWrt kern.info kernel: [    0.320000] pci_bus 0000:00: root bus resource [mem 0x10000000-0x13ffffff]
Feb 18 23:38:03 OpenWrt kern.info kernel: [    0.320000] pci_bus 0000:00: root bus resource [io  0x0000]
Feb 18 23:38:03 OpenWrt kern.debug kernel: [    0.330000] pci 0000:00:00.0: [168c:0033] type 0 class 0x000280
Feb 18 23:38:03 OpenWrt kern.err kernel: [    0.330000] pci 0000:00:00.0: invalid calibration data
Feb 18 23:38:03 OpenWrt kern.debug kernel: [    0.330000] pci 0000:00:00.0: reg 10: [mem 0x00000000-0x0001ffff 64bit]
Feb 18 23:38:03 OpenWrt kern.debug kernel: [    0.330000] pci 0000:00:00.0: reg 30: [mem 0x00000000-0x0000ffff pref]
Feb 18 23:38:03 OpenWrt kern.debug kernel: [    0.330000] pci 0000:00:00.0: supports D1
Feb 18 23:38:03 OpenWrt kern.debug kernel: [    0.330000] pci 0000:00:00.0: PME# supported from D0 D1 D3hot
Feb 18 23:38:03 OpenWrt kern.info kernel: [    0.330000] pci 0000:00:00.0: BAR 0: assigned [mem 0x10000000-0x1001ffff 64bit]
Feb 18 23:38:03 OpenWrt kern.debug kernel: [    9.630000] ath: EEPROM regdomain: 0x0
Feb 18 23:38:03 OpenWrt kern.debug kernel: [    9.630000] ath: EEPROM indicates default country code should be used
Feb 18 23:38:03 OpenWrt kern.debug kernel: [    9.630000] ath: doing EEPROM country->regdmn map search
Feb 18 23:38:03 OpenWrt kern.debug kernel: [    9.630000] ath: country maps to regdmn code: 0x3a
Feb 18 23:38:03 OpenWrt kern.debug kernel: [    9.630000] ath: Country alpha2 being used: US
Feb 18 23:38:03 OpenWrt kern.debug kernel: [    9.630000] ath: Regpair used: 0x3a
Feb 18 23:38:03 OpenWrt kern.debug kernel: [    9.640000] ieee80211 phy1: Selected rate control algorithm 'minstrel_ht'
Feb 18 23:38:03 OpenWrt kern.debug kernel: [    9.640000] Registered led device: ath9k-phy1
Feb 18 23:38:03 OpenWrt kern.info kernel: [    9.640000] ieee80211 phy1: Atheros AR9300 Rev:4 mem=0xb0000000, irq=40
Feb 18 23:38:03 OpenWrt kern.info kernel: [    9.650000] cfg80211: Calling CRDA for country: US
Feb 18 23:38:03 OpenWrt kern.info kernel: [    9.650000] cfg80211: Regulatory domain changed to country: US
Feb 18 23:38:03 OpenWrt kern.info kernel: [    9.660000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Feb 18 23:38:03 OpenWrt kern.info kernel: [    9.660000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2700 mBm)
Feb 18 23:38:03 OpenWrt kern.info kernel: [    9.670000] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 1700 mBm)
Feb 18 23:38:03 OpenWrt kern.info kernel: [    9.680000] cfg80211:   (5250000 KHz - 5330000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Feb 18 23:38:03 OpenWrt kern.info kernel: [    9.690000] cfg80211:   (5490000 KHz - 5600000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Feb 18 23:38:03 OpenWrt kern.info kernel: [    9.700000] cfg80211:   (5650000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Feb 18 23:38:03 OpenWrt kern.info kernel: [    9.700000] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 3000 mBm)
Feb 18 23:38:03 OpenWrt kern.info kernel: [    9.740000] PPP generic driver version 2.4.2
Feb 18 23:38:03 OpenWrt kern.info kernel: [    9.940000] ip_tables: (C) 2000-2006 Netfilter Core Team
Feb 18 23:38:03 OpenWrt kern.info kernel: [   10.100000] NET: Registered protocol family 24
Feb 18 23:38:03 OpenWrt kern.info kernel: [   10.120000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
Feb 18 23:38:03 OpenWrt kern.info kernel: [   10.130000] ehci-platform ehci-platform: Generic Platform EHCI Controller
Feb 18 23:38:03 OpenWrt kern.info kernel: [   10.130000] ehci-platform ehci-platform: new USB bus registered, assigned bus number 1
Feb 18 23:38:03 OpenWrt kern.info kernel: [   10.170000] ehci-platform ehci-platform: irq 3, io mem 0x1b000000
Feb 18 23:38:03 OpenWrt kern.info kernel: [   10.190000] ehci-platform ehci-platform: USB 2.0 started, EHCI 1.00
Feb 18 23:38:03 OpenWrt kern.info kernel: [   10.190000] hub 1-0:1.0: USB hub found
Feb 18 23:38:03 OpenWrt kern.info kernel: [   10.200000] hub 1-0:1.0: 1 port detected
Feb 18 23:38:03 OpenWrt kern.info kernel: [   10.220000] nf_conntrack version 0.5.0 (1979 buckets, 7916 max)
Feb 18 23:38:03 OpenWrt kern.info kernel: [   10.390000] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
Feb 18 23:38:03 OpenWrt kern.info kernel: [   10.520000] usb 1-1: new high-speed USB device number 2 using ehci-platform
Feb 18 23:38:03 OpenWrt kern.info kernel: [   10.670000] hub 1-1:1.0: USB hub found
Feb 18 23:38:03 OpenWrt kern.info kernel: [   10.670000] hub 1-1:1.0: 4 ports detected
Feb 18 23:38:04 OpenWrt kern.info kernel: [   13.410000] device eth0.1 entered promiscuous mode
Feb 18 23:38:04 OpenWrt kern.info kernel: [   13.410000] device eth0 entered promiscuous mode
Feb 18 23:38:04 OpenWrt daemon.notice netifd: Interface 'lan' is now up
Feb 18 23:38:04 OpenWrt daemon.notice netifd: Interface 'loopback' is now up
Feb 18 23:38:05 OpenWrt daemon.notice netifd: wan (688): udhcpc (v1.19.4) started
Feb 18 23:38:05 OpenWrt daemon.notice netifd: wan (688): Sending discover...
Feb 18 23:38:05 OpenWrt user.notice ifup: Enabling Router Solicitations on lan (br-lan)
Feb 18 23:38:06 OpenWrt kern.info kernel: [   14.710000] eth0: link up (1000Mbps/Full duplex)
Feb 18 23:38:06 OpenWrt kern.info kernel: [   14.710000] br-lan: port 1(eth0.1) entered forwarding state
Feb 18 23:38:06 OpenWrt kern.info kernel: [   14.720000] br-lan: port 1(eth0.1) entered forwarding state
Feb 18 23:38:07 OpenWrt user.notice ifup: Enabling Router Solicitations on loopback (lo)
Feb 18 23:38:08 OpenWrt kern.info kernel: [   16.720000] br-lan: port 1(eth0.1) entered forwarding state
Feb 18 23:38:08 OpenWrt daemon.notice netifd: wan (688): Sending discover...
Feb 18 23:38:10 OpenWrt user.info sysinit: 'radio1' is disabled
Feb 18 23:38:10 OpenWrt user.info sysinit: 'radio1' is disabled
Feb 18 23:38:10 OpenWrt user.info sysinit: command failed: Device or resource busy (-16)
Feb 18 23:38:11 OpenWrt daemon.notice netifd: wan (688): Sending discover...
Feb 18 23:38:12 OpenWrt user.info sysinit: 'radio1' is disabled
Feb 18 23:38:12 OpenWrt daemon.notice netifd: wwan (1084): udhcpc (v1.19.4) started
Feb 18 23:38:12 OpenWrt kern.info kernel: [   21.110000] wlan0: authenticate with c0:3f:0e:ca:91:c0
Feb 18 23:38:12 OpenWrt kern.info kernel: [   21.130000] wlan0: send auth to c0:3f:0e:ca:91:c0 (try 1/3)
Feb 18 23:38:12 OpenWrt kern.info kernel: [   21.130000] wlan0: authenticated
Feb 18 23:38:12 OpenWrt kern.info kernel: [   21.170000] wlan0: associate with c0:3f:0e:ca:91:c0 (try 1/3)
Feb 18 23:38:12 OpenWrt kern.info kernel: [   21.180000] wlan0: RX AssocResp from c0:3f:0e:ca:91:c0 (capab=0x431 status=0 aid=7)
Feb 18 23:38:12 OpenWrt kern.info kernel: [   21.180000] wlan0: associated
Feb 18 23:38:12 OpenWrt daemon.notice netifd: wwan (1084): Sending discover...
Feb 18 23:38:13 OpenWrt daemon.notice netifd: wwan (1084): Sending select for 192.168.0.10...
Feb 18 23:38:13 OpenWrt daemon.notice netifd: wwan (1084): Lease of 192.168.0.10 obtained, lease time 86400
Feb 18 23:38:13 OpenWrt daemon.notice netifd: Interface 'wwan' is now up
Feb 18 23:38:13 OpenWrt user.info sysinit: Loading defaults
Feb 18 23:38:14 OpenWrt user.info sysinit: Loading synflood protection
Feb 18 23:38:14 OpenWrt user.info sysinit: Adding custom chains
Feb 18 23:38:14 OpenWrt user.info sysinit: Loading zones
Feb 18 23:38:15 OpenWrt user.notice ifup: Allowing Router Advertisements on wwan (wlan0)
Feb 18 23:38:16 OpenWrt user.info sysinit: Loading forwardings
Feb 18 23:38:16 OpenWrt user.info sysinit: Loading rules
Feb 18 23:38:16 OpenWrt user.info sysinit: Loading redirects
Feb 18 23:38:16 OpenWrt user.info sysinit: Loading includes
Feb 18 23:38:16 OpenWrt user.info sysinit: Optimizing conntrack
Feb 18 23:38:16 OpenWrt user.info sysinit: Loading interfaces
Feb 18 23:38:16 OpenWrt user.info firewall: adding lan (br-lan) to zone lan
Feb 18 23:38:17 OpenWrt user.info firewall: adding wwan (wlan0) to zone lan
Feb 18 23:38:19 OpenWrt authpriv.info dropbear[1432]: Running in background
Feb 18 23:38:21 OpenWrt user.notice dnsmasq: DNS rebinding protection is active, will discard upstream RFC1918 responses!
Feb 18 23:38:21 OpenWrt user.notice dnsmasq: Allowing 127.0.0.0/8 responses
Feb 18 23:38:21 OpenWrt daemon.info dnsmasq[1481]: started, version 2.62 cachesize 150
Feb 18 23:38:21 OpenWrt daemon.info dnsmasq[1481]: compile time options: IPv6 GNU-getopt no-DBus no-i18n no-IDN DHCP no-DHCPv6 no-Lua TFTP no-conntrack
Feb 18 23:38:21 OpenWrt daemon.info dnsmasq[1481]: using local addresses only for domain lan
Feb 18 23:38:21 OpenWrt daemon.info dnsmasq[1481]: reading /tmp/resolv.conf.auto
Feb 18 23:38:21 OpenWrt daemon.info dnsmasq[1481]: using nameserver 192.168.0.1#53
Feb 18 23:38:21 OpenWrt daemon.info dnsmasq[1481]: using nameserver 192.168.0.1#53
Feb 18 23:38:21 OpenWrt daemon.info dnsmasq[1481]: using local addresses only for domain lan
Feb 18 23:38:21 OpenWrt daemon.info dnsmasq[1481]: read /etc/hosts - 1 addresses
Feb 18 23:38:21 OpenWrt user.info sysinit: setting up led USB1
Feb 18 23:38:21 OpenWrt user.info sysinit: setting up led USB2
Feb 18 23:38:21 OpenWrt user.info sysinit: setting up led WLAN2G
Feb 19 00:25:06 OpenWrt authpriv.info dropbear[1513]: Child connection from 192.168.1.100:34217
Feb 19 00:25:11 OpenWrt authpriv.notice dropbear[1513]: Password auth succeeded for 'root' from 192.168.1.100:34217

(Last edited by hobett on 19 Feb 2014, 02:15)