OpenWrt Forum Archive

Topic: TL-WR1043ND: Convert WAN Port into 5th LAN port

The content of this topic has been archived on 21 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Dear all,

I recently bought a TP-Link WR1043ND WLAN router with hardware revision 1.11 . The serial number starts with 13 . As recommended by various sources, I used a firmware downgrade to wr1043nv1_de_3_9_17_up_boot(100331) before installing OpenWRT to avoid WAN port disabling.

I managed to configure the device as a WLAN access point to my wired network already. But I constantly fail to "convert" the WAN port into a regular, 5th LAN port.

This is the current content of my /etc/config/network:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0.1'
        option type 'bridge'
        option proto 'dhcp'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'

config switch
        option name 'rtl8366rb'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'rtl8366rb'
        option vlan '1'
        option ports '1 2 3 4 5t'

config switch_vlan
        option device 'rtl8366rb'
        option vlan '2'
        option ports '0 5t'

According to this page i changed it to

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0.1'
        option type 'bridge'
        option proto 'dhcp'

config switch_vlan
        option device 'rtl8366rb'
        option vlan '1'
        option ports '0 1 2 3 4 5t'

and rebooted. This rendered device unusable (no network connectivity at all) and I had to go to failsafe mode and revert.

Using another tip, I removed the wan section and added eth0.2 to the bridge:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0.1 eth0.2'
        option type 'bridge'
        option proto 'dhcp'

config switch
        option name 'rtl8366rb'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'rtl8366rb'
        option vlan '1'
        option ports '1 2 3 4 5t'

config switch_vlan
        option device 'rtl8366rb'
        option vlan '2'
        option ports '0 5t'

After reboot, the router was still accessible. But - even with the uplink cable in LAN port - other LAN devices (non-pc devices, like TV, PS3) immediately lost network connectivity, not receiving their IP by DHCP anymore.

In addition, nameserver resolution directly on the router was notably slower (about 10sec delay) when plugging the uplink cable into the WAN port.

So, I reverted everything to the initial state and now gratefully wait for suggestions, hints how to deal with this issue.

Regards,

Maxim

imho you do not have to remove the "config switch" section!
just remove the config switch_vlan of vlan 2 and add port 0 to vlan 1...

I'll give this a try, even if the removal of the switch section is explicitely printed on the referenced page.

The entire networking config now looks like this

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0.1'
        option type 'bridge'
        option proto 'dhcp'

config switch
        option name 'rtl8366rb'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'rtl8366rb'
        option vlan '1'
        option ports '0 1 2 3 4 5t'
nebbia88 wrote:

imho you do not have to remove the "config switch" section!
just remove the config switch_vlan of vlan 2 and add port 0 to vlan 1...

That's it, that did the trick. Works like a charm now, thanks.

glad it worked.. i think that part in 1043 wiki has been pasted by mistake.

your config looks ok wink

nebbia88 wrote:

glad it worked.. i think that part in 1043 wiki has been pasted by mistake.

your config looks ok wink

Can I change the wiki? Or report the mistake to someone?

maxim.webster wrote:

Can I change the wiki? Or report the mistake to someone?

You can create an account on the wiki and you can change it.

Done.

Everybody - thanks for your help.

The discussion might have continued from here.