1 (edited by broadcom 2013-12-03 23:15:04)

Topic: ZyXEL P-870HN-51b - whats next vlans?

http://wiki.openwrt.org/toh/zyxel/p-870hn-51b


root@OpenWrt:/# swconfig list
Found: switch0 - eth0
root@OpenWrt:/# swconfig dev switch0 show
Global attributes:
        enable_vlan: 1
        ports: 0x0136
        reset_mib: ???
        enable_jumbo: 0
        allow_vid_4095: 0
Port 0:
        mib: ???
        pvid: 0
        link: port:0 link:down
Port 1:
        mib: TxOctets            : 0
TxDropPkts          : 0
TxQoSPkts           : 0
TxBroadcastPkts     : 0
TxMulticastPkts     : 0
TxUnicastPkts       : 0
TxCollisions        : 0
TxSingleCollision   : 0
TxMultipleCollision : 0
TxDeferredTransmit  : 0
TxLateCollision     : 0
TxExcessiveCollision: 0
TxPausePkts         : 0
TxQoSOctets         : 0
RxOctets            : 0
RxUndersizePkts     : 0
RxPausePkts         : 0
Pkts64Octets        : 0
Pkts65to127Octets   : 0
Pkts128to255Octets  : 0
Pkts256to511Octets  : 0
Pkts512to1023Octets : 0
Pkts1024to1522Octets: 0
RxOversizePkts      : 0
RxJabbers           : 0
RxAlignmentErrors   : 0
RxFCSErrors         : 0
RxGoodOctets        : 0
RxDropPkts          : 0
RxUnicastPkts       : 0
RxMulticastPkts     : 0
RxBroadcastPkts     : 0
RxSAChanges         : 0
RxFragments         : 0
RxSymbolErrors      : 0
RxQoSPkts           : 0
RxQoSOctets         : 0
Pkts1523to2047Octets: 0
Pkts2048to4095Octets: 0
Pkts4096to8191Octets: 0
Pkts8192to9728Octets: 0
RxDiscarded         : 0

        pvid: 1
        link: port:1 link:down
Port 2:
        mib: TxOctets            : 0
TxDropPkts          : 0
TxQoSPkts           : 0
TxBroadcastPkts     : 0
TxMulticastPkts     : 0
TxUnicastPkts       : 0
TxCollisions        : 0
TxSingleCollision   : 0
TxMultipleCollision : 0
TxDeferredTransmit  : 0
TxLateCollision     : 0
TxExcessiveCollision: 0
TxPausePkts         : 0
TxQoSOctets         : 0
RxOctets            : 0
RxUndersizePkts     : 0
RxPausePkts         : 0
Pkts64Octets        : 0
Pkts65to127Octets   : 0
Pkts128to255Octets  : 0
Pkts256to511Octets  : 0
Pkts512to1023Octets : 0
Pkts1024to1522Octets: 0
RxOversizePkts      : 0
RxJabbers           : 0
RxAlignmentErrors   : 0
RxFCSErrors         : 0
RxGoodOctets        : 0
RxDropPkts          : 0
RxUnicastPkts       : 0
RxMulticastPkts     : 0
RxBroadcastPkts     : 0
RxSAChanges         : 0
RxFragments         : 0
RxSymbolErrors      : 0
RxQoSPkts           : 0
RxQoSOctets         : 0
Pkts1523to2047Octets: 0
Pkts2048to4095Octets: 0
Pkts4096to8191Octets: 0
Pkts8192to9728Octets: 0
RxDiscarded         : 0

        pvid: 1
        link: port:2 link:down
Port 3:
        mib: ???
        pvid: 0
        link: port:3 link:down
Port 4:
        mib: TxOctets            : 0
TxDropPkts          : 0
TxQoSPkts           : 0
TxBroadcastPkts     : 0
TxMulticastPkts     : 0
TxUnicastPkts       : 0
TxCollisions        : 0
TxSingleCollision   : 0
TxMultipleCollision : 0
TxDeferredTransmit  : 0
TxLateCollision     : 0
TxExcessiveCollision: 0
TxPausePkts         : 0
TxQoSOctets         : 0
RxOctets            : 0
RxUndersizePkts     : 0
RxPausePkts         : 0
Pkts64Octets        : 0
Pkts65to127Octets   : 0
Pkts128to255Octets  : 0
Pkts256to511Octets  : 0
Pkts512to1023Octets : 0
Pkts1024to1522Octets: 0
RxOversizePkts      : 0
RxJabbers           : 0
RxAlignmentErrors   : 0
RxFCSErrors         : 0
RxGoodOctets        : 0
RxDropPkts          : 0
RxUnicastPkts       : 0
RxMulticastPkts     : 0
RxBroadcastPkts     : 0
RxSAChanges         : 0
RxFragments         : 0
RxSymbolErrors      : 0
RxQoSPkts           : 0
RxQoSOctets         : 0
Pkts1523to2047Octets: 0
Pkts2048to4095Octets: 0
Pkts4096to8191Octets: 0
Pkts8192to9728Octets: 0
RxDiscarded         : 0

        pvid: 1
        link: port:4 link:down
Port 5:
        mib: TxOctets            : 0
TxDropPkts          : 0
TxQoSPkts           : 0
TxBroadcastPkts     : 0
TxMulticastPkts     : 0
TxUnicastPkts       : 0
TxCollisions        : 0
TxSingleCollision   : 0
TxMultipleCollision : 0
TxDeferredTransmit  : 0
TxLateCollision     : 0
TxExcessiveCollision: 0
TxPausePkts         : 0
TxQoSOctets         : 0
RxOctets            : 0
RxUndersizePkts     : 0
RxPausePkts         : 0
Pkts64Octets        : 0
Pkts65to127Octets   : 0
Pkts128to255Octets  : 0
Pkts256to511Octets  : 0
Pkts512to1023Octets : 0
Pkts1024to1522Octets: 0
RxOversizePkts      : 0
RxJabbers           : 0
RxAlignmentErrors   : 0
RxFCSErrors         : 0
RxGoodOctets        : 0
RxDropPkts          : 0
RxUnicastPkts       : 0
RxMulticastPkts     : 0
RxBroadcastPkts     : 0
RxSAChanges         : 0
RxFragments         : 0
RxSymbolErrors      : 0
RxQoSPkts           : 0
RxQoSOctets         : 0
Pkts1523to2047Octets: 0
Pkts2048to4095Octets: 0
Pkts4096to8191Octets: 0
Pkts8192to9728Octets: 0
RxDiscarded         : 0

        pvid: 1
        link: port:5 link:down
Port 6:
        mib: ???
        pvid: 0
        link: port:6 link:down
Port 7:
        mib: ???
        pvid: 0
        link: port:7 link:down
Port 8:
        mib: TxOctets            : 0
TxDropPkts          : 0
TxQoSPkts           : 0
TxBroadcastPkts     : 0
TxMulticastPkts     : 0
TxUnicastPkts       : 0
TxCollisions        : 0
TxSingleCollision   : 0
TxMultipleCollision : 0
TxDeferredTransmit  : 0
TxLateCollision     : 0
TxExcessiveCollision: 0
TxPausePkts         : 0
TxQoSOctets         : 0
RxOctets            : 1764
RxUndersizePkts     : 0
RxPausePkts         : 0
Pkts64Octets        : 0
Pkts65to127Octets   : 10
Pkts128to255Octets  : 6
Pkts256to511Octets  : 0
Pkts512to1023Octets : 0
Pkts1024to1522Octets: 0
RxOversizePkts      : 0
RxJabbers           : 0
RxAlignmentErrors   : 0
RxFCSErrors         : 0
RxGoodOctets        : 1764
RxDropPkts          : 0
RxUnicastPkts       : 0
RxMulticastPkts     : 16
RxBroadcastPkts     : 0
RxSAChanges         : 0
RxFragments         : 0
RxSymbolErrors      : 0
RxQoSPkts           : 0
RxQoSOctets         : 0
Pkts1523to2047Octets: 0
Pkts2048to4095Octets: 0
Pkts4096to8191Octets: 0
Pkts8192to9728Octets: 0
RxDiscarded         : 0

        pvid: 0
        link: port:8 link:up speed:1000baseT full-duplex
VLAN 1:
        ports: 1 2 4 5 8t
root@OpenWrt:/#
root@OpenWrt:/# uci show network
network.loopback=interface
network.loopback.ifname=lo
network.loopback.proto=static
network.loopback.ipaddr=127.0.0.1
network.loopback.netmask=255.0.0.0
network.globals=globals
network.globals.ula_prefix=fd7d:92d9:4183::/48
network.lan=interface
network.lan.ifname=eth0.1
network.lan.type=bridge
network.lan.proto=static
network.lan.ipaddr=192.168.1.1
network.lan.netmask=255.255.255.0
network.lan.ip6assign=60
network.@switch[0]=switch
network.@switch[0].name=eth0
network.@switch[0].reset=1
network.@switch[0].enable_vlan=1
network.@switch_vlan[0]=switch_vlan
network.@switch_vlan[0].device=eth0
network.@switch_vlan[0].vlan=1
network.@switch_vlan[0].ports=1 2 4 5 8t
root@OpenWrt:/#
root@OpenWrt:/# ifconfig
br-lan    Link encap:Ethernet  HWaddr C8:6C:87:5C:11:A9
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::ca6c:87ff:fe5c:11a9/64 Scope:Link
          inet6 addr: fd7d:92d9:4183::1/60 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:706 (706.0 B)

eth0      Link encap:Ethernet  HWaddr C8:6C:87:5C:11:A9
          inet6 addr: fe80::ca6c:87ff:fe5c:11a9/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:14 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:1540 (1.5 KiB)

eth0.1    Link encap:Ethernet  HWaddr C8:6C:87:5C:11:A9
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:706 (706.0 B)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:216 errors:0 dropped:0 overruns:0 frame:0
          TX packets:216 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:14688 (14.3 KiB)  TX bytes:14688 (14.3 KiB)

wlan0     Link encap:Ethernet  HWaddr C8:6C:87:5C:11:AA
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:224 (224.0 B)

root@OpenWrt:/#
root@OpenWrt:/# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd7d:92d9:4183::/48'

config interface 'lan'
        option ifname 'eth0.1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config switch
        option name 'eth0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'eth0'
        option vlan '1'
        option ports '1 2 4 5 8t'

root@OpenWrt:/#
root@OpenWrt:/etc/config# wifi
root@OpenWrt:/etc/config# [ 1027.460000] device wlan0 left promiscuous mode
[ 1027.464000] br-lan: port 2(wlan0) entered disabled state
[ 1028.280000] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)
[ 1028.388000] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 1028.396000] device wlan0 entered promiscuous mode
[ 1028.400000] br-lan: port 2(wlan0) entered forwarding state
[ 1028.404000] br-lan: port 2(wlan0) entered forwarding state
[ 1028.416000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 1030.408000] br-lan: port 2(wlan0) entered forwarding state

I did what i can do. I dont know how to configure these vlans, can anybody give a tip?
Dhcp not giving ip to computer, wifi not working. Openwrt found switch.

-edit-
Sory its my fault didnt push enough plug to socket previous time , and didnt any led light this cheat me

[ 1266.172000] bcm63xx_enetsw bcm63xx_enetsw.0: link UP on port2, 100Mbps, full-duplex
[ 1387.180000] bcm63xx_enetsw bcm63xx_enetsw.0: link DOWN on port2
[ 1394.184000] bcm63xx_enetsw bcm63xx_enetsw.0: link UP on port2, 100Mbps, full-duplex
[ 1439.192000] bcm63xx_enetsw bcm63xx_enetsw.0: link DOWN on port2
[ 1441.196000] bcm63xx_enetsw bcm63xx_enetsw.0: link UP on port1, 100Mbps, full-duplex
[ 1460.204000] bcm63xx_enetsw bcm63xx_enetsw.0: link DOWN on port1
[ 1510.208000] bcm63xx_enetsw bcm63xx_enetsw.0: link UP on port1, 100Mbps, full-duplex
[ 1516.216000] bcm63xx_enetsw bcm63xx_enetsw.0: link DOWN on port1
[ 1519.220000] bcm63xx_enetsw bcm63xx_enetsw.0: link UP on port2, 100Mbps, full-duplex
[ 1527.228000] bcm63xx_enetsw bcm63xx_enetsw.0: link DOWN on port2

------------
To order things : doesnt matter to which port i plug rj-45 cable it always says port1/port2 - (shoulnt it find 1,2,3,4?)
Second wifi is not working even if it is saying "entered x state) my phone cannot detect signal even from 1 cm - wtf?
Third need to use one of this four ports as WAN port - how to configure that?

Re: ZyXEL P-870HN-51b - whats next vlans?

Hello!,

I just checked the information for connecting to Zyxel P-870HN-51b (serial port) and PINS are erroneous:

The correct order and tested is:

GND

RxD
TxD
+3.3 v

A greeting!
Zero13