OpenWrt Forum Archive

Topic: WD My Net N750 support

The content of this topic has been archived between 16 Mar 2018 and 21 Apr 2018. Unfortunately there are posts – most likely complete pages – missing.

I think there are packages to enable those features. You might have to install the USB and samba packages. I saw some tutorials when I googled about it once.
http://wiki.openwrt.org/doc/recipes/usb … binterface
There is also a luci frontend to manage the (un)mounting of USB storage.
But I never tried these. If you succeed, please add the details to the wiki at http://wiki.openwrt.org/toh/wd/n750

(Last edited by abhishek.anand.iitg on 5 Jan 2014, 18:00)

is the wd n900 mynet (central) also supported? i don't have access to jtag so i'm reluctant to be the first experimenter.
thanks!
edit - checked the toh and see the answer: NO! (ubicom)

(Last edited by ghoffman on 6 Jan 2014, 12:36)

I couldn't get USB to mount.  I don't see references/links to block devices /dev/sda1 etc.  Is this stuff outdated?

I have Atheros AR9344 rev 2, my wireless doesn't work at all. Any update for rev 2? Thanks.

my mtd

cat /proc/mtd
dev:    size   erasesize  name
mtd0: 00040000 00010000 "u-boot"
mtd1: 00010000 00010000 "u-boot-env"
mtd2: 00010000 00010000 "devdata"
mtd3: 00010000 00010000 "devconf"
mtd4: 00f80000 00010000 "firmware"
mtd5: 00140000 00010000 "kernel"
mtd6: 00e40000 00010000 "rootfs"
mtd7: 00c80000 00010000 "rootfs_data"
mtd8: 00010000 00010000 "radiocfg"

(Last edited by minipucchi on 7 Jan 2014, 11:14)

mtd8: 00010000 00010000 "radiocfg"

I think you need rename this to ART partition. OpenWRT looks for ART partiotion to for wireless information.

sylonn wrote:

I couldn't get USB to mount.  I don't see references/links to block devices /dev/sda1 etc.  Is this stuff outdated?

It works fine for me after installing the packages documented on the wiki (the instructions didn't seem out of date). If a package is missing, remember to "opkg update" before trying to install. The scsi/usb-storage modules have to be loaded in a specific order, it's best to reboot your router after installing the packages. I found /dev/sda1 would come straight up and was mountable, after rebooting.

Hi, i see this router on offer in a store and i want to know if it is possible to attach an usb wifi adapter to repeat the signal. the wifi adapter is a ralink 3070.
thanks, and sorry for my english.

ajs1984 wrote:

It works fine for me after installing the packages documented on the wiki (the instructions didn't seem out of date). If a package is missing, remember to "opkg update" before trying to install. The scsi/usb-storage modules have to be loaded in a specific order, it's best to reboot your router after installing the packages. I found /dev/sda1 would come straight up and was mountable, after rebooting.

hi, what packages did you install to get the usb-storage mount? I tried to install kmod-usb-storage, block-mount, and kmod-fs-ext4, but the kmod-usb-storage & kmod-fs-ext4 got errors. Thanks!

Collected errors:
* satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-usb-storage:
*     kernel (= 3.10.24-1-586e792aa7d1cbc59249e43ee51a59c3)
*     kernel (= 3.10.24-1-586e792aa7d1cbc59249e43ee51a59c3) *
* opkg_install_cmd: Cannot install package kmod-usb-storage.

* satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-fs-ext4:
*     kernel (= 3.10.24-1-586e792aa7d1cbc59249e43ee51a59c3)
*     kernel (= 3.10.24-1-586e792aa7d1cbc59249e43ee51a59c3)
*     kernel (= 3.10.24-1-586e792aa7d1cbc59249e43ee51a59c3) *
* opkg_install_cmd: Cannot install package kmod-fs-ext4.

(Last edited by kenliu68 on 10 Jan 2014, 22:52)

kenliu68 wrote:
ajs1984 wrote:

It works fine for me after installing the packages documented on the wiki (the instructions didn't seem out of date). If a package is missing, remember to "opkg update" before trying to install. The scsi/usb-storage modules have to be loaded in a specific order, it's best to reboot your router after installing the packages. I found /dev/sda1 would come straight up and was mountable, after rebooting.

hi, what packages did you install to get the usb-storage mount? I tried to install kmod-usb-storage, block-mount, and kmod-fs-ext4, but the kmod-usb-storage & kmod-fs-ext4 got errors. Thanks!

Collected errors:
* satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-usb-storage:
*     kernel (= 3.10.24-1-586e792aa7d1cbc59249e43ee51a59c3)
*     kernel (= 3.10.24-1-586e792aa7d1cbc59249e43ee51a59c3) *
* opkg_install_cmd: Cannot install package kmod-usb-storage.

* satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-fs-ext4:
*     kernel (= 3.10.24-1-586e792aa7d1cbc59249e43ee51a59c3)
*     kernel (= 3.10.24-1-586e792aa7d1cbc59249e43ee51a59c3)
*     kernel (= 3.10.24-1-586e792aa7d1cbc59249e43ee51a59c3) *
* opkg_install_cmd: Cannot install package kmod-fs-ext4.

The wiki page instructs to use the most recent snapshot image from trunk. Trunk is very frequently being updated by newer versions. In case you want to install kmod-* packages you need the same version that was available when you've downloaded your image. This is why it is better to build your own image along with packages. Or you can download all available packages along with the image file and store them on your hdd, so that you can install them manually in case you need them in the future.

dp79

I bought 5 of these routers since they were about $30 at staples.

trying to configure a wireless repeater by following: http://wiki.openwrt.org/doc/recipes/relayclient

I have a http://wiki.openwrt.org/toh/wd/n750
I flash it with openwrt-ar71xx-generic-mynet-n750-squashfs-factory.bin
telnet to 192.168.1.1
set password by typing:  passwd
ssh to 192.168.1.1
I then follow the steps at http://wiki.openwrt.org/doc/recipes/relayclient
I am getting stuck at Step 3.  It appears the wifi is not connected on wlan0 or radio0.  Below is the output from ifconfig.

(If it helps I can connect by plugging into the wan port and issuing these commands:
code

 uci set network.wan.proto=static
uci set network.wan.ipaddr=192.168.1.49

uci set network.wan.netmask=255.255.255.0

uci set network.wan.gateway=192.168.1.1

uci set network.wan.dns='8.8.8.8 8.8.4.4'

uci commit network

ifup wan

)


root@OpenWrt:~# ifconfig
br-lan    Link encap:Ethernet  HWaddr 00:90:A9:CD:B0:E6
          inet addr:192.168.2.1  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fde8:3d58:baa::1/60 Scope:Global
          inet6 addr: fe80::290:a9ff:fecd:b0e6/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2060 errors:0 dropped:0 overruns:0 frame:0
          TX packets:685 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:154251 (150.6 KiB)  TX bytes:112988 (110.3 KiB)

eth0      Link encap:Ethernet  HWaddr 00:90:A9:CD:B0:E6
          inet6 addr: fe80::290:a9ff:fecd:b0e6/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2099 errors:0 dropped:10 overruns:0 frame:0
          TX packets:869 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:194491 (189.9 KiB)  TX bytes:184745 (180.4 KiB)
          Interrupt:4

eth0.1    Link encap:Ethernet  HWaddr 00:90:A9:CD:B0:E6
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2065 errors:0 dropped:5 overruns:0 frame:0
          TX packets:685 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:154481 (150.8 KiB)  TX bytes:112988 (110.3 KiB)

eth0.2    Link encap:Ethernet  HWaddr 00:90:A9:CD:B0:E5
          inet6 addr: fe80::290:a9ff:fecd:b0e5/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:175 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:67611 (66.0 KiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1022 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1022 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:69456 (67.8 KiB)  TX bytes:69456 (67.8 KiB)

wlan0     Link encap:Ethernet  HWaddr 00:90:A9:CD:B0:E6
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

sparky1979 wrote:

I bought 5 of these routers since they were about $30 at staples.

trying to configure a wireless repeater by following: http://wiki.openwrt.org/doc/recipes/relayclient

I have a http://wiki.openwrt.org/toh/wd/n750
I flash it with openwrt-ar71xx-generic-mynet-n750-squashfs-factory.bin
telnet to 192.168.1.1
set password by typing:  passwd
ssh to 192.168.1.1
I then follow the steps at http://wiki.openwrt.org/doc/recipes/relayclient
I am getting stuck at Step 3.  It appears the wifi is not connected on wlan0 or radio0.  Below is the output from ifconfig.

(If it helps I can connect by plugging into the wan port and issuing these commands:
code

 uci set network.wan.proto=static
uci set network.wan.ipaddr=192.168.1.49

uci set network.wan.netmask=255.255.255.0

uci set network.wan.gateway=192.168.1.1

uci set network.wan.dns='8.8.8.8 8.8.4.4'

uci commit network

ifup wan

Hi sparky,

Please post the output of the following commands:

cat /etc/config/wireless
cat /etc/config/network

Also let me know how you are connecting to the router that supplies the internet connection to your repeater (dhcp or static, if static what is the lan side ip range/subnet/gateway ip). I see that you are trying to set it up as static, but the other router might have dhcp on with a different configuration.

dp79

Ho everyone,

I own one of these and I'm experiencing very poor wifi performance on both radios. I'm wondering if it is a driver issue or maybe a corrupted wifi config partition on my flash. Does anybody know how I can verify the content of my mtd8 partition (without serial connection)? I just want to make sure that I don't have a bunch of "0"-s or "F"-s there. Both device come up as wlan0 and wlan1, so most likely the config is ok, but I just want to make sure. This is my cat /proc/mtd output:

mtd0: 00040000 00010000 "u-boot"
mtd1: 00010000 00010000 "u-boot-env"
mtd2: 00010000 00010000 "devdata"
mtd3: 00010000 00010000 "devconf"
mtd4: 00f80000 00010000 "firmware"
mtd5: 00140000 00010000 "kernel"
mtd6: 00e40000 00010000 "rootfs"
mtd7: 00c80000 00010000 "rootfs_data"
mtd8: 00010000 00010000 "radiocfg"

The issue I'm seeing is that the 2.4 GHZ (AR9340) radio that I'm using right now is randomly dropping connection and the transfer rate is extremely low. I noticed that I get better performance if I set the wireless channel to #1. As I go higher the wifi performance gets worse. So I'm wondering if it is a driver issue or a corrupted config partition.

By the way, I'm using a ralink RT3070 in one of the USB ports as WAN interface, the onboard 2.4 GHZ radio is the LAN side and the device is set up in routed client mode.

Thanks,
     dp79

I could dump the config partition by this command : cat /dev/mtd8 > /tmp/caldata.bin

After this I just copied it to my PC via WinSCP. Most of it is empty. There are two data chunks in there though, for the two radios I guess.

1st  - Block 1000 - 143F
2nd - Block 5000 - 543F

@dp79

varkey wrote:

@dp79 - You may need to upgrade OpenWRT to a newer build with a patch which fixes wireless issues. Check this post -- https://www.crc.id.au/2014/01/10/wd-myn … rt-update/

The issue your experiencing is due to the Low Noise Amplifiers not being turn on.
The firmware at the above link fixes this shortcoming.

I tried this firmware - the patch that it includes, will give the radios an improved behavior.
Even LuCI becomes more responsive when setting up the WiFi radios.
The patch will eventually be incorporated to the images in trunk.

Thanks varkey amd Peter!
I've checked out the site and unfortunately  the package repo does not contain all packages I need. So I have to wait until they implement it in trunk. Or I build it myself, but I would need his patches for that to be done. I see an extra patches folder, but I guess those are additional patches over the main fix.

dp79 wrote:
sparky1979 wrote:

I bought 5 of these routers since they were about $30 at staples.

trying to configure a wireless repeater by following: http://wiki.openwrt.org/doc/recipes/relayclient

I have a http://wiki.openwrt.org/toh/wd/n750
I flash it with openwrt-ar71xx-generic-mynet-n750-squashfs-factory.bin
telnet to 192.168.1.1
set password by typing:  passwd
ssh to 192.168.1.1
I then follow the steps at http://wiki.openwrt.org/doc/recipes/relayclient
I am getting stuck at Step 3.  It appears the wifi is not connected on wlan0 or radio0.  Below is the output from ifconfig.

(If it helps I can connect by plugging into the wan port and issuing these commands:
code

 uci set network.wan.proto=static
uci set network.wan.ipaddr=192.168.1.49

uci set network.wan.netmask=255.255.255.0

uci set network.wan.gateway=192.168.1.1

uci set network.wan.dns='8.8.8.8 8.8.4.4'

uci commit network

ifup wan

Hi sparky,

Please post the output of the following commands:

cat /etc/config/wireless
cat /etc/config/network

Also let me know how you are connecting to the router that supplies the internet connection to your repeater (dhcp or static, if static what is the lan side ip range/subnet/gateway ip). I see that you are trying to set it up as static, but the other router might have dhcp on with a different configuration.

dp79

dp79,

Sorry for the late reply.  There is a DHCP on the lan and wifi that assigns from 192.168.1.2-192.168.1.150.

Here is the output of:
cat /etc/config/wireless

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11ng'
        option path 'platform/ar934x_wmac'
        option htmode 'HT20'
        list ht_capab 'LDPC'
        list ht_capab 'SHORT-GI-20'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'TX-STBC'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option disabled '1'
        option channel '1'

config wifi-iface
        option device 'radio0'
        option network 'wwan'
        option mode 'sta'
        option ssid 'SparkyRouter3-2.4'
        option encryption 'psk'
        option key '**********'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '36'
        option hwmode '11na'
        option path 'pci0000:00/0000:00:00.0'
        option htmode 'HT20'
        list ht_capab 'LDPC'
        list ht_capab 'SHORT-GI-20'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'TX-STBC'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option disabled '1'

config wifi-iface
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

cat /etc/config/network

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdb7:e9b2:290d::/48'

config interface 'lan'
        option ifname 'eth0.1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'
        option macaddr '00:90:a9:cd:b0:e5'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 1 2 3 4'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 5'

config interface 'wwan'
        option proto 'dhcp'

Followed all the relayd instructions and all is good for me, finally.


sparky1979: the option disabled line in the radio0 interface should be 0
Theres a couple commands to do before step1, under the configuration heading



Is there any point configuring 6relayd? Or just disable ipv6 all together

(Last edited by TonyL83 on 8 Feb 2014, 13:33)

sparky1979,

I can just repeat what TonyL83 is suggesting in the previous post, you need to enable your radios.
First of all consider using the firmware that varkey has posted below. The one in trunk has bugs and has poor wifi performance. Once you've done that, make these changes in your config:

change both radio configs from
option disabled '1'
to
option disabled '0'

after you have saved your modifications, apply these commands:

ifup wan
wifi


dp79

I am on OpenWrt Barrier Breaker r39487, but link speed of every device I connect to the switch gets negotiated down to 100 Mb/s instead of 1000 Mb/s. I tried different ports, cables, devices but all show the same behavior.

dmesg from a device I connected shows this.

[12065.603498] mv643xx_eth_port mv643xx_eth_port.0 eth0: link up, 1000 Mb/s, full duplex, flow control disabled
[12066.722052] mv643xx_eth_port mv643xx_eth_port.0 eth0: link down
[12071.529788] mv643xx_eth_port mv643xx_eth_port.0 eth0: link up, 100 Mb/s, full duplex, flow control disabled


Did any one else face this issue?

varkey wrote:

I am on OpenWrt Barrier Breaker r39487, but link speed of every device I connect to the switch gets negotiated down to 100 Mb/s instead of 1000 Mb/s. I tried different ports, cables, devices but all show the same behavior.

dmesg from a device I connected shows this.

[12065.603498] mv643xx_eth_port mv643xx_eth_port.0 eth0: link up, 1000 Mb/s, full duplex, flow control disabled
[12066.722052] mv643xx_eth_port mv643xx_eth_port.0 eth0: link down
[12071.529788] mv643xx_eth_port mv643xx_eth_port.0 eth0: link up, 100 Mb/s, full duplex, flow control disabled


Did any one else face this issue?

Are you sure you're talking about the WD My Net N750? Looks more like a kirkwood based device.

Heffer wrote:
varkey wrote:

I am on OpenWrt Barrier Breaker r39487, but link speed of every device I connect to the switch gets negotiated down to 100 Mb/s instead of 1000 Mb/s. I tried different ports, cables, devices but all show the same behavior.

dmesg from a device I connected shows this.

[12065.603498] mv643xx_eth_port mv643xx_eth_port.0 eth0: link up, 1000 Mb/s, full duplex, flow control disabled
[12066.722052] mv643xx_eth_port mv643xx_eth_port.0 eth0: link down
[12071.529788] mv643xx_eth_port mv643xx_eth_port.0 eth0: link up, 100 Mb/s, full duplex, flow control disabled


Did any one else face this issue?

Are you sure you're talking about the WD My Net N750? Looks more like a kirkwood based device.

Yes, the dmesg output is from a Kirkwood based device that I connected to the WD My Net N750. Even if I connect my laptop with gigabit ethernet, it only negotiates 100 Mb/s.

(Last edited by varkey on 12 Feb 2014, 19:09)

dp79 wrote:

sparky1979,

I can just repeat what TonyL83 is suggesting in the previous post, you need to enable your radios.
First of all consider using the firmware that varkey has posted below. The one in trunk has bugs and has poor wifi performance. Once you've done that, make these changes in your config:

change both radio configs from
option disabled '1'
to
option disabled '0'

after you have saved your modifications, apply these commands:

ifup wan
wifi


dp79

I enabled the 2.4GHz radio.  I'll keep the 5Ghz radio off to keep things simpler until I get 2.4 WAN working.  ifconfig still shows no activity on wlan0.

sparky1979 wrote:

I enabled the 2.4GHz radio.  I'll keep the 5Ghz radio off to keep things simpler until I get 2.4 WAN working.  ifconfig still shows no activity on wlan0.


I had a similar problem to detect wifi signals but installing luci i had been able to put the router on repeater mode via relay.
i followed  this instructions but they are in spanish but just look at the images.

http://www.forocoches.com/foro/showthread.php?t=3129752

to install luci
http://wiki.openwrt.org/doc/howto/luci.essentials

and install libiwinfo and libiwinfo-lua to enable wifi scan in luci.

and the packages to enable to work with relayd in luci: luci-proto-core luci-proto-relay

when you have luci and libiwinfo installed just go in your browser, enter 192.168.1.1 or the ip gateway you have assigned to your router and you have to enable the wifi in network---->wifi, scan for the wifi signal, conect to it and put the password and submit and save and apply like it is showed in the images.

and follow this instructions to repeat the signal(this are in english)

http://trac.gateworks.com/wiki/relayd

if you couldn't make it work i will try to translate the instructions to make it via commands or editing a files in winspc.

sorry for my english and i hope i have helped.

dp79 wrote:

By the way, I'm using a ralink RT3070 in one of the USB ports as WAN interface, the onboard 2.4 GHZ radio is the LAN side and the device is set up in routed client mode.

Thanks,
     dp79

Can you tell me how you make the ralink rt3070 usb adapter work in this router, please? in having some problems because when i install the packages the router mix the internal wifi with the adapter and only the internal wifi works.
thanks in advance.

(Last edited by perdido on 14 Feb 2014, 17:10)

Perdido,

Step by step would be helpful.  Quite a few screens are different at http://trac.gateworks.com/wiki/relayd compared to the latest luci interface.  It would be helpful to have it updated.  The spanish directions are for the tplink and not this particular trunk and router which I'm confuses things.