Topic: TP-Link TL-WA901N/ND always boots in failsafe mode

Greetings!

After sysupgrade of a couple of TP-Link TL-WA901N/ND to the latest trunk (r37018, 24 June) I have same issue on all of them: they boot in failsafe mode by default.

The only way I discovered to boot them in the normal mode is pressing "reset" button while booting for about 10-15 sec.

1) Tried to compare dmesg and logs from the other 3 AP with old OpenWRt build - there is no difference.
2) Tried to tcpdump traffic - no udp traffic at all when booting AP (seems to be some scripting issue during preinit).
3) Partially checked preinit scripts for mistakes in logic - didn't find anything - all logic works as expected.
4) Checked some timeline tickets for about 1 week on dev.openwrt.org.


Can somebody help me? Should I post some additional info?


Sorry for my English sad

Re: TP-Link TL-WA901N/ND always boots in failsafe mode

Hello

not sure if anyone is picking this up, but I have the same on my TP-LINK WR941ND (v3), and if I connect a TTL-serial, I get this in the console:

procd: Console is alive                                                         
procd: - watchdog -                                                             
[    3.410000] usbcore: registered new interface driver usbfs                   
[    3.420000] usbcore: registered new interface driver hub                     
[    3.420000] usbcore: registered new device driver usb                        
[    3.680000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver       
[    3.680000] ehci-platform: EHCI generic platform driver                      
[    3.750000] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver           
procd: - preinit -                                                              
[    4.280000] eth0: link up (100Mbps/Full duplex)                              
Press the [f] key and hit [enter] to enter failsafe mode                        
- failsafe button wps was pressed -                                             
- failsafe -                                                                    
                                                                                
                                                                                
BusyBox v1.19.4 (2013-08-03 15:36:02 UTC) built-in shell (ash)                  
Enter 'help' for a list of built-in commands.                                   
                                                                                
ash: can't access tty; job control turned off                                   
  _______                     ________        __                                
 |       |.-----.-----.-----.|  |  |  |.----.|  |_                              
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|                             
 |_______||   __|_____|__|__||________||__|  |____|                             
          |__| W I R E L E S S   F R E E D O M                                  
 -----------------------------------------------------                          
 BARRIER BREAKER (Bleeding Edge, r37660)                                        

As you can see, it thinks I pressed the wps button, I assure you I did not. Seems to me as if the button config is wrong in the latest trunk. Just to trick it (in case of on/off mistake) I keep it pressed during boot, but it still went to failsafe.

Before I was always using an old 10.03.1 trunk to satisfaction, except coova-chilli was getting old. When I upgraded to 10.06 stable, OpenWRT did not communicate if both an LAN *and* WAN cable was attached during boot (worked WAN was disconnected and then connected later. Probably some switch config problem)

So I upgraded to latest trunk, r37660, and now it always goes to failsafe.

Any thoughts?
I'll probably try to figure out how to downgrade with tftp or something, but if some of the dev's could look at the TP-LINK failsafe button config, that would be great.

Thanks

Re: TP-Link TL-WA901N/ND always boots in failsafe mode

Small followup: I managed to go back to non-trunk ATTITUDE ADJUSTMENT (12.09, r36088)   
using tftp, and now indeed it boots again.

Really: something is wrong in the failsafe button assignment for some of the TP-LINK models.
Please someone look into it, I suspect it may otherwise cause quite a few semi-bricks (not everyone can do serial console and/or tftp)

Re: TP-Link TL-WA901N/ND always boots in failsafe mode

However, r37619 build now works perfectly. Thanks to the developers!

Re: TP-Link TL-WA901N/ND always boots in failsafe mode

Hmm, so r37619 works on TP-LINK WA901ND, but later r37660 fails for WR941ND

So either the issues were not related, or worse, the button reconfig done for your model broke mine.

Re: TP-Link TL-WA901N/ND always boots in failsafe mode

https://dev.openwrt.org/changeset/37696

i think that this fixed 901.. seems unrelated (but maybe can be fixed similarly..) with 941, since the mach file is specific for 901...

Re: TP-Link TL-WA901N/ND always boots in failsafe mode

cybermaus, on my WR941ND the system seems to be booting ok on Barrier Breaker r37801. I just updated my firmware, so I am not sure if mine would have the same problem you had with earlier builds.