OpenWrt Forum Archive

Topic: Tp-Link td-w8970

The content of this topic has been archived between 26 Mar 2018 and 7 May 2018. Unfortunately there are posts – most likely complete pages – missing.

Hello everyone new here.
Bought my router year ago with Firmware Version:0.6.0 2.1 v000c.0 Build 130415 Rel.34164n
but getting the error for webpage update of the router "Error code: 4503 The uploaded file was not accepted by the device."

And after reading through everything I am confused as wiki says this version can be updated directly through webpage. Yet here I am asking for help because I can't make direct connections to router only have Ethernet connection and want to use openwrt on it. Completely new in router programming, but I am cs student have used languages like c, c++, java and others but don't know what to do here. Any help is appreciated and I have tried reading through posts but still confused what software to use and how to use it.

Hello,
i really happy with running openwrt on my w8970. It's runs so smooth and stable thats unbelievable. Also the vDSL Connection works without no trouble. And the cpu usage also normal if i use the full bandwith.

But ive got one trouble with it. And that's ipsec. Andybody know if there are some troubles with the kernel driver? Ipsec works but performance is very very poor no matter if i use 3des or aes128. I won't get more out then 4kb/s and thats terrible.

And the cpu is instead idling...

Would be great if anybody can help, i would like to use the new android app for strongswan.

Thanks

Can someone please write me a guide to what to do because wiki says older firmware is directly flashable from gui and i am still looking for software method don't way to play with wires.

I've compiled from trunk the last sources (clean trunk branch rev 39424) with the following config improvements:

- Disabled some kernel debug symbols, so image is smaller and optimized
- Added nano editor
- Configured busybox with mtime support, so scripts can manage files older than... (good for usb storage)

Link to the image: https://drive.google.com/folderview?id= … sp=sharing
(i will update image with improvements over time).

To program it from uboot you need these simple steps:

1)  setenv ipaddr 192.168.1.254; setenv serverip 192.168.1.5 (set ip to your needs)
2)  tftpboot 0x80800000 openwrt-lantiq-xrx200-TDW8970-sysupgrade.image
3)  sf erase 0x20000 0x7a0000           -    this clean the kernel and rootfs partitions
4)  sf write 0x80800000 0x20000 0x680004

then turn off and on TD-W8970
Enjoy OpenWRT

RyLoS

Here "1)  setenv ipaddr 192.168.1.254; setenv serverip 192.168.1.5 (set ip to your needs)" what software i use and how to use it till i have to write above command to even start flashing the software for it.

If someone can please write a consolidated guide for it would be great help to all of us please!

intikhab_choosenone wrote:

Can someone please write me a guide to what to do because wiki says older firmware is directly flashable from gui and i am still looking for software method don't way to play with wires.

What is your firmware version? Because very likely you need to solder to your router board.
Those commands you quoted are for the installation method via soldering.

intikhab_choosenone wrote:

Hello everyone new here.
Bought my router year ago with Firmware Version:0.6.0 2.1 v000c.0 Build 130415 Rel.34164n
but getting the error for webpage update of the router "Error code: 4503 The uploaded file was not accepted by the device."

And after reading through everything I am confused as wiki says this version can be updated directly through webpage. Yet here I am asking for help because I can't make direct connections to router only have Ethernet connection and want to use openwrt on it. Completely new in router programming, but I am cs student have used languages like c, c++, java and others but don't know what to do here. Any help is appreciated and I have tried reading through posts but still confused what software to use and how to use it.

My firmware version is Firmware version:0.6.0 2.1 v000c.0 Build 130415 Rel.34164n as stated above also.
This is one version before the change from tp-link which can't upload custom firmware, and mine qualifies as stated in wiki to be used without any problem through update firmware of the router. But how to do that? I tried openwrt-15.05-lantiq-xrx200-TDW8970-sysupgrade.image file to be used for it and got error "Error code: 4503 The uploaded file was not accepted by the device."

Hi all. Can someone comment on commits 48941 and 48942 by nbd - does that mean that lantiq adsl drivers are now included as standard? If so, would somebody be able to provide any updated instructions /builds, or feedback on the latest trunk versions? I really don't want to mess this up!

https://dev.openwrt.org/changeset/48942

Yes, trunk is now build with the VDSL firmwares included (both Annex A & B by default which wastes a bit of space). I'm just using the imagebuilder and there kmod-ath9k is currently missing, so wireless will not work. Apart from that, I'm rebuilding my images with the following:

only has to be done once (you should probably do all this in an extra folder):

wget https://downloads.openwrt.org/snapshots/trunk/lantiq/xrx200/OpenWrt-Toolchain-lantiq-xrx200_gcc-5.3.0_musl-1.1.14.Linux-x86_64.tar.bz2
wget https://downloads.openwrt.org/snapshots/trunk/lantiq/xrx200/OpenWrt-SDK-lantiq-xrx200_gcc-5.3.0_musl-1.1.14.Linux-x86_64.tar.bz2
tar -xjf *.tar.bz2

Then for each update:

wget https://downloads.openwrt.org/snapshots/trunk/lantiq/xrx200/OpenWrt-ImageBuilder-lantiq-xrx200.Linux-x86_64.tar.gz
tar -xjf OpenWrt-ImageBuilder-lantiq-xrx200.Linux-x86_64.tar.gz
cd OpenWrt-ImageBuilder-lantiq-xrx200.Linux-x86_64
make image PROFILE=TDW8970 PACKAGES="luci luci-app-sqm luci-app-upnp luci-app-ddns luci-app-statistics collectd-mod-ping"

In the PACKAGES="" you can add all the packages you want, I have luci, sqm, upnp, ddns and statistics with luci interface included. You propably at least want "luci" there.
I uploaded the build I'm currently using here (If you know a better upload service, let me know).
and @intikhab_choosenone, sorry for not having any usefull input for you...

(Last edited by SimpleMouse on 24 Mar 2016, 17:46)

Just a note w.r.t. SMP support.

As of today, using the CC15.05.1 head git source (kernel 3.18.27), the board boots and runs SMP (using the SMVP/VMSP flag and SMP scheduler found in kernel_menuconfig)!

However, using git HEAD (kernel 4.4.6), the exact same configuration results in a kernel Oops at boot time, and the SMVP/VMSP options need to be turned off for the board to boot (at least as a workaround).

The text of the Oops is appended below (hopefully as Google bait).

Hope this helps someone else!

--- Oops text ---
[    2.727091] CPU 0 Unable to handle kernel paging request at virtual address fffd7000, epc == 80029978, ra == 80096440
[    2.736265] Oops[#1]:
[    2.738534] CPU: 0 PID: 171 Comm: kworker/0:1 Not tainted 4.4.6 #3
[    2.744737] Workqueue: events_power_efficient phy_state_machine
[    2.750628] task: 839fa070 ti: 83a32000 task.ti: 83a32000
[    2.756015] $ 0   : 00000000 00000001 805a0000 fffd8000
[    2.761236] $ 4   : fffd7000 00000000 00000001 00000000
[    2.766458] $ 8   : 1100ff00 1000001f 00000000 00000008
[    2.771682] $12   : 00000000 00000015 00000000 70000003
[    2.776903] $16   : 83827db0 00000000 8002a3b8 fffd7000
[    2.782126] $20   : 8050ad00 80594140 80509318 805a0000
[    2.787349] $24   : 00000000 80029964
[    2.792571] $28   : 83a32000 83a33c48 805a0000 80096440
[    2.797794] Hi    : 00000000
[    2.800668] Lo    : 00007000
[    2.803562] epc   : 80029978 r4k_blast_dcache_page_dc32+0x14/0xb8
[    2.809675] ra    : 80096440 generic_smp_call_function_single_interrupt+0x160/0x200
[    2.817292] Status: 1100fd02 KERNEL EXL
[    2.821211] Cause : 00800008 (ExcCode 02)
[    2.825214] BadVA : fffd7000
[    2.828089] PrId  : 00019556 (MIPS 34Kc)
[    2.832000] Modules linked in:
[    2.835061] Process kworker/0:1 (pid: 171, threadinfo=83a32000, task=839fa070, tls=00000000)
[    2.843489] Stack : 9ce12200 7fffffff ffffffff 80090a00 805a2d20 805aad20 00000000 00000000
          00000001 8000e908 7fffffff 8108bb00 00000002 8108bb14 8108bb78 80071e20
          80509340 80509354 80594140 805aad20 8108bbb8 00000001 80509340 80509354
          80594140 805aad20 00000013 00000004 00000000 00000000 805a0000 805a0000
          805a0000 80076560 00000000 00000001 00000001 00014680 00000007 00000001
          ...
[    2.879002] Call Trace:
[    2.881454] [<80029978>] r4k_blast_dcache_page_dc32+0x14/0xb8
[    2.887211] [<80096440>] generic_smp_call_function_single_interrupt+0x160/0x200
[    2.894531] [<8000e908>] ipi_call_interrupt+0x10/0x20
[    2.899574] [<80071e20>] handle_irq_event_percpu+0x78/0x1b4
[    2.905144] [<80076560>] handle_percpu_irq+0x88/0xb8
[    2.910097] [<800714ec>] generic_handle_irq+0x40/0x58
[    2.915145] [<80015968>] do_IRQ+0x1c/0x2c
[    2.919146] [<80002830>] ret_from_irq+0x0/0x4
[    2.923509] [<80312a50>] xrx200_mdio_rd+0x30/0x7c
[    2.928213] [<802fe584>] mdiobus_read+0x58/0x84
[    2.932730] [<802fdb18>] genphy_read_status+0x120/0x230
[    2.937951] [<802fc41c>] phy_state_machine+0x8c/0x478
[    2.943002] [<80046918>] process_one_work+0x298/0x490
[    2.948045] [<80046e7c>] worker_thread+0x36c/0x5fc
[    2.952842] [<8004c334>] kthread+0x114/0x128
[    2.957097] [<80002878>] ret_from_kernel_thread+0x14/0x1c
[    2.962477]
[    2.963952]
Code: 00002821  10000026  8c464b6c <bc950000> bc950020  bc950040  bc950060  bc950080  bc9500a0
[    2.973947] ---[ end trace 3a2960d8dc1c7bd9 ]---
[    2.981811] Kernel panic - not syncing: Fatal exception in interrupt
[    2.988808] ---[ end Kernel panic - not syncing: Fatal exception in interrupt

(Last edited by fghorow on 27 Mar 2016, 16:42)

if somebody using it with adsl and OpenWRT
Does it work out of the box, or I'll need to do some tweaks? (I mean firmware, not provider settings)

(Last edited by Snakus on 4 May 2016, 12:18)

Yes adsl works. But you need to be aware that w8970 bought in annex A country will not work on annex B adsl (even if you use annex B firmware) and vice versa. There are multiple post here about that. There is no issue with vdsl apparently, that works everywhere.

Hi

I read all the topic and I'm still don't know how to install this firmware especially this part ( Download the openwrt-lantiq-xrx200-TDW8970-uImage-initramfs image from wherever you can find it (the official release does not supply a uImage with an initramfs, so booting that just gives you an error about a missing root filesystem.) )

can someone please write how to tutorial including download links steps in copy past format

really I need VDSL

Thank you all in advance

You did solder to the serial on the mainboard? Then you should be able to use the "Installation direct to Flash" instructions.

Thank you for your reply can you help me in these steps

Download the image into RAM (*not* flash):
Flash the newly downloaded sysimage:


from where I can download the specific images and how to flash them

Hi Guys.

I think i need some help.

I got a W8970B yesterday to replace my 10 year old DIY-Router (ancient x86 hardware thats using the telekom speedport w921v as a dumb PPPoE modem) thats dying of a failing harddrive right about now.
I have a Deutsche Telekom VDSL50 line and specifically got the W8970B because the lantiq chipset apparently supports VDSL.


Installed openwrt-15.05.1-lantiq-xrx200-TDW8970-sysupgrade.image from https://downloads.openwrt.org/chaos_cal … iq/xrx200/ via a USB-TTL serial console which worked flawlessly on the first attempt.


Unfortunately it appears as if i'm in a VDSL vectoring area (as discussed on page 4 of this thread) since dsl_control only says it syncs at about 18mb/1.5mb instead of the 50/10 it should be.
I played around for a while but gave up on the idea of having the openwrt router operate alone.

Next thing i tried was hooking up the Speedport to the OpenWRT router and use it as PPPoE Modem again, but i cant get that to work either.

It took some screwing around to even get the Router to send the PADI Discovery packets on the WAN Port (checked with a laptop and wireshark what its sending)

My /etc/config/network turned into kind of a mess i think, thats what it currently looks like:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd46:eb5d:d441::/48'

config interface 'lan'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ifname 'eth0.1'
        option macaddr 'e8:94:f6:84:d8:68'
        option ipaddr '192.168.5.1'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan 'eth0_1'
        option device 'switch0'
        option vlan '1'
        option ports '0 2 5 6t'

config switch_vlan 'eth0_2'
        option device 'switch0'
        option vlan '2'
        option ports '4 6t'

config atm-bridge 'atm'
        option vpi '1'
        option vci '32'
        option encaps 'llc'
        option payload 'bridged'

config interface 'wan'
        option proto 'pppoe'
        option macaddr '00:0A:5E:48:94:49'
        option username 'something@t-online.de'
        option password 'secret'
        option ifname 'eth0.2'                  
        option pppd_options 'debug' 
                                   
config interface 'wan6'                         
        option ifname '@wan'                    
        option proto 'dhcpv6'             
                                                   
config vdsl 'dsl'                               
        option annex 'a'                        
        option firmware '/lib/firmware/vdsl.bin'
        option tone 'av'      
        option xfer_mode 'atm' 

Unfortunately that is all it does when i hook it up to the speedport:

Sun May 22 16:14:01 2016 daemon.notice netifd: Interface 'wan' is now down
Sun May 22 16:14:01 2016 daemon.notice netifd: Interface 'wan' is disabled
Sun May 22 16:14:01 2016 daemon.notice netifd: Interface 'wan' is enabled
Sun May 22 16:14:01 2016 daemon.notice netifd: Interface 'wan' is setting up now
Sun May 22 16:14:01 2016 daemon.info pppd[11378]: Plugin rp-pppoe.so loaded.
Sun May 22 16:14:01 2016 daemon.info pppd[11378]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Sun May 22 16:14:01 2016 daemon.notice pppd[11378]: pppd 2.4.7 started by root, uid 0
Sun May 22 16:14:01 2016 daemon.debug pppd[11378]: Send PPPOE Discovery V1T1 PADI session 0x0 length 4
Sun May 22 16:14:01 2016 daemon.debug pppd[11378]:  dst ff:ff:ff:ff:ff:ff  src 00:0a:5e:48:94:49
Sun May 22 16:14:01 2016 daemon.debug pppd[11378]:  [service-name]
Sun May 22 16:14:06 2016 daemon.debug pppd[11378]: Send PPPOE Discovery V1T1 PADI session 0x0 length 4
Sun May 22 16:14:06 2016 daemon.debug pppd[11378]:  dst ff:ff:ff:ff:ff:ff  src 00:0a:5e:48:94:49
Sun May 22 16:14:06 2016 daemon.debug pppd[11378]:  [service-name]
Sun May 22 16:14:11 2016 daemon.debug pppd[11378]: Send PPPOE Discovery V1T1 PADI session 0x0 length 4
Sun May 22 16:14:11 2016 daemon.debug pppd[11378]:  dst ff:ff:ff:ff:ff:ff  src 00:0a:5e:48:94:49
Sun May 22 16:14:11 2016 daemon.debug pppd[11378]:  [service-name]
Sun May 22 16:14:16 2016 daemon.warn pppd[11378]: Timeout waiting for PADO packets
Sun May 22 16:14:16 2016 daemon.err pppd[11378]: Unable to complete PPPoE Discovery
Sun May 22 16:14:16 2016 daemon.info pppd[11378]: Exit.

Its not an issue with the Speedport or cabling, when i switch the cable back to my old router the VDSL connection is established in mere seconds.



I have no idea what to try next.
Any insight on how to fix the PPPoE problem, or how to get full VDSL speed with OpenWRT alone, would be appreciated.

(Last edited by hacki on 22 May 2016, 15:20)

hacki

config vdsl 'dsl'                               
        option annex 'a'

you should look here
this option operate with XTU bits, which tells to the router which protocol and speed to use

check dsl_control script for the options

(Last edited by Snakus on 22 May 2016, 15:44)

I tried all kinds of iterations of the vdsl subsection. Annex a, b, j, tone a, b, bv, xfer_mode atm, ptm
I'm not even sure  anymore which it was that got me the 18/1.5 sync.

But isnt that subsection irrelevant anyway when using PPPoE with an external modem?

(Last edited by hacki on 22 May 2016, 15:47)

hacki
I have a lot of trubles with modem work due to line quality.

you have B model
may be try to change to

config vdsl 'dsl'                               
        option annex 'b'                       
        option firmware '/lib/firmware/vdsl.bin'
        option tone 'bv'     
        option xfer_mode 'atm'

according to

# A43
84    tone_adsl_a="0x142" # A43C + J43 + A43
85    tone_vdsl_a="0x142" # A43C + J43 + A43
86   
87    # A43 + V43
88    tone_adsl_av="0x142" # A43C + J43 + A43
89    tone_vdsl_av="0x146" # A43C + J43 + A43 + V43
90   
91    # B43
92    tone_adsl_b="0x81" # B43 + B43c
93    tone_vdsl_b="0x1" # B43
94   
95    # B43 + V43
96    tone_adsl_bv="0x81" # B43 + B43c
97    tone_vdsl_bv="0x5" # B43 + V43

also check here http://openwrt-devel.openwrt.narkive.co … provements
and

(Last edited by Snakus on 22 May 2016, 16:40)

On a whim i deleted the entire

config vdsl 'dsl'                               
        option annex 'a'                        
        option firmware '/lib/firmware/vdsl.bin'
        option tone 'av'      
        option xfer_mode 'atm' 

section from my /etc/config/network file, restarted the router.... lo and behold, PPPoE worked and it logged right in.


Currently writing this via my openwrt router. smile

(Last edited by hacki on 22 May 2016, 18:30)

Hacki, the newest DD trunk supports vectoring. So if you are willing to compile it yourself you can get firmware that supports VDSL with vectoring running on TP-w8970.

DD? You mean DD-WRT?

I guess i'll leave it like it is for now. Its working, and thats good enough for me.


Maybe i'll upgrade once vectoring is supported out of the box in openwrt.

(Last edited by hacki on 22 May 2016, 21:57)

Though, i'm already seeing the first problem. Some websites take extremely long to load, ping has something like 20-30% package loss, yet downloading large files or speedtests are lightning fast..

hacki

same to me on ADSL line with stock firmware
but I know 2 problematic places on the line

hacki wrote:

DD? You mean DD-WRT?
Maybe i'll upgrade once vectoring is supported out of the box in openwrt.

No DD=Designated Driver (this is openwrt trunk).

Hi,

i bought two TD-W8970B and want to flash them. In putty I see a lot of text, when i power on the device but the text is not correct encoded. I thought it could be a problem with my modification so i tried the second one. Same problem here.

I used a USB Serial adapter where I added three cables (GND, TX, RX) to the w8970b. The adapter is from logilink. Settings in putty are 115200 8N1. Device is v1 and firmware version is 0.6.0 2.5 v000d.0 Build 140320 Rel.67818n.

I uploaded a screenshot
http://resimzade.com/Show.html?i=46869&amp;token=102076

Have someone an idea what I did wrong?

Is there an image to flash via webgui?

Greetings

BJ

(Last edited by BlackJack7986 on 23 May 2016, 15:05)

Sorry, posts 251 to 250 are missing from our archive.