1 (edited by stonecarver 2012-12-01 19:34:24)

Topic: How to resolve "DHCP packet received on wan which has no address"

Hello
I need your help please. In the system log this shows up several times.

DHCP packet received on wan which has no address

How do I resolve this?

I have a WR941ND, PPPOE wan, wifi network. I do not know how to go to this "etc/config/dhcp:"
Can I resolve this via LuCi? Please step by step. Thanks!

Edit:
Running RC1 on TL WR-941 ND v3 still getting this message in system log
Dec 1 18:25:43 OpenWrt daemon.warn dnsmasq-dhcp[1596]: DHCP packet received on wan which has no address
DHCP
etc/config/dhcp:
config dnsmasq
option domainneeded '1'
option boguspriv '1'
option filterwin2k '0'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option nonegcache '0'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.auto'
list notinterface 'wan'
config dhcp 'wan'
option interface 'wan'
option ignore '1'
NETWORK
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config interface 'lan'
option ifname 'lan1 lan2 lan2 lan3 lan4'
option type 'bridge'
option proto 'static'
option netmask '255.255.255.0'
option ipaddr '192.168.1.1'

config interface 'wan'
option ifname 'wan'
option _orig_ifname 'wan'
option _orig_bridge 'false'
option proto 'pppoe'
option username '*'
option password '*'

Re: How to resolve "DHCP packet received on wan which has no address"

I can confirm adding '''except-interface=wan''' to '''/etc/dnsmasq.conf''' solved my problem.