Topic: tp-link 3420 v1.3 dead after flash openwrt

subject, if flash backfire or trunk sad (after install not connect 192.168.1.1) and back alive only with serial and original firmware...
   
http://s49.radikal.ru/i125/1209/f2/69972bfb5d2d.jpg
http://s017.radikal.ru/i438/1209/33/150d5d354420.jpg
http://s019.radikal.ru/i629/1209/77/acfbb853e3e6.jpg
v1.3 not support openwrt? have any ideas?


v1.2 is ok

Re: tp-link 3420 v1.3 dead after flash openwrt

Have you read the Wiki page about it, what does it say?

Re: tp-link 3420 v1.3 dead after flash openwrt

written_direcon wrote:

Have you read the Wiki page about it, what does it say?

read what? i flash over 100 routers v1.2
but  v1.3 the first and will not work after flashing ... not available on the 192.168.1.1 and all ...:(
also flash use  serial, The same
if you know reference exactly about v1.3 that prompt me
just on the Russian wiki is not about this version of anything... sad

Re: tp-link 3420 v1.3 dead after flash openwrt

I have too revision v1.3 on my mr3420.

Have any idea how to upgrade with OPENWRT ?
Thanks.

Re: tp-link 3420 v1.3 dead after flash openwrt

Has anyone successfully loaded OpenWrt on a V1.3 MR 3420?

What Flash Chip is it using?


Any success with a Huawei 353s Dongle?


I would like to load balance with multiple 3G dongles to different, or same providers and seeking advice to do this,,,,,,,
THANKs

6 (edited by ard 2012-09-25 21:35:26)

Re: tp-link 3420 v1.3 dead after flash openwrt

Hello there...

Have same problem as garynych.

Fialsafe has worked for first time(when i flashed it with r33288), but than I flashed r29592 with LuCI web interface and now device is dead(i need to flash it with serial). 

If this information will be helpfull:
Flah Chip - cFeon Q32B-104HIP (same as on TL-WR1041) has 4mb
Other hardware is same as on any other version of TL-MR3420

I can`t pass it back to store now, so I`m realy hoping that OpenWRT will run on it:)

Re: tp-link 3420 v1.3 dead after flash openwrt

ard wrote:

Hello there...

Have same problem as garynych.

Fialsafe has worked for first time(when i flashed it with r33288), but than I flashed r29592 with LuCI web interface and now device is dead(i need to flash it with serial). 

If this information will be helpfull:
Flah Chip - cFeon Q32B-104HIP (same as on TL-WR1041) has 4mb
Other hardware is same as on any other version of TL-MR3420

I can`t pass it back to store now, so I`m realy hoping that OpenWRT will run on it:)

Hi, can you say, when you are flash at first with r33288 it work?
Thanks.

Re: tp-link 3420 v1.3 dead after flash openwrt

Benefits of  Deer Antler Velvet

Re: tp-link 3420 v1.3 dead after flash openwrt

marketarea wrote:

Hi, can you say, when you are flash at first with r33288 it work?
Thanks.

Hi,
Actualy it worked only in failsafemode, I don`t test anything, just as I got shh connected i flushed r29592.

I`m note sure that I was done flashing with r33288 correctly (I`m doubt that i flushed "upgrade" version of firmaware... roll)

Tommorow I going to flush it with serial, will report if any progres.

Re: tp-link 3420 v1.3 dead after flash openwrt

ard wrote:
marketarea wrote:

Hi, can you say, when you are flash at first with r33288 it work?
Thanks.

Hi,
Actualy it worked only in failsafemode, I don`t test anything, just as I got shh connected i flushed r29592.

I`m note sure that I was done flashing with r33288 correctly (I`m doubt that i flushed "upgrade" version of firmaware... roll)

Tommorow I going to flush it with serial, will report if any progres.

Ok, will wait.

11 (edited by Dioptimizer 2012-09-28 09:01:29)

Re: tp-link 3420 v1.3 dead after flash openwrt

Likely JEDEC ID of flash memory - some other. If not difficult: download then follow the instructions in this thread
load and run test uboot:

tftp 80000000 8Muboot_RAM_version.bin

go 80000000

fast put in console tt (not tpl)
and run the command:

flinfo

(print FLASH memory information)

If the value JEDEC ID is not as in MTD driver source:

{ "en25q32b", INFO(0x1c3016, 0, 64 * 1024,  64, 0) }

- it will speed up the supporting your hardware version by OpenWrt

12

Re: tp-link 3420 v1.3 dead after flash openwrt

The output of flinfo:

AR7241# flinfo # 1:
Flash MF_ID:[0x1c]
Dev_ID:[0x30]
Size_ID:[0x16]
Flash Size:[8MByte]
Flash has [128] Sectors

Seems all is ok... also i got this during standart boot(w.o. breaking):

m25p80 spi0.0: unrecognized JEDEC id 1c3016

13

Re: tp-link 3420 v1.3 dead after flash openwrt

Flashed it with r33312, one hour ago, working fine.

Re: tp-link 3420 v1.3 dead after flash openwrt

r33312 - Work fine!

15 (edited by marketarea 2012-09-29 20:15:53)

Re: tp-link 3420 v1.3 dead after flash openwrt

Cant connect with 300mbit/s with my motorola razr xt910. Just no more then 65mbit/s, but both have 80211n...
Have any ideas?
yes, i understand that 300mbit imposible.. but 100-135 its real...
-=-=-=-=-=-=-=-=-=-=
My config:
-----------------------------
root@OpenWrt:~# uci show /etc/config/wireless
wireless.radio0=wifi-device
wireless.radio0.type=mac80211
wireless.radio0.macaddr=64:70:02:75:e2:32
wireless.radio0.hwmode=11ng
wireless.radio0.ht_capab=SHORT-GI-20 SHORT-GI-40 TX-STBC RX-STBC1 DSSS_CCK-40
wireless.radio0.noscan=1
wireless.radio0.txpower=27
wireless.radio0.country=US
wireless.radio0.channel=11
wireless.radio0.htmode=HT40-
wireless.@wifi-iface[0]=wifi-iface
wireless.@wifi-iface[0].device=radio0
wireless.@wifi-iface[0].network=lan
wireless.@wifi-iface[0].mode=ap
wireless.@wifi-iface[0].ssid=OpenWrt
wireless.@wifi-iface[0].key=xxxxxxxxxxxxxxxx
wireless.@wifi-iface[0].encryption=psk-mixed+tkip+ccmp

Re: tp-link 3420 v1.3 dead after flash openwrt

Hi there...i need help..
Have same problem as garynych and i try to use serial cable using CA42. I'm follow the tutorial for debricking mr3420 and i got problem like this when try to flash with serial.
http://i1086.photobucket.com/albums/j447/affendi_1979/mr3420.jpg

17 (edited by nebbia88 2012-09-30 10:28:27)

Re: tp-link 3420 v1.3 dead after flash openwrt

have you connected a 10k resistor to TX like explained in wiki?

also always link the tutorial you are talking about!

18 (edited by marketarea 2012-10-01 13:32:44)

Re: tp-link 3420 v1.3 dead after flash openwrt

Cant switch to 40mhz, always have 20...
SSID    MAC-Address    IPv4-Address    Signal    Noise    RX Rate    TX Rate
OpenWrt Xxxxxxxxxxxxx  192.168.1.223    -47 dBm    -90 dBm    1.0 Mbit/s, MCS 0, 20MHz    65.0 Mbit/s, MCS 7, 20MHz

-------------------------------------------------------------------------
  uci set wireless.radio0.htmode=HT40+  # or: HT40- if using channel 11
  uci set wireless.radio0.noscan=1
  uci commit wireless; wifi

Encryption: WPA2 PSK (CCMP)

All did like her http://wiki.openwrt.org/doc/uci/wireless

Re: tp-link 3420 v1.3 dead after flash openwrt

nebbia88 wrote:

have you connected a 10k resistor to TX like explained in wiki?

also always link the tutorial you are talking about!

im not read yet from wiki, just follow from this site : http://www.kaskus.co.id/showpost.php?p=544581251&postcount=936

20 (edited by pjiwa 2012-10-03 15:19:11)

Re: tp-link 3420 v1.3 dead after flash openwrt

http://i1086.photobucket.com/albums/j447/affendi_1979/mr3420a.jpg
http://i1086.photobucket.com/albums/j447/affendi_1979/mr34201.jpg
http://i1086.photobucket.com/albums/j447/affendi_1979/CA-42GND1.jpg
http://i1086.photobucket.com/albums/j447/affendi_1979/CA-42TX-RX-33v1.jpg

garynych wrote:

connected a 10k resistor between (TX --- Vcc)
http://wiki.openwrt.org/ru/toh/tp-link/ … 1%80%D1%82


after read from wiki, this is happen..:(..
(I'm solder the blue wire after this pic but the error still same)

MR3420 ver 1.3
OpenWrt Version: r23138
Cable: Clone CA-42

21 (edited by garynych 2012-10-03 09:49:31)

Re: tp-link 3420 v1.3 dead after flash openwrt

connected a 10k resistor between (TX --- Vcc)
http://wiki.openwrt.org/ru/toh/tp-link/ … 1%80%D1%82

Re: tp-link 3420 v1.3 dead after flash openwrt

[Problem Solved] -need to add 1 more 10k resistor to rx and i flash back to tplink firmware..thank you garynych & nebbia88

Re: tp-link 3420 v1.3 dead after flash openwrt

Thank you for the feedback!

10K resistor connected between RX AND ?? Also, i imagine adapter rx, that means router TX??

Re: tp-link 3420 v1.3 dead after flash openwrt

nebbia88 wrote:

Thank you for the feedback!

10K resistor connected between RX AND ?? Also, i imagine adapter rx, that means router TX??

you're right nebbia88...see this diagram from as garynych post before http://wiki.openwrt.org/ru/toh/tp-link/ … 1%80%D1%82

http://i1086.photobucket.com/albums/j447/affendi_1979/288b91cf54.jpg



Router        CA-42/DKU-5   
Vcc   -------->   +3.3v
GND  ------->    GND
RX    --------->   TX
TX    --------->   RX

25 (edited by agpramono 2012-11-12 09:16:13)

Re: tp-link 3420 v1.3 dead after flash openwrt

i have same problem with my router tl mr3420 v1.3..
router have msg kernel panic after upgrade openwrt
i trying reback firmware using tplink using serial data in board
and then i try again with http://downloads.openwrt.org/backfire/10.03.1/ixp4xx_generic/packages/ and success but 3g menu not found..