OpenWrt Forum Archive

Topic: Repeater configurations here! Both ways, bridged and simple repeater

The content of this topic has been archived between 5 Oct 2014 and 6 May 2018. Unfortunately there are posts – most likely complete pages – missing.

Remember that some routers  simply won't accept relayed DHCP clients.
I had that problems on some Hitron brand routers. Only mode "1" worked.

Heya,

first of all, thanks for the very helpful posting. Being new to openwrt this helped me quite a lot.
However, I still got trouble with my TP Link WR 703N. I want it to act as a repeater for my existing wifi network on the same network (thus I tried mode 1 config). The goal is to extend the existing wifi range that way. My router is a Fritzbox and has 192.168.0.1 as IP address (subnet 255.255.255.0)

I can see the new wifi network SSID being broadcasted. However, the WR 703N can't ping the router and vice versa. The web interface claims the router is associated.
I'm using r40565 and can acccess the device via the LAN port and terminal (ssh). I installed relayd as well as the respective package for the web interface. I also stopped and disabled the firewall as you suggested.

I adapted my config files as closely as possible to the ones you posted, here they are:

wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11ng'
        option path 'platform/ar933x_wmac'
        list ht_capab 'SHORT-GI-20'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option htmode 'HT20'
        option country 'DE'
        option txpower '20'
        option channel '5'
        option disabled '0'

config wifi-iface
    option ssid 'FRITZ!Box'
     option encryption 'psk2'        # Set wep, psk or psk2 for WEP, WPA or W
      option device 'radio0'
      option mode 'sta'
      option network 'wwan'
      option key 'MyWifi12345'

 config wifi-iface                                       
         option device 'radio0'                              
         option mode 'ap'                                
         option ssid 'Repeater'                      
         option encryption 'psk2'                
         option key 'MyWifi12345' 
         option network 'lan' 

network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'


config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.0.3'
        option netmask '255.255.255.0'
        option gateway '192.168.0.1'
        option dns '192.168.0.1'


config interface 'stabridge'
        option proto 'relay'
        option network 'lan wwan'
        option ipaddr '192.168.0.4'
                            
config interface 'wwan'          
        option proto 'static'      
        option ipaddr '192.68.0.4'
        option netmask '255.255.255.0'
        option gateway '192.168.0.1'

By the way, not sure what the ipaddr of the stabridge should be like. Is that pointing to some existing IP (router/repeater or anything) or does it simply want a non-assigned IP of its own within the same network? I used the latter here.

dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
                                                 
config dhcp 'lan'                                
        option interface 'lan'                   
         option start     100                    
          option limit    150                 
          option leasetime    12h         
          option ignore    1                          
                                                 
config dhcp 'wan'                                
        option interface 'wan'          
        option ignore '1'    

Now the devices can connect to the repeater's wifi, get an IP and can access the internet - for a few sec or so. I have to reconnect my android phone or laptop to the repeater wifi to get internet access working again but still just for a few sec. Pinging IP addresses no longer work either once that happens. hmm

(Last edited by Landorin on 23 May 2014, 21:30)

There is something wrong in the main message. The "network" config has empty 'option' lines.
No idea of what happenned. Fixed !
Obviously it would't work like that
The "macaddr" option is just to spoof your mac address. You can set a different mac to the client and the AP, for example.

I see you changed the country to 'DE'. Unless you have compiled Openwrt yourself and enable the custom country options in wifi settings, it will give you problems. Set it back to 'US' for now, once it works try to set it again, but I had problems with wifi dying due this.


Try this network config:

NETWORK

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd0f:7949:bfb2::/48'

config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.10.1'
        option netmask '255.255.255.0'
        option gateway '192.168.0.1'
        option dns '192.168.0.1'


config interface 'stabridge'
        option proto 'relay'
        option network 'lan wwan'
        option ipaddr '192.168.0.4'
                            
config interface 'wwan'          
        option proto 'static'
        option ipaddr '192.168.0.4'
        option netmask '255.255.255.0'
        option gateway '192.168.0.1'
  


Also, make sure that you disabled the firewall:
/etc/init.d/firewall stop
/etc/init.d/firewall disable

(Last edited by dabyd64 on 28 Apr 2014, 02:44)

hugofrlima wrote:

Hello,

After breaking my head on the last 4 days I gave up and I will post here my problem so maybe I will get a answer.
I have a TPLIK 703N.
I want to use as a repeater.So my main router will be at a room and the repeater on the middle of the building.

I tried everything I read on this topic [MODE 2] and I believe the repeater is connecting succesfull with the Main router, with correct ssid and password.
But, if I connect to Repeater network, I don't get internet and i can not enter on Main router (192.168.1.254)

CAn someone please look at my config files and see what the problem could be?
Thanks very much
.
.
.
.
What could be wrong in here??
Thanks


Your network is incomplete, try this:

config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.33'
        option netmask '255.255.255.0'
        option gateway '192.168.1.254'
        option dns '192.168.1.254'       #or your preferred dns server

(Last edited by dabyd64 on 28 Apr 2014, 02:49)

normblop wrote:

Also, trying to reset it, the DIR-615 became semi-bricked.  It won't give out DHCP IPs, but if I set an Ethernet-connected computer to 192.168.1.x, I can hit 192.168.1.1 in a browser, I see the black "LuCI" screen, and then when it tries to reload to the full LuCI interface, it either times out or is "unable to establish a connection."  I also can't ping it at 192.168.1.1, and ssh and telnet are both down.

Edit: it's also responding this way when I plug my laptop into the WAN interface!

A 30/30/30 reset did not change the behavior.  LuCI still tries to load but it appears pretty much everything else on the router isn't working and I can't reflash it or get it to reset to defaults using the reset button, either 30/30/30 or power on held down, or power on, wait, hold down.

I assume you tried the emergency mode!
Power on, when you see the system led blinking, hit the reset button, then it will flash faster.
Now telnet 192.168.1.1 (set you ip manually) and reset to factory with this command:

mtd -r erase rootfs_data

It will erase all, and reboot after that. Once it boots up it will be like new!

Thanks a lot, dabyd64!! smile

Due to your suggestions I added some of the lines to my configuration (only the static IP settings for the wwan, I updated my config posting above) and since then it seems to works stable so far! smile I did not change the "lan" part to 192.168.10.1 as you suggested as that would be outside of the existing /24 network afaik as well as 0.1 is already used by the router.
I set DE as country as I am in Germany. Afaik with a totally different settings the wrong frequencies might be used by wifi.

Anyways, now I'm simply curious:
1) there's only 1 MAC address despite the device having a wifi and a LAN module?

2) I'd like to learn more about what I actually did with that config / the technical side of how this repeater now works. That is, how mode 1 actually works with that bridging and stuff. If there's a nice explanation and maybe some picture in the wiki or somewhere explaining this I'd be happy to get a link. smile
That way I can hopefully not just understand in which way the wifi signal is repeated/bridged but also understand what my openwrt config actually means.


Also, does the firewall remain disabled even after reboot or if the device loses power?

(Last edited by Landorin on 28 Apr 2014, 19:14)

Yes it remais disabled. Unless you enable it again with "/etc/init.d/firewall enable"or do a factory reset.
Maybe this helps:
http://wiki.openwrt.org/doc/recipes/relayclient

(Last edited by dabyd64 on 28 Apr 2014, 20:55)

Thanks again! smile

The website you linked contained an interesting link (http://trac.gateworks.com/wiki/relayd) and I think I got it now. wink
Apparently the wifi connection needs to be "routed" (or actually bridged) via the LAN port and back again (all "internally" inside the same device) to avoid data collision as the device only has 1 physical MAC address. At least that's what I think it explained, I might be wrong here. wink
If that is nearly correct then I can stop wondering why we all want to bridge stuff through the LAN port which has no LAN cable attached when using the device as repeater. wink

Yet that also means, apparently, that I can't set the wifi config to DHCP as the stabridge points to the same address (so it would need to be on DHCP as well but who knows if both interfaces get the same IP assigned then). I can live with that, however. If I change networks (vacation for example) I will have to change the IP network settings for both which isn't a too big deal.

(Last edited by Landorin on 28 Apr 2014, 21:16)

I am a novice and after struggling for two weeks to get something working on a tl1043nd v2 I thought your repeater article was just what I needed but having followed the configuration exactly I cannot see the openwrt router as available. All the lights (wifi, ethernet) seem ok. The openwrt tl1043 factsheet suggests that lan is on eth1 and wan is on eth0 for v2. How do I verify this and if it is so how do I alter the config. Also the main router is 192.168.1.1 and I have set the openwrt to 192.168.2.1. Do I need to specify a gateway and if so what is the address.

The gateway is the main router. First, what are you trying to do? Bridged or unbridged repeater?
It would be better that  you posted your configs wink

dabyd64 wrote:
normblop wrote:

Also, trying to reset it, the DIR-615 became semi-bricked.  It won't give out DHCP IPs, but if I set an Ethernet-connected computer to 192.168.1.x, I can hit 192.168.1.1 in a browser, I see the black "LuCI" screen, and then when it tries to reload to the full LuCI interface, it either times out or is "unable to establish a connection."  I also can't ping it at 192.168.1.1, and ssh and telnet are both down.

Edit: it's also responding this way when I plug my laptop into the WAN interface!

A 30/30/30 reset did not change the behavior.  LuCI still tries to load but it appears pretty much everything else on the router isn't working and I can't reflash it or get it to reset to defaults using the reset button, either 30/30/30 or power on held down, or power on, wait, hold down.

I assume you tried the emergency mode!
Power on, when you see the system led blinking, hit the reset button, then it will flash faster.
Now telnet 192.168.1.1 (set you ip manually) and reset to factory with this command:

mtd -r erase rootfs_data

It will erase all, and reboot after that. Once it boots up it will be like new!

That worked perfectly, thank you! smile

I'm still stuck at https://forum.openwrt.org/viewtopic.php … 66#p229666 and I'm not sure what configs I should post.  I was using relayd but it was not working.  Are there specific relayd configs + general configs I should post?

Reset your router to factory with that command. Then post the configs that it has by default

(Last edited by dabyd64 on 4 May 2014, 19:02)

dabyd64 wrote:

Reset your router to factory with that command. Then post the configs that it has by default

Yep I did, but I'm such an OpenWRT noob I don't know what configs to post. hmm  Is there a wiki article or forum sticky? I couldn't find it.

You might not believe it wink but I'm very good at writing docs and cleaning up a wiki. It's already clear that OpenWRT is going to be my preferred wireless networking distro from now on. If there is no such "guide for how to get help" I would be happy to help write one.  I contribute best to free software with docs and bug reporting wink  And contrary to a recent post, I've already found the OpenWRT community to be quite friendly. smile

Oh it is easy. Configs are stored in /etc/config/
The network related configs are:
dhcp,firewall,network,wireless

Just put "cat /etc/config/network" on telnet /ssh and the network config contents will be displayed on the screen.
Same for the other configs.

(Last edited by dabyd64 on 5 May 2014, 00:16)

Okay. Thank you so much. I know I'll get used to OpenWRT but I've been using Debian for nearly 15 years, lol.

Here are the bare OpenWRT config files on a D-Link DIR-615 just after wiping it with the above 'mtd -r erase rootfs_data' command.

As a quick reminder, what I need to do with this is set it up as a 'transparent' (eg both sides are on the same network, get the same broadcast traffic, and DHCP is properly relayed) wifi-to-Ethernet bridge.  I'm feeding an Ethernet cable, this is the receiver and bridge in a point-to-point wireless link. Thank you so much for any advice you can give, either using LuCI or UCI or however.  I'd like to learn it the "right" way.

/etc/config/network:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'

config interface 'wan'
        option ifname 'eth1'
        option proto 'dhcp'

config switch
        option name 'eth0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'eth0'
        option vlan '1'
        option ports '0 1 2 3 4'

/etc/config/dhcp:

config dnsmasq
        option domainneeded     1
        option boguspriv        1
        option filterwin2k      0  # enable for dial on demand
        option localise_queries 1
        option rebind_protection 1  # disable if upstream must serve RFC1918 addresses
        option rebind_localhost 1  # enable for RBL checking and similar services
        #list rebind_domain example.lan  # whitelist RFC1918 responses for domains
        option local    '/lan/'
        option domain   'lan'
        option expandhosts      1
        option nonegcache       0
        option authoritative    1
        option readethers       1
        option leasefile        '/tmp/dhcp.leases'
        option resolvfile       '/tmp/resolv.conf.auto'
        #list server            '/mycompany.local/1.2.3.4'
        #option nonwildcard     1
        #list interface         br-lan
        #list notinterface      lo
        #list bogusnxdomain     '64.94.110.11'

config dhcp lan
        option interface        lan
        option start    100
        option limit    150
        option leasetime        12h

config dhcp wan
        option interface        wan
        option ignore   1

/etc/config/wireless:

config wifi-device  radio0
        option type     mac80211
        option channel  11
        option macaddr  00:24:01:41:9b:bd
        option hwmode   11ng
        option htmode   HT20
        list ht_capab   SHORT-GI-40
        list ht_capab   DSSS_CCK-40
        # REMOVE THIS LINE TO ENABLE WIFI:
        option disabled 1

config wifi-iface
        option device   radio0
        option network  lan
        option mode     ap
        option ssid     OpenWrt
        option encryption none

/etc/config/firewall:

config defaults
        option syn_flood        1
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT
# Uncomment this line to disable ipv6 rules
#       option disable_ipv6     1

config zone
        option name             lan
        option network          'lan'
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT

config zone
        option name             wan
        option network          'wan'
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
        option masq             1
        option mtu_fix          1

config forwarding
        option src              lan
        option dest             wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
        option name             Allow-DHCP-Renew
        option src              wan
        option proto            udp
        option dest_port        68
        option target           ACCEPT
        option family           ipv4

# Allow IPv4 ping
config rule
        option name             Allow-Ping
        option src              wan
        option proto            icmp
        option icmp_type        echo-request
        option family           ipv4
        option target           ACCEPT

# Allow DHCPv6 replies
# see https://dev.openwrt.org/ticket/10381
config rule
        option name             Allow-DHCPv6
        option src              wan
        option proto            udp
        option src_ip           fe80::/10
        option src_port         547
        option dest_ip          fe80::/10
        option dest_port        546
        option family           ipv6
        option target           ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Input
        option src              wan
        option proto    icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        list icmp_type          router-solicitation
        list icmp_type          neighbour-solicitation
        list icmp_type          router-advertisement
        list icmp_type          neighbour-advertisement
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Forward
        option src              wan
        option dest             *
        option proto            icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

# include a file with users custom iptables rules
config include
        option path /etc/firewall.user


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#       option src              lan
#       option src_ip   192.168.45.2
#       option dest             wan
#       option proto    tcp
#       option target   REJECT

# block a specific mac on wan
#config rule
#       option dest             wan
#       option src_mac  00:11:22:33:44:66
#       option target   REJECT

# block incoming ICMP traffic on a zone
#config rule
#       option src              lan
#       option proto    ICMP
#       option target   DROP

# port redirect port coming in on wan to lan
#config redirect
#       option src                      wan
#       option src_dport        80
#       option dest                     lan
#       option dest_ip          192.168.16.235
#       option dest_port        80
#       option proto            tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#       option src              wan
#       option src_dport        22001
#       option dest             lan
#       option dest_port        22
#       option proto            tcp

# allow IPsec/ESP and ISAKMP passthrough
#config rule
#       option src              wan
#       option dest             lan
#       option protocol         esp
#       option target           ACCEPT

#config rule
#       option src              wan
#       option dest             lan
#       option src_port         500
#       option dest_port        500
#       option proto            udp
#       option target           ACCEPT

### FULL CONFIG SECTIONS
#config rule
#       option src              lan
#       option src_ip   192.168.45.2
#       option src_mac  00:11:22:33:44:55
#       option src_port 80
#       option dest             wan
#       option dest_ip  194.25.2.129
#       option dest_port        120
#       option proto    tcp
#       option target   REJECT

#config redirect
#       option src              lan
#       option src_ip   192.168.45.2
#       option src_mac  00:11:22:33:44:55
#       option src_port         1024
#       option src_dport        80
#       option dest_ip  194.25.2.129
#       option dest_port        120
#       option proto    tcp

If I understood well, what you want is an dumb AP only.
It just provides a wireless network, but not routing or dhcp, and all the traffic is bridged between LAN and WLAN.

http://wiki.openwrt.org/doc/recipes/dumbap


By default, just disabling DHCP will do this. LAN and WLAN are in "lan" network, so they are the same and no bridge is needed.


So:
Adjust your wireless net as you like:

config wifi-device  radio0
        option type     mac80211
        option channel  11
        option macaddr  00:24:01:41:9b:bd
        option hwmode   11ng
        option htmode   HT20
        list ht_capab   SHORT-GI-40
        list ht_capab   DSSS_CCK-40

config wifi-iface
        option device   radio0
        option network  lan
        option mode     ap
        option ssid     'MyWirelessNetwork'
        option encryption 'psk2'
        option key 'P4s5w0rD*_.-137'

Set openwrt box IP to the same range of your main router. Ex. 192.168.1.x

config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.254'          #Just for example. Match the same net as your main router
        option netmask '255.255.255.0'

Disable firewall and DHCP

uci set dhcp.lan.ignore=1
uci commit dhcp
/etc/init.d/firewall disable
/etc/init.d/firewall stop

Reboot and should be done!

dabyd64 wrote:

If I understood well, what you want is an dumb AP only.
It just provides a wireless network, but not routing or dhcp, and all the traffic is bridged between LAN and WLAN.

http://wiki.openwrt.org/doc/recipes/dumbap

No sir, I need a wifi TO ethernet bridge.  It needs to connect to an existing AP as a STA, then bridge that connection to its Ethernet LAN ports. More like this maybe? http://wiki.openwrt.org/doc/howto/clientmode

Except last time I tried, I tried the relayd method and it didn't work. I probably made a mistake.

(Last edited by normblop on 7 May 2014, 09:20)

Oh! I understood wrong!
Then yes, it's a bridged client. Follow the bridged repeater, but remove the AP config in the wireless config, leaving only the STA part

(Last edited by dabyd64 on 7 May 2014, 20:45)

hy guys
i'm in trouble.
i have a tp-link wa801nd v2.1 and i would like to use it as repeater, so i flash AA12.09 (36500) on it.
linksys wag54g2 is the main router. its IP is 192.168.2.1 and DHCP server is enabled on it.
i followed step by step the guide for pseudobridge (relayd) but after some minute the repeater dont works fine!!!!
when i power on the wa801nd it starts and i can use it to surf the web: wifi or lan either. after some minute if i want connect another client to it dont works: the client waits for IP but nothing happens. if i reboot the tplink it works fine for some times...

anyway this is the config

NETWORK

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config interface 'lan'
    option ifname 'eth0'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option gateway '192.168.2.1'
    option dns '192.168.2.1'

config interface 'wwan'
    option proto 'static'
    option ipaddr '192.168.2.254'
    option netmask '255.255.255.0'

config interface 'stabridge'
    option proto 'relay'
    list network 'lan'
    list network 'wwan'
    option ipaddr '192.168.2.254'

WIRELESS

config wifi-device 'radio0'
    option type 'mac80211'
    option hwmode '11ng'
    option macaddr '10:fe:ed:75:05:f6'
    option htmode 'HT20'
    list ht_capab 'LDPC'
    list ht_capab 'SHORT-GI-20'
    list ht_capab 'SHORT-GI-40'
    list ht_capab 'TX-STBC'
    list ht_capab 'RX-STBC1'
    list ht_capab 'DSSS_CCK-40'
    option txpower '27'
    option country 'US'
    option channel '6'
    option disabled '0'

config wifi-iface
    option network 'wwan'
    option ssid '^GeDa^'
    option encryption 'psk2'
    option device 'radio0'
    option mode 'sta'
    option bssid '00:21:29:xx:xx:xx'
    option key 'ge31nna05ro78da'

config wifi-iface
    option device 'radio0'
    option mode 'ap'
    option ssid '^GeDa^HotSpot'
    option network 'lan'
    option encryption 'psk2'
    option key 'ge31nna05ro78da'

DHCP

config dnsmasq
    option domainneeded    1
    option boguspriv    1
    option filterwin2k    0  # enable for dial on demand
    option localise_queries    1
    option rebind_protection 1  # disable if upstream must serve RFC1918 addresses
    option rebind_localhost 1  # enable for RBL checking and similar services
    #list rebind_domain example.lan  # whitelist RFC1918 responses for domains
    option local    '/lan/'
    option domain    'lan'
    option expandhosts    1
    option nonegcache    0
    option authoritative    1
    option readethers    1
    option leasefile    '/tmp/dhcp.leases'
    option resolvfile    '/tmp/resolv.conf.auto'
    #list server        '/mycompany.local/1.2.3.4'
    #option nonwildcard    1
    #list interface        br-lan
    #list notinterface    lo
    #list bogusnxdomain     '64.94.110.11'

config dhcp lan
    option interface    lan
    option start     100
    option limit    150
    option leasetime    12h
    option ignore    1

config dhcp wan
    option interface    wan
    option ignore    1

FIREWALL

config defaults
    option syn_flood '1'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'REJECT'

config zone
    option name 'lan'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option network 'lan wwan'
    option forward 'ACCEPT'

config zone
    option name 'wan'
    option network 'wan'
    option input 'REJECT'
    option output 'ACCEPT'
    option forward 'REJECT'
    option masq '1'
    option mtu_fix '1'

config forwarding
    option src 'lan'
    option dest 'wan'

config rule
    option name 'Allow-DHCP-Renew'
    option src 'wan'
    option proto 'udp'
    option dest_port '68'
    option target 'ACCEPT'
    option family 'ipv4'

config rule
    option name 'Allow-Ping'
    option src 'wan'
    option proto 'icmp'
    option icmp_type 'echo-request'
    option family 'ipv4'
    option target 'ACCEPT'

config rule
    option name 'Allow-DHCPv6'
    option src 'wan'
    option proto 'udp'
    option src_ip 'fe80::/10'
    option src_port '547'
    option dest_ip 'fe80::/10'
    option dest_port '546'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-ICMPv6-Input'
    option src 'wan'
    option proto 'icmp'
    list icmp_type 'echo-request'
    list icmp_type 'echo-reply'
    list icmp_type 'destination-unreachable'
    list icmp_type 'packet-too-big'
    list icmp_type 'time-exceeded'
    list icmp_type 'bad-header'
    list icmp_type 'unknown-header-type'
    list icmp_type 'router-solicitation'
    list icmp_type 'neighbour-solicitation'
    list icmp_type 'router-advertisement'
    list icmp_type 'neighbour-advertisement'
    option limit '1000/sec'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-ICMPv6-Forward'
    option src 'wan'
    option dest '*'
    option proto 'icmp'
    list icmp_type 'echo-request'
    list icmp_type 'echo-reply'
    list icmp_type 'destination-unreachable'
    list icmp_type 'packet-too-big'
    list icmp_type 'time-exceeded'
    list icmp_type 'bad-header'
    list icmp_type 'unknown-header-type'
    option limit '1000/sec'
    option family 'ipv6'
    option target 'ACCEPT'

config include
    option path '/etc/firewall.user'

what i did wrong?

Can you connect more that one device to the router? Some routers don't work with relayed dhcp, I don't know why.
Also, current trunk have problems with wireless drivers, since r40780, and was fixed in 40802.
Wait untill the trunk snapshot is updated to a newer build ( today's build is still 40783).
Check your openwrt version!
If you still have problems, try the normal repeater instead. Could be a wireless bug or just that the main router doesn't like relayed DHCP requests.

(Last edited by dabyd64 on 21 May 2014, 15:17)

dabyd64 wrote:

Can you connect more that one device to the router? Some routers don't work with relayed dhcp, I don't know why.

this id a band news...anyway I can connect many device to the main router, and I can connect many device to the repeater until it works.

dabyd64 wrote:

Also, current trunk have problems with wireless drivers, since r40780, and was fixed in 40802.
Wait untill the trunk snapshot is updated to a newer build ( today's build is still 40783).
Check your openwrt version!

I use old rev, maybe r36500 . Do you think that has the same problem?

dabyd64 wrote:

If you still have problems, try the normal repeater insteadp. Could be a wireless bug or just that the main router doesn't like relayed DHCP requests.

I already tried before the normal repeater and it works fine...but I need a single subnet
Do you know if the tplink's stock firmware use relayed DHCP? I had the same problem with the stock firmware and repeater config. I tried with two main router in different places.

What was the other main router you tried? Was the problem the same?
I don't know if the openwrt version is the cause, but there is only one way of checking it - testing other version.
I'm compiling the latest trunk for WA801, however I'll include only Luci and Relayd packages, if you need more you'll have to wait until the trunk snapshot is updated.

Edit: Compiled sucessfully!   https://dl.dropboxusercontent.com/u/239 … pgrade.bin


Telnet / SSH to your WA801 while it has internet access and do this:

cd /tmp
wget http://dl.dropboxusercontent.com/u/23958662/openwrt/wa801nd-v2-sysupgrade.bin

Check the integrity of the downloaded file before updating

md5sum wa801nd-v2-sysupgrade.bin

SHOULD BE: 6c9c491ed59e8b276e447929a1dc871a


Update the firmware:

sysupgrade wa801nd-v2-sysupgrade.bin

It will self reboot when it finish updating. With some luck, now it will work fine!

(Last edited by dabyd64 on 21 May 2014, 21:59)

Yes, different router same problem. The router was an Argo55+ by Fastweb (Italian provider) but the wa801 had stock firmware when I tried.

Thank you for the file and the "how to".  I will try it in the evening maybe. ;-)

Anyway I can try many other openwrt version https://www.dropbox.com/sh/4dd3x9jf6qc7gx6/W0XZ-0LrZ-
They were compiled by TaskofOhm

it doesn't work fine...new openwrt version, same problem...
DHCP SERVER works for few minutes only after boot...after that i can surf the web only using static ip on the clients....
if i ssh to the wa801 j can ping from openwrt any site...
if i acces the main router's web interface i can ping wa801nd

now i would try with another main router (the third...).

Really strange... Do you really need to be bridged?
On unbridged repeater, you will be able to access the main router from any device behind the repeater anyway.

Sorry, posts 101 to 100 are missing from our archive.