Re: Repeater configurations here! Both ways, bridged and simple repeater

So I am using a custom built firmware version, so I tried using the latest stock trunk build. I made the same modifications to the configs and everything worked.

I did notice that the stock version had an MAC address in the wireless config and previously I did not and instead had "option path     'platform/ar933x_wmac'". This doesn't even seem to be a valid entry and I don't know what it does. I instead used the macaddr that the stock firmware had put in and then things worked.

So I'm glad I seem to have things working, so thank you. But any idea what the option "path" does?

52 (edited by dabyd64 2013-09-28 15:55:14)

Re: Repeater configurations here! Both ways, bridged and simple repeater

Try with this:

config zone
    option name 'wan'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'REJECT'
    option masq '1'
    option mtu_fix '1'
    option network 'wan wwan'

I would reset everything and start over again.
Disabling the firewall is a bad idea, I had problems and even lost internet connectivity.
So, do the setup as is, no modifications but the main router's settings.
If it works, then try whatever you like, now you'll know the matter when something fails.
About the mac address, openwrt changed that far ago.
You can override it anyway.
After "config wifi-iface" add the line " option macaddr 00:11:22:33:44:55".
Of course you can choose any address you like.

Re: Repeater configurations here! Both ways, bridged and simple repeater

Thanks dabyd64! Your initial post was all I needed to set up a wireless repeater without issue.

Re: Repeater configurations here! Both ways, bridged and simple repeater

Nice that it was useful for you wink

Re: Repeater configurations here! Both ways, bridged and simple repeater

i have an issue.i have 2 ubiquiti unifi ap outdoor that i flashed with openwtr.i have a dhcp server that gives ip address to the main unifi  ( the default gateway of the dhcp server is 10.1.0.1 ).the main unifi static ip address is 192.168.1.254 and it is connected to internet.
i want to extend my network so that i installed the second unifi as repeater using the first mode,the unifi static ip address is 192.168.1.253.the laptop behind is able to get ip from the dchp server connected to the main router but the laptop is not able to go to internet.
i need help to solve that issue.
thanks

Re: Repeater configurations here! Both ways, bridged and simple repeater

Hi, please attach your configs (wireless, dhcp, network, firewall) to check if something is wrong. smile

Re: Repeater configurations here! Both ways, bridged and simple repeater

Hi, the any way to do this but true wire, i have a DD-WRT which is the AP, and want to connect to another room true a powerline network the OpenWRT and two pcs. can some one help me. or give me an idea how to do this.

Re: Repeater configurations here! Both ways, bridged and simple repeater

/etc/config/wireless
config wifi-device 'radio0'
    option type 'mac80211'
    option hwmode '11ng'
    option macaddr 'dc:9f:db:9b:05:ea'
    option htmode 'HT20'
    list ht_capab 'SHORT-GI-40'
    list ht_capab 'TX-STBC'
    list ht_capab 'RX-STBC1'
    list ht_capab 'DSSS_CCK-40'
    option disabled '0'
    option txpower '27'
    option country 'US'
    option channel '11'

config wifi-iface
    option ssid 'M@XNET'
    option encryption 'none'
    option device 'radio0'
    option mode 'sta'
    option network 'wwan'
    option bssid '00:27:22:0E:46:CD'

config wifi-iface
    option device 'radio0'
    option mode 'ap'
    option ssid 'OpenWrt'
    option encryption 'none'
    option network 'plug'

###############################################################

/etc/config/dhcp
config dnsmasq
    option boguspriv '1'
    option localise_queries '1'
    option rebind_protection '1'
    option rebind_localhost '1'
    option local '/mesh.local/'
    option domain 'mesh.local'
    option expandhosts '1'
    option readethers '1'
    option leasefile '/tmp/dhcp.leases'
    option resolvfile '/tmp/resolv.conf.auto'

config dhcp
    option interface 'plug'
    option ignore '1'

config dhcp
    option interface 'ap'
    option start '2'
    option limit '150'
    option leasetime '12h'
    option ignore '0'

config dhcp
    option interface 'mesh'
    option ignore '1'

###########################################################

/etc/config/network
config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config interface 'plug'
    option _orig_ifname 'eth0'
    option _orig_bridge 'false'
    option proto 'static'
    option type 'bridge'
    option ifname 'eth0'
    option gateway '10.1.0.1'
    option ipaddr '10.1.0.100'
    option netmask '255.255.0.0'

config alias
    option interface 'plug'
    option proto 'static'
    option ipaddr '192.168.1.20'
    option netmask '255.255.255.0'

config interface 'wwan'
    option proto 'dhcp'

config interface 'bridge'
    option proto 'relay'
    option ipaddr '10.1.3.124'
    list network 'plug'
    list network 'wwan'



here are my config

59 (edited by dabyd64 2013-11-21 10:36:30)

Re: Repeater configurations here! Both ways, bridged and simple repeater

eskwire wrote:

Hi, the any way to do this but true wire, i have a DD-WRT which is the AP, and want to connect to another room true a powerline network the OpenWRT and two pcs. can some one help me. or give me an idea how to do this.

Am I understanding it correctly?
You want to connect to a wifi AP , then  "repeat" through power line, and connect the computer with ethernert to it in the other room?


maxco Are you using 'relayd'? Did you installed it, right?
I think the problem is in the network config:

config interface 'wwan'
    option proto 'dhcp'
config interface 'bridge'
    option proto 'relay'
    option ipaddr '10.1.3.124'
    list network 'plug'
    list network 'wwan'

Try with:

config interface 'wwan'
        option proto 'static'
    option ipaddr '10.1.0.124'
    option netmask '255.255.255.0'
    option gateway '10.1.0.1'
    option dns '10.1.0.1'

config interface 'bridge'
    option proto 'relay'
    option ipaddr '10.1.0.124'
    option network 'plug wwan'

With relayd you MUST use an IP from the same subnet, while you wasn't.
Also, it is recommended to use a static IP for the wwan, and assing the same ip to the relayd bridge so you can access the router from the main router.
I don't know why you had "list network" instead "option network"
All is clear in the main post, where did you took all that from? tongue
Try this and tell how it went!

Re: Repeater configurations here! Both ways, bridged and simple repeater

Is it also possible to configure these using LuCI? Or are there options missing?

Re: Repeater configurations here! Both ways, bridged and simple repeater

Hi, after a few days of stress, I've managed to access the config files again wink

This time I copied the files under "option 2" precisely in the files on the router, via WinSCP. Deleted all other lines, only put in these.

Made one (significant) change;
option ipaddr '192.168.10.1'  changed that to '192.168.5.1'

Now wireless isn't working (regardless of the position the swith on the back is in), I can't reach the router (after setting my pc's address to 192.168.5.3) at 192.168.5.1 or 192.168.1.5 (which was the previous static ip-address.)

Should I really be deleting all lines and replacing them by the ones in the OP, or should I have added these lines to the config files?

I must be going wrong somewhere, but it is beyond me where it is.

One (other) question though:
In the OP you mention

First connect the router to internet, by connecting an ethernet cable between the openwrt's router WAN port and the main router.
Install Relayd

opkg update 
opkg install relayd
/etc/init.d/relayd enable

When I connect the router via the WAN port to my main router, do I need to alter some settings? Because I can't reach/access the router when it's connected only via the WAN port. Or can I?

Can I just use the web-interface? At what ip-address? Should I change settings on my main router? Sorry for all the questions, I do hope you can find some time to look a look at them.

62 (edited by dabyd64 2013-12-07 00:21:27)

Re: Repeater configurations here! Both ways, bridged and simple repeater

Did you changed the config first? If so, you did wrong:

First connect the router to internet, by connecting an ethernet cable between the openwrt's router WAN port and the main router.

Install Relayd
opkg update 
opkg install relayd
/etc/init.d/relayd enable

If you don't install relayd, nothing will work.
If you change the config before installing relayd, then surely you won't be able to install it unless you set defaults again.
FIRST - INSTALL relayd
How? Just connect the WAN port to a main routers's  LAN port. Then it will have internet automatically.
AFTER you connected to WAN, try "ping google.com" in telnet, if it works, NOW you can proceed to second step, intalling relayd.
THEN go to 3rd step, set the config!

Re: Repeater configurations here! Both ways, bridged and simple repeater

dabyd64 wrote:

Did you changed the config first? If so, you did wrong:

First connect the router to internet, by connecting an ethernet cable between the openwrt's router WAN port and the main router.

Install Relayd
opkg update 
opkg install relayd
/etc/init.d/relayd enable

If you don't install relayd, nothing will work.
If you change the config before installing relayd, then surely you won't be able to install it unless you set defaults again.
FIRST - INSTALL relayd
How? Just connect the WAN port to a main routers's  LAN port. Then it will have internet automatically.
AFTER you connected to WAN, try "ping google.com" in telnet, if it works, NOW you can proceed to second step, intalling relayd.
THEN go to 3rd step, set the config!

Excuse my ignorance, but how do I telnet when the router is only connected at WAN port?
Thanks ever so much for helping me out, it's highly appreciated!

Re: Repeater configurations here! Both ways, bridged and simple repeater

Use two lan cables, one for wan to the main router,  an other from computer to the router with openwrt.

65 (edited by drum 2013-12-10 08:32:49)

Re: Repeater configurations here! Both ways, bridged and simple repeater

Need little help...

I use MODE 2: REPEATER, DIFFERENT NETWORK

my config:

/etc/config/wireless

config wifi-device 'radio0'    
    option disabled '0'
    option channel '1'      

config wifi-iface
    option ssid 'MAIN_AP'
    option encryption 'psk'        
    option device 'radio0'
    option mode 'sta'
    option network 'wwan'
    option key 'pass'

config wifi-iface
    option device 'radio0'
    option mode 'ap'
    option ssid 'RepeaterAP'
    option encryption 'psk'
    option key 'pass
    option network 'lan'


/etc/config/network

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config interface 'lan'
    option ifname 'eth0'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.2.163'   
    option netmask '255.255.255.0'

config interface 'wwan'
    option proto 'static'
    option ipaddr '192.168.1.161'
    option netmask '255.255.255.0'
    option gateway '192.168.1.1'
    option dns     '8.8.8.8'


/etc/config/dhcp

config dhcp lan
    option interface    lan
    option start     100
    option limit    150
    option leasetime    12h
    option ignore    0

config dhcp wan
    option interface    wan
    option ignore    1



/etc/config/firewall

config defaults
    option syn_flood '1'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'REJECT'

config zone
    option name 'lan'
    option network 'lan'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'REJECT'

config zone
    option name 'wan'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'REJECT'
    option masq '1'
    option mtu_fix '1'
    option network 'wan wwan'

config forwarding
    option src 'lan'
    option dest 'wan'

All Repeater devises can see Main network devices and they have access to internet.

What can i do to get Main network devices to see Repeater clients?

sry for bad language wink

Re: Repeater configurations here! Both ways, bridged and simple repeater

After many attempts I was successfull configuring a TL-WA901ND as a bridged repeater with minor differences from the others reported here.
I have a working AP (providing dhcp and internet access) and just needed to extend its range using the TL-WA901ND as a repeater.

First I flashed this version of OpenWRT:
http://ooxion.com/openwrt/wax50re/openw … actory.bin

Installed relayd and luci-proto-relay:

opkg update 
opkg install relayd
/etc/init.d/relayd enable
opkg install luci-proto-relay

/etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '1'
        option hwmode '11ng'
        option path 'platform/ar934x_wmac'
        option htmode 'HT20'
        option macaddr '64:66:B3:CF:4C:FF'
        list ht_capab 'LDPC'
        list ht_capab 'SHORT-GI-20'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'TX-STBC'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option disable '0'

config wifi-iface
        option device 'radio0'
        option network 'wwan'
        option mode 'sta'
        option encryption 'psk'
        option ssid 'MainWirelessNetwork'
        option key 'MainWirelessPassword'

config wifi-iface
       option device 'radio0'
       option network 'lan'
       option mode 'ap'
       option encryption 'psk'
       option ssid 'RepeaterWirelessNetwork'
       option key 'RepeaterWirelessPassword'

/etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
                                      
config interface 'wwan'               
        option proto 'dhcp'         
                                       
config interface 'stabridge'           
        option proto      'relay'      
        option network    'lan wwan'   

/etc/config/dhcp

config dnsmasq
        option domainneeded     1
        option boguspriv        1
        option filterwin2k      0  # enable for dial on demand
        option localise_queries 1
        option rebind_protection 1  # disable if upstream must serve RFC1918 addresses
        option rebind_localhost 1  # enable for RBL checking and similar services
        #list rebind_domain example.lan  # whitelist RFC1918 responses for domains
        option local    '/lan/'
        option domain   'lan'
        option expandhosts      1
        option nonegcache       0
        option authoritative    1
        option readethers       1
        option leasefile        '/tmp/dhcp.leases'
        option resolvfile       '/tmp/resolv.conf.auto'
                                                          
config dhcp lan                               
        option interface        lan           
        option ignore   1                     
                                              
config dhcp wan                    
        option interface        wan
        option ignore   1          

Disabled the firewall and dnsmasq:

/etc/init.d/firewall stop
/etc/init.d/firewall disable

/etc/init.d/dnsmasq stop
/etc/init.d/dnsmasq disable

With this configuration only the wwan interface has an IP assigned (dynamically obtained from the main AP DHCP).

It's working fine. The only limitation is that I am unable to access the luci web interface from the RepeaterWirelessNetwork. But when I connect my computer to the main AP (MainWirelessNetwork) it works just fine. The same applies to ssh access.

Re: Repeater configurations here! Both ways, bridged and simple repeater

I followed the BRIDGED REPEATER configuration provided. And, since then, I can't even SSH into my router-  Western Digital MyNet N 600.

I think I pretty much understood/ and got all the settings right but for the ip 10.0.0.240 - not sure what that meant but I went ahead and put it. I might have set something else wrong...

Now, if only there is a way to access the router... to see what i did wrong - when I connect to it directly and try to SSH I get connection timed out error.

Any ideas on how to get back access to the router?

Re: Repeater configurations here! Both ways, bridged and simple repeater

So is Mode 1 for a scenario where the secondary router is connected via ethernet, or wifi?

This is what I am trying to accomplish:
I have two openwrt wireless routers, the main one connected to the DSL modem and the secondary connected to the first via ethernet.
Both are serving two SSID's, one private, one guest.
The purpose of the second one to to be a simple WAP. Right now it's working, but as two separate routers.
(the WAP is a dhcp client to the main router)
I would like the main router to provide all DHCP and all the connected devices on either segmet to be able to see each other.

I *think* Mode one from the OP is what I need, but I just want to confirm that.

Thanks in advance!

Re: Repeater configurations here! Both ways, bridged and simple repeater

corey.maddocks wrote:

So is Mode 1 for a scenario where the secondary router is connected via ethernet, or wifi?

This is what I am trying to accomplish:
I have two openwrt wireless routers, the main one connected to the DSL modem and the secondary connected to the first via ethernet.
Both are serving two SSID's, one private, one guest.
The purpose of the second one to to be a simple WAP. Right now it's working, but as two separate routers.
(the WAP is a dhcp client to the main router)
I would like the main router to provide all DHCP and all the connected devices on either segmet to be able to see each other.

I *think* Mode one from the OP is what I need, but I just want to confirm that.

Thanks in advance!

Ok, looks like I was not doing the 30/30/30 reset properly. Got back access. Re-installed relayd/ luci etc... on to trying to set this up as a bridge/ repeater.

Re: Repeater configurations here! Both ways, bridged and simple repeater

Took me 3 days, but here's my working configs for the inexpensive TP-Link TL-WR841N.

This "routed client using MASQUERADE" a.k.a. repeater with separate names.  That is, the wireless network acts as the WAN and as the LAN.  (I have not tried using wired interfaces for WAN or LAN, but I think both will work.)

The original network is "Warwick" running on an unmodified Linksys e2000.

Running trunk OpenWRT.
(openwrt-ar71xx-generic-tl-wr841n-v8-squashfs-b0b22d0/
openwrt-ar71xx-generic-tl-wr841n-v8-squashfs-factory.bin)

NOTE: I don't think LuCI can be used to create the second wireless network, but it was really good for setting up everything else.  Just be sure you don't delete the network connection you're using!

/etc/config/wireless
* MISTAKE: I put macaddr in here!  That's very bad!
* CHANGE: channel to match original router.
* REMOVE: htmode, htmode
* REMOVE: option disabled 1  (duh!)
* ADD: new wifi-iface  ('wwan', mode sta)
* NOTE: order of wifi-ifaces may matter for mac address allocation?
* NOTE: run 'wifi' to load.  'iw' provides some info, especially with 'wifi detect'.

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '1'
        option path 'platform/ar934x_wmac'
        list ht_capab 'LDPC'
        list ht_capab 'SHORT-GI-20'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'TX-STBC'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option disabled '0'
        option txpower '27'
        option country 'US'

config wifi-iface
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'Warwick2'
        option encryption 'psk-mixed'
        option key 'SuperSecretPassword'

config wifi-iface
        option device 'radio0'
        option network 'wwan'
        option mode 'sta'
        option ssid 'Warwick'
        option key 'SuperSecretPassword'
        option encryption 'psk-mixed'

/etc/config/network
* NOTE: 'wan' is eth0, bridged virtual LAN is eth1
* NOTE: In LuCI, 'wlan0' is first wifi-iface ('lan'), 'wlan0-1' is second wifi-iface ('wwan')
* NOTE: 'wan6' is the same as 'wan' except for IPv6
* NOTE: I overrode the MAC address on the wwan interface - not sure it's necessary.
* NOTE: 'switch' turns eth1 into many virtual interfaces, all bridged.
* CHANGE: 192.168.1.1 to 192.168.2.1 (to not clash with original network)
* ADDED: 'wwan' interface
* NOTE: '/etc/init.d/network reload' to reload

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd3f:049c:4572::/48'

config interface 'lan'
        option ifname 'eth1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wwan'
        option proto 'dhcp'
        option macaddr '10:FE:ED:DD:F9:4B'
        option _orig_ifname 'wwan'
        option _orig_bridge 'false'

config interface 'wan'
        option ifname 'eth0'
        option proto 'dhcp'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 4'

/etc/config/dhcp
* ADDED: settings for 'wwan'   (Which is just a copy of setting for 'wan')
* NOTE: '/etc/init.d/dnsmasq restart' to reload

config dnsmasq
# SKIPPING A LOT (UNCHANGED)

config dhcp lan
        option interface        lan
        option start    100
        option limit    150
        option leasetime        12h

config dhcp wan
        option interface        wan
        option ignore   1
        
config dhcp wwan
        option interface        wwan
        option ignore   1

/etc/config/firewall
* NOTE: This is responsible for forwarding from 'wwan' (and 'wan') to LANs.  It also does the change of IP address.  (from a 192.168.2.XXX to a 192.168.1.YYY)
* NOTE: 'lan' and 'wan' are names of both firewall zones and network interfaces.  They probably should be different names so that it's easier to read.
* CHANGED: 'wan' zone's network changed to 'wan wan6 wwan' (that is, 3 interfaces).   (You may be able to just add 'list network wwan' - but use "list" not "option"!)
* NOTE: '/etc/init.d/firewall restart' to reload

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network 'lan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        option network 'wan wan6 wwan'

# SKIPPING UNCHANGED rules
# SKIPPING UNCHANGED includes

# UNCHANGED (but important):
config forwarding
        option src 'lan'
        option dest 'wan'

71 (edited by sachin0235 2014-03-10 17:14:49)

Re: Repeater configurations here! Both ways, bridged and simple repeater

has anyone tried configuring repeater while main router is running a capative portal on coova chilli? I tried option 1 on non-coova router and it worked fine. Now when i do same settings on coova enabled router i am not able to get internet from repeater.

72 (edited by normblop 2014-04-09 07:57:02)

Re: Repeater configurations here! Both ways, bridged and simple repeater

I'm attempting to make a wireless-to-ethernet bridge and can't get the first set of instructions to work. I want to relay DHCP traffic, etc. because the router "closer" to the Internet link (this is a point-to-point link between houses) already handles DHCP and traffic management.  The whole network is more complex than this, but I've only included the parts that I care about. The OpenWRT wifi to ethernet bridge in the middle is what I can't get working. And it is not connecting to the other distant AP with the same SSID - I can't even get it working next to the shared router.

http://i.imgur.com/alfMfJQ.png

Unfortunately the shared router is a DIR-655 and I cannot install custom firmware on it.  I otherwise have total control over it.  I am sharing my internet connection with my neighbors and splitting the bill.  The DIR-655 shared router has directional Yagi antennas pointed at the distant house and can get a connection fine.

The problem is, using method 1 above, I cannot get OpenWRT to act as a wifi-to-Ethernet bridge on a DIR-615 rev C1.  That's all I want.  I don't want it to repeat Wifi, I only want it talking to the shared router for all traffic between houses, and bridging that to Ethernet.  Some clients connect directly by Ethernet and others connect using an existing access point in the distant house.

I've been through and through the wiki docs and this thread.  WDS doesn't work, presumably because it's a manufacturer specific implementation.  So I tried this guide, because relayd (relaying DHCP) is what I want, and I DO NOT want anything else provided by the bridge except ... a bridge.  No DNS, no nothing, just a bridge.

I tried method 1 above and even so, when I connected to the bridge by Ethernet, it was still giving me DHCP IPs in 192.168.1.1 (note the DIR-655 is 192.168.35.1 and if relayd were relaying DHCP, I should be getting IPs in 192.168.35.0/24).  I set the 10.0.0.240 address as described, and also the other address "not in the same subnet as the primary router" to be 192.168.36.1.  But, I still get DHCP in 192.168.1.0/24, and I can't connect to or ping the bridge any more - not on 192.168.1.1, not 192.168.35.2, not 192.168.36.1, and not 10.0.0.240, whether remaining with my laptop connected to it by Ethernet as 192.168.1.x, or setting my IP manually to all the different subnets.  So, I had to re-flash the bridge.

Can anyone help before I try again?  I know this is possible because it's working right now with stock firmware on a Buffalo WLAE-AG300N!  The only problem is that the Buffalo needs to be rebooted about twice a day, so I'm trying to use OpenWRT on a DIR-615 as a reliable replacement.

73 (edited by normblop 2014-04-09 08:27:54)

Re: Repeater configurations here! Both ways, bridged and simple repeater

Also, trying to reset it, the DIR-615 became semi-bricked.  It won't give out DHCP IPs, but if I set an Ethernet-connected computer to 192.168.1.x, I can hit 192.168.1.1 in a browser, I see the black "LuCI" screen, and then when it tries to reload to the full LuCI interface, it either times out or is "unable to establish a connection."  I also can't ping it at 192.168.1.1, and ssh and telnet are both down.

Edit: it's also responding this way when I plug my laptop into the WAN interface!

A 30/30/30 reset did not change the behavior.  LuCI still tries to load but it appears pretty much everything else on the router isn't working and I can't reflash it or get it to reset to defaults using the reset button, either 30/30/30 or power on held down, or power on, wait, hold down.

Re: Repeater configurations here! Both ways, bridged and simple repeater

Hello,

After breaking my head on the last 4 days I gave up and I will post here my problem so maybe I will get a answer.
I have a TPLIK 703N.
I want to use as a repeater.So my main router will be at a room and the repeater on the middle of the building.

I tried everything I read on this topic [MODE 2] and I believe the repeater is connecting succesfull with the Main router, with correct ssid and password.
But, if I connect to Repeater network, I don't get internet and i can not enter on Main router (192.168.1.254)

CAn someone please look at my config files and see what the problem could be?
Thanks very much

//////NETWORK//////

root@OpenWrt:/# vi /etc/config/network


config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd8f:f1df:916b::/48'

config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.33'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wwan'
option proto 'dhcp'
~
~
~
- /etc/config/network 1/20 5%
                                                                                
config interface 'loopback'                                                     
        option ifname 'lo'                                                      
        option proto 'static'                                                   
        option ipaddr '127.0.0.1'                                               
        option netmask '255.0.0.0'                                              
                                                                                
config globals 'globals'                                                        
        option ula_prefix 'fd8f:f1df:916b::/48'                                 
                                                                                
config interface 'lan'                                                          
        option ifname 'eth0'                                                    
        option type 'bridge'                                                    
        option proto 'static'                                                   
        option ipaddr '192.168.1.33'                                            
        option netmask '255.255.255.0'                                          
        option ip6assign '60'                                                   
                                                                                
config interface 'wwan'                                                         
option proto 'dhcp'                                                             
~                                                                               
~                                                                               
~                                                                               
~                                                                               

///////DHCP/////

config dnsmasq
        option domainneeded '1'
                option boguspriv '1'
                        option filterwin2k '0'
                                option localise_queries '1'
                                        option rebind_protection '1'
                                                option rebind_localhost '1'
                                                        option local '/lan/'
                                                                option domain 'lan'
                                                                        option expandhosts '1'
                                                                                option nonegcache '0'
                                                                                        option authoritative '1'
                                                                                                option readethers '1'
                                                                                                        option leasefile '/tmp/dhcp.leases'
                                                                                                                option resolvfile '/tmp/resolv.conf.auto'


                                                                                                                config dhcp lan
                                                                                                                    option interface    lan
                                                                                                                        option start     100
                                                                                                                            option limit    150
                                                                                                                                option leasetime    12h
                                                                                                                                    option ignore    0

                                                                                                                                    config dhcp wan
                                                                                                                                        option interface    wan
                                                                                                                                            option ignore    1

///////////WIRELESS//////

config wifi-device  'radio0'
        option type     'mac80211'
        option channel  '9'
        option hwmode   '11ng'
        option path     'platform/ar933x_wmac'
        list ht_capab   'SHORT-GI-20'
        list ht_capab   'SHORT-GI-40'
        list ht_capab   'RX-STBC1'
        list ht_capab   'DSSS_CCK-40'
        option htmode   'HT20'

        option disabled '0'

config wifi-iface
        option device   'radio0'
        option network  'wwan'
        option mode     'sta'
        option ssid     'D49830'
        option encryption 'psk'
        option key 'DCA8B03448'


        config wifi-iface
            option device 'radio0'
                option mode 'ap'
                    option ssid 'RepeaterWirelessNetwork'
                        option encryption 'psk'
                            option key 'RepeaterWirelessPassword'
                                option network 'lan'

What could be wrong in here??
Thanks

75 (edited by dabyd64 2014-04-20 20:27:19)

Re: Repeater configurations here! Both ways, bridged and simple repeater

Hi, I was a bit off lately, too much work! I'll have a look to that posts soon

hugofrlima, first check that the router is connected with your main network.
Try to ping the main router, inside the openwrt shell. What is its ip?